Continued: Debugging a web service

Discussion in 'ASP .Net Security' started by Meena, Sep 26, 2003.

  1. Meena

    Meena Guest

    Thanks a lot Chris! Here is my situation in detail.
    I have already created a domain account and I have
    configured mymachine.config (<processmodel>section) so
    that ASP.NET process runs with that account. On my local
    system where I have my web server and my asp.net web
    service application , I have logged in as a local
    administrator. Additionally , I have configured my domain
    account to be part of Debugger Users group on my local
    system( I could not do it on the domain controller as I
    cannot see that group there. Is it because .NET is not
    installed on my domain controller ?)

    Next my IIS is configured for Integrated Windows
    Authentication and No anonymous login. Since I am using
    Windows mode of authentication in my machine.config , I
    see that enabling anonymous access does not make my
    ASP.NET process to work. I had a hard time to figure this
    out.

    So with this in place I am happliy runnning my ASP.nET
    process fine , hotsing my asp.net webservice , reading
    from a remote database and whenever I want to debug I
    manually attach to the process aspnet_wp.exe.

    Chris , can i retain all my settings this way ( in IIS and
    machine.config ) and still make my debugging work ? I do
    not understand why I am not able to debug when I am a
    local adminisrtor and also the account running ASP.NET is
    assigned to Debugger Users .

    Thanks in advance ,

    Meena
    >-----Original Message-----
    >Are you running as an admin? Debugger user? The problem

    could be with
    >debugging into a process owned by another user. What I do

    is this (which you
    >actually have to do in order to debug as a non-admin

    user):
    >
    >- Set up my user name and password encrypted in the

    registry using
    >aspnet_setreg
    >- Change my machine.config to use my user name and

    password for aspnet_wp
    >- Configure IIS to use a separate, low privileged domain

    account for
    >anonymous access
    >- Configure my web site to use impersonation
    >
    >Since I use anonymous on IIS and forms on ASP.NET, this

    allows me to debug
    >as a non-admin (it's my process, so I can do that) while

    still passing
    >credentials that only allow the process to do what it

    needs to do, and no
    >more.
    >
    >--
    >Chris Jackson
    >Software Engineer
    >Microsoft MVP - Windows XP
    >Windows XP Associate Expert
    >--
    >"Meena" <> wrote in message
    >news:10eea01c38387$e65464e0$...
    >> Hi ,
    >>
    >> I have an ASP.NET web service running on a Windows

    2000
    >> Server (WHICH IS NOT A DOMAIN CONTROLLER). Since I

    wanted
    >> to access a remote database on my intranet , I set up my
    >> ASp.NET worker process(aspnet_wp.exe) to run under a
    >> domain account(<domainname>\meenaaspnet). Everything is
    >> workimg fine. I can access my remote database also.
    >> However when I try to debug my program (using F11) it
    >> gives me this error.
    >>
    >> "Error while trying to run project:Unable to start
    >> debugging on a web server. Catastrophic failure"
    >>
    >> I can however run my application if I choose the option

    to
    >> Start without debugging.
    >> What do I do?

    >
    >
    >.
    >

    ..
    Meena, Sep 26, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lloyd Dupont
    Replies:
    1
    Views:
    358
    Lloyd Dupont
    Sep 30, 2004
  2. Lloyd Dupont
    Replies:
    1
    Views:
    427
    Guest
    Dec 22, 2004
  3. Michael_jd
    Replies:
    4
    Views:
    339
    Toby Inkster
    Oct 19, 2005
  4. Rotsey
    Replies:
    1
    Views:
    258
    Rotsey
    Dec 10, 2006
  5. Java script Dude
    Replies:
    0
    Views:
    88
    Java script Dude
    Nov 18, 2007
Loading...

Share This Page