Cookieless session problem...

Discussion in 'ASP .Net' started by =?Utf-8?B?SmFjIFRpbW1z?=, Sep 23, 2005.

  1. Hi,

    I am building a mobile site. It has to have cookieless sessions enabled as
    asp.net mobile stores viewstate information for controls in session. I need
    one directory in the application (that takes input from a remote site), to
    not have cookieless sessions as it can't redirect the call from
    /_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
    this using the web.config location element, however I get the error "It is an
    error to use a section registered as allowDefinition='MachineToApplication'
    beyond application level. This error can be caused by a virtual directory not
    being configured as an application in IIS.".

    This can be solved by making the "_test" directory an application in iis,
    but then it needs its on bin folder for the dll's etc. I was wonder if anyone
    knew of a way around this, so I don't need to make the "_test" directory an
    application or can just disable sessions for certain scripts.

    Thanks in advance for any suggestions...
    -Jac
     
    =?Utf-8?B?SmFjIFRpbW1z?=, Sep 23, 2005
    #1
    1. Advertising

  2. Have you tried the EnableSessionState attribute of the @ Page directive?

    "Jac Timms" wrote:

    > Hi,
    >
    > I am building a mobile site. It has to have cookieless sessions enabled as
    > asp.net mobile stores viewstate information for controls in session. I need
    > one directory in the application (that takes input from a remote site), to
    > not have cookieless sessions as it can't redirect the call from
    > /_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
    > this using the web.config location element, however I get the error "It is an
    > error to use a section registered as allowDefinition='MachineToApplication'
    > beyond application level. This error can be caused by a virtual directory not
    > being configured as an application in IIS.".
    >
    > This can be solved by making the "_test" directory an application in iis,
    > but then it needs its on bin folder for the dll's etc. I was wonder if anyone
    > knew of a way around this, so I don't need to make the "_test" directory an
    > application or can just disable sessions for certain scripts.
    >
    > Thanks in advance for any suggestions...
    > -Jac
     
    =?Utf-8?B?QnJhZCBSb2JlcnRz?=, Sep 23, 2005
    #2
    1. Advertising

  3. brilliant, thank you!
    i can't believe i missed that...
    i looked on this page thinking there might be something i could do in the
    page directive.
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpgenref/html/cpconpage.asp
    thanks again.
    -jac


    "Brad Roberts" wrote:

    > Have you tried the EnableSessionState attribute of the @ Page directive?
    >
    > "Jac Timms" wrote:
    >
    > > Hi,
    > >
    > > I am building a mobile site. It has to have cookieless sessions enabled as
    > > asp.net mobile stores viewstate information for controls in session. I need
    > > one directory in the application (that takes input from a remote site), to
    > > not have cookieless sessions as it can't redirect the call from
    > > /_test/scriptname.aspx to /{sessionID}/_test/scriptname.aspx. I am able to do
    > > this using the web.config location element, however I get the error "It is an
    > > error to use a section registered as allowDefinition='MachineToApplication'
    > > beyond application level. This error can be caused by a virtual directory not
    > > being configured as an application in IIS.".
    > >
    > > This can be solved by making the "_test" directory an application in iis,
    > > but then it needs its on bin folder for the dll's etc. I was wonder if anyone
    > > knew of a way around this, so I don't need to make the "_test" directory an
    > > application or can just disable sessions for certain scripts.
    > >
    > > Thanks in advance for any suggestions...
    > > -Jac
     
    =?Utf-8?B?SmFjIFRpbW1z?=, Sep 23, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Carpe Diem
    Replies:
    3
    Views:
    7,259
    Carpe Diem
    Feb 23, 2004
  2. alex
    Replies:
    2
    Views:
    1,747
    =?Utf-8?B?bWtsYXBw?=
    Apr 12, 2004
  3. Hope Paka
    Replies:
    0
    Views:
    596
    Hope Paka
    Jun 7, 2005
  4. Replies:
    2
    Views:
    3,293
    Ravi Singh (UCSD)
    May 10, 2006
  5. Priya

    Problem while using cookieless session

    Priya, Aug 16, 2005, in forum: ASP .Net Security
    Replies:
    6
    Views:
    258
    Dominick Baier [DevelopMentor]
    Aug 19, 2005
Loading...

Share This Page