Could not load assembly. Make sure that it is compiled before accessing the page.

Discussion in 'ASP .Net' started by rachana, Jul 6, 2006.

  1. rachana

    rachana Guest

    Hi,

    I am trying to deploy a asp.net website developed using Visual Studio
    2005 on server. Application works fine on development machine, but when
    trying to run on server I get following error message.

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Parser Error
    Description: An error occurred during the parsing of a resource
    required to service this request. Please review the following specific
    parse error details and modify your source file appropriately.

    Parser Error Message: Could not load the assembly 'App_Web_pizv9cfi'.
    Make sure that it is compiled before accessing the page.

    Source Error:


    Line 1: <%@ page language="VB" autoeventwireup="false"
    inherits="_Default, App_Web_pizv9cfi" %>
    Line 2:
    Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.2300;
    ASP.NET Version:1.1.4322.2300

    - Server is running IIS 6.0. Both .NET framework 1.1 and 2.0 is
    installed on the server.
    - Server has many applications using framework 1.1 which are running
    fine. This is the first application using framework 2.0.
    - The applicaiton folder is configured as application in IIS virtual
    directory.
    - I have also changed asp.net version to 2.0 under asp.net tab in
    virtual directory settings. The weird thing is that the error message
    shows version as 1.1. I don't understand why?

    The application is compiled correctly and all necessary files are
    copied on server. I have tried copying the folder on another
    development machine and it works well.

    Any help would be really appreciated.

    Thanks,
    Rachana
     
    rachana, Jul 6, 2006
    #1
    1. Advertising

  2. rachana

    Winista Guest

    Is your application running in a separate pool? On IIS6.0 you can put
    applications in different pools. But in one pool you can use only one
    framework version. So if rest of the applications in your pool are
    configured for .Net1.1 and this one is using 2.0 then you will run into
    interesting problems.

    "rachana" <> wrote in message
    news:...
    > Hi,
    >
    > I am trying to deploy a asp.net website developed using Visual Studio
    > 2005 on server. Application works fine on development machine, but when
    > trying to run on server I get following error message.
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Parser Error
    > Description: An error occurred during the parsing of a resource
    > required to service this request. Please review the following specific
    > parse error details and modify your source file appropriately.
    >
    > Parser Error Message: Could not load the assembly 'App_Web_pizv9cfi'.
    > Make sure that it is compiled before accessing the page.
    >
    > Source Error:
    >
    >
    > Line 1: <%@ page language="VB" autoeventwireup="false"
    > inherits="_Default, App_Web_pizv9cfi" %>
    > Line 2:
    > Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    > "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    >
    >
    > --------------------------------------------------------------------------------
    > Version Information: Microsoft .NET Framework Version:1.1.4322.2300;
    > ASP.NET Version:1.1.4322.2300
    >
    > - Server is running IIS 6.0. Both .NET framework 1.1 and 2.0 is
    > installed on the server.
    > - Server has many applications using framework 1.1 which are running
    > fine. This is the first application using framework 2.0.
    > - The applicaiton folder is configured as application in IIS virtual
    > directory.
    > - I have also changed asp.net version to 2.0 under asp.net tab in
    > virtual directory settings. The weird thing is that the error message
    > shows version as 1.1. I don't understand why?
    >
    > The application is compiled correctly and all necessary files are
    > copied on server. I have tried copying the folder on another
    > development machine and it works well.
    >
    > Any help would be really appreciated.
    >
    > Thanks,
    > Rachana
    >
     
    Winista, Jul 6, 2006
    #2
    1. Advertising

  3. rachana

    rachana Guest

    Creating separate application pool solved the problem. Thanks a lot for
    your help.


    Winista wrote:
    > Is your application running in a separate pool? On IIS6.0 you can put
    > applications in different pools. But in one pool you can use only one
    > framework version. So if rest of the applications in your pool are
    > configured for .Net1.1 and this one is using 2.0 then you will run into
    > interesting problems.
    >
     
    rachana, Jul 6, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David Williams
    Replies:
    2
    Views:
    1,156
    Jacob Yang [MSFT]
    Aug 12, 2003
  2. Max
    Replies:
    1
    Views:
    13,099
    Brock Allen
    Sep 9, 2005
  3. Ryan Stewart
    Replies:
    3
    Views:
    642
    xarax
    Sep 7, 2003
  4. Replies:
    0
    Views:
    573
  5. glitteringsounds
    Replies:
    1
    Views:
    1,388
    Alf P. Steinbach /Usenet
    Jul 3, 2010
Loading...

Share This Page