Could not load type 'Global.yaddayadda'. - Global.asax.cs

Discussion in 'ASP .Net' started by Daniel Bass, Dec 31, 2003.

  1. Daniel Bass

    Daniel Bass Guest

    Scenario (Hardware)
    ----------------------

    I've got an engineering source server with Win 2k on it. We use it for all
    the source files for our projects etc...
    Let's call it "Engineering" for this scenario's sake.

    Next, I have a test machine, again running Win 2k, we'll call it "Test",
    that we use to drop all our compiled applications onto for testing before
    release to our clients.

    Finally, there's my box, (let's call it "Local") where the code is written
    and compiled from (not stored though). Local is running XP Pro.

    All machines have the latest patches and .Net frameworks, along with the IIS
    that came with their respective platforms.


    Scenario (Software)
    --------------------

    I'm writing an ASP.Net application with VS.Net 2003, running on Local, which
    creates a project in the IIS space of Test, which has a virtual directory
    pointing to code on Engineering. I didn't come up with this policy, it was
    before I arrived.


    The Problem
    -------------

    I'm getting this error when I first create and simply drop one label onto
    the WebForm1.aspx.

    =====================================================================

    Server Error in '/YaddaYadda' Application.
    ----------------------------------------------------------------------------
    ----

    Parser Error
    Description: An error occurred during the parsing of a resource required to
    service this request. Please review the following specific parse error
    details and modify your source file appropriately.

    Parser Error Message: Could not load type 'YaddaYadda.Global'.

    Source Error:


    Line 1: <%@ Application Codebehind="Global.asax.cs"
    Inherits="YaddaYadda.Global" %>



    Source File: \\Engineering\Projects\YaddaYadda\global.asax Line: 1


    ----------------------------------------------------------------------------
    ----
    Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET
    Version:1.1.4322.573

    ==========================================================================


    I've tried the "Rebuild Solutions", as well as ensuring the namespaces are
    all correct, and have reboot both Test and Local to no avail.

    Any ideas?

    Thanks for your time.
    Dan.

    PS. HAPPY NEW YEAR!
    Daniel Bass, Dec 31, 2003
    #1
    1. Advertising

  2. Daniel Bass

    John Ruiz Guest

    Daniel Bass wrote:
    "I'm writing an ASP.Net application with VS.Net 2003, running on Local,
    which creates a project in the IIS space of Test, which has a virtual
    directory pointing to code on Engineering"
    ---

    If you are trying to compile/run this on Local, I would bet you that your
    problem is in trying to get at code that resides on Engineering.

    Search the group archives for a post with the subject "Can't run ASP.NET
    application on local machine with network share" from around 06/2002.
    John Ruiz, Dec 31, 2003
    #2
    1. Advertising

  3. Daniel Bass

    Daniel Bass Guest

    Thanks, you were right... here's the solution i found with that tip.

    ----------------------------------------------------------------------------
    ------------
    When you trying to run asp.net application, IIS makes dll
    assembly in the /bin directory. That assembly must be
    registered in your desktop machine before you can run it.
    So, run "/Administrative tools/Microsoft .NET Framework
    Configuration" (\WINNT\Microsoft.NET\Framework\[version]
    \mscorcfg.msc), in the "Runtime security policy->Increase
    assembly trust" make full trust to
    your "//notebookname/../bin/assemblyname.dll"
    After that restart "w3svc" (type in dos console(cmd) [net
    stop w3svc] and start [net start w3svc]) or restart
    machine.
    ----------------------------------------------------------------------------
    ------------

    this is stupid though, because it means that for every DLL registered off
    site, you need to tell .Net that you want it to have permissions. It's a
    workaround to a problem, rather than a fix.
    Surely this should be apart of the project settings?

    Dan.


    "John Ruiz" <> wrote in message
    news:...
    Daniel Bass wrote:
    "I'm writing an ASP.Net application with VS.Net 2003, running on Local,
    which creates a project in the IIS space of Test, which has a virtual
    directory pointing to code on Engineering"
    ---

    If you are trying to compile/run this on Local, I would bet you that your
    problem is in trying to get at code that resides on Engineering.

    Search the group archives for a post with the subject "Can't run ASP.NET
    application on local machine with network share" from around 06/2002.
    Daniel Bass, Dec 31, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bob

    could not load type global

    bob, Jul 2, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    982
    Natty Gur
    Jul 2, 2003
  2. Jacob Yang [MSFT]
    Replies:
    3
    Views:
    2,243
  3. Tyson Zwicker
    Replies:
    3
    Views:
    26,943
    psusme1
    Mar 24, 2009
  4. =?Utf-8?B?YmNoYXJsZXM=?=

    global.asax and global.asax.cs

    =?Utf-8?B?YmNoYXJsZXM=?=, Oct 4, 2004, in forum: ASP .Net
    Replies:
    5
    Views:
    801
    =?Utf-8?B?YmNoYXJsZXM=?=
    Oct 5, 2004
  5. Mark Rae

    Global.asax / Global.asax.cs in v2

    Mark Rae, May 23, 2006, in forum: ASP .Net
    Replies:
    6
    Views:
    3,139
    Mark Rae
    May 23, 2006
Loading...

Share This Page