Create IIS Virtual Directory from ASP.NET page...

Discussion in 'ASP .Net' started by David Conorozzo, Nov 2, 2003.

  1. I am running Windows Server 2003 Enterprise. I had
    accomplished this by creating a COM+ application (.dll
    that uses ADSI) that runs as a higher powered user than
    the IIS process. No other method had worked for me (I
    tried that LogonUser API and it didn't work).

    Now, we set up a cluster. And I don't know how to set up
    the COM+ application. I can't do it through Component
    Manager, it just yells at me. I have no experience with
    this stuff. I basically need a way to add some vrtual
    directories to IIS from my web page (on the server side)
    and then send the IIS metabase that was altered to all of
    the other servers in the cluster (I was using IIS Sync but
    before, I knew which server's metabase I was altering).

    Thanks for any help.
    David Conorozzo, Nov 2, 2003
    #1
    1. Advertising

  2. David Conorozzo

    Natty Gur Guest

    Natty Gur, Nov 3, 2003
    #2
    1. Advertising

  3. Thanks. I know how to create a virtual directory
    already. I did that in the COM+ application. I need to
    be able to do it in an ASP.NET page and I am getting
    authorization/access errors. I have now tried
    impersonation in the web.config file of a XML Web Service
    page, but that seems to be failing also. Is there some
    ACL that needs to be set? Some registry key?

    >-----Original Message-----
    >Hi,
    >refer to :
    >http://www.c-

    sharpcorner.com/Code/2002/July/CreateVirtualDirs.asp
    >
    >Natty Gur[MVP]
    >Phone Numbers:
    >Office: +972-(0)9-7740261
    >Fax: +972-(0)9-7740261
    >Mobile: +972-(0)58-888377
    >
    >
    >*** Sent via Developersdex http://www.developersdex.com

    ***
    >Don't just participate in USENET...get rewarded for it!
    >.
    >
    David Conorozzo, Nov 5, 2003
    #3
  4. David Conorozzo

    Natty Gur Guest

    OK,

    I see, you need to assign user with administrative rights to do it. you
    can try to the identity tag user and password of administrator just to
    check it out. NOTE : that its extremely dangerous in term of security.

    Natty Gur[MVP]
    Phone Numbers:
    Office: +972-(0)9-7740261
    Fax: +972-(0)9-7740261
    Mobile: +972-(0)58-888377


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
    Natty Gur, Nov 6, 2003
    #4
  5. Natty Gur <> wrote in message news:<>...
    > OK,
    >
    > I see, you need to assign user with administrative rights to do it. you
    > can try to the identity tag user and password of administrator just to
    > check it out. NOTE : that its extremely dangerous in term of security.
    >
    > Natty Gur[MVP]
    > Phone Numbers:
    > Office: +972-(0)9-7740261
    > Fax: +972-(0)9-7740261
    > Mobile: +972-(0)58-888377
    >
    >
    > *** Sent via Developersdex http://www.developersdex.com ***
    > Don't just participate in USENET...get rewarded for it!


    I did that and it worked (I also had to use IIS:\\MachineName instead
    of IIS:\\localhost for some reason, localhost didn't work
    consistantly). Now the problem is, when I moved this to my live
    server it doesn't work. What could I be missing. I have the
    impersonate set to an admin account. Is there some registry key
    permission?
    David Conorozzo, Nov 9, 2003
    #5
  6. David Conorozzo

    Natty Gur Guest

    Hi,

    Probably the user you set with Identity tag doesn’t have administration
    rights. Remember that using administrator is extremely dangerous, it’s
    better to create special user for that task.

    Natty Gur[MVP]
    Phone Numbers:
    Office: +972-(0)9-7740261
    Fax: +972-(0)9-7740261
    Mobile: +972-(0)58-888377


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
    Natty Gur, Nov 9, 2003
    #6
  7. Natty Gur <> wrote in message news:<edH#>...
    > Hi,
    >
    > Probably the user you set with Identity tag doesn?t have administration
    > rights. Remember that using administrator is extremely dangerous, it?s
    > better to create special user for that task.
    >
    > Natty Gur[MVP]
    > Phone Numbers:
    > Office: +972-(0)9-7740261
    > Fax: +972-(0)9-7740261
    > Mobile: +972-(0)58-888377
    >
    >
    > *** Sent via Developersdex http://www.developersdex.com ***
    > Don't just participate in USENET...get rewarded for it!


    As I said before, I have the impersonate set to an admin account, so I
    don't think that it is simply a rights issue.
    David Conorozzo, Nov 10, 2003
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matt
    Replies:
    1
    Views:
    756
    Sherif ElMetainy
    Nov 10, 2003
  2. =?Utf-8?B?U3RlcGhhbmU=?=

    Cannot create Virtual Directory in IIS from asp.net

    =?Utf-8?B?U3RlcGhhbmU=?=, Dec 8, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    3,926
    =?Utf-8?B?U3RlcGhhbmU=?=
    Dec 9, 2004
  3. Eskimo
    Replies:
    5
    Views:
    134
    Joe Kaplan \(MVP - ADSI\)
    Nov 8, 2004
  4. Eskimo

    IIS Virtual Directory Create Failure :(

    Eskimo, Nov 4, 2004, in forum: ASP .Net Web Services
    Replies:
    4
    Views:
    176
    Eskimo
    Nov 22, 2004
  5. Matt
    Replies:
    2
    Views:
    138
    dlbjr
    Nov 9, 2003
Loading...

Share This Page