CreateToolhelp32Snapshot Page Faults

Discussion in 'C++' started by cablitoEscobar, Sep 27, 2006.

  1. The problem lies in the fact that whenever I call

    CreateToolhelp32Snapshot(TH32CS_SNAPPROCESS,0)

    a page fault occurs.

    The fact is I have a timer set to take a snap-shot per second and the
    page faults just go on increasing. It is very well isolated that only
    when calling the API the page fault occurs.

    Trying to use EnumProcesses but it also causes page faults, less
    though.

    Anyone got any pointers there?
    cablitoEscobar, Sep 27, 2006
    #1
    1. Advertising

  2. cablitoEscobar wrote:
    > The problem lies in the fact that whenever I call
    >
    > CreateToolhelp32Snapshot(TH32CS_SNAPPROCESS,0)
    > [...]
    > Anyone got any pointers there?


    news:comp.os.ms-windows.programmer.win32

    V
    --
    Please remove capital 'A's when replying by e-mail
    I do not respond to top-posted replies, please don't ask
    Victor Bazarov, Sep 27, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave Kirby

    page faults when spawning subprocesses

    Dave Kirby, Nov 9, 2005, in forum: Python
    Replies:
    2
    Views:
    272
    Daniel Kabs
    Nov 9, 2005
  2. Sune
    Replies:
    26
    Views:
    695
    Lawrence Kirby
    Aug 1, 2005
  3. benben
    Replies:
    3
    Views:
    514
    benben
    Jun 30, 2005
  4. none

    Acceptable level of page faults

    none, Nov 9, 2007, in forum: ASP .Net
    Replies:
    5
    Views:
    8,491
  5. David Morgan
    Replies:
    2
    Views:
    269
    Anthony Jones
    Jun 9, 2006
Loading...

Share This Page