creating new project in VS.NET

Discussion in 'ASP .Net' started by Sam Carleton, Aug 24, 2003.

  1. Sam Carleton

    Sam Carleton Guest

    I am trying to figure out how to get VS.Net and IIS6 to work
    together... I am working in domain nowhere.local. I have a W2K3
    server named server1.nowhere.local that is running IIS6. I want it
    to host a web site named jws.nowhere.local. Within II6 of server1,
    I created a new web site as to allow one to serf to
    jws.nowhere.local and see the simply default.htm doc. Then I have
    shared that directories root such that the path to the default file
    is: \\server1\jws$\default.html

    Then when I try to create a new ASP.NET Web Application:

    http://jws.nowhere.local/calendar

    With a file share path of:

    \\server1\jws$\calendar

    -------------- I get this error --------------

    The default Web access mode for this project is set to file share,
    but the project folder at 'http://jws.nowhere.local/calendar' cannot
    be opned with the path '\\server1\jws$\calendar'. The error
    returned was:

    Unable to create Web project 'calendar'. The file path
    '\\server1\jws$\calendar' does not correspond to the URL
    'http://jws.nowhere.local/calendar'. the two need to map to the
    same server location

    -------------- error --------------

    The file path and the URL do point to the same location. What do I
    need to do to get this setup correctly?

    Sam
    Sam Carleton, Aug 24, 2003
    #1
    1. Advertising

  2. "Sam Carleton" <> wrote in message
    news:kY92b.30480$...
    > I am trying to figure out how to get VS.Net and IIS6 to work
    > together... I am working in domain nowhere.local. I have a W2K3
    > server named server1.nowhere.local that is running IIS6. I want it
    > to host a web site named jws.nowhere.local. Within II6 of server1,
    > I created a new web site as to allow one to serf to
    > jws.nowhere.local and see the simply default.htm doc. Then I have
    > shared that directories root such that the path to the default file
    > is: \\server1\jws$\default.html
    >
    > Then when I try to create a new ASP.NET Web Application:
    >
    > http://jws.nowhere.local/calendar
    >
    > With a file share path of:
    >
    > \\server1\jws$\calendar
    >
    > -------------- I get this error --------------
    >
    > The default Web access mode for this project is set to file share,
    > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > be opned with the path '\\server1\jws$\calendar'. The error
    > returned was:
    >
    > Unable to create Web project 'calendar'. The file path
    > '\\server1\jws$\calendar' does not correspond to the URL
    > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > same server location
    >
    > -------------- error --------------
    >
    > The file path and the URL do point to the same location. What do I
    > need to do to get this setup correctly?


    In general, VS.NET wants to create web projects at
    http://localhost/webproject. It's not very good with anyplace else.
    --
    John Saunders
    Internet Engineer
    John Saunders, Aug 24, 2003
    #2
    1. Advertising

  3. Sam Carleton

    Rad Guest

    That's not really correct...

    Now back to Sam's question -- Sam, since you mention this is IIS6 you're
    dealing with... I also guess you might be using VS 2002... in which case,
    you will need to ensure that .tmp extension is allowed in IIS.

    VS places a file with .tmp extension in that file share, and then makes an
    HTTP request for that same name using that URL shown in the error. If it
    does not receive the same file, it throws the error you're seeing.

    ..tmp extension is prohibited in IIS6 by default, so you'll have to enable it
    first.

    PS. VS 2003 uses .htm extension, hence you would not run into this problem.
    If you're using 2003, then you'd probably need to double-check that the
    locations do really match.



    "John Saunders" <> wrote in message
    news:...
    > "Sam Carleton" <> wrote in message
    > news:kY92b.30480$...
    > > I am trying to figure out how to get VS.Net and IIS6 to work
    > > together... I am working in domain nowhere.local. I have a W2K3
    > > server named server1.nowhere.local that is running IIS6. I want it
    > > to host a web site named jws.nowhere.local. Within II6 of server1,
    > > I created a new web site as to allow one to serf to
    > > jws.nowhere.local and see the simply default.htm doc. Then I have
    > > shared that directories root such that the path to the default file
    > > is: \\server1\jws$\default.html
    > >
    > > Then when I try to create a new ASP.NET Web Application:
    > >
    > > http://jws.nowhere.local/calendar
    > >
    > > With a file share path of:
    > >
    > > \\server1\jws$\calendar
    > >
    > > -------------- I get this error --------------
    > >
    > > The default Web access mode for this project is set to file share,
    > > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > > be opned with the path '\\server1\jws$\calendar'. The error
    > > returned was:
    > >
    > > Unable to create Web project 'calendar'. The file path
    > > '\\server1\jws$\calendar' does not correspond to the URL
    > > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > > same server location
    > >
    > > -------------- error --------------
    > >
    > > The file path and the URL do point to the same location. What do I
    > > need to do to get this setup correctly?

    >
    > In general, VS.NET wants to create web projects at
    > http://localhost/webproject. It's not very good with anyplace else.
    > --
    > John Saunders
    > Internet Engineer
    >
    >
    >
    Rad, Aug 24, 2003
    #3
  4. Strange I have projects in all sorts of places and VSNet has absolutely no
    problems at all managing them.


    "John Saunders" <> wrote in message
    news:...
    > "Sam Carleton" <> wrote in message
    > news:kY92b.30480$...
    > > I am trying to figure out how to get VS.Net and IIS6 to work
    > > together... I am working in domain nowhere.local. I have a W2K3
    > > server named server1.nowhere.local that is running IIS6. I want it
    > > to host a web site named jws.nowhere.local. Within II6 of server1,
    > > I created a new web site as to allow one to serf to
    > > jws.nowhere.local and see the simply default.htm doc. Then I have
    > > shared that directories root such that the path to the default file
    > > is: \\server1\jws$\default.html
    > >
    > > Then when I try to create a new ASP.NET Web Application:
    > >
    > > http://jws.nowhere.local/calendar
    > >
    > > With a file share path of:
    > >
    > > \\server1\jws$\calendar
    > >
    > > -------------- I get this error --------------
    > >
    > > The default Web access mode for this project is set to file share,
    > > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > > be opned with the path '\\server1\jws$\calendar'. The error
    > > returned was:
    > >
    > > Unable to create Web project 'calendar'. The file path
    > > '\\server1\jws$\calendar' does not correspond to the URL
    > > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > > same server location
    > >
    > > -------------- error --------------
    > >
    > > The file path and the URL do point to the same location. What do I
    > > need to do to get this setup correctly?

    >
    > In general, VS.NET wants to create web projects at
    > http://localhost/webproject. It's not very good with anyplace else.
    > --
    > John Saunders
    > Internet Engineer
    >
    >
    >
    Jason \(MFT1\), Aug 24, 2003
    #4
  5. Rad,
    How do you make .tmp extension allowed in IIS? Mapping?



    "Rad" <> wrote in message
    news:sva2b.19846$...
    > That's not really correct...
    >
    > Now back to Sam's question -- Sam, since you mention this is IIS6 you're
    > dealing with... I also guess you might be using VS 2002... in which case,
    > you will need to ensure that .tmp extension is allowed in IIS.
    >
    > VS places a file with .tmp extension in that file share, and then makes an
    > HTTP request for that same name using that URL shown in the error. If it
    > does not receive the same file, it throws the error you're seeing.
    >
    > .tmp extension is prohibited in IIS6 by default, so you'll have to enable

    it
    > first.
    >
    > PS. VS 2003 uses .htm extension, hence you would not run into this

    problem.
    > If you're using 2003, then you'd probably need to double-check that the
    > locations do really match.
    >
    >
    >
    > "John Saunders" <> wrote in message
    > news:...
    > > "Sam Carleton" <> wrote in message
    > > news:kY92b.30480$...
    > > > I am trying to figure out how to get VS.Net and IIS6 to work
    > > > together... I am working in domain nowhere.local. I have a W2K3
    > > > server named server1.nowhere.local that is running IIS6. I want it
    > > > to host a web site named jws.nowhere.local. Within II6 of server1,
    > > > I created a new web site as to allow one to serf to
    > > > jws.nowhere.local and see the simply default.htm doc. Then I have
    > > > shared that directories root such that the path to the default file
    > > > is: \\server1\jws$\default.html
    > > >
    > > > Then when I try to create a new ASP.NET Web Application:
    > > >
    > > > http://jws.nowhere.local/calendar
    > > >
    > > > With a file share path of:
    > > >
    > > > \\server1\jws$\calendar
    > > >
    > > > -------------- I get this error --------------
    > > >
    > > > The default Web access mode for this project is set to file share,
    > > > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > > > be opned with the path '\\server1\jws$\calendar'. The error
    > > > returned was:
    > > >
    > > > Unable to create Web project 'calendar'. The file path
    > > > '\\server1\jws$\calendar' does not correspond to the URL
    > > > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > > > same server location
    > > >
    > > > -------------- error --------------
    > > >
    > > > The file path and the URL do point to the same location. What do I
    > > > need to do to get this setup correctly?

    > >
    > > In general, VS.NET wants to create web projects at
    > > http://localhost/webproject. It's not very good with anyplace else.
    > > --
    > > John Saunders
    > > Internet Engineer
    > >
    > >
    > >

    >
    >
    MS News \(MS ILM\), Aug 24, 2003
    #5
  6. This is the information I got from Microsoft when fighting this battle. I'm
    only repeating it.
    --
    John Saunders
    Internet Engineer


    "Jason (MFT1)" <> wrote in message
    news:...
    > Strange I have projects in all sorts of places and VSNet has absolutely no
    > problems at all managing them.
    >
    >
    > "John Saunders" <> wrote in message
    > news:...
    > > "Sam Carleton" <> wrote in message
    > > news:kY92b.30480$...
    > > > I am trying to figure out how to get VS.Net and IIS6 to work
    > > > together... I am working in domain nowhere.local. I have a W2K3
    > > > server named server1.nowhere.local that is running IIS6. I want it
    > > > to host a web site named jws.nowhere.local. Within II6 of server1,
    > > > I created a new web site as to allow one to serf to
    > > > jws.nowhere.local and see the simply default.htm doc. Then I have
    > > > shared that directories root such that the path to the default file
    > > > is: \\server1\jws$\default.html
    > > >
    > > > Then when I try to create a new ASP.NET Web Application:
    > > >
    > > > http://jws.nowhere.local/calendar
    > > >
    > > > With a file share path of:
    > > >
    > > > \\server1\jws$\calendar
    > > >
    > > > -------------- I get this error --------------
    > > >
    > > > The default Web access mode for this project is set to file share,
    > > > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > > > be opned with the path '\\server1\jws$\calendar'. The error
    > > > returned was:
    > > >
    > > > Unable to create Web project 'calendar'. The file path
    > > > '\\server1\jws$\calendar' does not correspond to the URL
    > > > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > > > same server location
    > > >
    > > > -------------- error --------------
    > > >
    > > > The file path and the URL do point to the same location. What do I
    > > > need to do to get this setup correctly?

    > >
    > > In general, VS.NET wants to create web projects at
    > > http://localhost/webproject. It's not very good with anyplace else.
    > > --
    > > John Saunders
    > > Internet Engineer
    > >
    > >
    > >

    >
    >
    John Saunders, Aug 24, 2003
    #6
  7. Sam Carleton

    Sam Carleton Guest

    On Sun, 24 Aug 2003 at 22:14 GMT, MS News (MS ILM) wrote:

    > How do you make .tmp extension allowed in IIS? Mapping?


    I just did some digging around and discovered that all you have to
    do is add .tmp to the MIME types of the server. In other words,
    open up properties on the server, click on the MIME Types... button
    and add .tmp.

    Sam
    Sam Carleton, Aug 25, 2003
    #7
  8. Sam Carleton

    Rad Guest

    This one sucks :) It's actually a bug in VS... you DO have permissions --
    you can confirm that by adding another type of file to the project (say an
    xml file.. or something like that.. whatever's available on the menu)

    I think there was a fix for it... you can call into support to request it
    (no charge of course).

    Optionally, you can use FrontPage Server Extensions instead -- they don't
    exhibit this particular problem.


    "Sam Carleton" <> wrote in message
    news:EHr2b.82135$...
    > Rad,
    >
    > Ok,
    >
    > I have moved onto the next step of my project and run into more
    > problems. I am simply trying to create a new webform and I am
    > getting an error:
    >
    > Directory does not have write permission.
    >
    > When I am on the development machine, I am able to create a new file
    > in \\server1\jws$\calendar. Where do I lack write permission? How
    > do I fix it?
    >
    > Sam
    >
    > On Sun, 24 Aug 2003 at 21:55 GMT, Rad wrote:
    > > That's not really correct...
    > >
    > > Now back to Sam's question -- Sam, since you mention this is IIS6 you're
    > > dealing with... I also guess you might be using VS 2002... in which

    case,
    > > you will need to ensure that .tmp extension is allowed in IIS.
    > >
    > > VS places a file with .tmp extension in that file share, and then makes

    an
    > > HTTP request for that same name using that URL shown in the error. If

    it
    > > does not receive the same file, it throws the error you're seeing.
    > >
    > > .tmp extension is prohibited in IIS6 by default, so you'll have to

    enable it
    > > first.
    > >
    > > PS. VS 2003 uses .htm extension, hence you would not run into this

    problem.
    > > If you're using 2003, then you'd probably need to double-check that the
    > > locations do really match.
    > >
    > >
    > >
    > > "John Saunders" <> wrote in message
    > > news:...
    > >> "Sam Carleton" <> wrote in message
    > >> news:kY92b.30480$...
    > >> > I am trying to figure out how to get VS.Net and IIS6 to work
    > >> > together... I am working in domain nowhere.local. I have a W2K3
    > >> > server named server1.nowhere.local that is running IIS6. I want it
    > >> > to host a web site named jws.nowhere.local. Within II6 of server1,
    > >> > I created a new web site as to allow one to serf to
    > >> > jws.nowhere.local and see the simply default.htm doc. Then I have
    > >> > shared that directories root such that the path to the default file
    > >> > is: \\server1\jws$\default.html
    > >> >
    > >> > Then when I try to create a new ASP.NET Web Application:
    > >> >
    > >> > http://jws.nowhere.local/calendar
    > >> >
    > >> > With a file share path of:
    > >> >
    > >> > \\server1\jws$\calendar
    > >> >
    > >> > -------------- I get this error --------------
    > >> >
    > >> > The default Web access mode for this project is set to file share,
    > >> > but the project folder at 'http://jws.nowhere.local/calendar' cannot
    > >> > be opned with the path '\\server1\jws$\calendar'. The error
    > >> > returned was:
    > >> >
    > >> > Unable to create Web project 'calendar'. The file path
    > >> > '\\server1\jws$\calendar' does not correspond to the URL
    > >> > 'http://jws.nowhere.local/calendar'. the two need to map to the
    > >> > same server location
    > >> >
    > >> > -------------- error --------------
    > >> >
    > >> > The file path and the URL do point to the same location. What do I
    > >> > need to do to get this setup correctly?
    > >>
    > >> In general, VS.NET wants to create web projects at
    > >> http://localhost/webproject. It's not very good with anyplace else.
    > >> --
    > >> John Saunders
    > >> Internet Engineer
    > >>
    > >>
    > >>

    > >
    > >

    >
    >
    > --
    > See my links engine for a collection of sites that
    > might be of interest to you. Your additions will
    > make this engine more powerful global resource.
    > http://www.miltonstreet.com/scarleton/links/
    Rad, Aug 26, 2003
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Patrick Spence
    Replies:
    2
    Views:
    2,266
    Patrick Spence
    Nov 20, 2003
  2. soni29
    Replies:
    0
    Views:
    337
    soni29
    Nov 30, 2003
  3. Chianti73
    Replies:
    0
    Views:
    371
    Chianti73
    Dec 12, 2003
  4. =?Utf-8?B?Sm9uOTY=?=

    Web Access Error when creating a new ASP.NET project...

    =?Utf-8?B?Sm9uOTY=?=, Jan 13, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    551
    John Soulis [MSFT]
    Jan 14, 2004
  5. Timbit
    Replies:
    2
    Views:
    480
    Justnew
    Jan 30, 2004
Loading...

Share This Page