'current custom error settings for application prevent details of application error from being viewe

Discussion in 'ASP .Net' started by Damian, Dec 30, 2003.

  1. Damian

    Damian Guest

    Hi everyone

    I'm having an issue with one of our applications. I'm getting the
    following error when attempting to log in to the site:

    Server Error in 'xxxxxxxxxxxxxxxx' Application.
    --------------------------------------------------------------------------------

    Runtime Error
    Description: An application error occurred on the server. The current
    custom error settings for this application prevent the details of the
    application error from being viewed.

    Details: To enable the details of this specific error message to be
    viewable on the local server machine, please create a <customErrors>
    tag within a "web.config" configuration file located in the root
    directory of the current web application. This <customErrors> tag
    should then have its "mode" attribute set to "RemoteOnly". To enable
    the details to be viewable on remote machines, please set "mode" to
    "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a
    custom error page by modifying the "defaultRedirect" attribute of the
    application's <customErrors> configuration tag to point to a custom
    error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    The customErrors setting appears to make no difference, whether it's
    the one on the machine.config file (.NET FWK 1.0) or the one on the
    application's web.config file, or both, or any of the combinations
    I've tried. The error stays the same

    As I mention the current .NET version on the system is 1.0, however by
    mistake I first installed (and uninstalled) the newer 1.1 version.

    The machine is a W2K domain controller and the user I'm logging in to
    the application with has been granted admin rights. The ProcessModel
    line on the machine.config file is set to 'SYSTEM', and security on
    IIS is set to Basic for the application. 'Impersonate' is set to True.

    I checked the application mappings part of the Configuration dialog
    for the application and the Microsoft .NET Framework entries are
    pointing to the proper (installed) version.

    I'm really not sure what else to check and I really need to get this
    going. I'll appreciate any and all help you could give me.

    Thanks in advance, regards

    Damián
     
    Damian, Dec 30, 2003
    #1
    1. Advertising

  2. Hi Damian,

    The fact that a change in the web.config does not illicit a change in
    behavior means that we aren't successfully parsing the configuration file.
    We aren't getting that far.

    The easiest way to figure out what's going on would be to create a simple
    inline ASP.NET page and place it in the folder for the default Web site.
    (If there is a web.config there, rename it first to web.config.old or
    something.) Here's a sample file you can use. Just paste this into an
    empty file and save it as test.aspx:

    <%@ Page Language="C#" %>
    <script runat="server">

    private void Page_Load(object sender, System.EventArgs e) {
    lblWho.Text = "ASP.NET running as : " +
    System.Security.Principal.WindowsIdentity.GetCurrent().Name;
    }

    </script>
    <html>
    <head>
    </head>
    <body>
    <form runat="server">
    <asp:Label id="lblWho" runat="server">Label</asp:Label>
    </form>
    </body>
    </html>


    Jim Cheshire, MCSE, MCSD [MSFT]
    ASP.NET Developer Support

    This post is provided "as-is" and confers no rights.


    --------------------
    >From: (Damian)
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Subject: 'current custom error settings for application prevent details of

    application error from being viewed. '
    >Date: 30 Dec 2003 07:54:47 -0800
    >Organization: http://groups.google.com
    >Lines: 68
    >Message-ID: <>
    >NNTP-Posting-Host: 200.80.152.107
    >Content-Type: text/plain; charset=ISO-8859-1
    >Content-Transfer-Encoding: 8bit
    >X-Trace: posting.google.com 1072799687 32106 127.0.0.1 (30 Dec 2003

    15:54:47 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Tue, 30 Dec 2003 15:54:47 +0000 (UTC)
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTNGXA05.phx.gbl!TK2MSFTNGP08
    ..phx.gbl!newsfeed00.sul.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fj
    serv.net!news.maxwell.syr.edu!postnews1.google.com!not-for-mail
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198864
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >Hi everyone
    >
    >I'm having an issue with one of our applications. I'm getting the
    >following error when attempting to log in to the site:
    >
    >Server Error in 'xxxxxxxxxxxxxxxx' Application.
    >---------------------------------------------------------------------------

    -----
    >
    >Runtime Error
    >Description: An application error occurred on the server. The current
    >custom error settings for this application prevent the details of the
    >application error from being viewed.
    >
    >Details: To enable the details of this specific error message to be
    >viewable on the local server machine, please create a <customErrors>
    >tag within a "web.config" configuration file located in the root
    >directory of the current web application. This <customErrors> tag
    >should then have its "mode" attribute set to "RemoteOnly". To enable
    >the details to be viewable on remote machines, please set "mode" to
    >"Off".
    >
    >
    ><!-- Web.Config Configuration File -->
    >
    ><configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"/>
    > </system.web>
    ></configuration>
    >
    >
    >Notes: The current error page you are seeing can be replaced by a
    >custom error page by modifying the "defaultRedirect" attribute of the
    >application's <customErrors> configuration tag to point to a custom
    >error page URL.
    >
    >
    ><!-- Web.Config Configuration File -->
    >
    ><configuration>
    > <system.web>
    > <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    > </system.web>
    ></configuration>
    >- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    >The customErrors setting appears to make no difference, whether it's
    >the one on the machine.config file (.NET FWK 1.0) or the one on the
    >application's web.config file, or both, or any of the combinations
    >I've tried. The error stays the same
    >
    >As I mention the current .NET version on the system is 1.0, however by
    >mistake I first installed (and uninstalled) the newer 1.1 version.
    >
    >The machine is a W2K domain controller and the user I'm logging in to
    >the application with has been granted admin rights. The ProcessModel
    >line on the machine.config file is set to 'SYSTEM', and security on
    >IIS is set to Basic for the application. 'Impersonate' is set to True.
    >
    >I checked the application mappings part of the Configuration dialog
    >for the application and the Microsoft .NET Framework entries are
    >pointing to the proper (installed) version.
    >
    >I'm really not sure what else to check and I really need to get this
    >going. I'll appreciate any and all help you could give me.
    >
    >Thanks in advance, regards
    >
    >Damián
    >
     
    Jim Cheshire [MSFT], Dec 30, 2003
    #2
    1. Advertising

  3. Damian

    BruceJohnson Guest

    As another possible way to diagnose web.config problems, trying running
    the web site though VS.NET using the Start without Debugging (Ctrl-F5)
    option. That causes the errors associated with web.config to be
    displayed (within the restrictions of remote debugging, of course).

    HTH

    Bruce Johnson
    http://www.ObjectSharp.com/Bruce

    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    BruceJohnson, Dec 30, 2003
    #3
  4. Bruce,

    That's not going to help here. We shouldn't be attempting to attach a
    debugger anyway. In this scenario, the user is simply browsing to the
    ASP.NET application. If there is something wrong with the ASP.NET worker
    process running the app and the app domain loading, you will get this
    error. It really isn't related to the web.config file. There's an problem
    somewhere else.

    Jim Cheshire, MCSE, MCSD [MSFT]
    Microsoft Developer Support
    ASP.NET


    This post is provided as-is with no warranties and confers no rights.

    --------------------
    >From: BruceJohnson <>
    >References: <>
    >X-Newsreader: AspNNTP 1.50 (ActionJackson.com)
    >Subject: RE: 'current custom error settings for application prevent

    details of application error from being viewed. '
    >Mime-Version: 1.0
    >Content-Type: text/plain; charset="us-ascii"
    >Content-Transfer-Encoding: 7bit
    >Message-ID: <>
    >Newsgroups: microsoft.public.dotnet.framework.aspnet
    >Date: Tue, 30 Dec 2003 09:50:05 -0800
    >NNTP-Posting-Host: actionjackson133.dsl.frii.net 216.17.147.133
    >Lines: 1
    >Path:

    cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!cpmsftngxa09.phx.gbl!TK2MSFTNGP08.
    phx.gbl!TK2MSFTNGP11.phx.gbl
    >Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:198912
    >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    >
    >As another possible way to diagnose web.config problems, trying running
    >the web site though VS.NET using the Start without Debugging (Ctrl-F5)
    >option. That causes the errors associated with web.config to be
    >displayed (within the restrictions of remote debugging, of course).
    >
    >HTH
    >
    >Bruce Johnson
    >http://www.ObjectSharp.com/Bruce
    >
    >*** Sent via Developersdex http://www.developersdex.com ***
    >Don't just participate in USENET...get rewarded for it!
    >
     
    Jim Cheshire [MSFT], Dec 30, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Stephen Adam
    Replies:
    1
    Views:
    940
    Scott Allen
    Nov 14, 2004
  2. =?Utf-8?B?Sm9l?=

    Show Details/Hide Details link button

    =?Utf-8?B?Sm9l?=, Mar 13, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    911
    dkode
    Mar 13, 2006
  3. helveticus
    Replies:
    0
    Views:
    382
    helveticus
    Aug 27, 2008
  4. donet programmer
    Replies:
    3
    Views:
    1,555
    Gregory A. Beamer
    Nov 20, 2009
  5. Julien
    Replies:
    1
    Views:
    165
    Steven D'Aprano
    Aug 28, 2011
Loading...

Share This Page