Custom App Pool & Windows Auth causing Login prompt to appear

Discussion in 'ASP .Net Security' started by Craig M, Apr 18, 2006.

  1. Craig M

    Craig M Guest

    Hi All,

    First post - i've searched high and low for an answer and cannot find one
    anywhere.

    Using IIS6, Windows Server 2003, ASP.Net 1.1

    I have a web app that uses a Custom App Pool which runs under a domain user
    login. This user is a member of IIS_WPG and also Users. The app runs with
    only Windows Authentication selected. I run the same setup on a UAT machine
    and everything runs fine. When I move to production whenever I try to access
    the website I am presented with a Login prompt as though the app is using
    Basic Authentication.

    There is one noticeable difference between the two machines. The UAT box has
    each website setup individually. The Production box has Default Web Site and
    then my Web Site setup under this. The application logs on fine using Windows
    Authentication when it is set to run under the Default App Pool so this
    proves the machines are on the same domain. There are no '.' in the URL so
    the client knows that the site is intranet based.

    I'm pulling my hair out, I think it might be permissions but everything is
    setup the same on each box, bar default web site part. Any help greatly
    appreciated.

    Thanks

    Craig
     
    Craig M, Apr 18, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?Q2hyaXMgTW9oYW4=?=

    Configuring Windows Auth & Forms Auth in Asp.Net

    =?Utf-8?B?Q2hyaXMgTW9oYW4=?=, Apr 28, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    706
    =?Utf-8?B?Q2hyaXMgTW9oYW4=?=
    Apr 28, 2004
  2. =?Utf-8?B?ZGhucml2ZXJzaWRl?=

    Windows Auth, but Forms Auth for one page?

    =?Utf-8?B?ZGhucml2ZXJzaWRl?=, Jan 8, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    569
    Elton Wang
    Jan 8, 2005
  3. Chris Mohan

    Configuring Windows Auth & Forms Auth in Asp.Net

    Chris Mohan, Apr 28, 2004, in forum: ASP .Net Security
    Replies:
    2
    Views:
    433
    Chris Mohan
    Apr 29, 2004
  4. Forms Auth Info passed to Windows Auth?

    , Apr 28, 2005, in forum: ASP .Net Security
    Replies:
    1
    Views:
    222
    Hernan de Lahitte
    May 3, 2005
  5. Ed Staffin
    Replies:
    1
    Views:
    356
    Ken Schaefer
    Apr 17, 2006
Loading...

Share This Page