<customErrors mode="Off"/> ERROR

Discussion in 'ASP .Net Web Controls' started by Savas Ates, Dec 19, 2005.

  1. Savas Ates

    Savas Ates Guest

    I have a web application It works well in my local folder.. When i upload
    it
    to my web server i got

    To enable the details of this specific error message to be viewable on
    remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".




    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".
    Savas Ates, Dec 19, 2005
    #1
    1. Advertising

  2. Savas Ates

    Guest

    It means you application crashes on the server. Put the
    customerrors-tag as listed in the web.config-file to see the
    error-output.

    Regards,
    Sjur Rondestveit
    , Dec 19, 2005
    #2
    1. Advertising

  3. Hi,

    Usually when a web project works on a local machine but not on your
    web host you are missing a dll referenced. I would check and make sure all
    the dll files in your projects bin folder are on the bin folder on your web
    host. Also adding that line to your web.config on your web host will give
    you a lot more information about the error.

    Ken
    -------------
    "Savas Ates" <> wrote in message
    news:eZ$...
    > I have a web application It works well in my local folder.. When i upload
    > it
    > to my web server i got
    >
    > To enable the details of this specific error message to be viewable on
    > remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    >
    >
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current
    > custom error settings for this application prevent the details of the
    > application error from being viewed remotely (for security reasons). It
    > could, however, be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    >
    Ken Tucker [MVP], Dec 19, 2005
    #3
  4. Savas Ates

    Savas Ates Guest

    I copied all bin directory with dll's.. There is no problem about missing
    files.. It is my web server. I have full access to change whatever i want ..
    By the way what you mean

    << Put the
    customerrors-tag as listed in the web.config-file to see the
    error-output.

    my web.config file
    <customErrors mode="Off" />



    any solution ?



    "Savas Ates" <>, haber iletisinde þunlarý
    yazdý:eZ$...
    > I have a web application It works well in my local folder.. When i upload
    > it
    > to my web server i got
    >
    > To enable the details of this specific error message to be viewable on
    > remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    >
    >
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current
    > custom error settings for this application prevent the details of the
    > application error from being viewed remotely (for security reasons). It
    > could, however, be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    >
    Savas Ates, Dec 19, 2005
    #4
  5. Savas Ates

    Greg Burns Guest

    Isn't "Server Error in '/' Application" idicative of the virtual directory
    not being marked as an application in IIS?

    PS: I've also seen the <customErrors> message even when it is set to Off,
    whenever there is a syntax error in the web.config.

    Greg


    "Savas Ates" <> wrote in message
    news:eZ$...
    > I have a web application It works well in my local folder.. When i upload
    > it
    > to my web server i got
    >
    > To enable the details of this specific error message to be viewable on
    > remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    >
    >
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current
    > custom error settings for this application prevent the details of the
    > application error from being viewed remotely (for security reasons). It
    > could, however, be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    >
    Greg Burns, Dec 19, 2005
    #5
  6. Savas Ates

    Guest

    do exactly what the error tells you. open the web.config
    and change
    <customErrors
    mode="RemoteOnly"
    />

    to <customErrors
    mode="Off"
    />


    thou shalt google before asking...

    Savas Ates wrote:
    > I copied all bin directory with dll's.. There is no problem about missing
    > files.. It is my web server. I have full access to change whatever i want..
    > By the way what you mean
    >
    > << Put the
    > customerrors-tag as listed in the web.config-file to see the
    > error-output.
    >
    > my web.config file
    > <customErrors mode="Off" />
    >
    >
    >
    > any solution ?
    >
    >
    >
    > "Savas Ates" <>, haber iletisinde þunlarý
    > yazdý:eZ$...
    > > I have a web application It works well in my local folder.. When i upload
    > > it
    > > to my web server i got
    > >
    > > To enable the details of this specific error message to be viewable on
    > > remote machines, please create a <customErrors> tag within a "web.config"
    > > configuration file located in the root directory of the current web
    > > application. This <customErrors> tag should then have its "mode" attribute
    > > set to "Off".
    > >
    > >
    > >
    > >
    > > Server Error in '/' Application.
    > > --------------------------------------------------------------------------------
    > >
    > > Runtime Error
    > > Description: An application error occurred on the server. The current
    > > custom error settings for this application prevent the details of the
    > > application error from being viewed remotely (for security reasons). It
    > > could, however, be viewed by browsers running on the local server machine.
    > >
    > > Details: To enable the details of this specific error message to be
    > > viewable on remote machines, please create a <customErrors> tag within a
    > > "web.config" configuration file located in the root directory of the
    > > current web application. This <customErrors> tag should then have its
    > > "mode" attribute set to "Off".
    > >
    > >
    , Dec 19, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Greg Burns

    Re: <customErrors mode="Off" />

    Greg Burns, Sep 9, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    3,870
    Greg Burns
    Sep 9, 2004
  2. Bruno Piovan

    Re: <customErrors mode="Off" />

    Bruno Piovan, Sep 10, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    447
    JustMe
    Oct 4, 2004
  3. Julia
    Replies:
    4
    Views:
    10,297
    Dan Linn
    Jun 29, 2005
  4. Savas Ates

    <customErrors mode="Off"/> ERROR

    Savas Ates, Dec 19, 2005, in forum: ASP .Net
    Replies:
    6
    Views:
    19,634
    lcpriya
    Jul 15, 2006
  5. Savas Ates

    <customErrors mode="Off"/> ERROR

    Savas Ates, Dec 19, 2005, in forum: ASP .Net Web Services
    Replies:
    5
    Views:
    218
Loading...

Share This Page