customErrors mode="Off" not working

Discussion in 'ASP General' started by Cam, Jan 29, 2009.

  1. Cam

    Cam Guest

    On one of our web sites, we want detailed errors to appear on remote browsers.

    The web.config of the application and the web.config in all parent folders
    up to the web site root and the machine.config all contain a <customErrors>
    block where the mode property is set to "off".

    In ASP.NET 1.1, we see the detailed error only when running the browser on
    the same machine as the web server. On any other computer, all we get (from a
    test app that intentionally generates a 500.19) is "The page cannot be
    displayed because an internal server error has occurred."
    What other settings need to be set?
    Cam, Jan 29, 2009
    #1
    1. Advertising

  2. Gazing into my crystal ball I observed =?Utf-8?B?Q2Ft?=
    <> writing in
    news::

    > On one of our web sites, we want detailed errors to appear on remote
    > browsers.
    >
    > The web.config of the application and the web.config in all parent
    > folders up to the web site root and the machine.config all contain a
    > <customErrors> block where the mode property is set to "off".
    >
    > In ASP.NET 1.1, we see the detailed error only when running the
    > browser on the same machine as the web server. On any other computer,
    > all we get (from a test app that intentionally generates a 500.19) is
    > "The page cannot be displayed because an internal server error has
    > occurred." What other settings need to be set?


    There was no way for you to know it (except maybe by browsing through
    some of the previous questions before posting yours - always a
    recommended practice), but this is a classic (COM-based) asp newsgroup.
    ASP.Net is a different technology from classic ASP. While you may be
    lucky enough to find a dotnet-savvy person here who can answer your
    question, you can eliminate the luck factor by posting your question to
    a newsgroup where the dotnet-savvy people hang out. I suggest

    microsoft.public.dotnet.framework.aspnet.

    There are also forums at www.asp.net where you can find a lot of people
    to help you.

    (Thanks, Bob)

    --
    Adrienne Boswell at Home
    Arbpen Web Site Design Services
    http://www.cavalcade-of-coding.info
    Please respond to the group so others can share
    Adrienne Boswell, Jan 29, 2009
    #2
    1. Advertising

  3. Cam

    Cam Guest

    I appreciate the tip!
    Cam, Jan 30, 2009
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Greg Burns

    Re: <customErrors mode="Off" />

    Greg Burns, Sep 9, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    3,870
    Greg Burns
    Sep 9, 2004
  2. Julia
    Replies:
    4
    Views:
    10,297
    Dan Linn
    Jun 29, 2005
  3. Beemer Biker

    not working: <customErrors mode="Off"/>

    Beemer Biker, Jan 24, 2007, in forum: ASP .Net
    Replies:
    2
    Views:
    1,027
    bruce barker
    Jan 24, 2007
  4. Andy Fish

    customErrors mode="Off" does not work

    Andy Fish, Mar 31, 2008, in forum: ASP .Net
    Replies:
    1
    Views:
    643
    Alvin Bruney [ASP.NET MVP]
    Apr 2, 2008
  5. Cam
    Replies:
    0
    Views:
    1,011
Loading...

Share This Page