Data Access Vista/IIS&/Access2000

Discussion in 'ASP General' started by hugh welford, Aug 26, 2007.

  1. hugh welford

    hugh welford Guest

    Hi

    Have just installed IIS7 on Vista and am trying to access a .mdb file
    through ASP. Getting server error.

    I think the problem is in the file permission. Under XP Pro/IIS6 is used to
    have to set the .mdb file security via windows explorer to give
    IUSR_machinename full permissions on this file for anonymous web access.

    Cant seem to do this with Vista explorer - says object cannot be found.

    Also, getting conflicting statements from IIS Help - it tells me firstly
    that

    a. By default, IIS 7.0 uses IUSR as the account for anonymous access.
    This account is created when you install IIS 7.0.

    and then

    b. Similarly, a new Windows built-in account named IUSRS replaces the
    local IUSR_MachineName anonymous account from IIS 6.0.

    Anyway, whatever syntax I use, I cant seem to add anonymous web user
    permission to daters.mdb via the security tab in Windown Explorer.

    Any help greatly appreciated - getting very frustrated

    Thanks

    Hugh
     
    hugh welford, Aug 26, 2007
    #1
    1. Advertising

  2. "hugh welford" <> wrote in message
    news:%...
    > Hi
    >
    > Have just installed IIS7 on Vista and am trying to access a .mdb file
    > through ASP. Getting server error.


    I know this is a Microsoft group and I'll get shot down for saying this,
    but...

    1. Remove Vista
    2. Revert to XP Pro (or preferably Server 2003)
    3. Wait 18 months to 2 years for sufficient servicepacks to render Vista
    usable.

    Past experience has shown (think back even to MS-DOS 4) that you should
    never trust a new operating system for any critical use. Might be great for
    games, but wait 'til it's had at least the major failings ironed out before
    using it for work.

    --
    Bob Milutinovic
    Cognicom - "Australia's Web Presence Specialists"
    http://www.cognicom.net.au/
    telephone (0417) 45-77-66
    facsimile (02) 9824-2240
     
    Bob Milutinovic, Aug 27, 2007
    #2
    1. Advertising

  3. hugh welford wrote:
    > Hi
    >
    > Have just installed IIS7 on Vista and am trying to access a .mdb file
    > through ASP. Getting server error.
    >


    Huh? What is the error message?

    > I think the problem is in the file permission.


    Why? Does the error message give you a clue?
    If it IS a file permission error, you need to figure out how to assign
    Modify permissions for the folder containing the file to ALL users of the
    database file. Try posting to a Vista group for help with that, or maybe
    someone in the iis group will be able to help.

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows [MVP], Aug 27, 2007
    #3
  4. hugh welford

    hugh welford Guest

    thanks Bob - already thinking along these lines

    hugh


    "Bob Milutinovic" <> wrote in message
    news:%...
    > "hugh welford" <> wrote in message
    > news:%...
    >> Hi
    >>
    >> Have just installed IIS7 on Vista and am trying to access a .mdb file
    >> through ASP. Getting server error.

    >
    > I know this is a Microsoft group and I'll get shot down for saying this,
    > but...
    >
    > 1. Remove Vista
    > 2. Revert to XP Pro (or preferably Server 2003)
    > 3. Wait 18 months to 2 years for sufficient servicepacks to render Vista
    > usable.
    >
    > Past experience has shown (think back even to MS-DOS 4) that you should
    > never trust a new operating system for any critical use. Might be great
    > for games, but wait 'til it's had at least the major failings ironed out
    > before using it for work.
    >
    > --
    > Bob Milutinovic
    > Cognicom - "Australia's Web Presence Specialists"
    > http://www.cognicom.net.au/
    > telephone (0417) 45-77-66
    > facsimile (02) 9824-2240
    >
    >
     
    hugh welford, Aug 27, 2007
    #4
  5. hugh welford

    hugh welford Guest

    Hi Bob

    Thanks for reply.

    The error merssage is the non-specific "An error occurred on the server when
    processing the URL" - not much help is it?

    I am assuming that the error is a permissions problem, as I have not been
    able to set the full permissions for the file - hence the post. I will
    re-post in vista and iis groups as suggested - thanks.

    Hugh

    "Bob Barrows [MVP]" <> wrote in message
    news:...
    > hugh welford wrote:
    >> Hi
    >>
    >> Have just installed IIS7 on Vista and am trying to access a .mdb file
    >> through ASP. Getting server error.
    >>

    >
    > Huh? What is the error message?
    >
    >> I think the problem is in the file permission.

    >
    > Why? Does the error message give you a clue?
    > If it IS a file permission error, you need to figure out how to assign
    > Modify permissions for the folder containing the file to ALL users of the
    > database file. Try posting to a Vista group for help with that, or maybe
    > someone in the iis group will be able to help.
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
     
    hugh welford, Aug 27, 2007
    #5
  6. Well your first step should be to shut off "friendly errors".
    This can be done in IIS Manager and may also need to be done in the
    browser you are using.



    hugh welford wrote:
    > Hi Bob
    >
    > Thanks for reply.
    >
    > The error merssage is the non-specific "An error occurred on the
    > server when processing the URL" - not much help is it?
    >
    > I am assuming that the error is a permissions problem, as I have not
    > been able to set the full permissions for the file - hence the post.
    > I will re-post in vista and iis groups as suggested - thanks.
    >
    > Hugh
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:...
    >> hugh welford wrote:
    >>> Hi
    >>>
    >>> Have just installed IIS7 on Vista and am trying to access a .mdb
    >>> file through ASP. Getting server error.
    >>>

    >>
    >> Huh? What is the error message?
    >>
    >>> I think the problem is in the file permission.

    >>
    >> Why? Does the error message give you a clue?
    >> If it IS a file permission error, you need to figure out how to
    >> assign Modify permissions for the folder containing the file to ALL
    >> users of the database file. Try posting to a Vista group for help
    >> with that, or maybe someone in the iis group will be able to help.
    >>
    >> --
    >> Microsoft MVP - ASP/ASP.NET
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"


    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
     
    Bob Barrows [MVP], Aug 27, 2007
    #6
  7. hugh welford

    hugh welford Guest

    Thanks Bob.

    Made a few changes, and now getting unspecified error on trying to open a
    connection with the string

    cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
    Source=c:/access/brits/daters.mdb"

    Presume new Provider with Vista.

    Any idea what the correct string should be under Vista???

    Thanks

    Hugh


    "Bob Barrows [MVP]" <> wrote in message
    news:...
    > Well your first step should be to shut off "friendly errors".
    > This can be done in IIS Manager and may also need to be done in the
    > browser you are using.
    >
    >
    >
    > hugh welford wrote:
    >> Hi Bob
    >>
    >> Thanks for reply.
    >>
    >> The error merssage is the non-specific "An error occurred on the
    >> server when processing the URL" - not much help is it?
    >>
    >> I am assuming that the error is a permissions problem, as I have not
    >> been able to set the full permissions for the file - hence the post.
    >> I will re-post in vista and iis groups as suggested - thanks.
    >>
    >> Hugh
    >>
    >> "Bob Barrows [MVP]" <> wrote in message
    >> news:...
    >>> hugh welford wrote:
    >>>> Hi
    >>>>
    >>>> Have just installed IIS7 on Vista and am trying to access a .mdb
    >>>> file through ASP. Getting server error.
    >>>>
    >>>
    >>> Huh? What is the error message?
    >>>
    >>>> I think the problem is in the file permission.
    >>>
    >>> Why? Does the error message give you a clue?
    >>> If it IS a file permission error, you need to figure out how to
    >>> assign Modify permissions for the folder containing the file to ALL
    >>> users of the database file. Try posting to a Vista group for help
    >>> with that, or maybe someone in the iis group will be able to help.
    >>>
    >>> --
    >>> Microsoft MVP - ASP/ASP.NET
    >>> Please reply to the newsgroup. This email account is my spam trap so
    >>> I don't check it very often. If you must reply off-line, then remove
    >>> the "NO SPAM"

    >
    > --
    > Microsoft MVP -- ASP/ASP.NET
    > Please reply to the newsgroup. The email account listed in my From
    > header is my spam trap, so I don't check it very often. You will get a
    > quicker response by posting to the newsgroup.
    >
    >
     
    hugh welford, Aug 27, 2007
    #7
  8. No, there is no new provider for Vista per se.
    However, there IS a new provider for Access 2007 if that is what you are
    using. See www.connectionstrings.com

    hugh welford wrote:
    > Thanks Bob.
    >
    > Made a few changes, and now getting unspecified error on trying to
    > open a connection with the string
    >
    > cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
    > Source=c:/access/brits/daters.mdb"
    >
    > Presume new Provider with Vista.
    >
    > Any idea what the correct string should be under Vista???
    >
    > Thanks
    >
    > Hugh
    >
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:...
    >> Well your first step should be to shut off "friendly errors".
    >> This can be done in IIS Manager and may also need to be done in the
    >> browser you are using.
    >>
    >>
    >>
    >> hugh welford wrote:
    >>> Hi Bob
    >>>
    >>> Thanks for reply.
    >>>
    >>> The error merssage is the non-specific "An error occurred on the
    >>> server when processing the URL" - not much help is it?
    >>>
    >>> I am assuming that the error is a permissions problem, as I have not
    >>> been able to set the full permissions for the file - hence the post.
    >>> I will re-post in vista and iis groups as suggested - thanks.
    >>>
    >>> Hugh
    >>>
    >>> "Bob Barrows [MVP]" <> wrote in message
    >>> news:...
    >>>> hugh welford wrote:
    >>>>> Hi
    >>>>>
    >>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
    >>>>> file through ASP. Getting server error.
    >>>>>
    >>>>
    >>>> Huh? What is the error message?
    >>>>
    >>>>> I think the problem is in the file permission.
    >>>>
    >>>> Why? Does the error message give you a clue?
    >>>> If it IS a file permission error, you need to figure out how to
    >>>> assign Modify permissions for the folder containing the file to ALL
    >>>> users of the database file. Try posting to a Vista group for help
    >>>> with that, or maybe someone in the iis group will be able to help.
    >>>>
    >>>> --
    >>>> Microsoft MVP - ASP/ASP.NET
    >>>> Please reply to the newsgroup. This email account is my spam trap
    >>>> so I don't check it very often. If you must reply off-line, then
    >>>> remove the "NO SPAM"

    >>
    >> --
    >> Microsoft MVP -- ASP/ASP.NET
    >> Please reply to the newsgroup. The email account listed in my From
    >> header is my spam trap, so I don't check it very often. You will get
    >> a quicker response by posting to the newsgroup.


    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
     
    Bob Barrows [MVP], Aug 27, 2007
    #8
  9. hugh welford

    hugh welford Guest

    Thanks again, Bob.

    It was permissions after all - it appears the following must have full
    control permissions for IUSR and IIS_IUSRS accounts

    a. The .mdb file to be accessed
    b. C:\Windows\Temp
    c. C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp

    Hope this is useful

    Regards

    Hugh


    "Bob Barrows [MVP]" <> wrote in message
    news:...
    > No, there is no new provider for Vista per se.
    > However, there IS a new provider for Access 2007 if that is what you are
    > using. See www.connectionstrings.com
    >
    > hugh welford wrote:
    >> Thanks Bob.
    >>
    >> Made a few changes, and now getting unspecified error on trying to
    >> open a connection with the string
    >>
    >> cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
    >> Source=c:/access/brits/daters.mdb"
    >>
    >> Presume new Provider with Vista.
    >>
    >> Any idea what the correct string should be under Vista???
    >>
    >> Thanks
    >>
    >> Hugh
    >>
    >>
    >> "Bob Barrows [MVP]" <> wrote in message
    >> news:...
    >>> Well your first step should be to shut off "friendly errors".
    >>> This can be done in IIS Manager and may also need to be done in the
    >>> browser you are using.
    >>>
    >>>
    >>>
    >>> hugh welford wrote:
    >>>> Hi Bob
    >>>>
    >>>> Thanks for reply.
    >>>>
    >>>> The error merssage is the non-specific "An error occurred on the
    >>>> server when processing the URL" - not much help is it?
    >>>>
    >>>> I am assuming that the error is a permissions problem, as I have not
    >>>> been able to set the full permissions for the file - hence the post.
    >>>> I will re-post in vista and iis groups as suggested - thanks.
    >>>>
    >>>> Hugh
    >>>>
    >>>> "Bob Barrows [MVP]" <> wrote in message
    >>>> news:...
    >>>>> hugh welford wrote:
    >>>>>> Hi
    >>>>>>
    >>>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
    >>>>>> file through ASP. Getting server error.
    >>>>>>
    >>>>>
    >>>>> Huh? What is the error message?
    >>>>>
    >>>>>> I think the problem is in the file permission.
    >>>>>
    >>>>> Why? Does the error message give you a clue?
    >>>>> If it IS a file permission error, you need to figure out how to
    >>>>> assign Modify permissions for the folder containing the file to ALL
    >>>>> users of the database file. Try posting to a Vista group for help
    >>>>> with that, or maybe someone in the iis group will be able to help.
    >>>>>
    >>>>> --
    >>>>> Microsoft MVP - ASP/ASP.NET
    >>>>> Please reply to the newsgroup. This email account is my spam trap
    >>>>> so I don't check it very often. If you must reply off-line, then
    >>>>> remove the "NO SPAM"
    >>>
    >>> --
    >>> Microsoft MVP -- ASP/ASP.NET
    >>> Please reply to the newsgroup. The email account listed in my From
    >>> header is my spam trap, so I don't check it very often. You will get
    >>> a quicker response by posting to the newsgroup.

    >
    > --
    > Microsoft MVP -- ASP/ASP.NET
    > Please reply to the newsgroup. The email account listed in my From
    > header is my spam trap, so I don't check it very often. You will get a
    > quicker response by posting to the newsgroup.
    >
    >
     
    hugh welford, Aug 27, 2007
    #9
  10. "Full" permissions is overkill. All that is required is "Modify". The
    users do not need the ability to assign permissions. Always work from
    the standpoint of assigning the least level of permission required to
    perform the task. In this case, users need to be able to create, modify
    and delete a locking file to enable multi-user access to the mdb file.
    The only permission required for that is "Modify", known as "Read/Write"
    in some OSs.

    hugh welford wrote:
    > Thanks again, Bob.
    >
    > It was permissions after all - it appears the following must have full
    > control permissions for IUSR and IIS_IUSRS accounts
    >
    > a. The .mdb file to be accessed
    > b. C:\Windows\Temp
    > c. C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp
    >
    > Hope this is useful
    >
    > Regards
    >
    > Hugh
    >
    >
    > "Bob Barrows [MVP]" <> wrote in message
    > news:...
    >> No, there is no new provider for Vista per se.
    >> However, there IS a new provider for Access 2007 if that is what you
    >> are using. See www.connectionstrings.com
    >>
    >> hugh welford wrote:
    >>> Thanks Bob.
    >>>
    >>> Made a few changes, and now getting unspecified error on trying to
    >>> open a connection with the string
    >>>
    >>> cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
    >>> Source=c:/access/brits/daters.mdb"
    >>>
    >>> Presume new Provider with Vista.
    >>>
    >>> Any idea what the correct string should be under Vista???
    >>>
    >>> Thanks
    >>>
    >>> Hugh
    >>>
    >>>
    >>> "Bob Barrows [MVP]" <> wrote in message
    >>> news:...
    >>>> Well your first step should be to shut off "friendly errors".
    >>>> This can be done in IIS Manager and may also need to be done in the
    >>>> browser you are using.
    >>>>
    >>>>
    >>>>
    >>>> hugh welford wrote:
    >>>>> Hi Bob
    >>>>>
    >>>>> Thanks for reply.
    >>>>>
    >>>>> The error merssage is the non-specific "An error occurred on the
    >>>>> server when processing the URL" - not much help is it?
    >>>>>
    >>>>> I am assuming that the error is a permissions problem, as I have
    >>>>> not been able to set the full permissions for the file - hence
    >>>>> the post. I will re-post in vista and iis groups as suggested -
    >>>>> thanks.
    >>>>>
    >>>>> Hugh
    >>>>>
    >>>>> "Bob Barrows [MVP]" <> wrote in message
    >>>>> news:...
    >>>>>> hugh welford wrote:
    >>>>>>> Hi
    >>>>>>>
    >>>>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
    >>>>>>> file through ASP. Getting server error.
    >>>>>>>
    >>>>>>
    >>>>>> Huh? What is the error message?
    >>>>>>
    >>>>>>> I think the problem is in the file permission.
    >>>>>>
    >>>>>> Why? Does the error message give you a clue?
    >>>>>> If it IS a file permission error, you need to figure out how to
    >>>>>> assign Modify permissions for the folder containing the file to
    >>>>>> ALL users of the database file. Try posting to a Vista group for
    >>>>>> help with that, or maybe someone in the iis group will be able
    >>>>>> to help.
    >>>>>>
    >>>>>> --
    >>>>>> Microsoft MVP - ASP/ASP.NET
    >>>>>> Please reply to the newsgroup. This email account is my spam trap
    >>>>>> so I don't check it very often. If you must reply off-line, then
    >>>>>> remove the "NO SPAM"
    >>>>
    >>>> --
    >>>> Microsoft MVP -- ASP/ASP.NET
    >>>> Please reply to the newsgroup. The email account listed in my From
    >>>> header is my spam trap, so I don't check it very often. You will
    >>>> get a quicker response by posting to the newsgroup.

    >>
    >> --
    >> Microsoft MVP -- ASP/ASP.NET
    >> Please reply to the newsgroup. The email account listed in my From
    >> header is my spam trap, so I don't check it very often. You will get
    >> a quicker response by posting to the newsgroup.


    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
     
    Bob Barrows [MVP], Aug 28, 2007
    #10
  11. Gazing into my crystal ball I observed "hugh welford"
    <> writing in
    news::

    > The error merssage is the non-specific "An error occurred on the
    > server when processing the URL" - not much help is it?
    >
    >


    Do you have friendly errors messages turned on? IIRC, that's what the
    "friendly" error message is.

    --
    Adrienne Boswell at Home
    Arbpen Web Site Design Services
    http://www.cavalcade-of-coding.info
    Please respond to the group so others can share
     
    Adrienne Boswell, Sep 2, 2007
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steven Spits

    IIS on Vista home premium?

    Steven Spits, Feb 23, 2007, in forum: ASP .Net
    Replies:
    48
    Views:
    2,559
    Gregory A. Beamer
    Dec 21, 2009
  2. Michael
    Replies:
    5
    Views:
    934
    Bjoern Schliessmann
    Nov 3, 2007
  3. jason
    Replies:
    2
    Views:
    127
    jason
    Sep 10, 2003
  4. jason
    Replies:
    3
    Views:
    192
    Aaron Bertrand - MVP
    Nov 18, 2003
  5. Paul
    Replies:
    3
    Views:
    132
    Bob Barrows [MVP]
    Jul 5, 2005
Loading...

Share This Page