dbd-PG install help

Discussion in 'Perl Misc' started by pyammine@gmail.com, Feb 1, 2006.

  1. Guest

    I am running redhat ES 4, postgres 8.0.x and cannot get DBD-pg to work.
    I get the following error

    install_driver(Pg) failed: Can't load
    '/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/DBD/Pg/Pg.so'
    for module DBD::pg: libpq.so.4: cannot open shared object file: No such
    file or directory at
    /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.
    at (eval 12) line 3
    Compilation failed in require at (eval 12) line 3.
    Perhaps a required shared library or dll isn't installed where expected


    I have tried many of the items shown in other discussions and have had
    no success. I dont know if this is a DBD concern or postgres concern. I
    am not that proficient in Linux and therefore may be missing something
    stupid. Please help.
    , Feb 1, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Crook

    DBD::CSV questions and is there a DBD::XML?

    Andrew Crook, Sep 2, 2003, in forum: Perl Misc
    Replies:
    2
    Views:
    161
    Andrew Crook
    Sep 11, 2003
  2. Mike Solomon

    DBD::mysqlPP v DBD::mysql

    Mike Solomon, Feb 16, 2004, in forum: Perl Misc
    Replies:
    1
    Views:
    201
    James Willmore
    Feb 16, 2004
  3. meneg
    Replies:
    2
    Views:
    111
    meneg
    Nov 17, 2004
  4. Richard Gration
    Replies:
    1
    Views:
    144
    Richard Gration
    Jul 7, 2005
  5. Jim Cochrane
    Replies:
    0
    Views:
    110
    Jim Cochrane
    Aug 25, 2007
Loading...

Share This Page