Debugging failed because integrated Windows authentication is not enabled

Discussion in 'ASP .Net' started by Dariusz Tomon, Jul 28, 2006.

  1. I got an ASPNET C# project from client. When I'm trying to open it in Visual
    Studio I get error message:

    "Unable to start debugging on the web server. Debugging failed because
    integrated Windows authentication is not enabled. Please see Help for
    assistance" - What could be the problem?

    Any suggestion will be appreciate.

    D.T.
    Dariusz Tomon, Jul 28, 2006
    #1
    1. Advertising

  2. Dariusz Tomon

    Teemu Keiski Guest

    Hi,

    in case the project is on local IIS server, you need to enable Integrated
    Windows Authentication on the local IIS.

    1. Open IIS Manager (Internbet Information Services)
    2. Right-click the web site (in case you run it locally you only have
    Default web site) and pick Properties
    3. Choose "Directory Security" tab and click Edit on "Anonymous access and
    authentication control"
    4. In the opening window, uncheck "Allow Anonymous access" and check
    "Integrated Windows Authentication" (allowing anonymous can make that you
    don't have enough permissions to debug)

    After that you also need to make sure your NT Debugger user is on Debugger
    users group (and in practise to attach to the aspnet_wp.exe process it also
    needs to be admin unless you change local security policies)

    --
    Teemu Keiski
    ASP.NET MVP, AspInsider
    Finland, EU
    http://blogs.aspadvice.com/joteke


    "Dariusz Tomon" <> wrote in message
    news:...
    >I got an ASPNET C# project from client. When I'm trying to open it in
    >Visual Studio I get error message:
    >
    > "Unable to start debugging on the web server. Debugging failed because
    > integrated Windows authentication is not enabled. Please see Help for
    > assistance" - What could be the problem?
    >
    > Any suggestion will be appreciate.
    >
    > D.T.
    >
    Teemu Keiski, Jul 28, 2006
    #2
    1. Advertising

  3. Dariusz Tomon

    sonu Guest

    Teemu Keiski wrote:
    > Hi,
    >
    > in case the project is on local IIS server, you need to enable Integrated
    > Windows Authentication on the local IIS.
    >
    > 1. Open IIS Manager (Internbet Information Services)
    > 2. Right-click the web site (in case you run it locally you only have
    > Default web site) and pick Properties
    > 3. Choose "Directory Security" tab and click Edit on "Anonymous access and
    > authentication control"
    > 4. In the opening window, uncheck "Allow Anonymous access" and check
    > "Integrated Windows Authentication" (allowing anonymous can make that you
    > don't have enough permissions to debug)
    >
    > After that you also need to make sure your NT Debugger user is on Debugger
    > users group (and in practise to attach to the aspnet_wp.exe process it also
    > needs to be admin unless you change local security policies)
    >
    > --
    > Teemu Keiski
    > ASP.NET MVP, AspInsider
    > Finland, EU
    > http://blogs.aspadvice.com/joteke
    >
    >
    > "Dariusz Tomon" <> wrote in message
    > news:...
    > >I got an ASPNET C# project from client. When I'm trying to open it in
    > >Visual Studio I get error message:
    > >
    > > "Unable to start debugging on the web server. Debugging failed because
    > > integrated Windows authentication is not enabled. Please see Help for
    > > assistance" - What could be the problem?
    > >
    > > Any suggestion will be appreciate.
    > >
    > > D.T.
    > >
    sonu, Aug 9, 2006
    #3
  4. Dariusz Tomon

    muralikrishna

    Joined:
    Oct 24, 2010
    Messages:
    1
    Yes i done the same as told by you.If i done like that when i started to debug it is opening the browser but it is asking for username and password. SO i went back to IIS and done the same thing as u told.but in addition i didnt uncheck the allow anonymous option. Now i am able to debug my project successfully. and the browser also not asking me for username and password.My problem is fixed.

    Thanks for ur step by step explanation sir.
    muralikrishna, Oct 24, 2010
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark
    Replies:
    0
    Views:
    666
  2. Will
    Replies:
    5
    Views:
    2,601
  3. Ken Cooper
    Replies:
    0
    Views:
    310
    Ken Cooper
    Oct 12, 2006
  4. Replies:
    11
    Views:
    1,064
  5. Stephane
    Replies:
    1
    Views:
    1,277
    Stephane
    Oct 10, 2008
Loading...

Share This Page