Debugging fails on Vista for Localhost

Discussion in 'ASP .Net' started by John Kotuby, Jan 6, 2008.

  1. John Kotuby

    John Kotuby Guest

    Hi all,
    I need to use debugging on the LocalHost on my Vista Premious machine using
    VS2005 and ASP.NET 2.0 so that all my images resolve properly.
    I am able to acomplish this type of debugging on my older Windows XP machine
    with no problem whatsoever, using the default IIS settings and copying to
    entire website to excatly the same locaion on the C drive. Thank goodness I
    did not get rid of my older development machine.

    "Debugging failed because Windows Integrated authentication is not enabled."
    I have done a number of Google searches on this topic and none of the
    information I have found so far has helped.

    When I go into Help from within IIS Manager on my Vista machine it points me
    to a technet article regarding Windows Authentication on IIS 7.

    ----------------------------------------------
    1.
    Open IIS Manager and navigate to the level you want to manage. For
    information about opening IIS Manager, see IIS 7.0: Open IIS Manager. For
    information about navigating to locations in the UI, see IIS 7.0: Navigation
    in IIS Manager.

    2.
    In Features View, double-click Authentication.

    3.
    On the Authentication page, select Windows Authentication.

    4.
    In the Actions pane, click Enable to use Windows authentication.

    Note:
    Optionally, you can disable Kernel-mode authentication by clicking Advanced
    Settings. As a best practice, you should not disable this setting if you use
    Kerberos authentication and a custom identity on the application pool.

    Command Line
    To enable or disable Windows authentication, use the following syntax:

    appcmd set config /section:windowsAuthentication /enabled:true | false

    By default, IIS sets the enabled attribute to false, which disables Windows
    authentication. If you set the attribute to true, you enable Windows
    authentication. For example, to enable Windows authentication, type the
    following at the command prompt, and then press ENTER:

    appcmd set config /section:windowsAuthentication /enabled:true


    -----------------------------------

    Well when I open Authenication in IIS manager I only get 3 choices:

    Anonymous Authentication
    Forms Authentication
    ASP.NET Impersonation

    When I go to edit Anonymous Authentication, as other documentaion suggested,
    I get the choices of :
    Specific User
    Application Pool Identity

    I have tried the command line solution copied and pasted from the article
    itself, and I am told "Windows cannot find appcmd" .
    I did a search with the Vista search utility on the entire C drive and it
    did not find any form of "appcmd ".

    I have changed a setting in Web.config (which by the way needs no changing
    to debug on my XP machine.
    ---------------------------
    <system.webServer>
    <validation validateIntegratedModeConfiguration="true"/>
    -----------------------

    However, leaving the value to "false" allows debugging on my XP machine with
    no problem.

    I need to be able to debug on LocalHost on my Vista machine. BTW, the
    website itself runs fine from http://localhost when not trying to run in
    debug mode.

    Lastly I have just gone thru an entire Vista upgrade re-intstall over my
    exisiting Vista install because w3p.exe was not being allowed to access some
    registry entries and the only way I could find to fix a corrupted .NET 2.o
    franework install was to re-install Vista entirely.
    Yes, I applied all the upgrades and service packs necessary as determined by
    Micorosoft Update.

    Vista has been a real pain development wise ever since I installed it.

    Can anyone help with this?

    Thanks to all....
     
    John Kotuby, Jan 6, 2008
    #1
    1. Advertising

  2. John Kotuby

    John Kotuby Guest

    This post by Mike Volodarsky on his blog has helped me out greatly....
    http://mvolo.com/blogs/serverside/a...ng-of-ASP.NET-applications-on-IIS7-Vista.aspx

    Why can't MSDN documentation even come close to being this good?
    I guess MS would rather sell their developer help for ridiculous hourly
    rates.
    It's a great source of income.
    It reminds me of an old Dilbert cartoon. Pointy-head remarks something to
    the effect that "Our documentation is so poor that we have started charging
    for technical support. We didn't plan it that way. It all came together when
    I realized I hate our customers."

    "John Kotuby" <> wrote in message
    news:...
    > Hi all,
    > I need to use debugging on the LocalHost on my Vista Premious machine
    > using VS2005 and ASP.NET 2.0 so that all my images resolve properly.
    > I am able to acomplish this type of debugging on my older Windows XP
    > machine with no problem whatsoever, using the default IIS settings and
    > copying to entire website to excatly the same locaion on the C drive.
    > Thank goodness I did not get rid of my older development machine.
    >
    > "Debugging failed because Windows Integrated authentication is not
    > enabled."
    > I have done a number of Google searches on this topic and none of the
    > information I have found so far has helped.
    >
    > When I go into Help from within IIS Manager on my Vista machine it points
    > me to a technet article regarding Windows Authentication on IIS 7.
    >
    > ----------------------------------------------
    > 1.
    > Open IIS Manager and navigate to the level you want to manage. For
    > information about opening IIS Manager, see IIS 7.0: Open IIS Manager. For
    > information about navigating to locations in the UI, see IIS 7.0:
    > Navigation in IIS Manager.
    >
    > 2.
    > In Features View, double-click Authentication.
    >
    > 3.
    > On the Authentication page, select Windows Authentication.
    >
    > 4.
    > In the Actions pane, click Enable to use Windows authentication.
    >
    > Note:
    > Optionally, you can disable Kernel-mode authentication by clicking
    > Advanced Settings. As a best practice, you should not disable this setting
    > if you use Kerberos authentication and a custom identity on the
    > application pool.
    >
    > Command Line
    > To enable or disable Windows authentication, use the following syntax:
    >
    > appcmd set config /section:windowsAuthentication /enabled:true | false
    >
    > By default, IIS sets the enabled attribute to false, which disables
    > Windows authentication. If you set the attribute to true, you enable
    > Windows authentication. For example, to enable Windows authentication,
    > type the following at the command prompt, and then press ENTER:
    >
    > appcmd set config /section:windowsAuthentication /enabled:true
    >
    >
    > -----------------------------------
    >
    > Well when I open Authenication in IIS manager I only get 3 choices:
    >
    > Anonymous Authentication
    > Forms Authentication
    > ASP.NET Impersonation
    >
    > When I go to edit Anonymous Authentication, as other documentaion
    > suggested, I get the choices of :
    > Specific User
    > Application Pool Identity
    >
    > I have tried the command line solution copied and pasted from the article
    > itself, and I am told "Windows cannot find appcmd" .
    > I did a search with the Vista search utility on the entire C drive and it
    > did not find any form of "appcmd ".
    >
    > I have changed a setting in Web.config (which by the way needs no changing
    > to debug on my XP machine.
    > ---------------------------
    > <system.webServer>
    > <validation validateIntegratedModeConfiguration="true"/>
    > -----------------------
    >
    > However, leaving the value to "false" allows debugging on my XP machine
    > with no problem.
    >
    > I need to be able to debug on LocalHost on my Vista machine. BTW, the
    > website itself runs fine from http://localhost when not trying to run in
    > debug mode.
    >
    > Lastly I have just gone thru an entire Vista upgrade re-intstall over my
    > exisiting Vista install because w3p.exe was not being allowed to access
    > some registry entries and the only way I could find to fix a corrupted
    > .NET 2.o franework install was to re-install Vista entirely.
    > Yes, I applied all the upgrades and service packs necessary as determined
    > by Micorosoft Update.
    >
    > Vista has been a real pain development wise ever since I installed it.
    >
    > Can anyone help with this?
    >
    > Thanks to all....
    >
    >
     
    John Kotuby, Jan 6, 2008
    #2
    1. Advertising

  3. John Kotuby

    John Kotuby Guest

    Another update. In IIS Manager I had to change from the "Default AppPool" to
    the "Classic .NET AppPool" in the advanced settings for the web application
    as outlined in this article:
    http://www.thousandtyone.com/blog/CategoryView,category,Vista.aspx

    All of this is supposed to be fixed in the Vista SP1 service pack.

    Hope everyone had a good holiday season. May the New Year be enjoyable and
    prosperous to all.

    "John Kotuby" <> wrote in message
    news:...
    > This post by Mike Volodarsky on his blog has helped me out greatly....
    > http://mvolo.com/blogs/serverside/a...ng-of-ASP.NET-applications-on-IIS7-Vista.aspx
    >
    > Why can't MSDN documentation even come close to being this good?
    > I guess MS would rather sell their developer help for ridiculous hourly
    > rates.
    > It's a great source of income.
    > It reminds me of an old Dilbert cartoon. Pointy-head remarks something to
    > the effect that "Our documentation is so poor that we have started
    > charging for technical support. We didn't plan it that way. It all came
    > together when I realized I hate our customers."
    >
    > "John Kotuby" <> wrote in message
    > news:...
    >> Hi all,
    >> I need to use debugging on the LocalHost on my Vista Premious machine
    >> using VS2005 and ASP.NET 2.0 so that all my images resolve properly.
    >> I am able to acomplish this type of debugging on my older Windows XP
    >> machine with no problem whatsoever, using the default IIS settings and
    >> copying to entire website to excatly the same locaion on the C drive.
    >> Thank goodness I did not get rid of my older development machine.
    >>
    >> "Debugging failed because Windows Integrated authentication is not
    >> enabled."
    >> I have done a number of Google searches on this topic and none of the
    >> information I have found so far has helped.
    >>
    >> When I go into Help from within IIS Manager on my Vista machine it points
    >> me to a technet article regarding Windows Authentication on IIS 7.
    >>
    >> ----------------------------------------------
    >> 1.
    >> Open IIS Manager and navigate to the level you want to manage. For
    >> information about opening IIS Manager, see IIS 7.0: Open IIS Manager. For
    >> information about navigating to locations in the UI, see IIS 7.0:
    >> Navigation in IIS Manager.
    >>
    >> 2.
    >> In Features View, double-click Authentication.
    >>
    >> 3.
    >> On the Authentication page, select Windows Authentication.
    >>
    >> 4.
    >> In the Actions pane, click Enable to use Windows authentication.
    >>
    >> Note:
    >> Optionally, you can disable Kernel-mode authentication by clicking
    >> Advanced Settings. As a best practice, you should not disable this
    >> setting if you use Kerberos authentication and a custom identity on the
    >> application pool.
    >>
    >> Command Line
    >> To enable or disable Windows authentication, use the following syntax:
    >>
    >> appcmd set config /section:windowsAuthentication /enabled:true | false
    >>
    >> By default, IIS sets the enabled attribute to false, which disables
    >> Windows authentication. If you set the attribute to true, you enable
    >> Windows authentication. For example, to enable Windows authentication,
    >> type the following at the command prompt, and then press ENTER:
    >>
    >> appcmd set config /section:windowsAuthentication /enabled:true
    >>
    >>
    >> -----------------------------------
    >>
    >> Well when I open Authenication in IIS manager I only get 3 choices:
    >>
    >> Anonymous Authentication
    >> Forms Authentication
    >> ASP.NET Impersonation
    >>
    >> When I go to edit Anonymous Authentication, as other documentaion
    >> suggested, I get the choices of :
    >> Specific User
    >> Application Pool Identity
    >>
    >> I have tried the command line solution copied and pasted from the article
    >> itself, and I am told "Windows cannot find appcmd" .
    >> I did a search with the Vista search utility on the entire C drive and it
    >> did not find any form of "appcmd ".
    >>
    >> I have changed a setting in Web.config (which by the way needs no
    >> changing to debug on my XP machine.
    >> ---------------------------
    >> <system.webServer>
    >> <validation validateIntegratedModeConfiguration="true"/>
    >> -----------------------
    >>
    >> However, leaving the value to "false" allows debugging on my XP machine
    >> with no problem.
    >>
    >> I need to be able to debug on LocalHost on my Vista machine. BTW, the
    >> website itself runs fine from http://localhost when not trying to run in
    >> debug mode.
    >>
    >> Lastly I have just gone thru an entire Vista upgrade re-intstall over my
    >> exisiting Vista install because w3p.exe was not being allowed to access
    >> some registry entries and the only way I could find to fix a corrupted
    >> .NET 2.o franework install was to re-install Vista entirely.
    >> Yes, I applied all the upgrades and service packs necessary as determined
    >> by Micorosoft Update.
    >>
    >> Vista has been a real pain development wise ever since I installed it.
    >>
    >> Can anyone help with this?
    >>
    >> Thanks to all....
    >>
    >>

    >
     
    John Kotuby, Jan 6, 2008
    #3
  4. "John Kotuby" <> wrote in message
    news:%...

    > Another update. In IIS Manager I had to change from the "Default AppPool"
    > to the "Classic .NET AppPool" in the advanced settings for the web
    > application as outlined in this article:
    > http://www.thousandtyone.com/blog/CategoryView,category,Vista.aspx
    >
    > All of this is supposed to be fixed in the Vista SP1 service pack.


    The app pool issue is fixed in Visual Studio.NET 2008, even without Vista
    SP1...

    At least, none of my VS.NET 2008 web apps need to run in the Classic pool
    any more...


    --
    Mark Rae
    ASP.NET MVP
    http://www.markrae.net
     
    Mark Rae [MVP], Jan 7, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    836
    Jiong Feng
    Nov 19, 2003
  2. Alex
    Replies:
    4
    Views:
    571
    Hasani Blackwell
    Feb 8, 2005
  3. =?Utf-8?B?S2VuTGVl?=
    Replies:
    5
    Views:
    2,716
  4. EdwardH

    Localhost isn't localhost

    EdwardH, Sep 29, 2005, in forum: Java
    Replies:
    20
    Views:
    6,407
    Roedy Green
    Oct 1, 2005
  5. koicat
    Replies:
    0
    Views:
    227
    koicat
    Jul 2, 2010
Loading...

Share This Page