Debugging problem

Discussion in 'ASP .Net' started by Kevin, Aug 25, 2003.

  1. Kevin

    Kevin Guest

    I've been unable to debug a .NET web application with Visual Studio.
    Every time I try to run it, I get the error message:

    Error while trying to run project: Unable to start debugging on the
    web server. Server side-error occurred on sending debug HTTP request.

    I know there are several posts from users who experienced the same
    problem, but none of the solutions are working for me. Based on
    information I read in previous posts, the gotdotnet and microsoft
    websites, as well as VS help, I have tried the following things:


    -Added new account ASPNET and ensured that process aspnet_wp.exe is
    running.

    -Verified that web.config is properly formed with no syntax errors and
    has the debug attribute set to true.

    -Reinstalled the dotnet framework

    -Verified IIS security settings and gave the web application a name in
    the Properties dialog box for the application.


    I'm running Windows XP Pro with IIS 5.1. If anyone has any other
    suggestions on how to resolve the problem, please let me know.

    Thanks,

    Kevin
    Kevin, Aug 25, 2003
    #1
    1. Advertising

  2. Kevin

    Tap Guest

    Do you have permission set for that application folder on
    the IIS ?

    >-----Original Message-----
    >I've been unable to debug a .NET web application with

    Visual Studio.
    >Every time I try to run it, I get the error message:
    >
    >Error while trying to run project: Unable to start

    debugging on the
    >web server. Server side-error occurred on sending debug

    HTTP request.
    >
    >I know there are several posts from users who experienced

    the same
    >problem, but none of the solutions are working for me.

    Based on
    >information I read in previous posts, the gotdotnet and

    microsoft
    >websites, as well as VS help, I have tried the following

    things:
    >
    >
    >-Added new account ASPNET and ensured that process

    aspnet_wp.exe is
    >running.
    >
    >-Verified that web.config is properly formed with no

    syntax errors and
    >has the debug attribute set to true.
    >
    >-Reinstalled the dotnet framework
    >
    >-Verified IIS security settings and gave the web

    application a name in
    >the Properties dialog box for the application.
    >
    >
    >I'm running Windows XP Pro with IIS 5.1. If anyone has

    any other
    >suggestions on how to resolve the problem, please let me

    know.
    >
    >Thanks,
    >
    >Kevin
    >.
    >
    Tap, Aug 25, 2003
    #2
    1. Advertising

  3. Kevin

    Kevin Guest

    I have it set to allow for anonymous access and integrated Windows
    authentication. Is this what you are referring to?


    "Tap" <> wrote in message news:<00d601c36b32$b618eed0$>...
    > Do you have permission set for that application folder on
    > the IIS ?
    >
    > >-----Original Message-----
    > >I've been unable to debug a .NET web application with

    > Visual Studio.
    > >Every time I try to run it, I get the error message:
    > >
    > >Error while trying to run project: Unable to start

    > debugging on the
    > >web server. Server side-error occurred on sending debug

    > HTTP request.
    > >
    > >I know there are several posts from users who experienced

    > the same
    > >problem, but none of the solutions are working for me.

    > Based on
    > >information I read in previous posts, the gotdotnet and

    > microsoft
    > >websites, as well as VS help, I have tried the following

    > things:
    > >
    > >
    > >-Added new account ASPNET and ensured that process

    > aspnet_wp.exe is
    > >running.
    > >
    > >-Verified that web.config is properly formed with no

    > syntax errors and
    > >has the debug attribute set to true.
    > >
    > >-Reinstalled the dotnet framework
    > >
    > >-Verified IIS security settings and gave the web

    > application a name in
    > >the Properties dialog box for the application.
    > >
    > >
    > >I'm running Windows XP Pro with IIS 5.1. If anyone has

    > any other
    > >suggestions on how to resolve the problem, please let me

    > know.
    > >
    > >Thanks,
    > >
    > >Kevin
    > >.
    > >
    Kevin, Aug 27, 2003
    #3
  4. Kevin

    Scott M. Guest

    Is your ASPNET account a memeber of the Debugger Users and VS Developers
    groups?


    "Kevin" <> wrote in message
    news:...
    > I have it set to allow for anonymous access and integrated Windows
    > authentication. Is this what you are referring to?
    >
    >
    > "Tap" <> wrote in message

    news:<00d601c36b32$b618eed0$>...
    > > Do you have permission set for that application folder on
    > > the IIS ?
    > >
    > > >-----Original Message-----
    > > >I've been unable to debug a .NET web application with

    > > Visual Studio.
    > > >Every time I try to run it, I get the error message:
    > > >
    > > >Error while trying to run project: Unable to start

    > > debugging on the
    > > >web server. Server side-error occurred on sending debug

    > > HTTP request.
    > > >
    > > >I know there are several posts from users who experienced

    > > the same
    > > >problem, but none of the solutions are working for me.

    > > Based on
    > > >information I read in previous posts, the gotdotnet and

    > > microsoft
    > > >websites, as well as VS help, I have tried the following

    > > things:
    > > >
    > > >
    > > >-Added new account ASPNET and ensured that process

    > > aspnet_wp.exe is
    > > >running.
    > > >
    > > >-Verified that web.config is properly formed with no

    > > syntax errors and
    > > >has the debug attribute set to true.
    > > >
    > > >-Reinstalled the dotnet framework
    > > >
    > > >-Verified IIS security settings and gave the web

    > > application a name in
    > > >the Properties dialog box for the application.
    > > >
    > > >
    > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

    > > any other
    > > >suggestions on how to resolve the problem, please let me

    > > know.
    > > >
    > > >Thanks,
    > > >
    > > >Kevin
    > > >.
    > > >
    Scott M., Aug 27, 2003
    #4
  5. Kevin

    Kevin Guest

    I'm not sure.. how do I verify this?

    "Scott M." <> wrote in message news:<#$>...
    > Is your ASPNET account a memeber of the Debugger Users and VS Developers
    > groups?
    >
    >
    > "Kevin" <> wrote in message
    > news:...
    > > I have it set to allow for anonymous access and integrated Windows
    > > authentication. Is this what you are referring to?
    > >
    > >
    > > "Tap" <> wrote in message

    > news:<00d601c36b32$b618eed0$>...
    > > > Do you have permission set for that application folder on
    > > > the IIS ?
    > > >
    > > > >-----Original Message-----
    > > > >I've been unable to debug a .NET web application with

    > Visual Studio.
    > > > >Every time I try to run it, I get the error message:
    > > > >
    > > > >Error while trying to run project: Unable to start

    > debugging on the
    > > > >web server. Server side-error occurred on sending debug

    > HTTP request.
    > > > >
    > > > >I know there are several posts from users who experienced

    > the same
    > > > >problem, but none of the solutions are working for me.

    > Based on
    > > > >information I read in previous posts, the gotdotnet and

    > microsoft
    > > > >websites, as well as VS help, I have tried the following

    > things:
    > > > >
    > > > >
    > > > >-Added new account ASPNET and ensured that process

    > aspnet_wp.exe is
    > > > >running.
    > > > >
    > > > >-Verified that web.config is properly formed with no

    > syntax errors and
    > > > >has the debug attribute set to true.
    > > > >
    > > > >-Reinstalled the dotnet framework
    > > > >
    > > > >-Verified IIS security settings and gave the web

    > application a name in
    > > > >the Properties dialog box for the application.
    > > > >
    > > > >
    > > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

    > any other
    > > > >suggestions on how to resolve the problem, please let me

    > know.
    > > > >
    > > > >Thanks,
    > > > >
    > > > >Kevin
    > > > >.
    > > > >
    Kevin, Aug 27, 2003
    #5
  6. Kevin

    Scott M. Guest

    On the machine that has the ASPNET account, go into Control Panel and then
    Administrative Tools then Computer Management.

    Once there expand the Local Users And Groups section. Under Users, double
    click the ASPNET account and look at the tab called Member Of.

    By default, the ASPNET account is not a member of the Debugger Users or VS
    Developers groups, so don't be surprised to not see these groups listed.

    If they are not listed, then go into the Groups section and then the
    Debugger Users group. Add the ASPNET account to that group, then repeat the
    process for the VS Developers group.

    Hope this helps!


    "Kevin" <> wrote in message
    news:...
    > I'm not sure.. how do I verify this?
    >
    > "Scott M." <> wrote in message

    news:<#$>...
    > > Is your ASPNET account a memeber of the Debugger Users and VS Developers
    > > groups?
    > >
    > >
    > > "Kevin" <> wrote in message
    > > news:...
    > > > I have it set to allow for anonymous access and integrated Windows
    > > > authentication. Is this what you are referring to?
    > > >
    > > >
    > > > "Tap" <> wrote in message

    > > news:<00d601c36b32$b618eed0$>...
    > > > > Do you have permission set for that application folder on
    > > > > the IIS ?
    > > > >
    > > > > >-----Original Message-----
    > > > > >I've been unable to debug a .NET web application with

    > > Visual Studio.
    > > > > >Every time I try to run it, I get the error message:
    > > > > >
    > > > > >Error while trying to run project: Unable to start

    > > debugging on the
    > > > > >web server. Server side-error occurred on sending debug

    > > HTTP request.
    > > > > >
    > > > > >I know there are several posts from users who experienced

    > > the same
    > > > > >problem, but none of the solutions are working for me.

    > > Based on
    > > > > >information I read in previous posts, the gotdotnet and

    > > microsoft
    > > > > >websites, as well as VS help, I have tried the following

    > > things:
    > > > > >
    > > > > >
    > > > > >-Added new account ASPNET and ensured that process

    > > aspnet_wp.exe is
    > > > > >running.
    > > > > >
    > > > > >-Verified that web.config is properly formed with no

    > > syntax errors and
    > > > > >has the debug attribute set to true.
    > > > > >
    > > > > >-Reinstalled the dotnet framework
    > > > > >
    > > > > >-Verified IIS security settings and gave the web

    > > application a name in
    > > > > >the Properties dialog box for the application.
    > > > > >
    > > > > >
    > > > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

    > > any other
    > > > > >suggestions on how to resolve the problem, please let me

    > > know.
    > > > > >
    > > > > >Thanks,
    > > > > >
    > > > > >Kevin
    > > > > >.
    > > > > >
    Scott M., Aug 28, 2003
    #6
  7. Kevin

    Kevin Guest

    Scott,

    I added ASPNET to the Debugger Users and VS Developers groups as you
    instructed, and rebooted. I tried to run the program again, but still
    got the same error. I have verified that the ASPNET account was added
    to both groups correctly, and don't know what else to check at this
    point. Do you have any other suggestions?

    Thanks for your help,

    Kevin


    "Scott M." <> wrote in message news:<>...
    > On the machine that has the ASPNET account, go into Control Panel and then
    > Administrative Tools then Computer Management.
    >
    > Once there expand the Local Users And Groups section. Under Users, double
    > click the ASPNET account and look at the tab called Member Of.
    >
    > By default, the ASPNET account is not a member of the Debugger Users or VS
    > Developers groups, so don't be surprised to not see these groups listed.
    >
    > If they are not listed, then go into the Groups section and then the
    > Debugger Users group. Add the ASPNET account to that group, then repeat the
    > process for the VS Developers group.
    >
    > Hope this helps!
    >
    >
    > "Kevin" <> wrote in message
    > news:...
    > > I'm not sure.. how do I verify this?
    > >
    > > "Scott M." <> wrote in message

    > news:<#$>...
    > > > Is your ASPNET account a memeber of the Debugger Users and VS Developers
    > > > groups?
    > > >
    > > >
    > > > "Kevin" <> wrote in message
    > > > news:...
    > > > > I have it set to allow for anonymous access and integrated Windows
    > > > > authentication. Is this what you are referring to?
    > > > >
    > > > >
    > > > > "Tap" <> wrote in message

    > news:<00d601c36b32$b618eed0$>...
    > > > > > Do you have permission set for that application folder on
    > > > > > the IIS ?
    > > > > >
    > > > > > >-----Original Message-----
    > > > > > >I've been unable to debug a .NET web application with

    > Visual Studio.
    > > > > > >Every time I try to run it, I get the error message:
    > > > > > >
    > > > > > >Error while trying to run project: Unable to start

    > debugging on the
    > > > > > >web server. Server side-error occurred on sending debug

    > HTTP request.
    > > > > > >
    > > > > > >I know there are several posts from users who experienced

    > the same
    > > > > > >problem, but none of the solutions are working for me.

    > Based on
    > > > > > >information I read in previous posts, the gotdotnet and

    > microsoft
    > > > > > >websites, as well as VS help, I have tried the following

    > things:
    > > > > > >
    > > > > > >
    > > > > > >-Added new account ASPNET and ensured that process

    > aspnet_wp.exe is
    > > > > > >running.
    > > > > > >
    > > > > > >-Verified that web.config is properly formed with no

    > syntax errors and
    > > > > > >has the debug attribute set to true.
    > > > > > >
    > > > > > >-Reinstalled the dotnet framework
    > > > > > >
    > > > > > >-Verified IIS security settings and gave the web

    > application a name in
    > > > > > >the Properties dialog box for the application.
    > > > > > >
    > > > > > >
    > > > > > >I'm running Windows XP Pro with IIS 5.1. If anyone has

    > any other
    > > > > > >suggestions on how to resolve the problem, please let me

    > know.
    > > > > > >
    > > > > > >Thanks,
    > > > > > >
    > > > > > >Kevin
    > > > > > >.
    > > > > > >
    Kevin, Aug 28, 2003
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?U2FuZHVyZWE=?=

    Problem Debugging COM componenets from ASP.NET

    =?Utf-8?B?U2FuZHVyZWE=?=, Jul 29, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    441
    =?Utf-8?B?U2FuZHVyZWE=?=
    Jul 29, 2005
  2. Stephen Noronha

    Debugging Problem

    Stephen Noronha, Sep 2, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    455
    Stephen Noronha
    Sep 2, 2005
  3. Johann Blake
    Replies:
    1
    Views:
    1,193
    Hermit Dave
    Jan 5, 2004
  4. jacob navia

    Debugging C vs debugging C++

    jacob navia, Oct 26, 2006, in forum: C Programming
    Replies:
    11
    Views:
    585
    Ian Collins
    Oct 27, 2006
  5. AAaron123
    Replies:
    3
    Views:
    658
    AAaron123
    Jul 28, 2009
Loading...

Share This Page