Debugging Problems on Windows Vista

Discussion in 'ASP .Net' started by TheDude5B, Sep 8, 2007.

  1. TheDude5B

    TheDude5B Guest

    Hi,

    I have just installed Visual Studio 2005 on my windows Vista machine,
    and everything seems to work well after installing the service pack
    and then the vista upgrades.

    However, when I try to debug an application, the debugger starts,
    launches the project in explorer, but then stops debugging. It pops up
    with an error saying:

    -----
    the following module was built either with optimizations enabled or
    without debug information:

    C:\Users\myname\AppData\Local\Temp\Temporary ASP.NET Files\root
    \assembly....\projectname

    To debug this module, change its project build configuration to Debug
    Mode.
    To suppress this message, disable the "Warn if no user code on launch"
    debugger option.
    -----

    The project build succeeds but I am just not able to debug. Is this a
    windows Vista problem?

    Please help.
     
    TheDude5B, Sep 8, 2007
    #1
    1. Advertising

  2. "TheDude5B" <> wrote in message
    news:...

    > The project build succeeds but I am just not able to debug. Is this a
    > windows Vista problem?


    No, it just means that you're trying to debug in Release mode... Switch the
    probject into Debug mode, hit Rebuild and then F5...


    --
    Mark Rae
    ASP.NET MVP
    http://www.markrae.net
     
    Mark Rae [MVP], Sep 8, 2007
    #2
    1. Advertising

  3. Aside from what Mark mentions, I have run into this several times. As the
    error dialog indicates, you can override this in Options. However, I
    remembere always being able to jump right over this and continue debugging
    successfully.
    -- Peter
    Recursion: see Recursion
    site: http://www.eggheadcafe.com
    unBlog: http://petesbloggerama.blogspot.com
    BlogMetaFinder: http://www.blogmetafinder.com



    "TheDude5B" wrote:

    > Hi,
    >
    > I have just installed Visual Studio 2005 on my windows Vista machine,
    > and everything seems to work well after installing the service pack
    > and then the vista upgrades.
    >
    > However, when I try to debug an application, the debugger starts,
    > launches the project in explorer, but then stops debugging. It pops up
    > with an error saying:
    >
    > -----
    > the following module was built either with optimizations enabled or
    > without debug information:
    >
    > C:\Users\myname\AppData\Local\Temp\Temporary ASP.NET Files\root
    > \assembly....\projectname
    >
    > To debug this module, change its project build configuration to Debug
    > Mode.
    > To suppress this message, disable the "Warn if no user code on launch"
    > debugger option.
    > -----
    >
    > The project build succeeds but I am just not able to debug. Is this a
    > windows Vista problem?
    >
    > Please help.
    >
    >
     
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Sep 9, 2007
    #3
  4. TheDude5B

    TheDude5B Guest


    > > The project build succeeds but I am just not able to debug. Is this a
    > > windows Vista problem?

    >
    > No, it just means that you're trying to debug in Release mode... Switch the
    > probject into Debug mode, hit Rebuild and then F5...
    >



    What do you mean by this? Do you mean set the <compilation
    debug="true"> in the web.config file or something else?
    I have <compilation debug="true"> in the web.config, but the error
    still appears. I have had a look around to see if there are any other
    settings which i can change, but still the same problem.
     
    TheDude5B, Sep 9, 2007
    #4
  5. TheDude5B

    TheDude5B Guest

    Found the problem. It is down to the Vista User security settings. If
    I run Vista "As Administrator" the problem goes away.
     
    TheDude5B, Sep 9, 2007
    #5
  6. "TheDude5B" <> wrote in message
    news:...

    > Found the problem. It is down to the Vista User security settings. If
    > I run Vista "As Administrator" the problem goes away.


    Ah yes...

    Presumably, though, you mean that you need to run VS.NET 2005 as
    administrator...?


    --
    Mark Rae
    ASP.NET MVP
    http://www.markrae.net
     
    Mark Rae [MVP], Sep 9, 2007
    #6
  7. TheDude5B

    TheDude5B Guest

    On Sep 9, 10:21 pm, "Mark Rae [MVP]" <> wrote:
    > "TheDude5B" <> wrote in message
    >
    > news:...
    >
    > > Found the problem. It is down to the Vista User security settings. If
    > > I run Vista "As Administrator" the problem goes away.

    >
    > Ah yes...
    >
    > Presumably, though, you mean that you need to run VS.NET 2005 as
    > administrator...?
    >
    > --
    > Mark Rae
    > ASP.NET MVPhttp://www.markrae.net


    yes exactly. Have not got used to this feature of Vista yet so keep
    coming across problems like this when trying to run different
    programs. First thing I will try in the future is to run everything as
    administrator. :)
     
    TheDude5B, Sep 10, 2007
    #7
  8. "TheDude5B" <> wrote in message
    news:...

    > yes exactly. Have not got used to this feature of Vista yet so keep
    > coming across problems like this when trying to run different
    > programs.


    1) Right-click on the item on the Start menu which launches Visual
    Studio.NET 2005

    2) Select Properties

    3) Click Advanced

    4) Check Run as administrator

    5) Click OK

    6) Click OK

    7) Launch Visual Studio.NET 2005

    > First thing I will try in the future is to run everything as
    > administrator. :)


    I strongly advise you *NOT* to do that! Visual Studio.NET 2005 is very much
    an exception - hardly any applications need to be run as administrator...


    --
    Mark Rae
    ASP.NET MVP
    http://www.markrae.net
     
    Mark Rae [MVP], Sep 10, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?U3JpZGhhcg==?=

    problems with vs.net 2003 on windows vista

    =?Utf-8?B?U3JpZGhhcg==?=, Feb 23, 2007, in forum: ASP .Net
    Replies:
    8
    Views:
    434
    Mark Rae
    Feb 24, 2007
  2. Michael
    Replies:
    5
    Views:
    934
    Bjoern Schliessmann
    Nov 3, 2007
  3. Hillbilly
    Replies:
    1
    Views:
    357
    Hillbilly
    Apr 21, 2009
  4. Jesse Houwing
    Replies:
    7
    Views:
    366
    Hillbilly
    Apr 21, 2009
  5. Mr. Arnold
    Replies:
    0
    Views:
    390
    Mr. Arnold
    Apr 21, 2009
Loading...

Share This Page