default ASP page displays but others don't

Discussion in 'ASP General' started by Kerry Sutton, Sep 18, 2003.

  1. Kerry Sutton

    Kerry Sutton Guest

    I have setup an IIS 6 server and I am trying to migrate a
    pretty basic website to it. It will display any ASP page
    that I set as the default page, but gives a 404.2 for any
    other ASP pages that I link to.

    What am I missing?
     
    Kerry Sutton, Sep 18, 2003
    #1
    1. Advertising

  2. Kerry Sutton

    Atrax Guest

    Err... do you mean 401.2 rather than 404.2?

    "You do not have permission to view this directory or page using the
    credentials you supplied."

    you need to change the NTFS permissions on the files causing the error
    so that the anonymous account has rights on them. see www.iisfaq.com




    ________________________________________
    Atrax. MVP, IIS
    http://rtfm.atrax.co.uk/

    newsflash : Atrax.Richedit 1.0 now released.
    http://rtfm.atrax.co.uk/infinitemonkeys/components/Atrax.RichEdit/

    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Atrax, Sep 18, 2003
    #2
    1. Advertising

  3. Kerry Sutton

    K Sutton Guest

    No, it is a 404.2 error which indicates that it can't find the file, but
    most likely that is due to permissions issues with ASP. I can run an
    html site from the same location without any trouble.



    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    K Sutton, Sep 18, 2003
    #3
  4. Kerry Sutton

    Mark Schupp Guest

    Are you using components on the other pages? If so, what are they and does
    the anonymous account have permission to create them?

    --
    Mark Schupp
    --
    Head of Development
    Integrity eLearning
    Online Learning Solutions Provider

    http://www.ielearning.com
    714.637.9480 x17


    "K Sutton" <> wrote in message
    news:...
    > No, it is a 404.2 error which indicates that it can't find the file, but
    > most likely that is due to permissions issues with ASP. I can run an
    > html site from the same location without any trouble.
    >
    >
    >
    > *** Sent via Developersdex http://www.developersdex.com ***
    > Don't just participate in USENET...get rewarded for it!
     
    Mark Schupp, Sep 18, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chumley Walrus
    Replies:
    1
    Views:
    12,201
    =?Utf-8?B?QnJpYW4gQnJvd24=?=
    Dec 16, 2004
  2. Altemir
    Replies:
    4
    Views:
    901
    Altemir
    Oct 27, 2006
  3. Chris Auer
    Replies:
    1
    Views:
    408
    Chris Auer
    Oct 16, 2007
  4. R. G.
    Replies:
    2
    Views:
    181
    R. G.
    Jul 8, 2004
  5. Travis
    Replies:
    3
    Views:
    381
Loading...

Share This Page