deploying not working??

Discussion in '.NET' started by Kirk, Mar 16, 2009.

  1. Kirk

    Kirk

    Joined:
    Mar 15, 2009
    Messages:
    1
    Okay, I'm a newbie at publishing asp.net so like I've done something ignorant here...

    I've got the book professional asp.net 3.5 (wrox) and it talks about publishing by using the Build --> Publish Web Site from the menu in Visual Studio 2008.

    Well, I did that. I left the check box "Allow this precompiled site to be updatable" checked. I didn't mark any other settings, and clicked OK. It showed it running and publishing to my host, BIZHOSTNET.COM.

    I can see some files in there though I don't see any .dll file unless its just not showing the extension. When I type in my web name, it stills shows the default bizhostnet commercial page, not my site. I'm thinking their support sucks because all they instructed when I asked how to publish my SQLexpress 2008 web, was to publish from visual studio. ??? Well, apparently you can choose ftp or front page. I chose front page because the book seemed to suggest that would be a good way.

    What did I do wrong? If I click on the name in my folder at the host for my temporary web name, I get this message:

    HTTP Error 403.1 - Forbidden
    You have attempted to run a CGI, ISAPI, or other executable program from a directory that does not allow executables to run.

    Module IIS Web Core
    Notification MapRequestHandler
    Handler PageHandlerFactory-Integrated
    Error Code 0x80070005

    * The "Scripts" or "Scripts and Executables" flag is not configured in Rights and Permissions at the server, site, application, or page level.
    * The configuration/system.webServer/handlers@accessPolicy attribute does not have Script or Execute configured.
    * Execute access is denied when you try to run a CGI file or other executable.
    * Script access is denied when you try to access an ASP, ASP.NET or other dynamic scripting file.
    * The script mapping for the file you are trying to run is not configured to recognize the HTTP verb you are using (such as GET or POST).
    * The HTTP verb for the script mapping is case sensitive, and use upper case. The HTTP verb "POST" is correct, while "post" is incorrect and execution is denied.
     
    Kirk, Mar 16, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Carl Prothman [MVP]
    Replies:
    2
    Views:
    5,655
    Carl Prothman [MVP]
    Aug 14, 2003
  2. Steve C. Orr, MCSD
    Replies:
    3
    Views:
    1,597
    William Sempf
    Aug 21, 2003
  3. =?Utf-8?B?VG9tIE4=?=

    deploying and re-deploying ASP.Net applications

    =?Utf-8?B?VG9tIE4=?=, Feb 4, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    414
    =?Utf-8?B?VG9tIE4=?=
    Feb 4, 2004
  4. Sam
    Replies:
    0
    Views:
    431
  5. Homer
    Replies:
    5
    Views:
    884
    Homer
    Jul 20, 2007
Loading...

Share This Page