devkit not able to find ruby installation

Discussion in 'Ruby' started by Stephen Boesch, Apr 9, 2011.

  1. As mentioned in title, devkit is not finding ruby installation. Also
    after adding to config.yml get an error of 'invalid configuration. help
    appreciated.

    Here is env:

    C:\zdisks\devkit>gem environment
    RubyGems Environment:
    - RUBYGEMS VERSION: 1.3.7
    - RUBY VERSION: 1.9.2 (2010-12-25 patchlevel 136) [i386-mingw32]
    - INSTALLATION DIRECTORY:
    C:/apps/pik/rubies/ruby-1.9.2-p136/lib/ruby/gems/1.9.1
    - RUBY EXECUTABLE: C:/apps/pik/rubies/ruby-1.9.2-p136/bin/ruby.exe
    - EXECUTABLE DIRECTORY: C:/apps/pik/rubies/ruby-1.9.2-p136/bin
    - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
    - GEM PATHS:
    - C:/apps/pik/rubies/ruby-1.9.2-p136/lib/ruby/gems/1.9.1
    - C:/Documents and Settings/sboesch/.gem/ruby/1.9.1
    - GEM CONFIGURATION:
    - :update_sources => true
    - :verbose => true
    - :benchmark => false
    - :backtrace => false
    - :bulk_threshold => 1000
    - REMOTE SOURCES:
    - http://rubygems.org/


    Here is command to create the config.yml:

    C:\zdisks\devkit>ruby dk.rb init

    But .. no ruby's were found .. ;(

    # This configuration file contains the absolute path locations of all
    # installed Rubies to be enhanced to work with the DevKit. This config
    # file is generated by the 'ruby dk.rb init' step and may be modified
    # before running the 'ruby dk.rb install' step. To include any installed
    # Rubies that were not automagically discovered, simply add a line below
    # the triple hyphens with the absolute path to the Ruby root directory.
    #
    # Example:
    #
    # ---
    # - C:/ruby19trunk
    # - C:/ruby192dev
    #

    Then when I MANUALLY add the ruby as follow:

    # ---
    # - C:/ruby19trunk
    # - C:/ruby192dev
    #
    C:/apps/pik/rubies/ruby-1.9.2-p136

    I get following:

    C:\zdisks\devkit>ruby dk.rb review

    Invalid configuration. Please fix 'config.yml.'


    How painful.

    --
    Posted via http://www.ruby-forum.com/.
     
    Stephen Boesch, Apr 9, 2011
    #1
    1. Advertising

  2. Stephen Boesch

    Nick Klauer Guest

    [Note: parts of this message were removed to make it a legal post.]

    Not sure if it will solve your problem, but could you try putting a '-
    'before the path, as shown in those examples? Here's my
    config.yml for instance:

    #
    # Example:
    #
    # ---
    # - C:/ruby19trunk
    # - C:/ruby192dev
    #
    ---
    - C:/Ruby192
    - C:/jruby-dev
    - C:/jruby-1.6.0


    -Nick Klauer


    On Fri, Apr 8, 2011 at 20:13, Stephen Boesch <> wrote:

    > As mentioned in title, devkit is not finding ruby installation. Also
    > after adding to config.yml get an error of 'invalid configuration. help
    > appreciated.
    >
    > Here is env:
    >
    > C:\zdisks\devkit>gem environment
    > RubyGems Environment:
    > - RUBYGEMS VERSION: 1.3.7
    > - RUBY VERSION: 1.9.2 (2010-12-25 patchlevel 136) [i386-mingw32]
    > - INSTALLATION DIRECTORY:
    > C:/apps/pik/rubies/ruby-1.9.2-p136/lib/ruby/gems/1.9.1
    > - RUBY EXECUTABLE: C:/apps/pik/rubies/ruby-1.9.2-p136/bin/ruby.exe
    > - EXECUTABLE DIRECTORY: C:/apps/pik/rubies/ruby-1.9.2-p136/bin
    > - RUBYGEMS PLATFORMS:
    > - ruby
    > - x86-mingw32
    > - GEM PATHS:
    > - C:/apps/pik/rubies/ruby-1.9.2-p136/lib/ruby/gems/1.9.1
    > - C:/Documents and Settings/sboesch/.gem/ruby/1.9.1
    > - GEM CONFIGURATION:
    > - :update_sources => true
    > - :verbose => true
    > - :benchmark => false
    > - :backtrace => false
    > - :bulk_threshold => 1000
    > - REMOTE SOURCES:
    > - http://rubygems.org/
    >
    >
    > Here is command to create the config.yml:
    >
    > C:\zdisks\devkit>ruby dk.rb init
    >
    > But .. no ruby's were found .. ;(
    >
    > # This configuration file contains the absolute path locations of all
    > # installed Rubies to be enhanced to work with the DevKit. This config
    > # file is generated by the 'ruby dk.rb init' step and may be modified
    > # before running the 'ruby dk.rb install' step. To include any installed
    > # Rubies that were not automagically discovered, simply add a line below
    > # the triple hyphens with the absolute path to the Ruby root directory.
    > #
    > # Example:
    > #
    > # ---
    > # - C:/ruby19trunk
    > # - C:/ruby192dev
    > #
    >
    > Then when I MANUALLY add the ruby as follow:
    >
    > # ---
    > # - C:/ruby19trunk
    > # - C:/ruby192dev
    > #
    > C:/apps/pik/rubies/ruby-1.9.2-p136
    >
    > I get following:
    >
    > C:\zdisks\devkit>ruby dk.rb review
    >
    > Invalid configuration. Please fix 'config.yml.'
    >
    >
    > How painful.
    >
    > --
    > Posted via http://www.ruby-forum.com/.
    >
    >
     
    Nick Klauer, Apr 9, 2011
    #2
    1. Advertising

  3. Stephen Boesch

    Luis Lavena Guest

    On Apr 8, 10:13 pm, Stephen Boesch <> wrote:
    > As mentioned in title, devkit is not finding ruby installation. Also
    > after adding to config.yml get an error of 'invalid configuration. help
    > appreciated.
    >
    > Here is env:
    >
    >   - RUBY EXECUTABLE: C:/apps/pik/rubies/ruby-1.9.2-p136/bin/ruby.exe
    >
    >
    > But .. no ruby's were found .. ;(
    >
    > # This configuration file contains the absolute path locations of all
    > # installed Rubies to be enhanced to work with the DevKit. This config
    > # file is generated by the 'ruby dk.rb init' step and may be modified
    > # before running the 'ruby dk.rb install' step. To include any installed
    > # Rubies that were not automagically discovered, simply add a line below
    > # the triple hyphens with the absolute path to the Ruby root directory.
    > #
    > # Example:
    > #
    > # ---
    > # - C:/ruby19trunk
    > # - C:/ruby192dev
    > #
    >
    > Then when I MANUALLY add the ruby as follow:
    >
    > # ---
    > # - C:/ruby19trunk
    > # - C:/ruby192dev
    > #
    > C:/apps/pik/rubies/ruby-1.9.2-p136
    >
    > I get following:
    >
    > C:\zdisks\devkit>ruby dk.rb review
    >
    > Invalid configuration. Please fix 'config.yml.'
    >
    > How painful.
    >



    As indicated in the example, you need to provide a list of
    directiories, even if there is one:

    - C:/Path/to/ruby
    - C:/Path/To/another/ruby

    Simply adding the dash should solve your problem.

    --
    Luis Lavena
     
    Luis Lavena, Apr 9, 2011
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?U3JpZGhhcg==?=

    Not able to find CrystalReport class in VS 2005.

    =?Utf-8?B?U3JpZGhhcg==?=, Apr 9, 2007, in forum: ASP .Net
    Replies:
    0
    Views:
    319
    =?Utf-8?B?U3JpZGhhcg==?=
    Apr 9, 2007
  2. Allan Chin
    Replies:
    16
    Views:
    486
    Roger Pack
    Nov 17, 2010
  3. Jon
    Replies:
    0
    Views:
    142
  4. Chris Lervag
    Replies:
    3
    Views:
    175
    Chris Lervag
    Mar 29, 2011
  5. sed_y
    Replies:
    0
    Views:
    1,023
    sed_y
    Feb 15, 2012
Loading...

Share This Page