Doesnot allow to debug or asks for username and password in visual studio.net academic 2003

Discussion in 'ASP .Net' started by Anita, Jan 14, 2005.

  1. Anita

    Anita Guest

    I have problem opening my existing projects or newly created project. It
    asks me for user name and password and if I provide then it allows me to
    open but when I debug either it gives error message that you are not the
    debugger user (although I am administrator of my computer) or while running
    it doesnot connect to the database server. I am using NT authentication.
    Please help.
    Thanks,
    Anita
     
    Anita, Jan 14, 2005
    #1
    1. Advertising

  2. Anita

    Suhaib Khan Guest

    You need to add the account to "Debugger Users" group to debug the
    application.

    Database connection - send more detail about your network setupo like
    whether databse server and your machine or in same domain or not.

    "Anita" <> wrote in message
    news:<#MO4QFo#>...

    > I have problem opening my existing projects or newly created project.


    > It


    > asks me for user name and password and if I provide then it allows me to


    > open but when I debug either it gives error message that you are not the


    > debugger user (although I am administrator of my computer) or while

    running

    > it doesnot connect to the database server. I am using NT authentication.


    > Please help.


    > Thanks,


    > Anita


    >


    >
     
    Suhaib Khan, Jan 14, 2005
    #2
    1. Advertising

  3. Anita

    Anita Gupta Guest

    My account is on the saas the database server. Database server name is
    cerebrum and domain name is som. My computer's name is axg68 and my
    login is anita. I am trying to use my domain user account like som\anita
    and I am the administrator and debugger user of my computer. My
    computer's hard drive was crashed and I was able to restore it to a new
    hard drive but I think I lost some of the information. I uninstalled and
    reinstalled iis and visual studio.net but it is not fixing the problem.
    Along with NT authentication I have also selected allow anonymous access
    and their I provided my user name and password and deselected the option
    allow IIS to change password for the virtual directory in my local IIS.
    Whenever I open a project it asks me for the user name and password and
    after supplying the login information it allows me to open the project
    and when I try to debug or run it again asks me for the login
    information and then it gives database connection error message. If I
    remove NT authentication from the IIS virtual directory then it doesnot
    asks me for the login information while opening the project but then it
    does not allow me to debug. It tells me that I am not a debugger user.
    Now I do not understand how to fix it. Before hard drive crash it was
    working fine.
    Thanks,
    Anita




    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Anita Gupta, Jan 15, 2005
    #3
  4. Anita

    eruth Guest

    I had this issue - when trying to debug an ASP.Net application from the
    VS2003 IDE I got a box popping up telling me to enter the name &
    password of an account that had permissions to debug on the server.

    It was one of two things that fixed it - not sure which one it was
    though!
    Firstly, I added the IWAM_MACHINENAME account into the debuggers group,
    then I made sure within visual studio that only ASP.Net debugging was
    enabled, and _NOT_ ASP debugging (look in the project's properties). I
    then rebooted my pc (not sure if this is a necessary step, you may get
    away with restarting IIS) and it all worked.



    HTH

    Emma
     
    eruth, Jan 18, 2005
    #4
  5. Anita

    Anita Gupta Guest

    Thanks Emma,
    I will try this and see if it works or not.
    Anita


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Anita Gupta, Jan 18, 2005
    #5
  6. Anita

    Anita Gupta Guest

    I checked both. I added IWAM_Machinename in the debugger user and enable
    ASP.NET debugging is set to true. Now it doesnot ask for user name and
    password when I open the project but it doenot let me debugg. Error is
    "Error while trying to run the project. Unable to start debugging on the
    web server. you donot have permission to debugs the server. Verify that
    you are a member of the "Debugger Users" group on the server." Now I
    really donot know what to do.
    Any help will be appreciated.
    Anita

    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Anita Gupta, Jan 18, 2005
    #6
  7. Anita

    Anita Gupta Guest

    Hi,
    The problem is solved and I would like to share with you all. Somehow it
    was not trusting on my on own localhost. I added http://localhost to the
    trusted sites option in internet explorer -> tools ->internet options ->
    security tab.
    thanks for all your help
    anita



    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Anita Gupta, Jan 18, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wh
    Replies:
    2
    Views:
    552
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  2. =?Utf-8?B?TmFz?=

    Visual Studio .Net Academic on intel based mac

    =?Utf-8?B?TmFz?=, Aug 15, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    928
    Scott M.
    Sep 9, 2006
  3. xman
    Replies:
    0
    Views:
    543
  4. xman
    Replies:
    1
    Views:
    640
    Victor Bazarov
    Aug 17, 2005
  5. Ashutosh

    Asp Page asks for username & password

    Ashutosh, Oct 5, 2005, in forum: ASP General
    Replies:
    2
    Views:
    171
    Alexandru TUDOSE
    Oct 7, 2005
Loading...

Share This Page