Don know Perl, don't know what's broke - re - type1inst!!

Discussion in 'Perl' started by DP, Jul 17, 2003.

  1. DP

    DP Guest

    (2nd post, I think my first may have been to the wrong group - sorry)

    Hello Perl-ers -

    I´m hoping I can get some help here, because I'm very lost. Don't know
    Perl, I'm not a programmer. And this is something that has worked for
    me earlier, only now it doesn't anymore.

    ---------------------------------
    The ¨problem¨ script -
    line 995 onwards as found in file 'type1inst' available in package/at
    http://www.ibiblio.org/pub/Linux/X11/xutils/type1inst-0.6.1.tar.gz
    which I've copied below. Simple enough, & looks OK too.
    ---------------------------------
    #
    # Some users have had problems with perl's file globbing not
    working.This
    # gets a shell to do it for us. It matches all files with the
    extension
    # specified in the parameter, i.e. if pat = "foo" then it matches all
    of
    # *.foo .
    #
    sub do_glob {
    ($pat) = @_;
    local($raw, @fnames);
    open(SHELL, "echo *.$pat|") || die("Couldn't open shell in
    do_glob\n");
    $raw = <SHELL>;
    $raw =~ s/\*\.$pat//;
    @fnames = split(/\s/,$raw); ## <--- line 1008
    close(SHELL);
    (@fnames);
    }
    ------------------------------------

    Error Message before I get before script dies -
    Split loop at /usr/bin/type1inst line 1008, <SHELL> line 1.
    ------------------------------------

    Now I KNOW this has worked for me on a previous machine, and only
    recently (just
    installed Linux, thus trying to transfer Type 1 fonts from my old
    machine to new one), I just don't know why it's not working any more.
    I don have my old machine for a reference anymore either.

    I'm running Redhat 9 and details from 'perl -V' are listed at the end
    of this email.

    So is there something wrong with my system? Is it the script that's
    broke, my system, or has something changed in Perl? If it's tha last
    of the three, could someone help me fix this?

    Any help will be greatly appreciated.

    TIA.
    Regards,

    Dinil Penne

    # perl -V
    Summary of my perl5 (revision 5.0 version 8 subversion 0)
    configuration:
    Platform:
    osname=linux, osvers=2.4.20-2.48smp,
    archname=i386-linux-thread-multi
    uname='linux str'
    config_args='-des -Doptimize=-O2 -march=i386 -mcpu=i686 -g
    -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red
    Hat, Inc. -Dinstallprefix=/usr -Dprefix=/usr -Darchname=i386-linux
    -Dvendorprefix=/usr -Dsiteprefix=/usr
    -Dotherlibdirs=/usr/lib/perl5/5.8.0 -Duseshrplib -Dusethreads
    -Duseithreads -Duselargefiles -Dd_dosuid -Dd_semctl_semun -Di_db
    -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio
    -Dinstallusrbinperl -Ubincompat5005 -Uversiononly
    -Dpager=/usr/bin/less -isr'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=undef'
    useithreads=define usemultiplicity=
    useperlio= d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=un uselongdouble=
    usemymalloc=, bincompat5005=undef
    Compiler:
    cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS
    -DDEBUGGING -fno-strict-aliasing -I/usr/local/include
    -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm',
    optimize='',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS
    -DDEBUGGING -fno-strict-aliasing -I/usr/local/include
    -I/usr/include/gdbm'
    ccversion='', gccversion='3.2.2 20030213 (Red Hat Linux 8.0
    3.2.2-1)', gccosandvers=''
    gccversion='3.2.2 200302'
    intsize=e, longsize= , ptrsize=p, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define,
    longdblsize=12
    ivtype='long'
    k', ivsize=4'
    ivtype='long'
    known_ext, nvtype='double'
    o_nonbl', nvsize=, Off_t='', lseeksize=8
    alignbytes=4, prototype=define
    Linker and Libraries:
    ld='gcc'
    l', ldflags =' -L/usr/local/lib'
    ldf'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lpthread -lc -lcrypt -lutil
    perllibs=
    libc=/lib/libc-2.3.1.so, so=so, useshrplib=true, libperl=libper
    gnulibc_version='2.3.1'
    Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so', d_dlsymun=undef,
    ccdlflags='-rdynamic
    -Wl,-rpath,/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE'
    cccdlflags='-fPIC'
    ccdlflags='-rdynamic -Wl,-rpath,/usr/lib/perl5', lddlflags='s
    Unicode/Normalize
    XS/A'


    Characteristics of this binary (from libperl):
    Compile-time options: DEBUGGING MULTIPLICITY USE_ITHREADS
    USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
    Locally applied patches:
    MAINT18379
    Built under linux
    Compiled at Feb 18 2003 22:19:53
    @INC:
    /usr/lib/perl5/5.8.0/i386-linux-thread-multi
    /usr/lib/perl5/5.8.0
    /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
    /usr/lib/perl5/site_perl/5.8.0
    /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.8.0
    /usr/lib/perl5/vendor_perl
    /usr/lib/perl5/5.8.0/i386-linux-thread-multi
    /usr/lib/perl5/5.8.0
    DP, Jul 17, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Troy
    Replies:
    2
    Views:
    430
    Troy Dedmon
    Jul 8, 2003
  2. MattB

    Broke my app

    MattB, Jan 21, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    448
    MattB
    Jan 22, 2004
  3. martin

    Framework 1.1 broke ado

    martin, Feb 11, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    1,220
    martin
    Feb 12, 2004
  4. Daniel Berger
    Replies:
    4
    Views:
    105
    Daniel Berger
    Sep 28, 2008
  5. Andries

    I know, I know, I don't know

    Andries, Apr 23, 2004, in forum: Perl Misc
    Replies:
    3
    Views:
    219
    Gregory Toomey
    Apr 23, 2004
Loading...

Share This Page