Eclipse and JBoss

Discussion in 'Java' started by tom.simmons@vetco.com, Apr 28, 2008.

  1. Guest

    Hi Folks

    I'm fairly new to using Eclipse and JBoss, so excuse me if this
    question is daft....

    I have JBoss (4.2) working fine with Eclipse (3.3.2) when all I want
    to do is run/debug stuff locally. The problem I currently have is I
    need someone else to point their browser at my development JBoss and
    see what I've been working on.

    As far as I can make out, the current config only responds to
    http://localhost:8080, I can't even use my IP address of machine name
    locally. From reading around, it seems I need to add -b <my ip
    address> to the arguments list, however when I try this I get an error
    towards the end of the server start up about it timing out. (I haven't
    found a more detailed output)

    Just for info, if I put 127.0.0.1 as my adress is starts fine, though
    obviously I still can't access my machine from another.


    Tom
     
    , Apr 28, 2008
    #1
    1. Advertising

  2. EricF Guest

    In article <>, "" <> wrote:
    >Hi Folks
    >
    >I'm fairly new to using Eclipse and JBoss, so excuse me if this
    >question is daft....
    >
    >I have JBoss (4.2) working fine with Eclipse (3.3.2) when all I want
    >to do is run/debug stuff locally. The problem I currently have is I
    >need someone else to point their browser at my development JBoss and
    >see what I've been working on.
    >
    >As far as I can make out, the current config only responds to
    >http://localhost:8080, I can't even use my IP address of machine name
    >locally. From reading around, it seems I need to add -b <my ip
    >address> to the arguments list, however when I try this I get an error
    >towards the end of the server start up about it timing out. (I haven't
    >found a more detailed output)
    >
    >Just for info, if I put 127.0.0.1 as my adress is starts fine, though
    >obviously I still can't access my machine from another.
    >
    >
    >Tom


    I think you are right about the -b option if using JBoss 4.2.x. From the
    release notes:

    * JBossAS now binds its services to localhost (127.0.0.1) *by default*,
    instead of binding to all available interfaces (0.0.0.0). This was primarily
    done for security reasons because of concerns of users going to production
    without having secured their servers properly. To enable remote access by
    binding JBoss services to a particular interface, simply run jboss with the -b
    option, but be aware you still need to secure you server properly.

    Try that, find the error in boot.log or server.log, and post the relevant
    errors message from the log, and mention what OS you are running.

    Eric
     
    EricF, Apr 29, 2008
    #2
    1. Advertising

  3. Tom Guest

    On Apr 29, 3:39 am, (EricF) wrote:
    > In article <>, "" <> wrote:
    >
    >
    >
    >
    >
    > >Hi Folks

    >
    > >I'm fairly new to using Eclipse and JBoss, so excuse me if this
    > >question is daft....

    >
    > >I have JBoss (4.2) working fine with Eclipse (3.3.2) when all I want
    > >to do is run/debug stuff locally.  The problem I currently have is I
    > >need someone else to point their browser at my development JBoss and
    > >see what I've been working on.

    >
    > >As far as I can make out, the current config only responds to
    > >http://localhost:8080, I can't even use my IP address of machine name
    > >locally.  From reading around, it seems I need to add -b <my ip
    > >address> to the arguments list, however when I try this I get an error
    > >towards the end of the server start up about it timing out. (I haven't
    > >found a more detailed output)

    >
    > >Just for info, if I put 127.0.0.1 as my adress is starts fine, though
    > >obviously I still can't access my machine from another.

    >
    > >Tom

    >
    > I think you are right about the -b option if using JBoss 4.2.x. From the
    > release notes:
    >
    >     * JBossAS now binds its services to localhost (127.0.0.1) *by default*,
    > instead of binding to all available interfaces (0.0.0.0). This was primarily
    > done for security reasons because of concerns of users going to production
    > without having secured their servers properly. To enable remote access by
    > binding JBoss services to a particular interface, simply run jboss with the -b
    > option, but be aware you still need to secure you server properly.
    >
    > Try that, find the error in boot.log or server.log, and post the relevant
    > errors message from the log, and mention what OS you are running.
    >
    > Eric- Hide quoted text -
    >
    > - Show quoted text -


    Thank you, you were spot on with 0.0.0.0.

    As for the reply previous to that, the reason I did not supply such
    details is because I am talking about JBoss being used with Eclipse on
    a development machine, not a mass audience machine.

    Tom
     
    Tom, Apr 29, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John F.
    Replies:
    1
    Views:
    774
    Bruno Grieder
    Oct 14, 2005
  2. Rob Mitchell
    Replies:
    0
    Views:
    2,217
    Rob Mitchell
    Jan 25, 2006
  3. han
    Replies:
    0
    Views:
    499
  4. Jubz
    Replies:
    0
    Views:
    2,355
  5. LprzemekL
    Replies:
    0
    Views:
    554
    LprzemekL
    Apr 10, 2008
Loading...

Share This Page