ERROR: 'HTTP/1.0 503 Service Unavailable'

Discussion in 'ASP .Net' started by =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 2, 2005.

  1. Hi,

    i'm trying to create my first ASP.NET project ( HelloASPWorld project) but
    an error occured when I put OK button in NewProject.
    ERROR:
    "The Web server reported the following error when attempting to create or
    open the Web project located at the following URL:
    'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."


    I have installed IIS first and then reinstall Visual Studio
    I don't know what I have to set yet to solve this problem.

    Please help me!
    --
    Tomas
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 2, 2005
    #1
    1. Advertising

  2. When I replace localhost in: 'https://localhost/HelloASPWorld' with 127.0.0.1
    'https://127.0.0.1/HelloASPWorld' an error accured:

    The Web server reported the following error when attempting to create or
    open the Web project located at the following URL:
    'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not be
    established'.

    So can anyone help me????

    Thanx, Tomas



    "Tomas Kepic" wrote:

    > Hi,
    >
    > i'm trying to create my first ASP.NET project ( HelloASPWorld project) but
    > an error occured when I put OK button in NewProject.
    > ERROR:
    > "The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:
    > 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
    >
    >
    > I have installed IIS first and then reinstall Visual Studio
    > I don't know what I have to set yet to solve this problem.
    >
    > Please help me!
    > --
    > Tomas
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 2, 2005
    #2
    1. Advertising

  3. Are you trying to create a secure site ?

    Try http://localhost/HelloASPWorld
    or http://127.0.0.1/HelloASPWorld
    and see if *those* work...




    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "Tomas Kepic" <> wrote in message
    news:...
    > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    > 127.0.0.1
    > 'https://127.0.0.1/HelloASPWorld' an error accured:
    >
    > The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:
    > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not
    > be
    > established'.
    >
    > So can anyone help me????
    >
    > Thanx, Tomas
    >
    >
    >
    > "Tomas Kepic" wrote:
    >
    >> Hi,
    >>
    >> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
    >> but
    >> an error occured when I put OK button in NewProject.
    >> ERROR:
    >> "The Web server reported the following error when attempting to create or
    >> open the Web project located at the following URL:
    >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
    >>
    >>
    >> I have installed IIS first and then reinstall Visual Studio
    >> I don't know what I have to set yet to solve this problem.
    >>
    >> Please help me!
    >> --
    >> Tomas
     
    Juan T. Llibre, Apr 2, 2005
    #3
  4. Hi Juan,

    first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
    Thanks.

    Can you tell me why alias 'localhost' doesn't work? In
    "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
    127.0.0.1 localhost

    Thank you, Tomas


    "Juan T. Llibre" wrote:

    > Are you trying to create a secure site ?
    >
    > Try http://localhost/HelloASPWorld
    > or http://127.0.0.1/HelloASPWorld
    > and see if *those* work...
    >
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "Tomas Kepic" <> wrote in message
    > news:...
    > > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    > > 127.0.0.1
    > > 'https://127.0.0.1/HelloASPWorld' an error accured:
    > >
    > > The Web server reported the following error when attempting to create or
    > > open the Web project located at the following URL:
    > > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could not
    > > be
    > > established'.
    > >
    > > So can anyone help me????
    > >
    > > Thanx, Tomas
    > >
    > >
    > >
    > > "Tomas Kepic" wrote:
    > >
    > >> Hi,
    > >>
    > >> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
    > >> but
    > >> an error occured when I put OK button in NewProject.
    > >> ERROR:
    > >> "The Web server reported the following error when attempting to create or
    > >> open the Web project located at the following URL:
    > >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
    > >>
    > >>
    > >> I have installed IIS first and then reinstall Visual Studio
    > >> I don't know what I have to set yet to solve this problem.
    > >>
    > >> Please help me!
    > >> --
    > >> Tomas

    >
    >
    >
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 3, 2005
    #4
  5. Your hosts file doesn't have an extension, does it ?
    ( You don't have hosts.txt, I assume )

    If your hosts file doesn't have an extension,
    there might be something wrong with your TCP/IP stack.

    It's difficult to diagnose the lack of recognition for localhost.

    Can you ping 127.0.0.1 ?
    Can you ping localhost ?

    Does your machine name work ?
    http://YourMachineName/ should work, too.

    Can you ping YourMachineName ?



    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "Tomas Kepic" <> wrote in message
    news:...
    > Hi Juan,
    >
    > first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
    > Thanks.
    >
    > Can you tell me why alias 'localhost' doesn't work? In
    > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
    > 127.0.0.1 localhost
    >
    > Thank you, Tomas
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> Are you trying to create a secure site ?
    >>
    >> Try http://localhost/HelloASPWorld
    >> or http://127.0.0.1/HelloASPWorld
    >> and see if *those* work...
    >>
    >>
    >>
    >>
    >> Juan T. Llibre
    >> ASP.NET MVP
    >> http://asp.net.do/foros/
    >> Foros de ASP.NET en Español
    >> Ven, y hablemos de ASP.NET...
    >> ======================
    >>
    >> "Tomas Kepic" <> wrote in message
    >> news:...
    >> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    >> > 127.0.0.1
    >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    >> >
    >> > The Web server reported the following error when attempting to create
    >> > or
    >> > open the Web project located at the following URL:
    >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could
    >> > not
    >> > be
    >> > established'.
    >> >
    >> > So can anyone help me????
    >> >
    >> > Thanx, Tomas
    >> >
    >> >
    >> >
    >> > "Tomas Kepic" wrote:
    >> >
    >> >> Hi,
    >> >>
    >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
    >> >> but
    >> >> an error occured when I put OK button in NewProject.
    >> >> ERROR:
    >> >> "The Web server reported the following error when attempting to create
    >> >> or
    >> >> open the Web project located at the following URL:
    >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
    >> >>
    >> >>
    >> >> I have installed IIS first and then reinstall Visual Studio
    >> >> I don't know what I have to set yet to solve this problem.
    >> >>
    >> >> Please help me!
    >> >> --
    >> >> Tomas

    >>
    >>
    >>
     
    Juan T. Llibre, Apr 3, 2005
    #5
  6. Hi,

    I can ping all from this options:
    ping 127.0.0.1
    ping localhost
    and also ping MyMachineName

    but http://myMachineName/ doesn't work!!!


    And you are true, my host file doesn't have an extension. Should I rename it
    to host.txt?

    Tomas

    "Juan T. Llibre" wrote:

    > Your hosts file doesn't have an extension, does it ?
    > ( You don't have hosts.txt, I assume )
    >
    > If your hosts file doesn't have an extension,
    > there might be something wrong with your TCP/IP stack.
    >
    > It's difficult to diagnose the lack of recognition for localhost.
    >
    > Can you ping 127.0.0.1 ?
    > Can you ping localhost ?
    >
    > Does your machine name work ?
    > http://YourMachineName/ should work, too.
    >
    > Can you ping YourMachineName ?
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "Tomas Kepic" <> wrote in message
    > news:...
    > > Hi Juan,
    > >
    > > first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
    > > Thanks.
    > >
    > > Can you tell me why alias 'localhost' doesn't work? In
    > > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
    > > 127.0.0.1 localhost
    > >
    > > Thank you, Tomas
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> Are you trying to create a secure site ?
    > >>
    > >> Try http://localhost/HelloASPWorld
    > >> or http://127.0.0.1/HelloASPWorld
    > >> and see if *those* work...
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre
    > >> ASP.NET MVP
    > >> http://asp.net.do/foros/
    > >> Foros de ASP.NET en Español
    > >> Ven, y hablemos de ASP.NET...
    > >> ======================
    > >>
    > >> "Tomas Kepic" <> wrote in message
    > >> news:...
    > >> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    > >> > 127.0.0.1
    > >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    > >> >
    > >> > The Web server reported the following error when attempting to create
    > >> > or
    > >> > open the Web project located at the following URL:
    > >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server could
    > >> > not
    > >> > be
    > >> > established'.
    > >> >
    > >> > So can anyone help me????
    > >> >
    > >> > Thanx, Tomas
    > >> >
    > >> >
    > >> >
    > >> > "Tomas Kepic" wrote:
    > >> >
    > >> >> Hi,
    > >> >>
    > >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld project)
    > >> >> but
    > >> >> an error occured when I put OK button in NewProject.
    > >> >> ERROR:
    > >> >> "The Web server reported the following error when attempting to create
    > >> >> or
    > >> >> open the Web project located at the following URL:
    > >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service Unavailable'."
    > >> >>
    > >> >>
    > >> >> I have installed IIS first and then reinstall Visual Studio
    > >> >> I don't know what I have to set yet to solve this problem.
    > >> >>
    > >> >> Please help me!
    > >> >> --
    > >> >> Tomas
    > >>
    > >>
    > >>

    >
    >
    >
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 3, 2005
    #6
  7. re:
    > Should I rename it to host.txt?


    No. Do *not* rename it.

    It should *not* have an extension.
    It's fine as it is.

    If it *did* have an extension ( like .txt,
    added almost automatically by Notepad ),
    *That* could be a reason for it *not* to work.

    Sorry if I wasn't clear enough.

    re:
    > but http://myMachineName/ doesn't work!!!


    Then, it's pretty sure there's something
    screwed up in your TCP/IP stack.

    That happened to me a long time ago,
    using Windows 98 and ASP 1.0.

    It was a pain in the you-know-what,
    and I was never able to fix it

    Only when I changed the OS to a Server OS,
    was I able to use localhost for a web address.

    Which OS are you using ? Windows XP ?

    There's a patch available from Microsoft
    which covers precisely that problem.

    You might want to apply it, if you're running
    Windows XP and have applied SP2.

    It's at

    http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en

    Try that, and let us know...




    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "Tomas Kepic" <> wrote in message
    news:...
    > Hi,
    >
    > I can ping all from this options:
    > ping 127.0.0.1
    > ping localhost
    > and also ping MyMachineName
    >
    > but http://myMachineName/ doesn't work!!!
    >
    >
    > And you are true, my host file doesn't have an extension. Should I rename
    > it
    > to host.txt?
    >
    > Tomas
    >
    > "Juan T. Llibre" wrote:
    >
    >> Your hosts file doesn't have an extension, does it ?
    >> ( You don't have hosts.txt, I assume )
    >>
    >> If your hosts file doesn't have an extension,
    >> there might be something wrong with your TCP/IP stack.
    >>
    >> It's difficult to diagnose the lack of recognition for localhost.
    >>
    >> Can you ping 127.0.0.1 ?
    >> Can you ping localhost ?
    >>
    >> Does your machine name work ?
    >> http://YourMachineName/ should work, too.
    >>
    >> Can you ping YourMachineName ?
    >>
    >>
    >>
    >> Juan T. Llibre
    >> ASP.NET MVP
    >> http://asp.net.do/foros/
    >> Foros de ASP.NET en Español
    >> Ven, y hablemos de ASP.NET...
    >> ======================
    >>
    >> "Tomas Kepic" <> wrote in message
    >> news:...
    >> > Hi Juan,
    >> >
    >> > first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
    >> > Thanks.
    >> >
    >> > Can you tell me why alias 'localhost' doesn't work? In
    >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
    >> > 127.0.0.1 localhost
    >> >
    >> > Thank you, Tomas
    >> >
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> Are you trying to create a secure site ?
    >> >>
    >> >> Try http://localhost/HelloASPWorld
    >> >> or http://127.0.0.1/HelloASPWorld
    >> >> and see if *those* work...
    >> >>
    >> >>
    >> >>
    >> >>
    >> >> Juan T. Llibre
    >> >> ASP.NET MVP
    >> >> http://asp.net.do/foros/
    >> >> Foros de ASP.NET en Español
    >> >> Ven, y hablemos de ASP.NET...
    >> >> ======================
    >> >>
    >> >> "Tomas Kepic" <> wrote in message
    >> >> news:...
    >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    >> >> > 127.0.0.1
    >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    >> >> >
    >> >> > The Web server reported the following error when attempting to
    >> >> > create
    >> >> > or
    >> >> > open the Web project located at the following URL:
    >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
    >> >> > could
    >> >> > not
    >> >> > be
    >> >> > established'.
    >> >> >
    >> >> > So can anyone help me????
    >> >> >
    >> >> > Thanx, Tomas
    >> >> >
    >> >> >
    >> >> >
    >> >> > "Tomas Kepic" wrote:
    >> >> >
    >> >> >> Hi,
    >> >> >>
    >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    >> >> >> project)
    >> >> >> but
    >> >> >> an error occured when I put OK button in NewProject.
    >> >> >> ERROR:
    >> >> >> "The Web server reported the following error when attempting to
    >> >> >> create
    >> >> >> or
    >> >> >> open the Web project located at the following URL:
    >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    >> >> >> Unavailable'."
    >> >> >>
    >> >> >>
    >> >> >> I have installed IIS first and then reinstall Visual Studio
    >> >> >> I don't know what I have to set yet to solve this problem.
    >> >> >>
    >> >> >> Please help me!
    >> >> >> --
    >> >> >> Tomas
    >> >>
    >> >>
    >> >>

    >>
    >>
    >>
     
    Juan T. Llibre, Apr 3, 2005
    #7
  8. Hi,

    yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.

    I'll try "your" patch and I'll give you an answer if it helps.

    Tomas

    "Juan T. Llibre" wrote:

    > re:
    > > Should I rename it to host.txt?

    >
    > No. Do *not* rename it.
    >
    > It should *not* have an extension.
    > It's fine as it is.
    >
    > If it *did* have an extension ( like .txt,
    > added almost automatically by Notepad ),
    > *That* could be a reason for it *not* to work.
    >
    > Sorry if I wasn't clear enough.
    >
    > re:
    > > but http://myMachineName/ doesn't work!!!

    >
    > Then, it's pretty sure there's something
    > screwed up in your TCP/IP stack.
    >
    > That happened to me a long time ago,
    > using Windows 98 and ASP 1.0.
    >
    > It was a pain in the you-know-what,
    > and I was never able to fix it
    >
    > Only when I changed the OS to a Server OS,
    > was I able to use localhost for a web address.
    >
    > Which OS are you using ? Windows XP ?
    >
    > There's a patch available from Microsoft
    > which covers precisely that problem.
    >
    > You might want to apply it, if you're running
    > Windows XP and have applied SP2.
    >
    > It's at
    >
    > http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en
    >
    > Try that, and let us know...
    >
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "Tomas Kepic" <> wrote in message
    > news:...
    > > Hi,
    > >
    > > I can ping all from this options:
    > > ping 127.0.0.1
    > > ping localhost
    > > and also ping MyMachineName
    > >
    > > but http://myMachineName/ doesn't work!!!
    > >
    > >
    > > And you are true, my host file doesn't have an extension. Should I rename
    > > it
    > > to host.txt?
    > >
    > > Tomas
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> Your hosts file doesn't have an extension, does it ?
    > >> ( You don't have hosts.txt, I assume )
    > >>
    > >> If your hosts file doesn't have an extension,
    > >> there might be something wrong with your TCP/IP stack.
    > >>
    > >> It's difficult to diagnose the lack of recognition for localhost.
    > >>
    > >> Can you ping 127.0.0.1 ?
    > >> Can you ping localhost ?
    > >>
    > >> Does your machine name work ?
    > >> http://YourMachineName/ should work, too.
    > >>
    > >> Can you ping YourMachineName ?
    > >>
    > >>
    > >>
    > >> Juan T. Llibre
    > >> ASP.NET MVP
    > >> http://asp.net.do/foros/
    > >> Foros de ASP.NET en Español
    > >> Ven, y hablemos de ASP.NET...
    > >> ======================
    > >>
    > >> "Tomas Kepic" <> wrote in message
    > >> news:...
    > >> > Hi Juan,
    > >> >
    > >> > first option failed, but second "http://127.0.0.1/HelloASPWorld" works.
    > >> > Thanks.
    > >> >
    > >> > Can you tell me why alias 'localhost' doesn't work? In
    > >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP address:
    > >> > 127.0.0.1 localhost
    > >> >
    > >> > Thank you, Tomas
    > >> >
    > >> >
    > >> > "Juan T. Llibre" wrote:
    > >> >
    > >> >> Are you trying to create a secure site ?
    > >> >>
    > >> >> Try http://localhost/HelloASPWorld
    > >> >> or http://127.0.0.1/HelloASPWorld
    > >> >> and see if *those* work...
    > >> >>
    > >> >>
    > >> >>
    > >> >>
    > >> >> Juan T. Llibre
    > >> >> ASP.NET MVP
    > >> >> http://asp.net.do/foros/
    > >> >> Foros de ASP.NET en Español
    > >> >> Ven, y hablemos de ASP.NET...
    > >> >> ======================
    > >> >>
    > >> >> "Tomas Kepic" <> wrote in message
    > >> >> news:...
    > >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld' with
    > >> >> > 127.0.0.1
    > >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    > >> >> >
    > >> >> > The Web server reported the following error when attempting to
    > >> >> > create
    > >> >> > or
    > >> >> > open the Web project located at the following URL:
    > >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
    > >> >> > could
    > >> >> > not
    > >> >> > be
    > >> >> > established'.
    > >> >> >
    > >> >> > So can anyone help me????
    > >> >> >
    > >> >> > Thanx, Tomas
    > >> >> >
    > >> >> >
    > >> >> >
    > >> >> > "Tomas Kepic" wrote:
    > >> >> >
    > >> >> >> Hi,
    > >> >> >>
    > >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    > >> >> >> project)
    > >> >> >> but
    > >> >> >> an error occured when I put OK button in NewProject.
    > >> >> >> ERROR:
    > >> >> >> "The Web server reported the following error when attempting to
    > >> >> >> create
    > >> >> >> or
    > >> >> >> open the Web project located at the following URL:
    > >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    > >> >> >> Unavailable'."
    > >> >> >>
    > >> >> >>
    > >> >> >> I have installed IIS first and then reinstall Visual Studio
    > >> >> >> I don't know what I have to set yet to solve this problem.
    > >> >> >>
    > >> >> >> Please help me!
    > >> >> >> --
    > >> >> >> Tomas
    > >> >>
    > >> >>
    > >> >>
    > >>
    > >>
    > >>

    >
    >
    >
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 3, 2005
    #8
  9. It's not "my" patch.

    It's an "official" Microsoft patch.

    Apparently, others have had
    the same problem you're reporting.

    It *clicked* for me, after we'd exchanged a couple of posts,
    that this patch had been made available to Windows XP SP2
    users, to solve -precisely- that problem, last September.

    I'll be looking forward to your confirmation that installing the
    patch does, indeed, make it possible for you to connect to
    localhost and to your machinename in URL addresses.




    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "Tomas Kepic" <> wrote in message
    news:...
    > Hi,
    >
    > yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
    >
    > I'll try "your" patch and I'll give you an answer if it helps.
    >
    > Tomas
    >
    > "Juan T. Llibre" wrote:
    >
    >> re:
    >> > Should I rename it to host.txt?

    >>
    >> No. Do *not* rename it.
    >>
    >> It should *not* have an extension.
    >> It's fine as it is.
    >>
    >> If it *did* have an extension ( like .txt,
    >> added almost automatically by Notepad ),
    >> *That* could be a reason for it *not* to work.
    >>
    >> Sorry if I wasn't clear enough.
    >>
    >> re:
    >> > but http://myMachineName/ doesn't work!!!

    >>
    >> Then, it's pretty sure there's something
    >> screwed up in your TCP/IP stack.
    >>
    >> That happened to me a long time ago,
    >> using Windows 98 and ASP 1.0.
    >>
    >> It was a pain in the you-know-what,
    >> and I was never able to fix it
    >>
    >> Only when I changed the OS to a Server OS,
    >> was I able to use localhost for a web address.
    >>
    >> Which OS are you using ? Windows XP ?
    >>
    >> There's a patch available from Microsoft
    >> which covers precisely that problem.
    >>
    >> You might want to apply it, if you're running
    >> Windows XP and have applied SP2.
    >>
    >> It's at
    >>
    >> http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en
    >>
    >> Try that, and let us know...
    >>
    >>
    >>
    >>
    >> Juan T. Llibre
    >> ASP.NET MVP
    >> http://asp.net.do/foros/
    >> Foros de ASP.NET en Español
    >> Ven, y hablemos de ASP.NET...
    >> ======================
    >>
    >> "Tomas Kepic" <> wrote in message
    >> news:...
    >> > Hi,
    >> >
    >> > I can ping all from this options:
    >> > ping 127.0.0.1
    >> > ping localhost
    >> > and also ping MyMachineName
    >> >
    >> > but http://myMachineName/ doesn't work!!!
    >> >
    >> >
    >> > And you are true, my host file doesn't have an extension. Should I
    >> > rename
    >> > it
    >> > to host.txt?
    >> >
    >> > Tomas
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> Your hosts file doesn't have an extension, does it ?
    >> >> ( You don't have hosts.txt, I assume )
    >> >>
    >> >> If your hosts file doesn't have an extension,
    >> >> there might be something wrong with your TCP/IP stack.
    >> >>
    >> >> It's difficult to diagnose the lack of recognition for localhost.
    >> >>
    >> >> Can you ping 127.0.0.1 ?
    >> >> Can you ping localhost ?
    >> >>
    >> >> Does your machine name work ?
    >> >> http://YourMachineName/ should work, too.
    >> >>
    >> >> Can you ping YourMachineName ?
    >> >>
    >> >>
    >> >>
    >> >> Juan T. Llibre
    >> >> ASP.NET MVP
    >> >> http://asp.net.do/foros/
    >> >> Foros de ASP.NET en Español
    >> >> Ven, y hablemos de ASP.NET...
    >> >> ======================
    >> >>
    >> >> "Tomas Kepic" <> wrote in message
    >> >> news:...
    >> >> > Hi Juan,
    >> >> >
    >> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
    >> >> > works.
    >> >> > Thanks.
    >> >> >
    >> >> > Can you tell me why alias 'localhost' doesn't work? In
    >> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
    >> >> > address:
    >> >> > 127.0.0.1 localhost
    >> >> >
    >> >> > Thank you, Tomas
    >> >> >
    >> >> >
    >> >> > "Juan T. Llibre" wrote:
    >> >> >
    >> >> >> Are you trying to create a secure site ?
    >> >> >>
    >> >> >> Try http://localhost/HelloASPWorld
    >> >> >> or http://127.0.0.1/HelloASPWorld
    >> >> >> and see if *those* work...
    >> >> >>
    >> >> >>
    >> >> >>
    >> >> >>
    >> >> >> Juan T. Llibre
    >> >> >> ASP.NET MVP
    >> >> >> http://asp.net.do/foros/
    >> >> >> Foros de ASP.NET en Español
    >> >> >> Ven, y hablemos de ASP.NET...
    >> >> >> ======================
    >> >> >>
    >> >> >> "Tomas Kepic" <> wrote in
    >> >> >> message
    >> >> >> news:...
    >> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
    >> >> >> > with
    >> >> >> > 127.0.0.1
    >> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    >> >> >> >
    >> >> >> > The Web server reported the following error when attempting to
    >> >> >> > create
    >> >> >> > or
    >> >> >> > open the Web project located at the following URL:
    >> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
    >> >> >> > could
    >> >> >> > not
    >> >> >> > be
    >> >> >> > established'.
    >> >> >> >
    >> >> >> > So can anyone help me????
    >> >> >> >
    >> >> >> > Thanx, Tomas
    >> >> >> >
    >> >> >> >
    >> >> >> >
    >> >> >> > "Tomas Kepic" wrote:
    >> >> >> >
    >> >> >> >> Hi,
    >> >> >> >>
    >> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    >> >> >> >> project)
    >> >> >> >> but
    >> >> >> >> an error occured when I put OK button in NewProject.
    >> >> >> >> ERROR:
    >> >> >> >> "The Web server reported the following error when attempting to
    >> >> >> >> create
    >> >> >> >> or
    >> >> >> >> open the Web project located at the following URL:
    >> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    >> >> >> >> Unavailable'."
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> I have installed IIS first and then reinstall Visual Studio
    >> >> >> >> I don't know what I have to set yet to solve this problem.
    >> >> >> >>
    >> >> >> >> Please help me!
    >> >> >> >> --
    >> >> >> >> Tomas
    >> >> >>
    >> >> >>
    >> >> >>
    >> >>
    >> >>
    >> >>

    >>
    >>
    >>
     
    Juan T. Llibre, Apr 3, 2005
    #9
  10. Hello Juan,

    hmm, this patch doesn't work with my problem. I installed this patch,
    restarted OS and then I tried again create a new project using 'localhost'
    ('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
    Service Unavailable'.
    Also htttp://localhost/ and http://MyMachineName/ doesn't work.

    So, seems that I have just use 127.0.0.1 address if I want create some ASP
    project.

    Thanks Juan for your time.
    Tomas



    "Juan T. Llibre" wrote:

    > It's not "my" patch.
    >
    > It's an "official" Microsoft patch.
    >
    > Apparently, others have had
    > the same problem you're reporting.
    >
    > It *clicked* for me, after we'd exchanged a couple of posts,
    > that this patch had been made available to Windows XP SP2
    > users, to solve -precisely- that problem, last September.
    >
    > I'll be looking forward to your confirmation that installing the
    > patch does, indeed, make it possible for you to connect to
    > localhost and to your machinename in URL addresses.
    >
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "Tomas Kepic" <> wrote in message
    > news:...
    > > Hi,
    > >
    > > yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
    > >
    > > I'll try "your" patch and I'll give you an answer if it helps.
    > >
    > > Tomas
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> re:
    > >> > Should I rename it to host.txt?
    > >>
    > >> No. Do *not* rename it.
    > >>
    > >> It should *not* have an extension.
    > >> It's fine as it is.
    > >>
    > >> If it *did* have an extension ( like .txt,
    > >> added almost automatically by Notepad ),
    > >> *That* could be a reason for it *not* to work.
    > >>
    > >> Sorry if I wasn't clear enough.
    > >>
    > >> re:
    > >> > but http://myMachineName/ doesn't work!!!
    > >>
    > >> Then, it's pretty sure there's something
    > >> screwed up in your TCP/IP stack.
    > >>
    > >> That happened to me a long time ago,
    > >> using Windows 98 and ASP 1.0.
    > >>
    > >> It was a pain in the you-know-what,
    > >> and I was never able to fix it
    > >>
    > >> Only when I changed the OS to a Server OS,
    > >> was I able to use localhost for a web address.
    > >>
    > >> Which OS are you using ? Windows XP ?
    > >>
    > >> There's a patch available from Microsoft
    > >> which covers precisely that problem.
    > >>
    > >> You might want to apply it, if you're running
    > >> Windows XP and have applied SP2.
    > >>
    > >> It's at
    > >>
    > >> http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en
    > >>
    > >> Try that, and let us know...
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre
    > >> ASP.NET MVP
    > >> http://asp.net.do/foros/
    > >> Foros de ASP.NET en Español
    > >> Ven, y hablemos de ASP.NET...
    > >> ======================
    > >>
    > >> "Tomas Kepic" <> wrote in message
    > >> news:...
    > >> > Hi,
    > >> >
    > >> > I can ping all from this options:
    > >> > ping 127.0.0.1
    > >> > ping localhost
    > >> > and also ping MyMachineName
    > >> >
    > >> > but http://myMachineName/ doesn't work!!!
    > >> >
    > >> >
    > >> > And you are true, my host file doesn't have an extension. Should I
    > >> > rename
    > >> > it
    > >> > to host.txt?
    > >> >
    > >> > Tomas
    > >> >
    > >> > "Juan T. Llibre" wrote:
    > >> >
    > >> >> Your hosts file doesn't have an extension, does it ?
    > >> >> ( You don't have hosts.txt, I assume )
    > >> >>
    > >> >> If your hosts file doesn't have an extension,
    > >> >> there might be something wrong with your TCP/IP stack.
    > >> >>
    > >> >> It's difficult to diagnose the lack of recognition for localhost.
    > >> >>
    > >> >> Can you ping 127.0.0.1 ?
    > >> >> Can you ping localhost ?
    > >> >>
    > >> >> Does your machine name work ?
    > >> >> http://YourMachineName/ should work, too.
    > >> >>
    > >> >> Can you ping YourMachineName ?
    > >> >>
    > >> >>
    > >> >>
    > >> >> Juan T. Llibre
    > >> >> ASP.NET MVP
    > >> >> http://asp.net.do/foros/
    > >> >> Foros de ASP.NET en Español
    > >> >> Ven, y hablemos de ASP.NET...
    > >> >> ======================
    > >> >>
    > >> >> "Tomas Kepic" <> wrote in message
    > >> >> news:...
    > >> >> > Hi Juan,
    > >> >> >
    > >> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
    > >> >> > works.
    > >> >> > Thanks.
    > >> >> >
    > >> >> > Can you tell me why alias 'localhost' doesn't work? In
    > >> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
    > >> >> > address:
    > >> >> > 127.0.0.1 localhost
    > >> >> >
    > >> >> > Thank you, Tomas
    > >> >> >
    > >> >> >
    > >> >> > "Juan T. Llibre" wrote:
    > >> >> >
    > >> >> >> Are you trying to create a secure site ?
    > >> >> >>
    > >> >> >> Try http://localhost/HelloASPWorld
    > >> >> >> or http://127.0.0.1/HelloASPWorld
    > >> >> >> and see if *those* work...
    > >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >> >> Juan T. Llibre
    > >> >> >> ASP.NET MVP
    > >> >> >> http://asp.net.do/foros/
    > >> >> >> Foros de ASP.NET en Español
    > >> >> >> Ven, y hablemos de ASP.NET...
    > >> >> >> ======================
    > >> >> >>
    > >> >> >> "Tomas Kepic" <> wrote in
    > >> >> >> message
    > >> >> >> news:...
    > >> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
    > >> >> >> > with
    > >> >> >> > 127.0.0.1
    > >> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    > >> >> >> >
    > >> >> >> > The Web server reported the following error when attempting to
    > >> >> >> > create
    > >> >> >> > or
    > >> >> >> > open the Web project located at the following URL:
    > >> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the server
    > >> >> >> > could
    > >> >> >> > not
    > >> >> >> > be
    > >> >> >> > established'.
    > >> >> >> >
    > >> >> >> > So can anyone help me????
    > >> >> >> >
    > >> >> >> > Thanx, Tomas
    > >> >> >> >
    > >> >> >> >
    > >> >> >> >
    > >> >> >> > "Tomas Kepic" wrote:
    > >> >> >> >
    > >> >> >> >> Hi,
    > >> >> >> >>
    > >> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    > >> >> >> >> project)
    > >> >> >> >> but
    > >> >> >> >> an error occured when I put OK button in NewProject.
    > >> >> >> >> ERROR:
    > >> >> >> >> "The Web server reported the following error when attempting to
    > >> >> >> >> create
    > >> >> >> >> or
    > >> >> >> >> open the Web project located at the following URL:
    > >> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    > >> >> >> >> Unavailable'."
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >> I have installed IIS first and then reinstall Visual Studio
    > >> >> >> >> I don't know what I have to set yet to solve this problem.
    > >> >> >> >>
    > >> >> >> >> Please help me!
    > >> >> >> >> --
    > >> >> >> >> Tomas
    > >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >> >>
    > >>
    > >>
    > >>

    >
    >
    >
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 3, 2005
    #10
  11. Hmmm...

    Sorry to hear that.
    I was hopeful that the patch would be the solution.

    I'll see what I can do to explain your problem to
    the development teams, and see if some sort
    of answer comes out of that.



    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "Tomas Kepic" <> wrote in message
    news:D...
    > Hello Juan,
    >
    > hmm, this patch doesn't work with my problem. I installed this patch,
    > restarted OS and then I tried again create a new project using 'localhost'
    > ('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
    > Service Unavailable'.
    > Also htttp://localhost/ and http://MyMachineName/ doesn't work.
    >
    > So, seems that I have just use 127.0.0.1 address if I want create some ASP
    > project.
    >
    > Thanks Juan for your time.
    > Tomas


    > "Juan T. Llibre" wrote:
    >
    >> It's not "my" patch.
    >>
    >> It's an "official" Microsoft patch.
    >>
    >> Apparently, others have had
    >> the same problem you're reporting.
    >>
    >> It *clicked* for me, after we'd exchanged a couple of posts,
    >> that this patch had been made available to Windows XP SP2
    >> users, to solve -precisely- that problem, last September.
    >>
    >> I'll be looking forward to your confirmation that installing the
    >> patch does, indeed, make it possible for you to connect to
    >> localhost and to your machinename in URL addresses.
    >>
    >> Juan T. Llibre
    >> ===========
    >>
    >> "Tomas Kepic" <> wrote in message
    >> news:...
    >> > Hi,
    >> >
    >> > yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
    >> >
    >> > I'll try "your" patch and I'll give you an answer if it helps.
    >> >
    >> > Tomas
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> re:
    >> >> > Should I rename it to host.txt?
    >> >>
    >> >> No. Do *not* rename it.
    >> >>
    >> >> It should *not* have an extension.
    >> >> It's fine as it is.
    >> >>
    >> >> If it *did* have an extension ( like .txt,
    >> >> added almost automatically by Notepad ),
    >> >> *That* could be a reason for it *not* to work.
    >> >>
    >> >> Sorry if I wasn't clear enough.
    >> >>
    >> >> re:
    >> >> > but http://myMachineName/ doesn't work!!!
    >> >>
    >> >> Then, it's pretty sure there's something
    >> >> screwed up in your TCP/IP stack.
    >> >>
    >> >> That happened to me a long time ago,
    >> >> using Windows 98 and ASP 1.0.
    >> >>
    >> >> It was a pain in the you-know-what,
    >> >> and I was never able to fix it
    >> >>
    >> >> Only when I changed the OS to a Server OS,
    >> >> was I able to use localhost for a web address.
    >> >>
    >> >> Which OS are you using ? Windows XP ?
    >> >>
    >> >> There's a patch available from Microsoft
    >> >> which covers precisely that problem.
    >> >>
    >> >> You might want to apply it, if you're running
    >> >> Windows XP and have applied SP2.
    >> >>
    >> >> It's at
    >> >>
    >> >> http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en
    >> >>
    >> >> Try that, and let us know...
    >> >>
    >> >> Juan T. Llibre
    >> >> ==========
    >> >>
    >> >> "Tomas Kepic" <> wrote in message
    >> >> news:...
    >> >> > Hi,
    >> >> >
    >> >> > I can ping all from this options:
    >> >> > ping 127.0.0.1
    >> >> > ping localhost
    >> >> > and also ping MyMachineName
    >> >> >
    >> >> > but http://myMachineName/ doesn't work!!!
    >> >> >
    >> >> >
    >> >> > And you are true, my host file doesn't have an extension. Should I
    >> >> > rename
    >> >> > it
    >> >> > to host.txt?
    >> >> >
    >> >> > Tomas
    >> >> >
    >> >> > "Juan T. Llibre" wrote:
    >> >> >
    >> >> >> Your hosts file doesn't have an extension, does it ?
    >> >> >> ( You don't have hosts.txt, I assume )
    >> >> >>
    >> >> >> If your hosts file doesn't have an extension,
    >> >> >> there might be something wrong with your TCP/IP stack.
    >> >> >>
    >> >> >> It's difficult to diagnose the lack of recognition for localhost.
    >> >> >>
    >> >> >> Can you ping 127.0.0.1 ?
    >> >> >> Can you ping localhost ?
    >> >> >>
    >> >> >> Does your machine name work ?
    >> >> >> http://YourMachineName/ should work, too.
    >> >> >>
    >> >> >> Can you ping YourMachineName ?
    >> >> >>
    >> >> >> Juan T. Llibre
    >> >> >> ==========
    >> >> >>
    >> >> >> "Tomas Kepic" <> wrote in
    >> >> >> message
    >> >> >> news:...
    >> >> >> > Hi Juan,
    >> >> >> >
    >> >> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
    >> >> >> > works.
    >> >> >> > Thanks.
    >> >> >> >
    >> >> >> > Can you tell me why alias 'localhost' doesn't work? In
    >> >> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
    >> >> >> > address:
    >> >> >> > 127.0.0.1 localhost
    >> >> >> >
    >> >> >> > Thank you, Tomas
    >> >> >> >
    >> >> >> >
    >> >> >> > "Juan T. Llibre" wrote:
    >> >> >> >
    >> >> >> >> Are you trying to create a secure site ?
    >> >> >> >>
    >> >> >> >> Try http://localhost/HelloASPWorld
    >> >> >> >> or http://127.0.0.1/HelloASPWorld
    >> >> >> >> and see if *those* work...
    >> >> >> >>
    >> >> >> >> Juan T. Llibre
    >> >> >> >> ===========
    >> >> >> >>
    >> >> >> >> "Tomas Kepic" <> wrote in
    >> >> >> >> message
    >> >> >> >> news:...
    >> >> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
    >> >> >> >> > with
    >> >> >> >> > 127.0.0.1
    >> >> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    >> >> >> >> >
    >> >> >> >> > The Web server reported the following error when attempting to
    >> >> >> >> > create
    >> >> >> >> > or
    >> >> >> >> > open the Web project located at the following URL:
    >> >> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the
    >> >> >> >> > server
    >> >> >> >> > could
    >> >> >> >> > not
    >> >> >> >> > be
    >> >> >> >> > established'.
    >> >> >> >> >
    >> >> >> >> > So can anyone help me????
    >> >> >> >> >
    >> >> >> >> > Thanx, Tomas
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> >
    >> >> >> >> > "Tomas Kepic" wrote:
    >> >> >> >> >
    >> >> >> >> >> Hi,
    >> >> >> >> >>
    >> >> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    >> >> >> >> >> project)
    >> >> >> >> >> but
    >> >> >> >> >> an error occured when I put OK button in NewProject.
    >> >> >> >> >> ERROR:
    >> >> >> >> >> "The Web server reported the following error when attempting
    >> >> >> >> >> to
    >> >> >> >> >> create
    >> >> >> >> >> or
    >> >> >> >> >> open the Web project located at the following URL:
    >> >> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    >> >> >> >> >> Unavailable'."
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >> >> I have installed IIS first and then reinstall Visual Studio
    >> >> >> >> >> I don't know what I have to set yet to solve this problem.
    >> >> >> >> >>
    >> >> >> >> >> Please help me!
    >> >> >> >> >> --
    >> >> >> >> >> Tomas
     
    Juan T. Llibre, Apr 3, 2005
    #11
  12. Thanx, Tomas

    "Juan T. Llibre" wrote:

    > Hmmm...
    >
    > Sorry to hear that.
    > I was hopeful that the patch would be the solution.
    >
    > I'll see what I can do to explain your problem to
    > the development teams, and see if some sort
    > of answer comes out of that.
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "Tomas Kepic" <> wrote in message
    > news:D...
    > > Hello Juan,
    > >
    > > hmm, this patch doesn't work with my problem. I installed this patch,
    > > restarted OS and then I tried again create a new project using 'localhost'
    > > ('http://localhost/TestProject') and the same error occured: 'HTTP/1.0 503
    > > Service Unavailable'.
    > > Also htttp://localhost/ and http://MyMachineName/ doesn't work.
    > >
    > > So, seems that I have just use 127.0.0.1 address if I want create some ASP
    > > project.
    > >
    > > Thanks Juan for your time.
    > > Tomas

    >
    > > "Juan T. Llibre" wrote:
    > >
    > >> It's not "my" patch.
    > >>
    > >> It's an "official" Microsoft patch.
    > >>
    > >> Apparently, others have had
    > >> the same problem you're reporting.
    > >>
    > >> It *clicked* for me, after we'd exchanged a couple of posts,
    > >> that this patch had been made available to Windows XP SP2
    > >> users, to solve -precisely- that problem, last September.
    > >>
    > >> I'll be looking forward to your confirmation that installing the
    > >> patch does, indeed, make it possible for you to connect to
    > >> localhost and to your machinename in URL addresses.
    > >>
    > >> Juan T. Llibre
    > >> ===========
    > >>
    > >> "Tomas Kepic" <> wrote in message
    > >> news:...
    > >> > Hi,
    > >> >
    > >> > yes, my OS is Windows XP Professional, Version 2002, Service Pack 2.
    > >> >
    > >> > I'll try "your" patch and I'll give you an answer if it helps.
    > >> >
    > >> > Tomas
    > >> >
    > >> > "Juan T. Llibre" wrote:
    > >> >
    > >> >> re:
    > >> >> > Should I rename it to host.txt?
    > >> >>
    > >> >> No. Do *not* rename it.
    > >> >>
    > >> >> It should *not* have an extension.
    > >> >> It's fine as it is.
    > >> >>
    > >> >> If it *did* have an extension ( like .txt,
    > >> >> added almost automatically by Notepad ),
    > >> >> *That* could be a reason for it *not* to work.
    > >> >>
    > >> >> Sorry if I wasn't clear enough.
    > >> >>
    > >> >> re:
    > >> >> > but http://myMachineName/ doesn't work!!!
    > >> >>
    > >> >> Then, it's pretty sure there's something
    > >> >> screwed up in your TCP/IP stack.
    > >> >>
    > >> >> That happened to me a long time ago,
    > >> >> using Windows 98 and ASP 1.0.
    > >> >>
    > >> >> It was a pain in the you-know-what,
    > >> >> and I was never able to fix it
    > >> >>
    > >> >> Only when I changed the OS to a Server OS,
    > >> >> was I able to use localhost for a web address.
    > >> >>
    > >> >> Which OS are you using ? Windows XP ?
    > >> >>
    > >> >> There's a patch available from Microsoft
    > >> >> which covers precisely that problem.
    > >> >>
    > >> >> You might want to apply it, if you're running
    > >> >> Windows XP and have applied SP2.
    > >> >>
    > >> >> It's at
    > >> >>
    > >> >> http://www.microsoft.com/downloads/...d2-5034-4bbb-b74d-ad8430a1f7c8&DisplayLang=en
    > >> >>
    > >> >> Try that, and let us know...
    > >> >>
    > >> >> Juan T. Llibre
    > >> >> ==========
    > >> >>
    > >> >> "Tomas Kepic" <> wrote in message
    > >> >> news:...
    > >> >> > Hi,
    > >> >> >
    > >> >> > I can ping all from this options:
    > >> >> > ping 127.0.0.1
    > >> >> > ping localhost
    > >> >> > and also ping MyMachineName
    > >> >> >
    > >> >> > but http://myMachineName/ doesn't work!!!
    > >> >> >
    > >> >> >
    > >> >> > And you are true, my host file doesn't have an extension. Should I
    > >> >> > rename
    > >> >> > it
    > >> >> > to host.txt?
    > >> >> >
    > >> >> > Tomas
    > >> >> >
    > >> >> > "Juan T. Llibre" wrote:
    > >> >> >
    > >> >> >> Your hosts file doesn't have an extension, does it ?
    > >> >> >> ( You don't have hosts.txt, I assume )
    > >> >> >>
    > >> >> >> If your hosts file doesn't have an extension,
    > >> >> >> there might be something wrong with your TCP/IP stack.
    > >> >> >>
    > >> >> >> It's difficult to diagnose the lack of recognition for localhost.
    > >> >> >>
    > >> >> >> Can you ping 127.0.0.1 ?
    > >> >> >> Can you ping localhost ?
    > >> >> >>
    > >> >> >> Does your machine name work ?
    > >> >> >> http://YourMachineName/ should work, too.
    > >> >> >>
    > >> >> >> Can you ping YourMachineName ?
    > >> >> >>
    > >> >> >> Juan T. Llibre
    > >> >> >> ==========
    > >> >> >>
    > >> >> >> "Tomas Kepic" <> wrote in
    > >> >> >> message
    > >> >> >> news:...
    > >> >> >> > Hi Juan,
    > >> >> >> >
    > >> >> >> > first option failed, but second "http://127.0.0.1/HelloASPWorld"
    > >> >> >> > works.
    > >> >> >> > Thanks.
    > >> >> >> >
    > >> >> >> > Can you tell me why alias 'localhost' doesn't work? In
    > >> >> >> > "C:\WINDOWS\system32\drivers\etc\hosts" I have mapped IIS IP
    > >> >> >> > address:
    > >> >> >> > 127.0.0.1 localhost
    > >> >> >> >
    > >> >> >> > Thank you, Tomas
    > >> >> >> >
    > >> >> >> >
    > >> >> >> > "Juan T. Llibre" wrote:
    > >> >> >> >
    > >> >> >> >> Are you trying to create a secure site ?
    > >> >> >> >>
    > >> >> >> >> Try http://localhost/HelloASPWorld
    > >> >> >> >> or http://127.0.0.1/HelloASPWorld
    > >> >> >> >> and see if *those* work...
    > >> >> >> >>
    > >> >> >> >> Juan T. Llibre
    > >> >> >> >> ===========
    > >> >> >> >>
    > >> >> >> >> "Tomas Kepic" <> wrote in
    > >> >> >> >> message
    > >> >> >> >> news:...
    > >> >> >> >> > When I replace localhost in: 'https://localhost/HelloASPWorld'
    > >> >> >> >> > with
    > >> >> >> >> > 127.0.0.1
    > >> >> >> >> > 'https://127.0.0.1/HelloASPWorld' an error accured:
    > >> >> >> >> >
    > >> >> >> >> > The Web server reported the following error when attempting to
    > >> >> >> >> > create
    > >> >> >> >> > or
    > >> >> >> >> > open the Web project located at the following URL:
    > >> >> >> >> > 'https://127.0.0.1/HelloASPWorld'.'A connection with the
    > >> >> >> >> > server
    > >> >> >> >> > could
    > >> >> >> >> > not
    > >> >> >> >> > be
    > >> >> >> >> > established'.
    > >> >> >> >> >
    > >> >> >> >> > So can anyone help me????
    > >> >> >> >> >
    > >> >> >> >> > Thanx, Tomas
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> >
    > >> >> >> >> > "Tomas Kepic" wrote:
    > >> >> >> >> >
    > >> >> >> >> >> Hi,
    > >> >> >> >> >>
    > >> >> >> >> >> i'm trying to create my first ASP.NET project ( HelloASPWorld
    > >> >> >> >> >> project)
    > >> >> >> >> >> but
    > >> >> >> >> >> an error occured when I put OK button in NewProject.
    > >> >> >> >> >> ERROR:
    > >> >> >> >> >> "The Web server reported the following error when attempting
    > >> >> >> >> >> to
    > >> >> >> >> >> create
    > >> >> >> >> >> or
    > >> >> >> >> >> open the Web project located at the following URL:
    > >> >> >> >> >> 'https://localhost/HelloASPWorld'.'HTTP/1.0 503 Service
    > >> >> >> >> >> Unavailable'."
    > >> >> >> >> >>
    > >> >> >> >> >>
    > >> >> >> >> >> I have installed IIS first and then reinstall Visual Studio
    > >> >> >> >> >> I don't know what I have to set yet to solve this problem.
    > >> >> >> >> >>
    > >> >> >> >> >> Please help me!
    > >> >> >> >> >> --
    > >> >> >> >> >> Tomas

    >
    >
    >
     
    =?Utf-8?B?VG9tYXMgS2VwaWM=?=, Apr 5, 2005
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. harinath
    Replies:
    0
    Views:
    3,664
    harinath
    Feb 7, 2006
  2. Pasha
    Replies:
    2
    Views:
    13,709
  3. Dilip
    Replies:
    1
    Views:
    392
    Dilip
    Jul 18, 2003
  4. BuddyWork

    HTTP Status-Code=503 (Service Unavailable)

    BuddyWork, May 4, 2005, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    203
    BuddyWork
    May 4, 2005
  5. BuddyWork

    HTTP Status-Code=503 (Service Unavailable)

    BuddyWork, May 10, 2005, in forum: ASP .Net Web Services
    Replies:
    2
    Views:
    430
    BuddyWork
    May 11, 2005
Loading...

Share This Page