error in asmx

Discussion in 'ASP .Net Web Services' started by Savas Ates, Nov 25, 2004.

  1. Savas Ates

    Savas Ates Guest

    it runs well in my local server but when i post it my server it gives an
    error how can i solve it?

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
     
    Savas Ates, Nov 25, 2004
    #1
    1. Advertising

  2. Open the web.config file that is present in the same folder with your asmx
    file.
    You'll find a tag called "customErrors". You would normally find it as:
    <customErrors mode="RemoteOnly" />
    Change this to <customErrors mode="Off"/>
    and retry your web service. The details of the error message should appear
    to you after that.

    Regards
    Mohamed El Ashmawy
    MEA Developer Support Center
    ITWorx on behalf of Microsoft EMEA GTSC
     
    Mohamed El Ashmawy, Nov 28, 2004
    #2
    1. Advertising

  3. Savas Ates

    Peter Theill Guest

    Try what it says:

    To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a
    "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode"
    attribute
    set to "Off".

    and then post the error you're getting.
     
    Peter Theill, Nov 28, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John
    Replies:
    6
    Views:
    672
  2. david
    Replies:
    1
    Views:
    558
    bruce barker
    Dec 11, 2007
  3. AC [MVP MCMS]

    Error when setting Credentials property of an ASMX

    AC [MVP MCMS], Dec 20, 2005, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    124
    AC [MVP MCMS]
    Dec 20, 2005
  4. iss gives cannot find error for asmx page

    , Apr 6, 2006, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    153
  5. imonline

    ASMX page giving error

    imonline, Dec 6, 2006, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    114
    imonline
    Dec 6, 2006
Loading...

Share This Page