Error making Oracle connection from webservice

Discussion in 'ASP .Net Web Services' started by Adam P., May 18, 2006.

  1. Adam P.

    Adam P. Guest

    I have written a test method that opens a connection to an Oracle database
    and just does a Select query. The method works correctly from a Windows
    application or from an ASP.NET web page. But when I run the same method from
    a ASP.NET Web Service, an exception occurs with the message
    "System.Data.OracleClient requires Oracle client software version 8.1.7 or
    greater."

    I'm have the Oracle 9i client software installed on the server running the
    webservice.

    I've found some other posts that offer the solution of re-applying Read &
    Execute permissions on the ORACLE_HOME directory for the Authenticated Users
    group. I've followed these steps, and gave the ASPNET account the
    permissions as well, but the exception still occurs.

    It's very strange because the same code is successful from an ASP.NET web
    page, but not from a web service.

    Any ideas on what's causing this to be a problem only for web services?
     
    Adam P., May 18, 2006
    #1
    1. Advertising

  2. Thank you for posting.

    From your description, one of your ASP.NET webservice application is
    encountering some error when try accessing Oracle database. Also, the same
    code works correctly in other winform and ASP.NET (web page based)
    application correct?

    Based on my experience, the "System.Data.OracleClient requires Oracle
    client software version 8.1.7 or greater." is possibly caused by permission
    issue. And for your scenario, the same code works in winform application ,
    this also indicate such problem. As for the ASP.NET web page
    application(which also works for the oracle accessing code), it is using
    the same security setting (in IIS and ASP.NET) with the webservice
    application?

    Regards,

    Steven Cheng
    Microsoft Online Community Support


    ==================================================

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    ==================================================


    This posting is provided "AS IS" with no warranties, and confers no rights.



    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], May 19, 2006
    #2
    1. Advertising

  3. Adam P.

    Adam P. Guest

    Thanks for your response Steven. I found the cause of the problem yesterday,
    and you are correct it was a permission problem.

    I had re-applied the Read & Execute on the ORACLE_HOME directory for
    Authenticated Users and it was set to "Apply To = This folder, subfolders and
    files". Apparently it didn't apply correctly, or I didn't follow the
    instructions correctly, because the oci.dll which is file in one of the
    subfolders didn't have any permissions set for the Authenticated Users group.



    "Steven Cheng[MSFT]" wrote:

    > Thank you for posting.
    >
    > From your description, one of your ASP.NET webservice application is
    > encountering some error when try accessing Oracle database. Also, the same
    > code works correctly in other winform and ASP.NET (web page based)
    > application correct?
    >
    > Based on my experience, the "System.Data.OracleClient requires Oracle
    > client software version 8.1.7 or greater." is possibly caused by permission
    > issue. And for your scenario, the same code works in winform application ,
    > this also indicate such problem. As for the ASP.NET web page
    > application(which also works for the oracle accessing code), it is using
    > the same security setting (in IIS and ASP.NET) with the webservice
    > application?
    >
    > Regards,
    >
    > Steven Cheng
    > Microsoft Online Community Support
    >
    >
    > ==================================================
    >
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    >
    > ==================================================
    >
    >
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    >
    >
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
    >
    >
    >
    >
     
    Adam P., May 19, 2006
    #3
  4. Thanks for your followup.

    Glad that you've figured it out.

    Have a good day!

    Regards,

    Steven Cheng
    Microsoft Online Community Support


    ==================================================

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    ==================================================


    This posting is provided "AS IS" with no warranties, and confers no rights.



    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
     
    Steven Cheng[MSFT], May 22, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Juha Laiho
    Replies:
    0
    Views:
    564
    Juha Laiho
    Jul 30, 2003
  2. David Rudder
    Replies:
    0
    Views:
    421
    David Rudder
    Jul 30, 2003
  3. Scott

    WebService To WebService HTTP Connection Limit

    Scott, Jan 31, 2006, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    699
    Scott
    Feb 1, 2006
  4. Roberto Giorgetti

    Error connection using webservice locally (3 webservice in balanci

    Roberto Giorgetti, Jun 13, 2006, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    211
    Roberto Giorgetti
    Jun 13, 2006
  5. Feyruz
    Replies:
    4
    Views:
    2,340
    Sherm Pendley
    Oct 14, 2005
Loading...

Share This Page