F5 debug mode for ASP.NET Application “Not in Debugger Group” Warning

Discussion in 'ASP .Net Web Services' started by SeanMc, Sep 19, 2009.

  1. SeanMc

    SeanMc Guest

    F5 debug mode for ASP.NET Application “Not in Debugger Group” Warning
    Hello All,
    First – I apologize if this is not the correct group – the asp groups
    seem to have a very low activity rate, so I decided to give this a try
    here.
    Whenever I try and run/debug my ASP.NET application, I receive the
    warning that “You do not have permissions to Debug the Server. Verify
    that you are a member of the Debugger users group on the server”.
    Some times I get the warning “This project is not configured to be
    debugged”
    The problem is, I believe that I am member of this group. I have
    opened up the project config file and debug is set to YES.
    IIS was installed AFTER VS.NET, so I ran the .NET repair described in
    help, by reinserting my VS disc and running from the command line:
    D:\dotNetFramework\dotnetfx.exe /t:c:\temp /c:"msiexec.exe /fvecms c:
    \temp\netfx.msi"

    Windows XP SP3
    .NET versions 1.1, 2, 3, and 3.5 installed on machine
    Visual Studio.NET 2003

    Administrative Tools > Internet Information Services > Web Sites >
    Default Web Site > Right Click “Properties” >

    Directory Security Tab:
    • Anonymous Access = Y
    o UserName = Device\User
    o Allow IIS to control Password = Y
    • Integrated Windows Authentication = Y

    Home Directory Tab :
    • When connecting to the resource, the content should come from
    o A directory on this computer
    • Local Path : c:\inetpub\www.root
    • Application Name : Default Application
    • Execute Permissions : Scripts and Executables
    • Application Protection : Medium (Pooled)
    • True :
    o Script Source Acess
    o Read
    o Write
    o Directory Browsing
    o Log Visits
    o Index This Resource

    Configuration from Home Directory Tab
    Enable ASP Server Side Debugging set to TRUE
    ASP.NET Tab :
    IF set to Version 1.1.4322, the web.config path is set to \inetpub
    \www.root.
    Edit Configuration is button inactivated

    If set to Version 2.0.50727, I can Edit the config file.
    o Editing Config File > Application Tab > Debugging = True

    Can someone please help? Im at wits end here as to how to get this
    running and debugging.
    Thanks in advance for any help or advice given,
    Sean
    SeanMc, Sep 19, 2009
    #1
    1. Advertising

  2. SeanMc

    SeanMc Guest

    On Sep 19, 7:42 am, SeanMc <> wrote:
    > F5 debug mode for ASP.NET Application “Not in Debugger Group†Warning
    > Hello All,
    >         First – I apologize if this is not the correct group – the asp groups
    > seem to have a very low activity rate, so I decided to give this a try
    > here.
    > Whenever I try and run/debug my ASP.NET application, I receive the
    > warning that “You do not have permissions to Debug the Server. Verify
    > that you are a member of the Debugger users group on the serverâ€.
    > Some times I get the warning “This project is not configured to be
    > debuggedâ€
    > The problem is, I believe that I am member of this group. I have
    > opened up the project config file and debug is set to YES.
    > IIS was installed AFTER VS.NET, so I ran the .NET repair described in
    > help, by reinserting my VS disc and running from the command line:
    > D:\dotNetFramework\dotnetfx.exe /t:c:\temp /c:"msiexec.exe /fvecms c:
    > \temp\netfx.msi"
    >
    > Windows XP SP3
    >         .NET versions 1.1, 2, 3, and 3.5 installed onmachine
    > Visual Studio.NET 2003
    >
    > Administrative Tools > Internet Information Services > Web Sites >
    > Default Web Site > Right Click “Properties†>
    >
    > Directory Security Tab:
    > •     Anonymous Access = Y
    > o       UserName = Device\User
    > o       Allow IIS to control Password = Y
    > •     Integrated Windows Authentication = Y
    >
    > Home Directory Tab :
    > •     When connecting to the resource, the content should come from
    > o       A directory on this computer
    > •     Local Path : c:\inetpub\www.root
    > •     Application Name : Default Application
    > •     Execute Permissions : Scripts and Executables
    > •     Application Protection : Medium (Pooled)
    > •     True :
    > o       Script Source Acess
    > o       Read
    > o       Write
    > o       Directory Browsing
    > o       Log Visits
    > o       Index This Resource
    >
    > Configuration from Home Directory Tab
    >         Enable ASP Server Side Debugging set to TRUE
    > ASP.NET Tab :
    >         IF set to Version 1.1.4322, the web.config path is set to \inetpub
    > \www.root.
    >         Edit Configuration is button inactivated
    >
    >         If set to Version 2.0.50727, I can Edit the config file.
    > o       Editing Config File > Application Tab > Debugging = True
    >
    > Can someone please help? Im at wits end here as to how to get this
    > running and debugging.
    > Thanks in advance for any help or advice given,
    >         Sean


    I am trying this from a home computer running WinXP Pro, on a home
    network with no Domain, debugging on local machine.
    I have added my User Name to the Debugger Users, Power Users, and VS
    Developers Groups, as well as originally being in the Administrators
    group.
    I have checked the error log immediately after running (or attempting
    to run) my ASP project in Debug mode, and am receiving no errors or
    warnings. I am still recieving the “You do not have permissions to
    Debug the Server. Verify that you are a member of the Debugger users
    group on the server†message from VS.

    Could this possibly be because of the other versions of the .NET
    framework running on my PC, when VS2003 wants 1.1? As I said earlier,
    when I choose v1.1 in my web properties, the edit Config File option
    gets inactivated - this appears to be because there is no config file
    in the Framework 1.1 folder, and the only config file in wwwroot is
    the one copied from Framework 2.0 folder. (Im guessing – and cringinf
    at the thought of having to do an OS re-install, followed by dozens of
    software re-installs - ïŒ )

    Thanks,
    ~Sean
    SeanMc, Sep 20, 2009
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Do
    Replies:
    2
    Views:
    1,561
    Do Duong
    Dec 2, 2003
  2. feng
    Replies:
    1
    Views:
    1,596
    Jim Cheshire [MSFT]
    Mar 2, 2004
  3. =?Utf-8?B?UmVraGE=?=

    Cannot run a ASP.NET application in Debug Mode

    =?Utf-8?B?UmVraGE=?=, Sep 1, 2006, in forum: ASP .Net
    Replies:
    4
    Views:
    5,246
    Daniel Yafac
    Oct 16, 2006
  4. sujeet
    Replies:
    5
    Views:
    559
    Bart van Ingen Schenau
    Sep 16, 2007
  5. Deepa
    Replies:
    0
    Views:
    104
    Deepa
    Mar 31, 2007
Loading...

Share This Page