faild to start listening port 1034

Discussion in 'ASP .Net' started by kai, Nov 20, 2005.

  1. kai

    kai Guest

    Hi,
    I was tring to run an example (HelloWorld.aspx) from MSPrss book, I get
    this message:

    "ASP.NET Development Server faild to start listening port 1034.

    Error message:

    An attempt was made to access a socket in a way fobidden by its access
    permissions."

    I cannot fix it. Please help.

    Thanks
    Kai
    kai, Nov 20, 2005
    #1
    1. Advertising

  2. Hi Kai,

    Welcome to ASPNET newsgroup.
    From your description, when you try running an ASP.NET 2.0 web app in
    VS.NET 2005 through filesystem server, you got the following error:

    "ASP.NET Development Server faild to start listening port 1034."

    From the exception info, it is caused by the random port for running VS.NET
    2005 debug server not accessible. What's the OS version of the development
    server? You can try turn off the windows firewall to see whether it is the
    cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
    through filesystem, we can manually specify a port number for the project.
    Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
    port" property to "false" in the project setting, then we can manually
    specify a unused port number. Please try using some other ports to see
    whether you also get such error. If there're any other finding, please feel
    free to post here.

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)

    --------------------
    | From: "kai" <>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | Subject: faild to start listening port 1034
    | Lines: 21
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | X-RFC2646: Format=Flowed; Original
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | Message-ID: <tF6gf.3408$>
    | Date: Sun, 20 Nov 2005 22:21:13 GMT
    | NNTP-Posting-Host: 66.32.86.150
    | X-Complaints-To:
    | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150 (Sun,
    20 Nov 2005 14:21:13 PST)
    | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | Path:
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    POSTED!a96f5a29!not-for-mail
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:359667
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi,
    | I was tring to run an example (HelloWorld.aspx) from MSPrss book, I get
    | this message:
    |
    | "ASP.NET Development Server faild to start listening port 1034.
    |
    | Error message:
    |
    | An attempt was made to access a socket in a way fobidden by its access
    | permissions."
    |
    | I cannot fix it. Please help.
    |
    | Thanks
    | Kai
    |
    |
    |
    |
    |
    |
    |
    Steven Cheng[MSFT], Nov 21, 2005
    #2
    1. Advertising

  3. kai

    kai Guest

    Steven,
    Thanks for your elp.

    I use XP Pro. This is the exisiting HelloWorld program, every time I run,
    it uses the same port. If I want to change port 1034 to different one, where
    can I re-set the port number for existing application?

    Thanks
    Kai
    "Steven Cheng[MSFT]" <> wrote in message
    news:...
    > Hi Kai,
    >
    > Welcome to ASPNET newsgroup.
    > From your description, when you try running an ASP.NET 2.0 web app in
    > VS.NET 2005 through filesystem server, you got the following error:
    >
    > "ASP.NET Development Server faild to start listening port 1034."
    >
    > From the exception info, it is caused by the random port for running
    > VS.NET
    > 2005 debug server not accessible. What's the OS version of the
    > development
    > server? You can try turn off the windows firewall to see whether it is the
    > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
    > through filesystem, we can manually specify a port number for the project.
    > Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
    > port" property to "false" in the project setting, then we can manually
    > specify a unused port number. Please try using some other ports to see
    > whether you also get such error. If there're any other finding, please
    > feel
    > free to post here.
    >
    > Thanks,
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    > --------------------
    > | From: "kai" <>
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | Subject: faild to start listening port 1034
    > | Lines: 21
    > | X-Priority: 3
    > | X-MSMail-Priority: Normal
    > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    > | X-RFC2646: Format=Flowed; Original
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    > | Message-ID: <tF6gf.3408$>
    > | Date: Sun, 20 Nov 2005 22:21:13 GMT
    > | NNTP-Posting-Host: 66.32.86.150
    > | X-Complaints-To:
    > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150 (Sun,
    > 20 Nov 2005 14:21:13 PST)
    > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    > | Organization: EarthLink Inc. -- http://www.EarthLink.net
    > | Path:
    > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    > stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    > shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    > arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    > POSTED!a96f5a29!not-for-mail
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:359667
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | Hi,
    > | I was tring to run an example (HelloWorld.aspx) from MSPrss book, I
    > get
    > | this message:
    > |
    > | "ASP.NET Development Server faild to start listening port 1034.
    > |
    > | Error message:
    > |
    > | An attempt was made to access a socket in a way fobidden by its access
    > | permissions."
    > |
    > | I cannot fix it. Please help.
    > |
    > | Thanks
    > | Kai
    > |
    > |
    > |
    > |
    > |
    > |
    > |
    >
    kai, Nov 21, 2005
    #3
  4. Thanks for your response Kai,

    Since you're using XP pro, I think the windows XP sp2's firewall setting is
    also a possible cause. Have you tried turn off it (if you're currently
    turning on it) to see whether it helps? Also, for manually specifying port
    number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we can
    follow the below steps:

    1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.

    2. In the Property window, you can find there is two properties under the
    "Web Developer Server" category:

    "Port Number" and "Use Dynamic Port".

    Set the "Use Dynamnmic Port" to false, then we can change the "Port Number"
    ....

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)





    --------------------
    | From: "kai" <>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | References: <tF6gf.3408$>
    <>
    | Subject: Re: faild to start listening port 1034
    | Lines: 96
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | X-RFC2646: Format=Flowed; Original
    | Message-ID: <lmjgf.1614$>
    | Date: Mon, 21 Nov 2005 12:48:17 GMT
    | NNTP-Posting-Host: 66.32.86.150
    | X-Complaints-To:
    | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150 (Mon,
    21 Nov 2005 04:48:17 PST)
    | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
    | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | Path:
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
    ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
    earthlink.net!stamper.news.atl.earthlink.net!newsread2.news.atl.earthlink.ne
    t.POSTED!a96f5a29!not-for-mail
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:359762
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Steven,
    | Thanks for your elp.
    |
    | I use XP Pro. This is the exisiting HelloWorld program, every time I
    run,
    | it uses the same port. If I want to change port 1034 to different one,
    where
    | can I re-set the port number for existing application?
    |
    | Thanks
    | Kai
    | "Steven Cheng[MSFT]" <> wrote in message
    | news:...
    | > Hi Kai,
    | >
    | > Welcome to ASPNET newsgroup.
    | > From your description, when you try running an ASP.NET 2.0 web app in
    | > VS.NET 2005 through filesystem server, you got the following error:
    | >
    | > "ASP.NET Development Server faild to start listening port 1034."
    | >
    | > From the exception info, it is caused by the random port for running
    | > VS.NET
    | > 2005 debug server not accessible. What's the OS version of the
    | > development
    | > server? You can try turn off the windows firewall to see whether it is
    the
    | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
    | > through filesystem, we can manually specify a port number for the
    project.
    | > Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
    | > port" property to "false" in the project setting, then we can manually
    | > specify a unused port number. Please try using some other ports to see
    | > whether you also get such error. If there're any other finding, please
    | > feel
    | > free to post here.
    | >
    | > Thanks,
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | > --------------------
    | > | From: "kai" <>
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | Subject: faild to start listening port 1034
    | > | Lines: 21
    | > | X-Priority: 3
    | > | X-MSMail-Priority: Normal
    | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | > | X-RFC2646: Format=Flowed; Original
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | > | Message-ID: <tF6gf.3408$>
    | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
    | > | NNTP-Posting-Host: 66.32.86.150
    | > | X-Complaints-To:
    | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
    (Sun,
    | > 20 Nov 2005 14:21:13 PST)
    | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | > | Path:
    | >
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    | >
    stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    | >
    shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    | >
    arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    | > POSTED!a96f5a29!not-for-mail
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:359667
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | Hi,
    | > | I was tring to run an example (HelloWorld.aspx) from MSPrss book, I
    | > get
    | > | this message:
    | > |
    | > | "ASP.NET Development Server faild to start listening port 1034.
    | > |
    | > | Error message:
    | > |
    | > | An attempt was made to access a socket in a way fobidden by its access
    | > | permissions."
    | > |
    | > | I cannot fix it. Please help.
    | > |
    | > | Thanks
    | > | Kai
    | > |
    | > |
    | > |
    | > |
    | > |
    | > |
    | > |
    | >
    |
    |
    |
    Steven Cheng[MSFT], Nov 22, 2005
    #4
  5. Hi Kai,

    Have you got any further progress on this issue? If there're anything else
    we can help, please feel free to post here.

    Thanks & Regards,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)

    --------------------
    | X-Tomcat-ID: 222779052
    | References: <tF6gf.3408$>
    <>
    <lmjgf.1614$>
    | MIME-Version: 1.0
    | Content-Type: text/plain
    | Content-Transfer-Encoding: 7bit
    | From: (Steven Cheng[MSFT])
    | Organization: Microsoft
    | Date: Tue, 22 Nov 2005 11:10:59 GMT
    | Subject: Re: faild to start listening port 1034
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | Message-ID: <>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | Lines: 143
    | Path: TK2MSFTNGXA02.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:360065
    | NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
    |
    | Thanks for your response Kai,
    |
    | Since you're using XP pro, I think the windows XP sp2's firewall setting
    is
    | also a possible cause. Have you tried turn off it (if you're currently
    | turning on it) to see whether it helps? Also, for manually specifying
    port
    | number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we can
    | follow the below steps:
    |
    | 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
    |
    | 2. In the Property window, you can find there is two properties under
    the
    | "Web Developer Server" category:
    |
    | "Port Number" and "Use Dynamic Port".
    |
    | Set the "Use Dynamnmic Port" to false, then we can change the "Port
    Number"
    | ...
    |
    | Thanks,
    |
    | Steven Cheng
    | Microsoft Online Support
    |
    | Get Secure! www.microsoft.com/security
    | (This posting is provided "AS IS", with no warranties, and confers no
    | rights.)
    |
    |
    |
    |
    |
    | --------------------
    | | From: "kai" <>
    | | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | | References: <tF6gf.3408$>
    | <>
    | | Subject: Re: faild to start listening port 1034
    | | Lines: 96
    | | X-Priority: 3
    | | X-MSMail-Priority: Normal
    | | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | | X-RFC2646: Format=Flowed; Original
    | | Message-ID: <lmjgf.1614$>
    | | Date: Mon, 21 Nov 2005 12:48:17 GMT
    | | NNTP-Posting-Host: 66.32.86.150
    | | X-Complaints-To:
    | | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150 (Mon,
    | 21 Nov 2005 04:48:17 PST)
    | | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
    | | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | | Path:
    |
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
    |
    ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
    |
    earthlink.net!stamper.news.atl.earthlink.net!newsread2.news.atl.earthlink.ne
    | t.POSTED!a96f5a29!not-for-mail
    | | Xref: TK2MSFTNGXA02.phx.gbl
    | microsoft.public.dotnet.framework.aspnet:359762
    | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | |
    | | Steven,
    | | Thanks for your elp.
    | |
    | | I use XP Pro. This is the exisiting HelloWorld program, every time I
    | run,
    | | it uses the same port. If I want to change port 1034 to different one,
    | where
    | | can I re-set the port number for existing application?
    | |
    | | Thanks
    | | Kai
    | | "Steven Cheng[MSFT]" <> wrote in message
    | | news:...
    | | > Hi Kai,
    | | >
    | | > Welcome to ASPNET newsgroup.
    | | > From your description, when you try running an ASP.NET 2.0 web app in
    | | > VS.NET 2005 through filesystem server, you got the following error:
    | | >
    | | > "ASP.NET Development Server faild to start listening port 1034."
    | | >
    | | > From the exception info, it is caused by the random port for running
    | | > VS.NET
    | | > 2005 debug server not accessible. What's the OS version of the
    | | > development
    | | > server? You can try turn off the windows firewall to see whether it
    is
    | the
    | | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
    | | > through filesystem, we can manually specify a port number for the
    | project.
    | | > Just select the ASP.NET project in VS2005 ide, and set the "use
    dynamic
    | | > port" property to "false" in the project setting, then we can manually
    | | > specify a unused port number. Please try using some other ports to see
    | | > whether you also get such error. If there're any other finding,
    please
    | | > feel
    | | > free to post here.
    | | >
    | | > Thanks,
    | | >
    | | > Steven Cheng
    | | > Microsoft Online Support
    | | >
    | | > Get Secure! www.microsoft.com/security
    | | > (This posting is provided "AS IS", with no warranties, and confers no
    | | > rights.)
    | | >
    | | > --------------------
    | | > | From: "kai" <>
    | | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | | > | Subject: faild to start listening port 1034
    | | > | Lines: 21
    | | > | X-Priority: 3
    | | > | X-MSMail-Priority: Normal
    | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | | > | X-RFC2646: Format=Flowed; Original
    | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | | > | Message-ID: <tF6gf.3408$>
    | | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
    | | > | NNTP-Posting-Host: 66.32.86.150
    | | > | X-Complaints-To:
    | | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
    | (Sun,
    | | > 20 Nov 2005 14:21:13 PST)
    | | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    | | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | | > | Path:
    | | >
    |
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    | | >
    |
    stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    | | >
    |
    shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    | | >
    |
    arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    | | > POSTED!a96f5a29!not-for-mail
    | | > | Xref: TK2MSFTNGXA02.phx.gbl
    | | > microsoft.public.dotnet.framework.aspnet:359667
    | | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | | > |
    | | > | Hi,
    | | > | I was tring to run an example (HelloWorld.aspx) from MSPrss book,
    I
    | | > get
    | | > | this message:
    | | > |
    | | > | "ASP.NET Development Server faild to start listening port 1034.
    | | > |
    | | > | Error message:
    | | > |
    | | > | An attempt was made to access a socket in a way fobidden by its
    access
    | | > | permissions."
    | | > |
    | | > | I cannot fix it. Please help.
    | | > |
    | | > | Thanks
    | | > | Kai
    | | > |
    | | > |
    | | > |
    | | > |
    | | > |
    | | > |
    | | > |
    | | >
    | |
    | |
    | |
    |
    |
    Steven Cheng[MSFT], Nov 24, 2005
    #5
  6. kai

    kai Guest

    Hi, Steven
    I turned off firewall, it did not work. After I reboot my computer, it
    works. Than I turned on the fire wall again, it is working.
    Thank you very much for your expertise. It really helps me a lot.

    Kai

    "Steven Cheng[MSFT]" <> wrote in message
    news:NucZ%...
    > Hi Kai,
    >
    > Have you got any further progress on this issue? If there're anything else
    > we can help, please feel free to post here.
    >
    > Thanks & Regards,
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    > --------------------
    > | X-Tomcat-ID: 222779052
    > | References: <tF6gf.3408$>
    > <>
    > <lmjgf.1614$>
    > | MIME-Version: 1.0
    > | Content-Type: text/plain
    > | Content-Transfer-Encoding: 7bit
    > | From: (Steven Cheng[MSFT])
    > | Organization: Microsoft
    > | Date: Tue, 22 Nov 2005 11:10:59 GMT
    > | Subject: Re: faild to start listening port 1034
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | Message-ID: <>
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | Lines: 143
    > | Path: TK2MSFTNGXA02.phx.gbl
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:360065
    > | NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
    > |
    > | Thanks for your response Kai,
    > |
    > | Since you're using XP pro, I think the windows XP sp2's firewall setting
    > is
    > | also a possible cause. Have you tried turn off it (if you're currently
    > | turning on it) to see whether it helps? Also, for manually specifying
    > port
    > | number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we
    > can
    > | follow the below steps:
    > |
    > | 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
    > |
    > | 2. In the Property window, you can find there is two properties under
    > the
    > | "Web Developer Server" category:
    > |
    > | "Port Number" and "Use Dynamic Port".
    > |
    > | Set the "Use Dynamnmic Port" to false, then we can change the "Port
    > Number"
    > | ...
    > |
    > | Thanks,
    > |
    > | Steven Cheng
    > | Microsoft Online Support
    > |
    > | Get Secure! www.microsoft.com/security
    > | (This posting is provided "AS IS", with no warranties, and confers no
    > | rights.)
    > |
    > |
    > |
    > |
    > |
    > | --------------------
    > | | From: "kai" <>
    > | | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | | References: <tF6gf.3408$>
    > | <>
    > | | Subject: Re: faild to start listening port 1034
    > | | Lines: 96
    > | | X-Priority: 3
    > | | X-MSMail-Priority: Normal
    > | | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    > | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    > | | X-RFC2646: Format=Flowed; Original
    > | | Message-ID: <lmjgf.1614$>
    > | | Date: Mon, 21 Nov 2005 12:48:17 GMT
    > | | NNTP-Posting-Host: 66.32.86.150
    > | | X-Complaints-To:
    > | | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150
    > (Mon,
    > | 21 Nov 2005 04:48:17 PST)
    > | | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
    > | | Organization: EarthLink Inc. -- http://www.EarthLink.net
    > | | Path:
    > |
    > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
    > |
    > ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
    > |
    > earthlink.net!stamper.news.atl.earthlink.net!newsread2.news.atl.earthlink.ne
    > | t.POSTED!a96f5a29!not-for-mail
    > | | Xref: TK2MSFTNGXA02.phx.gbl
    > | microsoft.public.dotnet.framework.aspnet:359762
    > | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | |
    > | | Steven,
    > | | Thanks for your elp.
    > | |
    > | | I use XP Pro. This is the exisiting HelloWorld program, every time I
    > | run,
    > | | it uses the same port. If I want to change port 1034 to different one,
    > | where
    > | | can I re-set the port number for existing application?
    > | |
    > | | Thanks
    > | | Kai
    > | | "Steven Cheng[MSFT]" <> wrote in message
    > | | news:...
    > | | > Hi Kai,
    > | | >
    > | | > Welcome to ASPNET newsgroup.
    > | | > From your description, when you try running an ASP.NET 2.0 web app
    > in
    > | | > VS.NET 2005 through filesystem server, you got the following error:
    > | | >
    > | | > "ASP.NET Development Server faild to start listening port 1034."
    > | | >
    > | | > From the exception info, it is caused by the random port for running
    > | | > VS.NET
    > | | > 2005 debug server not accessible. What's the OS version of the
    > | | > development
    > | | > server? You can try turn off the windows firewall to see whether it
    > is
    > | the
    > | | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET
    > 2005
    > | | > through filesystem, we can manually specify a port number for the
    > | project.
    > | | > Just select the ASP.NET project in VS2005 ide, and set the "use
    > dynamic
    > | | > port" property to "false" in the project setting, then we can
    > manually
    > | | > specify a unused port number. Please try using some other ports to
    > see
    > | | > whether you also get such error. If there're any other finding,
    > please
    > | | > feel
    > | | > free to post here.
    > | | >
    > | | > Thanks,
    > | | >
    > | | > Steven Cheng
    > | | > Microsoft Online Support
    > | | >
    > | | > Get Secure! www.microsoft.com/security
    > | | > (This posting is provided "AS IS", with no warranties, and confers
    > no
    > | | > rights.)
    > | | >
    > | | > --------------------
    > | | > | From: "kai" <>
    > | | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | | > | Subject: faild to start listening port 1034
    > | | > | Lines: 21
    > | | > | X-Priority: 3
    > | | > | X-MSMail-Priority: Normal
    > | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    > | | > | X-RFC2646: Format=Flowed; Original
    > | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    > | | > | Message-ID: <tF6gf.3408$>
    > | | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
    > | | > | NNTP-Posting-Host: 66.32.86.150
    > | | > | X-Complaints-To:
    > | | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
    > | (Sun,
    > | | > 20 Nov 2005 14:21:13 PST)
    > | | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    > | | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
    > | | > | Path:
    > | | >
    > |
    > TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    > | | >
    > |
    > stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    > | | >
    > |
    > shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    > | | >
    > |
    > arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    > | | > POSTED!a96f5a29!not-for-mail
    > | | > | Xref: TK2MSFTNGXA02.phx.gbl
    > | | > microsoft.public.dotnet.framework.aspnet:359667
    > | | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | | > |
    > | | > | Hi,
    > | | > | I was tring to run an example (HelloWorld.aspx) from MSPrss
    > book,
    > I
    > | | > get
    > | | > | this message:
    > | | > |
    > | | > | "ASP.NET Development Server faild to start listening port 1034.
    > | | > |
    > | | > | Error message:
    > | | > |
    > | | > | An attempt was made to access a socket in a way fobidden by its
    > access
    > | | > | permissions."
    > | | > |
    > | | > | I cannot fix it. Please help.
    > | | > |
    > | | > | Thanks
    > | | > | Kai
    > | | > |
    > | | > |
    > | | > |
    > | | > |
    > | | > |
    > | | > |
    > | | > |
    > | | >
    > | |
    > | |
    > | |
    > |
    > |
    >
    kai, Nov 25, 2005
    #6
  7. Thanks for your followup Kai,

    Glad that our suggestions are of assistance. Also, as for the firewall
    setting, it may require your rebooting to make effect. Also, you can choose
    to add an exception (tcp/udp port) for your debugging server's listening
    port instead of turn off the whole firewall for secuirty consideration.

    Good luck!

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)
    --------------------
    | From: "kai" <>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | References: <tF6gf.3408$>
    <>
    <lmjgf.1614$>
    <>
    <NucZ#>
    | Subject: Re: faild to start listening port 1034
    | Lines: 239
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | X-RFC2646: Format=Flowed; Original
    | Message-ID: <ZrJhf.5474$>
    | Date: Fri, 25 Nov 2005 19:18:17 GMT
    | NNTP-Posting-Host: 66.32.86.150
    | X-Complaints-To:
    | X-Trace: newsread3.news.atl.earthlink.net 1132946297 66.32.86.150 (Fri,
    25 Nov 2005 11:18:17 PST)
    | NNTP-Posting-Date: Fri, 25 Nov 2005 11:18:17 PST
    | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | Path:
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
    ne.de!border2.nntp.dca.giganews.com!nntp.giganews.com!elnk-atl-nf1!newsfeed.
    earthlink.net!stamper.news.atl.earthlink.net!newsread3.news.atl.earthlink.ne
    t.POSTED!a96f5a29!not-for-mail
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:360976
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi, Steven
    | I turned off firewall, it did not work. After I reboot my computer, it
    | works. Than I turned on the fire wall again, it is working.
    | Thank you very much for your expertise. It really helps me a lot.
    |
    | Kai
    |
    | "Steven Cheng[MSFT]" <> wrote in message
    | news:NucZ%...
    | > Hi Kai,
    | >
    | > Have you got any further progress on this issue? If there're anything
    else
    | > we can help, please feel free to post here.
    | >
    | > Thanks & Regards,
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | > --------------------
    | > | X-Tomcat-ID: 222779052
    | > | References: <tF6gf.3408$>
    | > <>
    | > <lmjgf.1614$>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain
    | > | Content-Transfer-Encoding: 7bit
    | > | From: (Steven Cheng[MSFT])
    | > | Organization: Microsoft
    | > | Date: Tue, 22 Nov 2005 11:10:59 GMT
    | > | Subject: Re: faild to start listening port 1034
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > | Message-ID: <>
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | Lines: 143
    | > | Path: TK2MSFTNGXA02.phx.gbl
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:360065
    | > | NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
    | > |
    | > | Thanks for your response Kai,
    | > |
    | > | Since you're using XP pro, I think the windows XP sp2's firewall
    setting
    | > is
    | > | also a possible cause. Have you tried turn off it (if you're currently
    | > | turning on it) to see whether it helps? Also, for manually specifying
    | > port
    | > | number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we
    | > can
    | > | follow the below steps:
    | > |
    | > | 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
    | > |
    | > | 2. In the Property window, you can find there is two properties under
    | > the
    | > | "Web Developer Server" category:
    | > |
    | > | "Port Number" and "Use Dynamic Port".
    | > |
    | > | Set the "Use Dynamnmic Port" to false, then we can change the "Port
    | > Number"
    | > | ...
    | > |
    | > | Thanks,
    | > |
    | > | Steven Cheng
    | > | Microsoft Online Support
    | > |
    | > | Get Secure! www.microsoft.com/security
    | > | (This posting is provided "AS IS", with no warranties, and confers no
    | > | rights.)
    | > |
    | > |
    | > |
    | > |
    | > |
    | > | --------------------
    | > | | From: "kai" <>
    | > | | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | | References: <tF6gf.3408$>
    | > | <>
    | > | | Subject: Re: faild to start listening port 1034
    | > | | Lines: 96
    | > | | X-Priority: 3
    | > | | X-MSMail-Priority: Normal
    | > | | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | > | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | > | | X-RFC2646: Format=Flowed; Original
    | > | | Message-ID: <lmjgf.1614$>
    | > | | Date: Mon, 21 Nov 2005 12:48:17 GMT
    | > | | NNTP-Posting-Host: 66.32.86.150
    | > | | X-Complaints-To:
    | > | | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150
    | > (Mon,
    | > | 21 Nov 2005 04:48:17 PST)
    | > | | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
    | > | | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | > | | Path:
    | > |
    | >
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.sul.t-online.de!t-onli
    | > |
    | >
    ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
    | > |
    | >
    earthlink.net!stamper.news.atl.earthlink.net!newsread2.news.atl.earthlink.ne
    | > | t.POSTED!a96f5a29!not-for-mail
    | > | | Xref: TK2MSFTNGXA02.phx.gbl
    | > | microsoft.public.dotnet.framework.aspnet:359762
    | > | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > | |
    | > | | Steven,
    | > | | Thanks for your elp.
    | > | |
    | > | | I use XP Pro. This is the exisiting HelloWorld program, every
    time I
    | > | run,
    | > | | it uses the same port. If I want to change port 1034 to different
    one,
    | > | where
    | > | | can I re-set the port number for existing application?
    | > | |
    | > | | Thanks
    | > | | Kai
    | > | | "Steven Cheng[MSFT]" <> wrote in message
    | > | | news:...
    | > | | > Hi Kai,
    | > | | >
    | > | | > Welcome to ASPNET newsgroup.
    | > | | > From your description, when you try running an ASP.NET 2.0 web
    app
    | > in
    | > | | > VS.NET 2005 through filesystem server, you got the following
    error:
    | > | | >
    | > | | > "ASP.NET Development Server faild to start listening port 1034."
    | > | | >
    | > | | > From the exception info, it is caused by the random port for
    running
    | > | | > VS.NET
    | > | | > 2005 debug server not accessible. What's the OS version of the
    | > | | > development
    | > | | > server? You can try turn off the windows firewall to see whether
    it
    | > is
    | > | the
    | > | | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET
    | > 2005
    | > | | > through filesystem, we can manually specify a port number for the
    | > | project.
    | > | | > Just select the ASP.NET project in VS2005 ide, and set the "use
    | > dynamic
    | > | | > port" property to "false" in the project setting, then we can
    | > manually
    | > | | > specify a unused port number. Please try using some other ports
    to
    | > see
    | > | | > whether you also get such error. If there're any other finding,
    | > please
    | > | | > feel
    | > | | > free to post here.
    | > | | >
    | > | | > Thanks,
    | > | | >
    | > | | > Steven Cheng
    | > | | > Microsoft Online Support
    | > | | >
    | > | | > Get Secure! www.microsoft.com/security
    | > | | > (This posting is provided "AS IS", with no warranties, and
    confers
    | > no
    | > | | > rights.)
    | > | | >
    | > | | > --------------------
    | > | | > | From: "kai" <>
    | > | | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | | > | Subject: faild to start listening port 1034
    | > | | > | Lines: 21
    | > | | > | X-Priority: 3
    | > | | > | X-MSMail-Priority: Normal
    | > | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
    | > | | > | X-RFC2646: Format=Flowed; Original
    | > | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
    | > | | > | Message-ID:
    <tF6gf.3408$>
    | > | | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
    | > | | > | NNTP-Posting-Host: 66.32.86.150
    | > | | > | X-Complaints-To:
    | > | | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273
    66.32.86.150
    | > | (Sun,
    | > | | > 20 Nov 2005 14:21:13 PST)
    | > | | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
    | > | | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
    | > | | > | Path:
    | > | | >
    | > |
    | >
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornado.fa
    | > | | >
    | > |
    | >
    stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newshub.sdsu.edu!nx02.iad01.new
    | > | | >
    | > |
    | >
    shosting.com!newshosting.com!207.69.154.102.MISMATCH!elnk-atl-nf2!newsfeed.e
    | > | | >
    | > |
    | >
    arthlink.net!stamper.news.atl.earthlink.net!newsread1.news.atl.earthlink.net
    | > | | > POSTED!a96f5a29!not-for-mail
    | > | | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > | | > microsoft.public.dotnet.framework.aspnet:359667
    | > | | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > | | > |
    | > | | > | Hi,
    | > | | > | I was tring to run an example (HelloWorld.aspx) from MSPrss
    | > book,
    | > I
    | > | | > get
    | > | | > | this message:
    | > | | > |
    | > | | > | "ASP.NET Development Server faild to start listening port 1034.
    | > | | > |
    | > | | > | Error message:
    | > | | > |
    | > | | > | An attempt was made to access a socket in a way fobidden by its
    | > access
    | > | | > | permissions."
    | > | | > |
    | > | | > | I cannot fix it. Please help.
    | > | | > |
    | > | | > | Thanks
    | > | | > | Kai
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | > |
    | > | | >
    | > | |
    | > | |
    | > | |
    | > |
    | > |
    | >
    |
    |
    |
    Steven Cheng[MSFT], Nov 28, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bob Garbados
    Replies:
    5
    Views:
    448
    Bob Garbados
    Dec 22, 2004
  2. Firas Rashid
    Replies:
    2
    Views:
    2,034
  3. akshar108 via DotNetMonster.com

    Interop is being faild in server2003

    akshar108 via DotNetMonster.com, Sep 24, 2007, in forum: ASP .Net
    Replies:
    1
    Views:
    337
    Mark Rae [MVP]
    Sep 24, 2007
  4. listening on TCP port

    , May 7, 2008, in forum: Python
    Replies:
    0
    Views:
    268
  5. Replies:
    17
    Views:
    309
    Big and Blue
    Jun 22, 2006
Loading...

Share This Page