Failed to map the path '/App_GlobalResources/'

Discussion in 'ASP .Net' started by =?Utf-8?B?QWRhbQ==?=, Nov 9, 2005.

  1. Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    bunch of people with this error on the net, but no solution:

    Works fine on my local machine, deployed to a server it yields this message.

    Failed to map the path '/App_GlobalResources/'

    Stack trace: at
    System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    Boolean permitNull)
    at
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache diskCache)
    at
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache diskCache)
    at
    System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    at System.Web.Compilation.BuildManager.Initialize()
    at System.Web.Compilation.BuildManager.InitializeBuildManager()
    at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)



    --
    Adam Tuliper
    http://www.secure-coding.com
    =?Utf-8?B?QWRhbQ==?=, Nov 9, 2005
    #1
    1. Advertising

  2. Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    Make sure there isn't a "\" character at the end of the directory name.




    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    ASPNETFAQ.COM : http://www.aspnetfaq.com/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "Adam" <> wrote in message
    news:...
    > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    > bunch of people with this error on the net, but no solution:
    >
    > Works fine on my local machine, deployed to a server it yields this message.
    >
    > Failed to map the path '/App_GlobalResources/'
    >
    > Stack trace: at
    > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    > Boolean permitNull)
    > at
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    > diskCache)
    > at
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    > diskCache)
    > at
    > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > at System.Web.Compilation.BuildManager.Initialize()
    > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    >
    >
    >
    > --
    > Adam Tuliper
    > http://www.secure-coding.com
    >
    Juan T. Llibre, Nov 9, 2005
    #2
    1. Advertising

  3. I had seen that posted on the net.. but unfortunately it seems for most
    people (and my case) this isn't the cause. Thanks though.


    --
    Adam Tuliper
    http://www.secure-coding.com


    "Juan T. Llibre" wrote:

    > Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    > Make sure there isn't a "\" character at the end of the directory name.
    >
    >
    >
    >
    > Juan T. Llibre, ASP.NET MVP
    > ASP.NET FAQ : http://asp.net.do/faq/
    > ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > Foros de ASP.NET en Español : http://asp.net.do/foros/
    > ======================================
    > "Adam" <> wrote in message
    > news:...
    > > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    > > bunch of people with this error on the net, but no solution:
    > >
    > > Works fine on my local machine, deployed to a server it yields this message.
    > >
    > > Failed to map the path '/App_GlobalResources/'
    > >
    > > Stack trace: at
    > > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    > > Boolean permitNull)
    > > at
    > > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    > > diskCache)
    > > at
    > > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    > > diskCache)
    > > at
    > > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > > at System.Web.Compilation.BuildManager.Initialize()
    > > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    > >
    > >
    > >
    > > --
    > > Adam Tuliper
    > > http://www.secure-coding.com
    > >

    >
    >
    >
    =?Utf-8?B?QWRhbQ==?=, Nov 9, 2005
    #3
  4. Im also curious if it has anything to do with Netegrity's siteminder. I seem
    to recall they set a flag in the metabase preventing updates. Installing sp4
    on win2k3 a while back had this issue with their product.

    There have been prior issues with updating the metabase and netegrity
    preventing it. This is happening on windows 2000, which several postings on
    the net have also pointed to. hmmm... I wonder if the metabase is missing
    information it needed during the setup, although asp.net 2.0 does seem to be
    installed properly, and the temp asp.net compilation directories are getting
    created for each app, just nothing is put in them because of this issue
    causing compilation to fail. Ive even tried adding a virtual directory in my
    app to the app_globalresources folder just for the heck of it.. no go. From
    the response and watching filemon, it seems that asp.net recognizes this as a
    special name and doesn't attempt to check for the physical location, but
    using App_GlobalResources1 does cause a file system check.

    This happens for any asp.net 2.0 app or page, even if I just create a
    directory and drop in a main.aspx (of course setting the site properties to
    be .net 2.0).


    --
    Adam Tuliper
    http://www.secure-coding.com


    "Juan T. Llibre" wrote:

    > Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    > Make sure there isn't a "\" character at the end of the directory name.
    >
    >
    >
    >
    > Juan T. Llibre, ASP.NET MVP
    > ASP.NET FAQ : http://asp.net.do/faq/
    > ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > Foros de ASP.NET en Español : http://asp.net.do/foros/
    > ======================================
    > "Adam" <> wrote in message
    > news:...
    > > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    > > bunch of people with this error on the net, but no solution:
    > >
    > > Works fine on my local machine, deployed to a server it yields this message.
    > >
    > > Failed to map the path '/App_GlobalResources/'
    > >
    > > Stack trace: at
    > > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    > > Boolean permitNull)
    > > at
    > > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    > > diskCache)
    > > at
    > > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    > > diskCache)
    > > at
    > > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > > at System.Web.Compilation.BuildManager.Initialize()
    > > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    > >
    > >
    > >
    > > --
    > > Adam Tuliper
    > > http://www.secure-coding.com
    > >

    >
    >
    >
    =?Utf-8?B?QWRhbQ==?=, Nov 9, 2005
    #4
  5. There was a bug filed for this situation this morning :

    http://lab.msdn.microsoft.com/produ...edbackid=1224adb4-8794-46cc-873b-1ce2b55b5bb4

    It's currently "Under review".

    I'd suggest that you check there over the next few days,
    to see if there's a resolution or see if a workaround has been posted for it.



    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    ASPNETFAQ.COM : http://www.aspnetfaq.com/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "Adam" <> wrote in message
    news:...
    > Im also curious if it has anything to do with Netegrity's siteminder. I seem
    > to recall they set a flag in the metabase preventing updates. Installing sp4
    > on win2k3 a while back had this issue with their product.
    >
    > There have been prior issues with updating the metabase and netegrity
    > preventing it. This is happening on windows 2000, which several postings on
    > the net have also pointed to. hmmm... I wonder if the metabase is missing
    > information it needed during the setup, although asp.net 2.0 does seem to be
    > installed properly, and the temp asp.net compilation directories are getting
    > created for each app, just nothing is put in them because of this issue
    > causing compilation to fail. Ive even tried adding a virtual directory in my
    > app to the app_globalresources folder just for the heck of it.. no go. From
    > the response and watching filemon, it seems that asp.net recognizes this as a
    > special name and doesn't attempt to check for the physical location, but
    > using App_GlobalResources1 does cause a file system check.
    >
    > This happens for any asp.net 2.0 app or page, even if I just create a
    > directory and drop in a main.aspx (of course setting the site properties to
    > be .net 2.0).
    >
    >
    > --
    > Adam Tuliper
    > http://www.secure-coding.com
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    >> Make sure there isn't a "\" character at the end of the directory name.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, ASP.NET MVP
    >> ASP.NET FAQ : http://asp.net.do/faq/
    >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    >> ======================================
    >> "Adam" <> wrote in message
    >> news:...
    >> > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    >> > bunch of people with this error on the net, but no solution:
    >> >
    >> > Works fine on my local machine, deployed to a server it yields this message.
    >> >
    >> > Failed to map the path '/App_GlobalResources/'
    >> >
    >> > Stack trace: at
    >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    >> > Boolean permitNull)
    >> > at
    >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    >> > diskCache)
    >> > at
    >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    >> > diskCache)
    >> > at
    >> > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    >> > at System.Web.Compilation.BuildManager.Initialize()
    >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    >> >
    >> >
    >> >
    >> > --
    >> > Adam Tuliper
    >> > http://www.secure-coding.com
    >> >

    >>
    >>
    >>
    Juan T. Llibre, Nov 9, 2005
    #5
  6. Im not sure thats it though.

    That situation sounds a little bit different, depending on iis settings
    mapping to a location outside of your application isn't allowed. Not being
    able to find "App_GlobalResources" is a different story. The call stack in
    that issue is very different as well. It seems this issue is being caused
    from a call to:
    combiner1.AddResourcesDirectory(HttpRuntime.ResourcesDirectoryVirtualPath.MapPathInternal());

    Which causes an exception to be thrown in MapPathActual because
    HostingEnvironment.GetVirtualPathToFileMapping("MyApp/App_GlobalResources/");
    returns null for whatever reason.. still trying to figure that one out.


    --
    Adam Tuliper
    http://www.secure-coding.com


    "Juan T. Llibre" wrote:

    > There was a bug filed for this situation this morning :
    >
    > http://lab.msdn.microsoft.com/produ...edbackid=1224adb4-8794-46cc-873b-1ce2b55b5bb4
    >
    > It's currently "Under review".
    >
    > I'd suggest that you check there over the next few days,
    > to see if there's a resolution or see if a workaround has been posted for it.
    >
    >
    >
    > Juan T. Llibre, ASP.NET MVP
    > ASP.NET FAQ : http://asp.net.do/faq/
    > ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > Foros de ASP.NET en Español : http://asp.net.do/foros/
    > ======================================
    > "Adam" <> wrote in message
    > news:...
    > > Im also curious if it has anything to do with Netegrity's siteminder. I seem
    > > to recall they set a flag in the metabase preventing updates. Installing sp4
    > > on win2k3 a while back had this issue with their product.
    > >
    > > There have been prior issues with updating the metabase and netegrity
    > > preventing it. This is happening on windows 2000, which several postings on
    > > the net have also pointed to. hmmm... I wonder if the metabase is missing
    > > information it needed during the setup, although asp.net 2.0 does seem to be
    > > installed properly, and the temp asp.net compilation directories are getting
    > > created for each app, just nothing is put in them because of this issue
    > > causing compilation to fail. Ive even tried adding a virtual directory in my
    > > app to the app_globalresources folder just for the heck of it.. no go. From
    > > the response and watching filemon, it seems that asp.net recognizes this as a
    > > special name and doesn't attempt to check for the physical location, but
    > > using App_GlobalResources1 does cause a file system check.
    > >
    > > This happens for any asp.net 2.0 app or page, even if I just create a
    > > directory and drop in a main.aspx (of course setting the site properties to
    > > be .net 2.0).
    > >
    > >
    > > --
    > > Adam Tuliper
    > > http://www.secure-coding.com
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    > >> Make sure there isn't a "\" character at the end of the directory name.
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre, ASP.NET MVP
    > >> ASP.NET FAQ : http://asp.net.do/faq/
    > >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > >> ======================================
    > >> "Adam" <> wrote in message
    > >> news:...
    > >> > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    > >> > bunch of people with this error on the net, but no solution:
    > >> >
    > >> > Works fine on my local machine, deployed to a server it yields this message.
    > >> >
    > >> > Failed to map the path '/App_GlobalResources/'
    > >> >
    > >> > Stack trace: at
    > >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    > >> > Boolean permitNull)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    > >> > diskCache)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    > >> > diskCache)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > >> > at System.Web.Compilation.BuildManager.Initialize()
    > >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    > >> >
    > >> >
    > >> >
    > >> > --
    > >> > Adam Tuliper
    > >> > http://www.secure-coding.com
    > >> >
    > >>
    > >>
    > >>

    >
    >
    >
    =?Utf-8?B?QWRhbQ==?=, Nov 10, 2005
    #6
  7. Actually I did find the issue at that site
    http://lab.msdn.microsoft.com/produ...edbackid=7346e3d6-3f9d-444b-8839-885cbbb23375
    says it was fixed in the rtm of asp.net, but thats the only build that is on
    our machine, and the call stack is close (the offending method is the same)


    --
    Adam Tuliper
    http://www.secure-coding.com


    "Juan T. Llibre" wrote:

    > There was a bug filed for this situation this morning :
    >
    > http://lab.msdn.microsoft.com/produ...edbackid=1224adb4-8794-46cc-873b-1ce2b55b5bb4
    >
    > It's currently "Under review".
    >
    > I'd suggest that you check there over the next few days,
    > to see if there's a resolution or see if a workaround has been posted for it.
    >
    >
    >
    > Juan T. Llibre, ASP.NET MVP
    > ASP.NET FAQ : http://asp.net.do/faq/
    > ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > Foros de ASP.NET en Español : http://asp.net.do/foros/
    > ======================================
    > "Adam" <> wrote in message
    > news:...
    > > Im also curious if it has anything to do with Netegrity's siteminder. I seem
    > > to recall they set a flag in the metabase preventing updates. Installing sp4
    > > on win2k3 a while back had this issue with their product.
    > >
    > > There have been prior issues with updating the metabase and netegrity
    > > preventing it. This is happening on windows 2000, which several postings on
    > > the net have also pointed to. hmmm... I wonder if the metabase is missing
    > > information it needed during the setup, although asp.net 2.0 does seem to be
    > > installed properly, and the temp asp.net compilation directories are getting
    > > created for each app, just nothing is put in them because of this issue
    > > causing compilation to fail. Ive even tried adding a virtual directory in my
    > > app to the app_globalresources folder just for the heck of it.. no go. From
    > > the response and watching filemon, it seems that asp.net recognizes this as a
    > > special name and doesn't attempt to check for the physical location, but
    > > using App_GlobalResources1 does cause a file system check.
    > >
    > > This happens for any asp.net 2.0 app or page, even if I just create a
    > > directory and drop in a main.aspx (of course setting the site properties to
    > > be .net 2.0).
    > >
    > >
    > > --
    > > Adam Tuliper
    > > http://www.secure-coding.com
    > >
    > >
    > > "Juan T. Llibre" wrote:
    > >
    > >> Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    > >> Make sure there isn't a "\" character at the end of the directory name.
    > >>
    > >>
    > >>
    > >>
    > >> Juan T. Llibre, ASP.NET MVP
    > >> ASP.NET FAQ : http://asp.net.do/faq/
    > >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > >> ======================================
    > >> "Adam" <> wrote in message
    > >> news:...
    > >> > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    > >> > bunch of people with this error on the net, but no solution:
    > >> >
    > >> > Works fine on my local machine, deployed to a server it yields this message.
    > >> >
    > >> > Failed to map the path '/App_GlobalResources/'
    > >> >
    > >> > Stack trace: at
    > >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    > >> > Boolean permitNull)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    > >> > diskCache)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    > >> > diskCache)
    > >> > at
    > >> > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > >> > at System.Web.Compilation.BuildManager.Initialize()
    > >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    > >> >
    > >> >
    > >> >
    > >> > --
    > >> > Adam Tuliper
    > >> > http://www.secure-coding.com
    > >> >
    > >>
    > >>
    > >>

    >
    >
    >
    =?Utf-8?B?QWRhbQ==?=, Nov 10, 2005
    #7
  8. In that case, bug it, and enlist Microsoft Support's help in finding an answer.

    http://lab.msdn.microsoft.com/productfeedback/



    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    ASPNETFAQ.COM : http://www.aspnetfaq.com/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "Adam" <> wrote in message
    news:...
    > Im not sure thats it though.
    >
    > That situation sounds a little bit different, depending on iis settings
    > mapping to a location outside of your application isn't allowed. Not being
    > able to find "App_GlobalResources" is a different story. The call stack in
    > that issue is very different as well. It seems this issue is being caused
    > from a call to:
    > combiner1.AddResourcesDirectory(HttpRuntime.ResourcesDirectoryVirtualPath.MapPathInternal());
    >
    > Which causes an exception to be thrown in MapPathActual because
    > HostingEnvironment.GetVirtualPathToFileMapping("MyApp/App_GlobalResources/");
    > returns null for whatever reason.. still trying to figure that one out.
    >
    >
    > --
    > Adam Tuliper
    > http://www.secure-coding.com
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> There was a bug filed for this situation this morning :
    >>
    >> http://lab.msdn.microsoft.com/produ...edbackid=1224adb4-8794-46cc-873b-1ce2b55b5bb4
    >>
    >> It's currently "Under review".
    >>
    >> I'd suggest that you check there over the next few days,
    >> to see if there's a resolution or see if a workaround has been posted for it.
    >>
    >>
    >>
    >> Juan T. Llibre, ASP.NET MVP
    >> ASP.NET FAQ : http://asp.net.do/faq/
    >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    >> ======================================
    >> "Adam" <> wrote in message
    >> news:...
    >> > Im also curious if it has anything to do with Netegrity's siteminder. I seem
    >> > to recall they set a flag in the metabase preventing updates. Installing sp4
    >> > on win2k3 a while back had this issue with their product.
    >> >
    >> > There have been prior issues with updating the metabase and netegrity
    >> > preventing it. This is happening on windows 2000, which several postings on
    >> > the net have also pointed to. hmmm... I wonder if the metabase is missing
    >> > information it needed during the setup, although asp.net 2.0 does seem to be
    >> > installed properly, and the temp asp.net compilation directories are getting
    >> > created for each app, just nothing is put in them because of this issue
    >> > causing compilation to fail. Ive even tried adding a virtual directory in my
    >> > app to the app_globalresources folder just for the heck of it.. no go. From
    >> > the response and watching filemon, it seems that asp.net recognizes this as a
    >> > special name and doesn't attempt to check for the physical location, but
    >> > using App_GlobalResources1 does cause a file system check.
    >> >
    >> > This happens for any asp.net 2.0 app or page, even if I just create a
    >> > directory and drop in a main.aspx (of course setting the site properties to
    >> > be .net 2.0).
    >> >
    >> >
    >> > --
    >> > Adam Tuliper
    >> > http://www.secure-coding.com
    >> >
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    >> >> Make sure there isn't a "\" character at the end of the directory name.
    >> >>
    >> >>
    >> >>
    >> >>
    >> >> Juan T. Llibre, ASP.NET MVP
    >> >> ASP.NET FAQ : http://asp.net.do/faq/
    >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    >> >> ======================================
    >> >> "Adam" <> wrote in message
    >> >> news:...
    >> >> > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    >> >> > bunch of people with this error on the net, but no solution:
    >> >> >
    >> >> > Works fine on my local machine, deployed to a server it yields this message.
    >> >> >
    >> >> > Failed to map the path '/App_GlobalResources/'
    >> >> >
    >> >> > Stack trace: at
    >> >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    >> >> > Boolean permitNull)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    >> >> > diskCache)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    >> >> > diskCache)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    >> >> > at System.Web.Compilation.BuildManager.Initialize()
    >> >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    >> >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    >> >> >
    >> >> >
    >> >> >
    >> >> > --
    >> >> > Adam Tuliper
    >> >> > http://www.secure-coding.com
    >> >> >
    >> >>
    >> >>
    >> >>

    >>
    >>
    >>
    Juan T. Llibre, Nov 10, 2005
    #8
  9. re:
    > says it was fixed in the rtm of asp.net,
    > but thats the only build that is on our machine


    Is your .net version 2.0.50727.42 (RTM.050727-4200) ?

    If not, install it, and check to see whether the bug remains.
    If it does, bug it.

    If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go to
    the bug report on the link you posted, validate the bug, vote on it,
    and ask that the bug be reopened in a comment to that bug report.

    That will catch their attention more than anything else.



    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    ASPNETFAQ.COM : http://www.aspnetfaq.com/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "Adam" <> wrote in message
    news:...
    > Actually I did find the issue at that site:
    > http://lab.msdn.microsoft.com/produ...edbackid=7346e3d6-3f9d-444b-8839-885cbbb23375
    > says it was fixed in the rtm of asp.net, but thats the only build that is on
    > our machine, and the call stack is close (the offending method is the same)
    >
    >
    > --
    > Adam Tuliper
    > http://www.secure-coding.com
    >
    >
    > "Juan T. Llibre" wrote:
    >
    >> There was a bug filed for this situation this morning :
    >>
    >> http://lab.msdn.microsoft.com/produ...edbackid=1224adb4-8794-46cc-873b-1ce2b55b5bb4
    >>
    >> It's currently "Under review".
    >>
    >> I'd suggest that you check there over the next few days,
    >> to see if there's a resolution or see if a workaround has been posted for it.
    >>
    >>
    >>
    >> Juan T. Llibre, ASP.NET MVP
    >> ASP.NET FAQ : http://asp.net.do/faq/
    >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    >> ======================================
    >> "Adam" <> wrote in message
    >> news:...
    >> > Im also curious if it has anything to do with Netegrity's siteminder. I seem
    >> > to recall they set a flag in the metabase preventing updates. Installing sp4
    >> > on win2k3 a while back had this issue with their product.
    >> >
    >> > There have been prior issues with updating the metabase and netegrity
    >> > preventing it. This is happening on windows 2000, which several postings on
    >> > the net have also pointed to. hmmm... I wonder if the metabase is missing
    >> > information it needed during the setup, although asp.net 2.0 does seem to be
    >> > installed properly, and the temp asp.net compilation directories are getting
    >> > created for each app, just nothing is put in them because of this issue
    >> > causing compilation to fail. Ive even tried adding a virtual directory in my
    >> > app to the app_globalresources folder just for the heck of it.. no go. From
    >> > the response and watching filemon, it seems that asp.net recognizes this as a
    >> > special name and doesn't attempt to check for the physical location, but
    >> > using App_GlobalResources1 does cause a file system check.
    >> >
    >> > This happens for any asp.net 2.0 app or page, even if I just create a
    >> > directory and drop in a main.aspx (of course setting the site properties to
    >> > be .net 2.0).
    >> >
    >> >
    >> > --
    >> > Adam Tuliper
    >> > http://www.secure-coding.com
    >> >
    >> >
    >> > "Juan T. Llibre" wrote:
    >> >
    >> >> Check the IIS Default Web Site Properties -> Home Directory -> Local Path.
    >> >> Make sure there isn't a "\" character at the end of the directory name.
    >> >>
    >> >>
    >> >>
    >> >>
    >> >> Juan T. Llibre, ASP.NET MVP
    >> >> ASP.NET FAQ : http://asp.net.do/faq/
    >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    >> >> ======================================
    >> >> "Adam" <> wrote in message
    >> >> news:...
    >> >> > Trying to get an asp.net 2.0 app running and am receiving this error. I see a
    >> >> > bunch of people with this error on the net, but no solution:
    >> >> >
    >> >> > Works fine on my local machine, deployed to a server it yields this message.
    >> >> >
    >> >> > Failed to map the path '/App_GlobalResources/'
    >> >> >
    >> >> > Stack trace: at
    >> >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath virtualPath,
    >> >> > Boolean permitNull)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDiskBuildResultCache
    >> >> > diskCache)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskBuildResultCache
    >> >> > diskCache)
    >> >> > at
    >> >> > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    >> >> > at System.Web.Compilation.BuildManager.Initialize()
    >> >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    >> >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
    >> >> >
    >> >> >
    >> >> >
    >> >> > --
    >> >> > Adam Tuliper
    >> >> > http://www.secure-coding.com
    >> >> >
    >> >>
    >> >>
    >> >>

    >>
    >>
    >>
    Juan T. Llibre, Nov 10, 2005
    #9
  10. Hi Adam,

    How did you deploy the website from your local dev box to the deployment
    server? Have you tried using the PublishSite in VS.NET 2005 to see whether
    it works? Also, as Juan has mentioned, you can check the Full version of
    the .net runtime on the server, if that did equals 2.0.50727.42
    (RTM.050727-4200), I think this should be a serious problem. Though it is
    likely enviornment specific, I'm still think whether it's ok for me to
    build a local reproduce steps. Would you also try deploying a very simple
    website to reproduce the behavior and let me know the server's IIS site's
    setting info?

    Thank you!

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)








    --------------------
    | From: "Juan T. Llibre" <>
    | References: <>
    <>
    <>
    <>
    <>
    | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | Date: Wed, 9 Nov 2005 20:44:38 -0400
    | Lines: 132
    | X-Priority: 3
    | X-MSMail-Priority: Normal
    | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | X-RFC2646: Format=Flowed; Original
    | Message-ID: <Oog$>
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: 222stb33.codetel.net.do 64.32.114.222
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:356894
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | re:
    | > says it was fixed in the rtm of asp.net,
    | > but thats the only build that is on our machine
    |
    | Is your .net version 2.0.50727.42 (RTM.050727-4200) ?
    |
    | If not, install it, and check to see whether the bug remains.
    | If it does, bug it.
    |
    | If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go to
    | the bug report on the link you posted, validate the bug, vote on it,
    | and ask that the bug be reopened in a comment to that bug report.
    |
    | That will catch their attention more than anything else.
    |
    |
    |
    | Juan T. Llibre, ASP.NET MVP
    | ASP.NET FAQ : http://asp.net.do/faq/
    | ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | Foros de ASP.NET en Español : http://asp.net.do/foros/
    | ======================================
    | "Adam" <> wrote in message
    | news:...
    | > Actually I did find the issue at that site:
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=7
    346e3d6-3f9d-444b-8839-885cbbb23375
    | > says it was fixed in the rtm of asp.net, but thats the only build that
    is on
    | > our machine, and the call stack is close (the offending method is the
    same)
    | >
    | >
    | > --
    | > Adam Tuliper
    | > http://www.secure-coding.com
    | >
    | >
    | > "Juan T. Llibre" wrote:
    | >
    | >> There was a bug filed for this situation this morning :
    | >>
    | >>
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=1
    224adb4-8794-46cc-873b-1ce2b55b5bb4
    | >>
    | >> It's currently "Under review".
    | >>
    | >> I'd suggest that you check there over the next few days,
    | >> to see if there's a resolution or see if a workaround has been posted
    for it.
    | >>
    | >>
    | >>
    | >> Juan T. Llibre, ASP.NET MVP
    | >> ASP.NET FAQ : http://asp.net.do/faq/
    | >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | >> ======================================
    | >> "Adam" <> wrote in message
    | >> news:...
    | >> > Im also curious if it has anything to do with Netegrity's
    siteminder. I seem
    | >> > to recall they set a flag in the metabase preventing updates.
    Installing sp4
    | >> > on win2k3 a while back had this issue with their product.
    | >> >
    | >> > There have been prior issues with updating the metabase and netegrity
    | >> > preventing it. This is happening on windows 2000, which several
    postings on
    | >> > the net have also pointed to. hmmm... I wonder if the metabase is
    missing
    | >> > information it needed during the setup, although asp.net 2.0 does
    seem to be
    | >> > installed properly, and the temp asp.net compilation directories are
    getting
    | >> > created for each app, just nothing is put in them because of this
    issue
    | >> > causing compilation to fail. Ive even tried adding a virtual
    directory in my
    | >> > app to the app_globalresources folder just for the heck of it.. no
    go. From
    | >> > the response and watching filemon, it seems that asp.net recognizes
    this as a
    | >> > special name and doesn't attempt to check for the physical location,
    but
    | >> > using App_GlobalResources1 does cause a file system check.
    | >> >
    | >> > This happens for any asp.net 2.0 app or page, even if I just create a
    | >> > directory and drop in a main.aspx (of course setting the site
    properties to
    | >> > be .net 2.0).
    | >> >
    | >> >
    | >> > --
    | >> > Adam Tuliper
    | >> > http://www.secure-coding.com
    | >> >
    | >> >
    | >> > "Juan T. Llibre" wrote:
    | >> >
    | >> >> Check the IIS Default Web Site Properties -> Home Directory ->
    Local Path.
    | >> >> Make sure there isn't a "\" character at the end of the directory
    name.
    | >> >>
    | >> >>
    | >> >>
    | >> >>
    | >> >> Juan T. Llibre, ASP.NET MVP
    | >> >> ASP.NET FAQ : http://asp.net.do/faq/
    | >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | >> >> ======================================
    | >> >> "Adam" <> wrote in message
    | >> >> news:...
    | >> >> > Trying to get an asp.net 2.0 app running and am receiving this
    error. I see a
    | >> >> > bunch of people with this error on the net, but no solution:
    | >> >> >
    | >> >> > Works fine on my local machine, deployed to a server it yields
    this message.
    | >> >> >
    | >> >> > Failed to map the path '/App_GlobalResources/'
    | >> >> >
    | >> >> > Stack trace: at
    | >> >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath
    virtualPath,
    | >> >> > Boolean permitNull)
    | >> >> > at
    | >> >> >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDisk
    BuildResultCache
    | >> >> > diskCache)
    | >> >> > at
    | >> >> >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskB
    uildResultCache
    | >> >> > diskCache)
    | >> >> > at
    | >> >> >
    System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    | >> >> > at System.Web.Compilation.BuildManager.Initialize()
    | >> >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    | >> >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags
    hostingFlags)
    | >> >> >
    | >> >> >
    | >> >> >
    | >> >> > --
    | >> >> > Adam Tuliper
    | >> >> > http://www.secure-coding.com
    | >> >> >
    | >> >>
    | >> >>
    | >> >>
    | >>
    | >>
    | >>
    |
    |
    |
    Steven Cheng[MSFT], Nov 10, 2005
    #10
  11. Hi Steven,
    This was done through a the publish feature in visual studio. To make sure
    it wasnt something assembly specific, I created a new folder, create an app
    from it in iisadmin, set the properties to run asp.net version 2.0.50727 (the
    only other available versions in the dropdown on the asp.net tab in iis are
    1.X versions - there are no other 2.x versions on this server). I added a
    test.aspx page which simply wrote out the headers, and access to this page
    fails with the same error. I have reported this at
    http://lab.msdn.microsoft.com/produ...edbackid=b48bbff7-7182-4ce5-9e54-70c7a2584f89

    Thanks,
    Adam

    --
    Adam Tuliper
    http://www.secure-coding.com

    "Steven Cheng[MSFT]" wrote:

    > Hi Adam,
    >
    > How did you deploy the website from your local dev box to the deployment
    > server? Have you tried using the PublishSite in VS.NET 2005 to see whether
    > it works? Also, as Juan has mentioned, you can check the Full version of
    > the .net runtime on the server, if that did equals 2.0.50727.42
    > (RTM.050727-4200), I think this should be a serious problem. Though it is
    > likely enviornment specific, I'm still think whether it's ok for me to
    > build a local reproduce steps. Would you also try deploying a very simple
    > website to reproduce the behavior and let me know the server's IIS site's
    > setting info?
    >
    > Thank you!
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
    >
    >
    >
    >
    >
    >
    > --------------------
    > | From: "Juan T. Llibre" <>
    > | References: <>
    > <>
    > <>
    > <>
    > <>
    > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    > | Date: Wed, 9 Nov 2005 20:44:38 -0400
    > | Lines: 132
    > | X-Priority: 3
    > | X-MSMail-Priority: Normal
    > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    > | X-RFC2646: Format=Flowed; Original
    > | Message-ID: <Oog$>
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: 222stb33.codetel.net.do 64.32.114.222
    > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10.phx.gbl
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:356894
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | re:
    > | > says it was fixed in the rtm of asp.net,
    > | > but thats the only build that is on our machine
    > |
    > | Is your .net version 2.0.50727.42 (RTM.050727-4200) ?
    > |
    > | If not, install it, and check to see whether the bug remains.
    > | If it does, bug it.
    > |
    > | If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go to
    > | the bug report on the link you posted, validate the bug, vote on it,
    > | and ask that the bug be reopened in a comment to that bug report.
    > |
    > | That will catch their attention more than anything else.
    > |
    > |
    > |
    > | Juan T. Llibre, ASP.NET MVP
    > | ASP.NET FAQ : http://asp.net.do/faq/
    > | ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | ======================================
    > | "Adam" <> wrote in message
    > | news:...
    > | > Actually I did find the issue at that site:
    > | >
    > http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=7
    > 346e3d6-3f9d-444b-8839-885cbbb23375
    > | > says it was fixed in the rtm of asp.net, but thats the only build that
    > is on
    > | > our machine, and the call stack is close (the offending method is the
    > same)
    > | >
    > | >
    > | > --
    > | > Adam Tuliper
    > | > http://www.secure-coding.com
    > | >
    > | >
    > | > "Juan T. Llibre" wrote:
    > | >
    > | >> There was a bug filed for this situation this morning :
    > | >>
    > | >>
    > http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=1
    > 224adb4-8794-46cc-873b-1ce2b55b5bb4
    > | >>
    > | >> It's currently "Under review".
    > | >>
    > | >> I'd suggest that you check there over the next few days,
    > | >> to see if there's a resolution or see if a workaround has been posted
    > for it.
    > | >>
    > | >>
    > | >>
    > | >> Juan T. Llibre, ASP.NET MVP
    > | >> ASP.NET FAQ : http://asp.net.do/faq/
    > | >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | >> ======================================
    > | >> "Adam" <> wrote in message
    > | >> news:...
    > | >> > Im also curious if it has anything to do with Netegrity's
    > siteminder. I seem
    > | >> > to recall they set a flag in the metabase preventing updates.
    > Installing sp4
    > | >> > on win2k3 a while back had this issue with their product.
    > | >> >
    > | >> > There have been prior issues with updating the metabase and netegrity
    > | >> > preventing it. This is happening on windows 2000, which several
    > postings on
    > | >> > the net have also pointed to. hmmm... I wonder if the metabase is
    > missing
    > | >> > information it needed during the setup, although asp.net 2.0 does
    > seem to be
    > | >> > installed properly, and the temp asp.net compilation directories are
    > getting
    > | >> > created for each app, just nothing is put in them because of this
    > issue
    > | >> > causing compilation to fail. Ive even tried adding a virtual
    > directory in my
    > | >> > app to the app_globalresources folder just for the heck of it.. no
    > go. From
    > | >> > the response and watching filemon, it seems that asp.net recognizes
    > this as a
    > | >> > special name and doesn't attempt to check for the physical location,
    > but
    > | >> > using App_GlobalResources1 does cause a file system check.
    > | >> >
    > | >> > This happens for any asp.net 2.0 app or page, even if I just create a
    > | >> > directory and drop in a main.aspx (of course setting the site
    > properties to
    > | >> > be .net 2.0).
    > | >> >
    > | >> >
    > | >> > --
    > | >> > Adam Tuliper
    > | >> > http://www.secure-coding.com
    > | >> >
    > | >> >
    > | >> > "Juan T. Llibre" wrote:
    > | >> >
    > | >> >> Check the IIS Default Web Site Properties -> Home Directory ->
    > Local Path.
    > | >> >> Make sure there isn't a "\" character at the end of the directory
    > name.
    > | >> >>
    > | >> >>
    > | >> >>
    > | >> >>
    > | >> >> Juan T. Llibre, ASP.NET MVP
    > | >> >> ASP.NET FAQ : http://asp.net.do/faq/
    > | >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | >> >> ======================================
    > | >> >> "Adam" <> wrote in message
    > | >> >> news:...
    > | >> >> > Trying to get an asp.net 2.0 app running and am receiving this
    > error. I see a
    > | >> >> > bunch of people with this error on the net, but no solution:
    > | >> >> >
    > | >> >> > Works fine on my local machine, deployed to a server it yields
    > this message.
    > | >> >> >
    > | >> >> > Failed to map the path '/App_GlobalResources/'
    > | >> >> >
    > | >> >> > Stack trace: at
    > | >> >> > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath
    > virtualPath,
    > | >> >> > Boolean permitNull)
    > | >> >> > at
    > | >> >> >
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDisk
    > BuildResultCache
    > | >> >> > diskCache)
    > | >> >> > at
    > | >> >> >
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskB
    > uildResultCache
    > | >> >> > diskCache)
    > | >> >> > at
    > | >> >> >
    > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > | >> >> > at System.Web.Compilation.BuildManager.Initialize()
    > | >> >> > at System.Web.Compilation.BuildManager.InitializeBuildManager()
    > | >> >> > at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags
    > hostingFlags)
    > | >> >> >
    > | >> >> >
    > | >> >> >
    > | >> >> > --
    > | >> >> > Adam Tuliper
    > | >> >> > http://www.secure-coding.com
    > | >> >> >
    > | >> >>
    > | >> >>
    > | >> >>
    > | >>
    > | >>
    > | >>
    > |
    > |
    > |
    >
    >
    =?Utf-8?B?QWRhbQ==?=, Nov 10, 2005
    #11
  12. Thanks for your response Adam,

    Have you also tested on other server to see whether you'll encounter the
    same problem? Also, is this the first time you try deploying 2.0 website on
    that server. I'm thinking maybe we can try reinstalling the .NET 2.0
    framework on that server. At least from reregister the ASP.NET 2.0
    runtime...

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)



    --------------------
    | Thread-Topic: Failed to map the path '/App_GlobalResources/'
    | thread-index: AcXmCzWr0CQREpPhQoOXPytpqLbEug==
    | X-WBNR-Posting-Host: 63.66.47.208
    | From: "=?Utf-8?B?QWRhbQ==?=" <>
    | References: <>
    <>
    <>
    <>
    <>
    <Oog$>
    <>
    | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | Date: Thu, 10 Nov 2005 07:27:06 -0800
    | Lines: 235
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 8bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:357052
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi Steven,
    | This was done through a the publish feature in visual studio. To make
    sure
    | it wasnt something assembly specific, I created a new folder, create an
    app
    | from it in iisadmin, set the properties to run asp.net version 2.0.50727
    (the
    | only other available versions in the dropdown on the asp.net tab in iis
    are
    | 1.X versions - there are no other 2.x versions on this server). I added a
    | test.aspx page which simply wrote out the headers, and access to this
    page
    | fails with the same error. I have reported this at:
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=b
    48bbff7-7182-4ce5-9e54-70c7a2584f89
    |
    | Thanks,
    | Adam
    |
    | --
    | Adam Tuliper
    | http://www.secure-coding.com
    |
    | "Steven Cheng[MSFT]" wrote:
    |
    | > Hi Adam,
    | >
    | > How did you deploy the website from your local dev box to the
    deployment
    | > server? Have you tried using the PublishSite in VS.NET 2005 to see
    whether
    | > it works? Also, as Juan has mentioned, you can check the Full version
    of
    | > the .net runtime on the server, if that did equals 2.0.50727.42
    | > (RTM.050727-4200), I think this should be a serious problem. Though it
    is
    | > likely enviornment specific, I'm still think whether it's ok for me to
    | > build a local reproduce steps. Would you also try deploying a very
    simple
    | > website to reproduce the behavior and let me know the server's IIS
    site's
    | > setting info?
    | >
    | > Thank you!
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | >
    | >
    | >
    | >
    | >
    | >
    | >
    | > --------------------
    | > | From: "Juan T. Llibre" <>
    | > | References: <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | > | Date: Wed, 9 Nov 2005 20:44:38 -0400
    | > | Lines: 132
    | > | X-Priority: 3
    | > | X-MSMail-Priority: Normal
    | > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | > | X-RFC2646: Format=Flowed; Original
    | > | Message-ID: <Oog$>
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | NNTP-Posting-Host: 222stb33.codetel.net.do 64.32.114.222
    | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10.phx.gbl
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:356894
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | re:
    | > | > says it was fixed in the rtm of asp.net,
    | > | > but thats the only build that is on our machine
    | > |
    | > | Is your .net version 2.0.50727.42 (RTM.050727-4200) ?
    | > |
    | > | If not, install it, and check to see whether the bug remains.
    | > | If it does, bug it.
    | > |
    | > | If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go to
    | > | the bug report on the link you posted, validate the bug, vote on it,
    | > | and ask that the bug be reopened in a comment to that bug report.
    | > |
    | > | That will catch their attention more than anything else.
    | > |
    | > |
    | > |
    | > | Juan T. Llibre, ASP.NET MVP
    | > | ASP.NET FAQ : http://asp.net.do/faq/
    | > | ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | ======================================
    | > | "Adam" <> wrote in message
    | > | news:...
    | > | > Actually I did find the issue at that site:
    | > | >
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=7
    | > 346e3d6-3f9d-444b-8839-885cbbb23375
    | > | > says it was fixed in the rtm of asp.net, but thats the only build
    that
    | > is on
    | > | > our machine, and the call stack is close (the offending method is
    the
    | > same)
    | > | >
    | > | >
    | > | > --
    | > | > Adam Tuliper
    | > | > http://www.secure-coding.com
    | > | >
    | > | >
    | > | > "Juan T. Llibre" wrote:
    | > | >
    | > | >> There was a bug filed for this situation this morning :
    | > | >>
    | > | >>
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=1
    | > 224adb4-8794-46cc-873b-1ce2b55b5bb4
    | > | >>
    | > | >> It's currently "Under review".
    | > | >>
    | > | >> I'd suggest that you check there over the next few days,
    | > | >> to see if there's a resolution or see if a workaround has been
    posted
    | > for it.
    | > | >>
    | > | >>
    | > | >>
    | > | >> Juan T. Llibre, ASP.NET MVP
    | > | >> ASP.NET FAQ : http://asp.net.do/faq/
    | > | >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | >> ======================================
    | > | >> "Adam" <> wrote in message
    | > | >> news:...
    | > | >> > Im also curious if it has anything to do with Netegrity's
    | > siteminder. I seem
    | > | >> > to recall they set a flag in the metabase preventing updates.
    | > Installing sp4
    | > | >> > on win2k3 a while back had this issue with their product.
    | > | >> >
    | > | >> > There have been prior issues with updating the metabase and
    netegrity
    | > | >> > preventing it. This is happening on windows 2000, which several
    | > postings on
    | > | >> > the net have also pointed to. hmmm... I wonder if the metabase
    is
    | > missing
    | > | >> > information it needed during the setup, although asp.net 2.0
    does
    | > seem to be
    | > | >> > installed properly, and the temp asp.net compilation directories
    are
    | > getting
    | > | >> > created for each app, just nothing is put in them because of
    this
    | > issue
    | > | >> > causing compilation to fail. Ive even tried adding a virtual
    | > directory in my
    | > | >> > app to the app_globalresources folder just for the heck of it..
    no
    | > go. From
    | > | >> > the response and watching filemon, it seems that asp.net
    recognizes
    | > this as a
    | > | >> > special name and doesn't attempt to check for the physical
    location,
    | > but
    | > | >> > using App_GlobalResources1 does cause a file system check.
    | > | >> >
    | > | >> > This happens for any asp.net 2.0 app or page, even if I just
    create a
    | > | >> > directory and drop in a main.aspx (of course setting the site
    | > properties to
    | > | >> > be .net 2.0).
    | > | >> >
    | > | >> >
    | > | >> > --
    | > | >> > Adam Tuliper
    | > | >> > http://www.secure-coding.com
    | > | >> >
    | > | >> >
    | > | >> > "Juan T. Llibre" wrote:
    | > | >> >
    | > | >> >> Check the IIS Default Web Site Properties -> Home Directory ->
    | > Local Path.
    | > | >> >> Make sure there isn't a "\" character at the end of the
    directory
    | > name.
    | > | >> >>
    | > | >> >>
    | > | >> >>
    | > | >> >>
    | > | >> >> Juan T. Llibre, ASP.NET MVP
    | > | >> >> ASP.NET FAQ : http://asp.net.do/faq/
    | > | >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | >> >> ======================================
    | > | >> >> "Adam" <> wrote in message
    | > | >> >> news:...
    | > | >> >> > Trying to get an asp.net 2.0 app running and am receiving
    this
    | > error. I see a
    | > | >> >> > bunch of people with this error on the net, but no solution:
    | > | >> >> >
    | > | >> >> > Works fine on my local machine, deployed to a server it
    yields
    | > this message.
    | > | >> >> >
    | > | >> >> > Failed to map the path '/App_GlobalResources/'
    | > | >> >> >
    | > | >> >> > Stack trace: at
    | > | >> >> >
    System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath
    | > virtualPath,
    | > | >> >> > Boolean permitNull)
    | > | >> >> > at
    | > | >> >> >
    | >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDisk
    | > BuildResultCache
    | > | >> >> > diskCache)
    | > | >> >> > at
    | > | >> >> >
    | >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskB
    | > uildResultCache
    | > | >> >> > diskCache)
    | > | >> >> > at
    | > | >> >> >
    | >
    System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    | > | >> >> > at System.Web.Compilation.BuildManager.Initialize()
    | > | >> >> > at
    System.Web.Compilation.BuildManager.InitializeBuildManager()
    | > | >> >> > at
    System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags
    | > hostingFlags)
    | > | >> >> >
    | > | >> >> >
    | > | >> >> >
    | > | >> >> > --
    | > | >> >> > Adam Tuliper
    | > | >> >> > http://www.secure-coding.com
    | > | >> >> >
    | > | >> >>
    | > | >> >>
    | > | >> >>
    | > | >>
    | > | >>
    | > | >>
    | > |
    | > |
    | > |
    | >
    | >
    |
    Steven Cheng[MSFT], Nov 11, 2005
    #12
  13. Hi Steven,
    The solution is to set security permissions for the aspnet user on
    %SystemDrive%\Documents and Settings\All Users\Application
    Data\Microsoft\Crypto\RSA\MachineKeys

    Watching filemon:
    aspnet_wp.exe:3084 IRP_MJ_CREATE C:\Documents and Settings\All
    Users\Application
    Data\Microsoft\Crypto\RSA\MachineKeys\3d79497f094c7a30f1ab27ae62464e2b_f66df180-918e-466d-8201-73e51626aac5 ACCESS
    DENIED Attributes: S Options: OpenIf Sequential

    aspnet_wp.exe tries over and over to create this (for several minutes) and
    then fails. This folder contains read permissions for everyone, but needs
    write permissions set just for aspnet.



    --
    Adam Tuliper
    http://www.secure-coding.com


    "Steven Cheng[MSFT]" wrote:

    > Thanks for your response Adam,
    >
    > Have you also tested on other server to see whether you'll encounter the
    > same problem? Also, is this the first time you try deploying 2.0 website on
    > that server. I'm thinking maybe we can try reinstalling the .NET 2.0
    > framework on that server. At least from reregister the ASP.NET 2.0
    > runtime...
    >
    > Thanks,
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
    >
    > --------------------
    > | Thread-Topic: Failed to map the path '/App_GlobalResources/'
    > | thread-index: AcXmCzWr0CQREpPhQoOXPytpqLbEug==
    > | X-WBNR-Posting-Host: 63.66.47.208
    > | From: "=?Utf-8?B?QWRhbQ==?=" <>
    > | References: <>
    > <>
    > <>
    > <>
    > <>
    > <Oog$>
    > <>
    > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    > | Date: Thu, 10 Nov 2005 07:27:06 -0800
    > | Lines: 235
    > | Message-ID: <>
    > | MIME-Version: 1.0
    > | Content-Type: text/plain;
    > | charset="Utf-8"
    > | Content-Transfer-Encoding: 8bit
    > | X-Newsreader: Microsoft CDO for Windows 2000
    > | Content-Class: urn:content-classes:message
    > | Importance: normal
    > | Priority: normal
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:357052
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | Hi Steven,
    > | This was done through a the publish feature in visual studio. To make
    > sure
    > | it wasnt something assembly specific, I created a new folder, create an
    > app
    > | from it in iisadmin, set the properties to run asp.net version 2.0.50727
    > (the
    > | only other available versions in the dropdown on the asp.net tab in iis
    > are
    > | 1.X versions - there are no other 2.x versions on this server). I added a
    > | test.aspx page which simply wrote out the headers, and access to this
    > page
    > | fails with the same error. I have reported this at:
    > http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=b
    > 48bbff7-7182-4ce5-9e54-70c7a2584f89
    > |
    > | Thanks,
    > | Adam
    > |
    > | --
    > | Adam Tuliper
    > | http://www.secure-coding.com
    > |
    > | "Steven Cheng[MSFT]" wrote:
    > |
    > | > Hi Adam,
    > | >
    > | > How did you deploy the website from your local dev box to the
    > deployment
    > | > server? Have you tried using the PublishSite in VS.NET 2005 to see
    > whether
    > | > it works? Also, as Juan has mentioned, you can check the Full version
    > of
    > | > the .net runtime on the server, if that did equals 2.0.50727.42
    > | > (RTM.050727-4200), I think this should be a serious problem. Though it
    > is
    > | > likely enviornment specific, I'm still think whether it's ok for me to
    > | > build a local reproduce steps. Would you also try deploying a very
    > simple
    > | > website to reproduce the behavior and let me know the server's IIS
    > site's
    > | > setting info?
    > | >
    > | > Thank you!
    > | >
    > | > Steven Cheng
    > | > Microsoft Online Support
    > | >
    > | > Get Secure! www.microsoft.com/security
    > | > (This posting is provided "AS IS", with no warranties, and confers no
    > | > rights.)
    > | >
    > | >
    > | >
    > | >
    > | >
    > | >
    > | >
    > | >
    > | > --------------------
    > | > | From: "Juan T. Llibre" <>
    > | > | References: <>
    > | > <>
    > | > <>
    > | > <>
    > | > <>
    > | > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    > | > | Date: Wed, 9 Nov 2005 20:44:38 -0400
    > | > | Lines: 132
    > | > | X-Priority: 3
    > | > | X-MSMail-Priority: Normal
    > | > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
    > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    > | > | X-RFC2646: Format=Flowed; Original
    > | > | Message-ID: <Oog$>
    > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > | NNTP-Posting-Host: 222stb33.codetel.net.do 64.32.114.222
    > | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10.phx.gbl
    > | > | Xref: TK2MSFTNGXA02.phx.gbl
    > | > microsoft.public.dotnet.framework.aspnet:356894
    > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > |
    > | > | re:
    > | > | > says it was fixed in the rtm of asp.net,
    > | > | > but thats the only build that is on our machine
    > | > |
    > | > | Is your .net version 2.0.50727.42 (RTM.050727-4200) ?
    > | > |
    > | > | If not, install it, and check to see whether the bug remains.
    > | > | If it does, bug it.
    > | > |
    > | > | If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go to
    > | > | the bug report on the link you posted, validate the bug, vote on it,
    > | > | and ask that the bug be reopened in a comment to that bug report.
    > | > |
    > | > | That will catch their attention more than anything else.
    > | > |
    > | > |
    > | > |
    > | > | Juan T. Llibre, ASP.NET MVP
    > | > | ASP.NET FAQ : http://asp.net.do/faq/
    > | > | ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | > | Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | > | ======================================
    > | > | "Adam" <> wrote in message
    > | > | news:...
    > | > | > Actually I did find the issue at that site:
    > | > | >
    > | >
    > http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=7
    > | > 346e3d6-3f9d-444b-8839-885cbbb23375
    > | > | > says it was fixed in the rtm of asp.net, but thats the only build
    > that
    > | > is on
    > | > | > our machine, and the call stack is close (the offending method is
    > the
    > | > same)
    > | > | >
    > | > | >
    > | > | > --
    > | > | > Adam Tuliper
    > | > | > http://www.secure-coding.com
    > | > | >
    > | > | >
    > | > | > "Juan T. Llibre" wrote:
    > | > | >
    > | > | >> There was a bug filed for this situation this morning :
    > | > | >>
    > | > | >>
    > | >
    > http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=1
    > | > 224adb4-8794-46cc-873b-1ce2b55b5bb4
    > | > | >>
    > | > | >> It's currently "Under review".
    > | > | >>
    > | > | >> I'd suggest that you check there over the next few days,
    > | > | >> to see if there's a resolution or see if a workaround has been
    > posted
    > | > for it.
    > | > | >>
    > | > | >>
    > | > | >>
    > | > | >> Juan T. Llibre, ASP.NET MVP
    > | > | >> ASP.NET FAQ : http://asp.net.do/faq/
    > | > | >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | > | >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | > | >> ======================================
    > | > | >> "Adam" <> wrote in message
    > | > | >> news:...
    > | > | >> > Im also curious if it has anything to do with Netegrity's
    > | > siteminder. I seem
    > | > | >> > to recall they set a flag in the metabase preventing updates.
    > | > Installing sp4
    > | > | >> > on win2k3 a while back had this issue with their product.
    > | > | >> >
    > | > | >> > There have been prior issues with updating the metabase and
    > netegrity
    > | > | >> > preventing it. This is happening on windows 2000, which several
    > | > postings on
    > | > | >> > the net have also pointed to. hmmm... I wonder if the metabase
    > is
    > | > missing
    > | > | >> > information it needed during the setup, although asp.net 2.0
    > does
    > | > seem to be
    > | > | >> > installed properly, and the temp asp.net compilation directories
    > are
    > | > getting
    > | > | >> > created for each app, just nothing is put in them because of
    > this
    > | > issue
    > | > | >> > causing compilation to fail. Ive even tried adding a virtual
    > | > directory in my
    > | > | >> > app to the app_globalresources folder just for the heck of it..
    > no
    > | > go. From
    > | > | >> > the response and watching filemon, it seems that asp.net
    > recognizes
    > | > this as a
    > | > | >> > special name and doesn't attempt to check for the physical
    > location,
    > | > but
    > | > | >> > using App_GlobalResources1 does cause a file system check.
    > | > | >> >
    > | > | >> > This happens for any asp.net 2.0 app or page, even if I just
    > create a
    > | > | >> > directory and drop in a main.aspx (of course setting the site
    > | > properties to
    > | > | >> > be .net 2.0).
    > | > | >> >
    > | > | >> >
    > | > | >> > --
    > | > | >> > Adam Tuliper
    > | > | >> > http://www.secure-coding.com
    > | > | >> >
    > | > | >> >
    > | > | >> > "Juan T. Llibre" wrote:
    > | > | >> >
    > | > | >> >> Check the IIS Default Web Site Properties -> Home Directory ->
    > | > Local Path.
    > | > | >> >> Make sure there isn't a "\" character at the end of the
    > directory
    > | > name.
    > | > | >> >>
    > | > | >> >>
    > | > | >> >>
    > | > | >> >>
    > | > | >> >> Juan T. Llibre, ASP.NET MVP
    > | > | >> >> ASP.NET FAQ : http://asp.net.do/faq/
    > | > | >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    > | > | >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    > | > | >> >> ======================================
    > | > | >> >> "Adam" <> wrote in message
    > | > | >> >> news:...
    > | > | >> >> > Trying to get an asp.net 2.0 app running and am receiving
    > this
    > | > error. I see a
    > | > | >> >> > bunch of people with this error on the net, but no solution:
    > | > | >> >> >
    > | > | >> >> > Works fine on my local machine, deployed to a server it
    > yields
    > | > this message.
    > | > | >> >> >
    > | > | >> >> > Failed to map the path '/App_GlobalResources/'
    > | > | >> >> >
    > | > | >> >> > Stack trace: at
    > | > | >> >> >
    > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath
    > | > virtualPath,
    > | > | >> >> > Boolean permitNull)
    > | > | >> >> > at
    > | > | >> >> >
    > | >
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDisk
    > | > BuildResultCache
    > | > | >> >> > diskCache)
    > | > | >> >> > at
    > | > | >> >> >
    > | >
    > System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskB
    > | > uildResultCache
    > | > | >> >> > diskCache)
    > | > | >> >> > at
    > | > | >> >> >
    > | >
    > System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    > | > | >> >> > at System.Web.Compilation.BuildManager.Initialize()
    > | > | >> >> > at
    > System.Web.Compilation.BuildManager.InitializeBuildManager()
    =?Utf-8?B?QWRhbQ==?=, Nov 11, 2005
    #13
  14. Thanks for your followup Adam,

    Glad that you've figured out the problem. So the cause of it is still some
    security setting not configured properly on the server... Anyway, if
    there're any further things we can help, please feel free to post here.

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)



    --------------------
    | Thread-Topic: Failed to map the path '/App_GlobalResources/'
    | thread-index: AcXmzbeaM7PnS5cPSfmG9lG66Ba7sg==
    | X-WBNR-Posting-Host: 63.66.47.208
    | From: "=?Utf-8?B?QWRhbQ==?=" <>
    | References: <>
    <>
    <>
    <>
    <>
    <Oog$>
    <>
    <>
    <>
    | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | Date: Fri, 11 Nov 2005 06:39:27 -0800
    | Lines: 324
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 8bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:357361
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi Steven,
    | The solution is to set security permissions for the aspnet user on
    | %SystemDrive%\Documents and Settings\All Users\Application
    | Data\Microsoft\Crypto\RSA\MachineKeys
    |
    | Watching filemon:
    | aspnet_wp.exe:3084 IRP_MJ_CREATE C:\Documents and Settings\All
    | Users\Application
    |
    Data\Microsoft\Crypto\RSA\MachineKeys\3d79497f094c7a30f1ab27ae62464e2b_f66df
    180-918e-466d-8201-73e51626aac5 ACCESS
    | DENIED Attributes: S Options: OpenIf Sequential
    |
    | aspnet_wp.exe tries over and over to create this (for several minutes)
    and
    | then fails. This folder contains read permissions for everyone, but needs
    | write permissions set just for aspnet.
    |
    |
    |
    | --
    | Adam Tuliper
    | http://www.secure-coding.com
    |
    |
    | "Steven Cheng[MSFT]" wrote:
    |
    | > Thanks for your response Adam,
    | >
    | > Have you also tested on other server to see whether you'll encounter
    the
    | > same problem? Also, is this the first time you try deploying 2.0
    website on
    | > that server. I'm thinking maybe we can try reinstalling the .NET 2.0
    | > framework on that server. At least from reregister the ASP.NET 2.0
    | > runtime...
    | >
    | > Thanks,
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | >
    | >
    | > --------------------
    | > | Thread-Topic: Failed to map the path '/App_GlobalResources/'
    | > | thread-index: AcXmCzWr0CQREpPhQoOXPytpqLbEug==
    | > | X-WBNR-Posting-Host: 63.66.47.208
    | > | From: "=?Utf-8?B?QWRhbQ==?=" <>
    | > | References: <>
    | > <>
    | > <>
    | > <>
    | > <>
    | > <Oog$>
    | > <>
    | > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | > | Date: Thu, 10 Nov 2005 07:27:06 -0800
    | > | Lines: 235
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 8bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:357052
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | Hi Steven,
    | > | This was done through a the publish feature in visual studio. To make
    | > sure
    | > | it wasnt something assembly specific, I created a new folder, create
    an
    | > app
    | > | from it in iisadmin, set the properties to run asp.net version
    2.0.50727
    | > (the
    | > | only other available versions in the dropdown on the asp.net tab in
    iis
    | > are
    | > | 1.X versions - there are no other 2.x versions on this server). I
    added a
    | > | test.aspx page which simply wrote out the headers, and access to this
    | > page
    | > | fails with the same error. I have reported this at:
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=b
    | > 48bbff7-7182-4ce5-9e54-70c7a2584f89
    | > |
    | > | Thanks,
    | > | Adam
    | > |
    | > | --
    | > | Adam Tuliper
    | > | http://www.secure-coding.com
    | > |
    | > | "Steven Cheng[MSFT]" wrote:
    | > |
    | > | > Hi Adam,
    | > | >
    | > | > How did you deploy the website from your local dev box to the
    | > deployment
    | > | > server? Have you tried using the PublishSite in VS.NET 2005 to see
    | > whether
    | > | > it works? Also, as Juan has mentioned, you can check the Full
    version
    | > of
    | > | > the .net runtime on the server, if that did equals 2.0.50727.42
    | > | > (RTM.050727-4200), I think this should be a serious problem. Though
    it
    | > is
    | > | > likely enviornment specific, I'm still think whether it's ok for me
    to
    | > | > build a local reproduce steps. Would you also try deploying a very
    | > simple
    | > | > website to reproduce the behavior and let me know the server's IIS
    | > site's
    | > | > setting info?
    | > | >
    | > | > Thank you!
    | > | >
    | > | > Steven Cheng
    | > | > Microsoft Online Support
    | > | >
    | > | > Get Secure! www.microsoft.com/security
    | > | > (This posting is provided "AS IS", with no warranties, and confers
    no
    | > | > rights.)
    | > | >
    | > | >
    | > | >
    | > | >
    | > | >
    | > | >
    | > | >
    | > | >
    | > | > --------------------
    | > | > | From: "Juan T. Llibre" <>
    | > | > | References: <>
    | > | > <>
    | > | > <>
    | > | > <>
    | > | > <>
    | > | > | Subject: Re: Failed to map the path '/App_GlobalResources/'
    | > | > | Date: Wed, 9 Nov 2005 20:44:38 -0400
    | > | > | Lines: 132
    | > | > | X-Priority: 3
    | > | > | X-MSMail-Priority: Normal
    | > | > | X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
    | > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | > | > | X-RFC2646: Format=Flowed; Original
    | > | > | Message-ID: <Oog$>
    | > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | > | NNTP-Posting-Host: 222stb33.codetel.net.do 64.32.114.222
    | > | > | Path:
    TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP10.phx.gbl
    | > | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > | > microsoft.public.dotnet.framework.aspnet:356894
    | > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > | > |
    | > | > | re:
    | > | > | > says it was fixed in the rtm of asp.net,
    | > | > | > but thats the only build that is on our machine
    | > | > |
    | > | > | Is your .net version 2.0.50727.42 (RTM.050727-4200) ?
    | > | > |
    | > | > | If not, install it, and check to see whether the bug remains.
    | > | > | If it does, bug it.
    | > | > |
    | > | > | If your .net version *is* 2.0.50727.42 (RTM.050727-4200), then go
    to
    | > | > | the bug report on the link you posted, validate the bug, vote on
    it,
    | > | > | and ask that the bug be reopened in a comment to that bug report.
    | > | > |
    | > | > | That will catch their attention more than anything else.
    | > | > |
    | > | > |
    | > | > |
    | > | > | Juan T. Llibre, ASP.NET MVP
    | > | > | ASP.NET FAQ : http://asp.net.do/faq/
    | > | > | ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | > | Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | > | ======================================
    | > | > | "Adam" <> wrote in message
    | > | > | news:...
    | > | > | > Actually I did find the issue at that site:
    | > | > | >
    | > | >
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=7
    | > | > 346e3d6-3f9d-444b-8839-885cbbb23375
    | > | > | > says it was fixed in the rtm of asp.net, but thats the only
    build
    | > that
    | > | > is on
    | > | > | > our machine, and the call stack is close (the offending method
    is
    | > the
    | > | > same)
    | > | > | >
    | > | > | >
    | > | > | > --
    | > | > | > Adam Tuliper
    | > | > | > http://www.secure-coding.com
    | > | > | >
    | > | > | >
    | > | > | > "Juan T. Llibre" wrote:
    | > | > | >
    | > | > | >> There was a bug filed for this situation this morning :
    | > | > | >>
    | > | > | >>
    | > | >
    | >
    http://lab.msdn.microsoft.com/productfeedback/viewfeedback.aspx?feedbackid=1
    | > | > 224adb4-8794-46cc-873b-1ce2b55b5bb4
    | > | > | >>
    | > | > | >> It's currently "Under review".
    | > | > | >>
    | > | > | >> I'd suggest that you check there over the next few days,
    | > | > | >> to see if there's a resolution or see if a workaround has been
    | > posted
    | > | > for it.
    | > | > | >>
    | > | > | >>
    | > | > | >>
    | > | > | >> Juan T. Llibre, ASP.NET MVP
    | > | > | >> ASP.NET FAQ : http://asp.net.do/faq/
    | > | > | >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | > | >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | > | >> ======================================
    | > | > | >> "Adam" <> wrote in message
    | > | > | >> news:...
    | > | > | >> > Im also curious if it has anything to do with Netegrity's
    | > | > siteminder. I seem
    | > | > | >> > to recall they set a flag in the metabase preventing
    updates.
    | > | > Installing sp4
    | > | > | >> > on win2k3 a while back had this issue with their product.
    | > | > | >> >
    | > | > | >> > There have been prior issues with updating the metabase and
    | > netegrity
    | > | > | >> > preventing it. This is happening on windows 2000, which
    several
    | > | > postings on
    | > | > | >> > the net have also pointed to. hmmm... I wonder if the
    metabase
    | > is
    | > | > missing
    | > | > | >> > information it needed during the setup, although asp.net 2.0
    | > does
    | > | > seem to be
    | > | > | >> > installed properly, and the temp asp.net compilation
    directories
    | > are
    | > | > getting
    | > | > | >> > created for each app, just nothing is put in them because of
    | > this
    | > | > issue
    | > | > | >> > causing compilation to fail. Ive even tried adding a virtual
    | > | > directory in my
    | > | > | >> > app to the app_globalresources folder just for the heck of
    it..
    | > no
    | > | > go. From
    | > | > | >> > the response and watching filemon, it seems that asp.net
    | > recognizes
    | > | > this as a
    | > | > | >> > special name and doesn't attempt to check for the physical
    | > location,
    | > | > but
    | > | > | >> > using App_GlobalResources1 does cause a file system check.
    | > | > | >> >
    | > | > | >> > This happens for any asp.net 2.0 app or page, even if I just
    | > create a
    | > | > | >> > directory and drop in a main.aspx (of course setting the
    site
    | > | > properties to
    | > | > | >> > be .net 2.0).
    | > | > | >> >
    | > | > | >> >
    | > | > | >> > --
    | > | > | >> > Adam Tuliper
    | > | > | >> > http://www.secure-coding.com
    | > | > | >> >
    | > | > | >> >
    | > | > | >> > "Juan T. Llibre" wrote:
    | > | > | >> >
    | > | > | >> >> Check the IIS Default Web Site Properties -> Home Directory
    ->
    | > | > Local Path.
    | > | > | >> >> Make sure there isn't a "\" character at the end of the
    | > directory
    | > | > name.
    | > | > | >> >>
    | > | > | >> >>
    | > | > | >> >>
    | > | > | >> >>
    | > | > | >> >> Juan T. Llibre, ASP.NET MVP
    | > | > | >> >> ASP.NET FAQ : http://asp.net.do/faq/
    | > | > | >> >> ASPNETFAQ.COM : http://www.aspnetfaq.com/
    | > | > | >> >> Foros de ASP.NET en Español : http://asp.net.do/foros/
    | > | > | >> >> ======================================
    | > | > | >> >> "Adam" <> wrote in message
    | > | > | >> >> news:...
    | > | > | >> >> > Trying to get an asp.net 2.0 app running and am receiving
    | > this
    | > | > error. I see a
    | > | > | >> >> > bunch of people with this error on the net, but no
    solution:
    | > | > | >> >> >
    | > | > | >> >> > Works fine on my local machine, deployed to a server it
    | > yields
    | > | > this message.
    | > | > | >> >> >
    | > | > | >> >> > Failed to map the path '/App_GlobalResources/'
    | > | > | >> >> >
    | > | > | >> >> > Stack trace: at
    | > | > | >> >> >
    | > System.Web.Hosting.HostingEnvironment.MapPathActual(VirtualPath
    | > | > virtualPath,
    | > | > | >> >> > Boolean permitNull)
    | > | > | >> >> > at
    | > | > | >> >> >
    | > | >
    | >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate2(StandardDisk
    | > | > BuildResultCache
    | > | > | >> >> > diskCache)
    | > | > | >> >> > at
    | > | > | >> >> >
    | > | >
    | >
    System.Web.Compilation.BuildManager.CheckTopLevelFilesUpToDate(StandardDiskB
    | > | > uildResultCache
    | > | > | >> >> > diskCache)
    | > | > | >> >> > at
    | > | > | >> >> >
    | > | >
    | >
    System.Web.Compilation.BuildManager.PrecompiledAppRuntimeModeInitialize()
    | > | > | >> >> > at System.Web.Compilation.BuildManager.Initialize()
    | > | > | >> >> > at
    | > System.Web.Compilation.BuildManager.InitializeBuildManager()
    |
    Steven Cheng[MSFT], Nov 14, 2005
    #14
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    2,227
  2. Jody Gelowitz

    Failed to map the path App_GlobalResources

    Jody Gelowitz, Dec 19, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    2,181
    Jody Gelowitz
    Dec 19, 2005
  3. Pippo
    Replies:
    1
    Views:
    8,288
    =?Utf-8?B?Q293Ym95IChHcmVnb3J5IEEuIEJlYW1lcikgLSBN
    Feb 1, 2006
  4. CuriousGeorge

    App_GlobalResources & Resources namespace

    CuriousGeorge, Mar 21, 2006, in forum: ASP .Net
    Replies:
    5
    Views:
    7,475
    Steven Cheng[MSFT]
    Mar 23, 2006
  5. ad
    Replies:
    0
    Views:
    481
Loading...

Share This Page