Famous error - Unable to start debugging on the webserver: Details inside

Discussion in 'ASP .Net' started by loser, Aug 7, 2003.

  1. loser

    loser Guest

    Hi,

    I made the unfortunate mistake of installing Windows 2000 Service Pack
    4 and .NET Framework 1.0 Service Pack 2 on a development machine
    (1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
    Fixxml.exe at Microsoft.com fixed that issue. We developed without
    issue for the rest of the day (mostly javascript/related client side
    code) but then the famous "Error trying to run project: Unable to
    start debugging on the web server: Would you like to disable...."
    cropped up.

    These are the following steps that we have taken to resolve this
    problem, all of which were unsuccessful (Debugging worked prior to
    SP4/.Net SP2):

    Verified web.config debug=true in the specific application
    Verified no syntax errors in web.config
    Verified users in Debugger Users/Administrators
    Verified project creation was by NetBIOS name rather than IP address
    Verified Anonymous ACcess/Integrated Windows Authentication enabled
    Verified DEBUG keywords in configuration for .aspx, .asax, .asmx

    Virtual folders for the applications were assigned, but the
    application name dialog boxes were blank. Assigned names to the
    applications corresponding to the actual project names.

    Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
    aspnet_wp.exe to be assigned to all scriptmappings.

    Ran regsvr32
    %SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll

    Ran iisreset multiple times.

    I cannot verify that vs.net remote components are installed for this
    version of .net (.288). I also have not of course rebuilt the .net
    framework yet, as my boss has asked me not to until I get some
    responses to this news post.

    Can anyone advise on best way to solve this?
     
    loser, Aug 7, 2003
    #1
    1. Advertising

  2. loser

    loser Guest

    I also just added the ASPNET user to the Administrators group and
    Debuggers group. Still doesn't work.


    On Thu, 07 Aug 2003 11:43:24 -0500, loser <> wrote:

    >Hi,
    >
    >I made the unfortunate mistake of installing Windows 2000 Service Pack
    >4 and .NET Framework 1.0 Service Pack 2 on a development machine
    >(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
    >Fixxml.exe at Microsoft.com fixed that issue. We developed without
    >issue for the rest of the day (mostly javascript/related client side
    >code) but then the famous "Error trying to run project: Unable to
    >start debugging on the web server: Would you like to disable...."
    >cropped up.
    >
    >These are the following steps that we have taken to resolve this
    >problem, all of which were unsuccessful (Debugging worked prior to
    >SP4/.Net SP2):
    >
    >Verified web.config debug=true in the specific application
    >Verified no syntax errors in web.config
    >Verified users in Debugger Users/Administrators
    >Verified project creation was by NetBIOS name rather than IP address
    >Verified Anonymous ACcess/Integrated Windows Authentication enabled
    >Verified DEBUG keywords in configuration for .aspx, .asax, .asmx
    >
    >Virtual folders for the applications were assigned, but the
    >application name dialog boxes were blank. Assigned names to the
    >applications corresponding to the actual project names.
    >
    >Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
    >aspnet_wp.exe to be assigned to all scriptmappings.
    >
    >Ran regsvr32
    >%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll
    >
    >Ran iisreset multiple times.
    >
    >I cannot verify that vs.net remote components are installed for this
    >version of .net (.288). I also have not of course rebuilt the .net
    >framework yet, as my boss has asked me not to until I get some
    >responses to this news post.
    >
    >Can anyone advise on best way to solve this?
    >
    >
     
    loser, Aug 7, 2003
    #2
    1. Advertising

  3. loser

    loser Guest


    >Hi,
    >
    >I made the unfortunate mistake of installing Windows 2000 Service Pack
    >4 and .NET Framework 1.0 Service Pack 2 on a development machine
    >(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
    >Fixxml.exe at Microsoft.com fixed that issue. We developed without
    >issue for the rest of the day (mostly javascript/related client side
    >code) but then the famous "Error trying to run project: Unable to
    >start debugging on the web server: Would you like to disable...."
    >cropped up.
    >
    >These are the following steps that we have taken to resolve this
    >problem, all of which were unsuccessful (Debugging worked prior to
    >SP4/.Net SP2):
    >
    >Verified web.config debug=true in the specific application
    >Verified no syntax errors in web.config
    >Verified users in Debugger Users/Administrators
    >Verified project creation was by NetBIOS name rather than IP address
    >Verified Anonymous ACcess/Integrated Windows Authentication enabled
    >Verified DEBUG keywords in configuration for .aspx, .asax, .asmx
    >
    >Virtual folders for the applications were assigned, but the
    >application name dialog boxes were blank. Assigned names to the
    >applications corresponding to the actual project names.
    >
    >Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
    >aspnet_wp.exe to be assigned to all scriptmappings.
    >
    >Ran regsvr32
    >%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll
    >
    >Ran iisreset multiple times.
    >
    >I cannot verify that vs.net remote components are installed for this
    >version of .net (.288). I also have not of course rebuilt the .net
    >framework yet, as my boss has asked me not to until I get some
    >responses to this news post.
    >
    >Can anyone advise on best way to solve this?
    >
    >
     
    loser, Aug 7, 2003
    #3
  4. loser

    loser Guest

    I have now reinstalled .net framework according to the "rebuild"
    instructions...it still doesn't work.

    I am nearing the end of my rope here.



    On Thu, 07 Aug 2003 11:43:24 -0500, loser <> wrote:

    >Hi,
    >
    >I made the unfortunate mistake of installing Windows 2000 Service Pack
    >4 and .NET Framework 1.0 Service Pack 2 on a development machine
    >(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
    >Fixxml.exe at Microsoft.com fixed that issue. We developed without
    >issue for the rest of the day (mostly javascript/related client side
    >code) but then the famous "Error trying to run project: Unable to
    >start debugging on the web server: Would you like to disable...."
    >cropped up.
    >
    >These are the following steps that we have taken to resolve this
    >problem, all of which were unsuccessful (Debugging worked prior to
    >SP4/.Net SP2):
    >
    >Verified web.config debug=true in the specific application
    >Verified no syntax errors in web.config
    >Verified users in Debugger Users/Administrators
    >Verified project creation was by NetBIOS name rather than IP address
    >Verified Anonymous ACcess/Integrated Windows Authentication enabled
    >Verified DEBUG keywords in configuration for .aspx, .asax, .asmx
    >
    >Virtual folders for the applications were assigned, but the
    >application name dialog boxes were blank. Assigned names to the
    >applications corresponding to the actual project names.
    >
    >Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
    >aspnet_wp.exe to be assigned to all scriptmappings.
    >
    >Ran regsvr32
    >%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\aspnet_isapi.dll
    >
    >Ran iisreset multiple times.
    >
    >I cannot verify that vs.net remote components are installed for this
    >version of .net (.288). I also have not of course rebuilt the .net
    >framework yet, as my boss has asked me not to until I get some
    >responses to this news post.
    >
    >Can anyone advise on best way to solve this?
    >
    >
     
    loser, Aug 7, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Annie
    Replies:
    1
    Views:
    958
    Vijay
    Aug 31, 2005
  2. logan
    Replies:
    1
    Views:
    805
    =?Utf-8?B?QWFydGhp?=
    Oct 18, 2005
  3. 1388-2/HB
    Replies:
    3
    Views:
    417
    1388-2/HB
    Feb 5, 2007
  4. loser
    Replies:
    0
    Views:
    126
    loser
    Aug 7, 2003
  5. loser
    Replies:
    0
    Views:
    120
    loser
    Aug 7, 2003
Loading...

Share This Page