Fatal Error during VS2008 SP1 Installation

Discussion in 'ASP .Net' started by Cirene, Sep 10, 2008.

  1. Cirene

    Cirene Guest

    I uninstalled VS2008 and reinstalled it. Then, when trying to install SP1 I
    got a "fatal error" at the end. Any suggestions?

    Here's the detail towards the bottom...

    [9/10/2008, 14:14:40]
    (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning
    IDOK. INSTALLMESSAGE_ERROR [Error 1719.The Windows Installer Service could
    not be accessed. This can occur if you are running Windows in safe mode, or
    if the Windows Installer is not correctly installed. Contact your support
    personnel for assistance.]
    [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) Patch
    (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    SP1\vstor30sp1-KB949258-x86.msp) install failed on product (Visual Studio
    Tools for the Office system 3.0 Runtime). Msi Log: Microsoft Visual Studio
    2008 SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    Runtime-MSP0.txt
    [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation)
    MsiApplyMultiplePatches returned 0x643

    [9/10/2008, 14:14:40] Action complete. Log File:
    C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    Runtime-MSP0.txt
    [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) exiting
    function/method

    [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) failed and
    stopped (no rollback)
    [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    PerformMsiOperation returned 0x643
    [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction) exiting
    function/method
     
    Cirene, Sep 10, 2008
    #1
    1. Advertising

  2. On Sep 10, 8:16 pm, "Cirene" <> wrote:
    > I uninstalled VS2008 and reinstalled it.  Then, when trying to install SP1 I
    > got a "fatal error" at the end.  Any suggestions?
    >
    > Here's the detail towards the bottom...
    >
    > [9/10/2008, 14:14:40]
    > (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning
    > IDOK. INSTALLMESSAGE_ERROR [Error 1719.The Windows Installer Service could
    > not be accessed. This can occur if you are running Windows in safe mode, or
    > if the Windows Installer is not correctly installed. Contact your support
    > personnel for assistance.]
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) Patch
    > (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > SP1\vstor30sp1-KB949258-x86.msp) install failed on product (Visual Studio
    > Tools for the Office system 3.0 Runtime). Msi Log: Microsoft Visual Studio
    > 2008 SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    > Runtime-MSP0.txt
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation)
    > MsiApplyMultiplePatches returned 0x643
    >
    > [9/10/2008, 14:14:40] Action complete. Log File:
    > C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    > Runtime-MSP0.txt
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) exiting
    > function/method
    >
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) failed and
    > stopped (no rollback)
    > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    > PerformMsiOperation returned 0x643
    > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction) exiting
    > function/method


    If you have Vista, you need to have Vista SP1 installed before VS 2008
    SP1.
     
    Alexey Smirnov, Sep 11, 2008
    #2
    1. Advertising

  3. Cirene

    Cirene Guest

    I have XP Media Center SP2

    Should I install XP SP3? Is it pretty compatible with VS2008, SQL
    Server2005, etc?

    "Alexey Smirnov" <> wrote in message
    news:...
    On Sep 10, 8:16 pm, "Cirene" <> wrote:
    > I uninstalled VS2008 and reinstalled it. Then, when trying to install SP1
    > I
    > got a "fatal error" at the end. Any suggestions?
    >
    > Here's the detail towards the bottom...
    >
    > [9/10/2008, 14:14:40]
    > (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning
    > IDOK. INSTALLMESSAGE_ERROR [Error 1719.The Windows Installer Service could
    > not be accessed. This can occur if you are running Windows in safe mode,
    > or
    > if the Windows Installer is not correctly installed. Contact your support
    > personnel for assistance.]
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) Patch
    > (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > SP1\vstor30sp1-KB949258-x86.msp) install failed on product (Visual Studio
    > Tools for the Office system 3.0 Runtime). Msi Log: Microsoft Visual Studio
    > 2008 SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    > Runtime-MSP0.txt
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation)
    > MsiApplyMultiplePatches returned 0x643
    >
    > [9/10/2008, 14:14:40] Action complete. Log File:
    > C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    > Runtime-MSP0.txt
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) exiting
    > function/method
    >
    > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) failed and
    > stopped (no rollback)
    > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    > PerformMsiOperation returned 0x643
    > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    > exiting
    > function/method


    If you have Vista, you need to have Vista SP1 installed before VS 2008
    SP1.
     
    Cirene, Sep 11, 2008
    #3
  4. On Sep 11, 1:23 pm, "Cirene" <> wrote:
    > I have XP Media Center SP2
    >
    > Should I install XP SP3?  Is it pretty compatible with VS2008, SQL
    > Server2005, etc?
    >
    > "Alexey Smirnov" <> wrote in message
    >
    > news:...
    > On Sep 10, 8:16 pm, "Cirene" <> wrote:
    >
    >
    >
    > > I uninstalled VS2008 and reinstalled it. Then, when trying to install SP1
    > > I
    > > got a "fatal error" at the end. Any suggestions?

    >
    > > Here's the detail towards the bottom...

    >
    > > [9/10/2008, 14:14:40]
    > > (IronSpigot::MsiExternalUiHandler::InstallMessageErrorHandler) Returning
    > > IDOK. INSTALLMESSAGE_ERROR [Error 1719.The Windows Installer Service could
    > > not be accessed. This can occur if you are running Windows in safe mode,
    > > or
    > > if the Windows Installer is not correctly installed. Contact your support
    > > personnel for assistance.]
    > > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) Patch
    > > (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > > SP1\vstor30sp1-KB949258-x86.msp) install failed on product (Visual Studio
    > > Tools for the Office system 3.0 Runtime). Msi Log: Microsoft Visual Studio
    > > 2008 SP1_20080910_140151098-Visual Studio Tools for the Office system 3..0
    > > Runtime-MSP0.txt
    > > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation)
    > > MsiApplyMultiplePatches returned 0x643

    >
    > > [9/10/2008, 14:14:40] Action complete. Log File:
    > > C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\Microsoft Visual Studio 2008
    > > SP1_20080910_140151098-Visual Studio Tools for the Office system 3.0
    > > Runtime-MSP0.txt
    > > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) exiting
    > > function/method

    >
    > > [9/10/2008, 14:14:40] (IronSpigot::MspInstallerT<class
    > > ATL::CStringT<unsigned short,class ATL::StrTraitATL<unsigned short,class
    > > ATL::ChTraitsCRT<unsigned short> > > >::performMsiOperation) failed and
    > > stopped (no rollback)
    > > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    > > PerformMsiOperation returned 0x643
    > > [9/10/2008, 14:14:40] (IronSpigot::BaseMspInstaller::performAction)
    > > exiting
    > > function/method

    >
    > If you have Vista, you need to have Vista SP1 installed before VS 2008
    > SP1.


    As far as I can see there is nothing written on microsoft.com
    regarding XP edition and its service pack. Take a look at the
    Readme.txt

    http://download.microsoft.com/downl...61-4B66-9B31-9205C3F22252/VS2008SP1Readme.htm

    There are few requirements you might need to check

    Uninstalling a patch may downgrade files in other Visual Studio
    products
    Each language version of Visual Studio requires the matching language
    version of the service pack
    Visual Studio 2008 SP1 installation fails when .NET Framework 2.0 SP2
    is unable to upgrade .NET Framework 2.0 or .NET Framework 2.0 SP1
    etc.
     
    Alexey Smirnov, Sep 11, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. fpgaengineer
    Replies:
    7
    Views:
    3,780
    Mike Treseler
    Mar 12, 2007
  2. Cirene

    VS2008 SP1

    Cirene, May 27, 2008, in forum: ASP .Net
    Replies:
    8
    Views:
    665
    Cirene
    May 27, 2008
  3. jlea
    Replies:
    1
    Views:
    340
    llevi
    Jun 25, 2008
  4. Cirene

    Nice FATAL ERROR for VS.NET SP1

    Cirene, Aug 12, 2008, in forum: ASP .Net
    Replies:
    0
    Views:
    356
    Cirene
    Aug 12, 2008
  5. Cirene
    Replies:
    2
    Views:
    2,159
    Cirene
    Sep 12, 2008
Loading...

Share This Page