Fatal Python error: Interpreter not initialized (version mismatch?) - Solution

Discussion in 'Python' started by Chris Matuszewski, Aug 24, 2003.

  1. Potential Solution!

    I had this problem when I built an extension module using a debug
    version of python.lib. The problem occured when attempting to import
    the extended module with the release version of the python executable.

    This solution will probably work vice versa.

    So if you link to pythonxx_d.lib, then use python_d.exe (on windows)
    If you link using pythonxx.lib, then use python.exe
     
    Chris Matuszewski, Aug 24, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ryan Jud Hughes
    Replies:
    1
    Views:
    438
    Fredrik Lundh
    Jan 17, 2005
  2. Replies:
    0
    Views:
    416
  3. Replies:
    3
    Views:
    762
    Ziga Seilnacht
    Jan 3, 2007
  4. V Green
    Replies:
    0
    Views:
    859
    V Green
    Feb 5, 2008
  5. PA Bear [MS MVP]
    Replies:
    0
    Views:
    969
    PA Bear [MS MVP]
    Feb 5, 2008
Loading...

Share This Page