fetchmail - daemon intervals

Discussion in 'HTML' started by Andreas Paasch, Feb 17, 2004.

  1. I am used to run fetchmail as follows:

    fetchmail -d 60

    which will poll my emails from around every minute ...

    Now that used to work fine.

    Then I figured that I wanted fetchmail to start automatically upon some
    reboot, and added it.

    Now I do have:

    [andreas@domain andreas]$ ps aux | grep fetchmail
    root 2051 0.0 0.1 3320 944 ? S 00:19 0:00 fetchmail -d
    180 -f /etc/fetchmailrc
    andreas 5357 0.0 0.2 3560 1372 ? S 02:30 0:00 fetchmail -d
    60
    andreas 10948 0.0 0.1 1828 624 pts/4 S 13:39 0:00 grep
    fetchmail

    which is weird for the root process polling every 180 seconds
    as:

    /etc/fetchmailrc has this one:

    "
    set daemon 60

    poll [IP] with proto APOP interval 60"

    So it should run every 60 seconds, according to my wishes.

    I have no idea where the 180 seconds come from ... any hint would be nice as
    the settings tell me it should state 60.

    /Andreas
    --
    Registeret Linux user #292411
     
    Andreas Paasch, Feb 17, 2004
    #1
    1. Advertising

  2. Andreas Paasch wrote:


    Sorry !

    system screwed up, hit the wrong NG.

    /Andreas


    >
    > I am used to run fetchmail as follows:
    >
    > fetchmail -d 60
    >
    > which will poll my emails from around every minute ...
    >
    > Now that used to work fine.
    >
    > Then I figured that I wanted fetchmail to start automatically upon some
    > reboot, and added it.
    >
    > Now I do have:
    >
    > [andreas@domain andreas]$ ps aux | grep fetchmail
    > root 2051 0.0 0.1 3320 944 ? S 00:19 0:00 fetchmail
    > -d
    > 180 -f
    >

    /etc/fetchmailrc
    > andreas 5357 0.0 0.2 3560 1372 ? S 02:30 0:00 fetchmail
    > -d
    > 60
    > andreas 10948 0.0 0.1 1828 624 pts/4 S 13:39 0:00 grep
    > fetchmail
    >
    > which is weird for the root process polling every 180 seconds
    > as:
    >
    > /etc/fetchmailrc has this one:
    >
    > "
    > set daemon 60
    >
    > poll [IP] with proto APOP interval 60"
    >
    > So it should run every 60 seconds, according to my wishes.
    >
    > I have no idea where the 180 seconds come from ... any hint would be nice
    > as the settings tell me it should state 60.
    >
    > /Andreas


    --
    Registeret Linux user #292411
     
    Andreas Paasch, Feb 17, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David Stockwell
    Replies:
    1
    Views:
    534
    Grant Edwards
    May 28, 2004
  2. Jean-Paul Calderone
    Replies:
    0
    Views:
    457
    Jean-Paul Calderone
    Mar 20, 2009
  3. Floris Bruynooghe
    Replies:
    1
    Views:
    454
    Floris Bruynooghe
    Mar 24, 2009
  4. Payton Swick

    Daemonize like fetchmail

    Payton Swick, Jan 5, 2006, in forum: Ruby
    Replies:
    7
    Views:
    116
    tony summerfelt
    Jan 11, 2006
  5. Daemon Win32::Daemon;

    , Sep 7, 2006, in forum: Perl Misc
    Replies:
    0
    Views:
    255
Loading...

Share This Page