first click wont fire on dynamic load of usercontrol

Discussion in 'ASP .Net' started by roni, Aug 6, 2005.

  1. roni

    roni Guest

    hi.
    what im doing is replacing user control in dyanamic way,with
    page.loadcontrol.
    after i replace , when i click on the first time on button, there is no
    respond.
    only the second click get respond.

    i guess it's somthing with the dynamic loading and the "connection" between
    the button and his handler.

    is there a way to fix this ?
     
    roni, Aug 6, 2005
    #1
    1. Advertising

  2. roni

    Brock Allen Guest

    You'll need to show some code (the minimal amount of code), since it's hard
    to tell what's going on from the short description you've given.

    -Brock
    DevelopMentor
    http://staff.develop.com/ballen



    > hi.
    > what im doing is replacing user control in dyanamic way,with
    > page.loadcontrol.
    > after i replace , when i click on the first time on button, there is
    > no
    > respond.
    > only the second click get respond.
    > i guess it's somthing with the dynamic loading and the "connection"
    > between the button and his handler.
    >
    > is there a way to fix this ?
    >
     
    Brock Allen, Aug 7, 2005
    #2
    1. Advertising

  3. roni

    roni Guest

    found the answer.

    the solution is to set Id to the control.id of the dynamic loaded control.

    "Brock Allen" <> wrote in message
    news:...
    > You'll need to show some code (the minimal amount of code), since it's

    hard
    > to tell what's going on from the short description you've given.
    >
    > -Brock
    > DevelopMentor
    > http://staff.develop.com/ballen
    >
    >
    >
    > > hi.
    > > what im doing is replacing user control in dyanamic way,with
    > > page.loadcontrol.
    > > after i replace , when i click on the first time on button, there is
    > > no
    > > respond.
    > > only the second click get respond.
    > > i guess it's somthing with the dynamic loading and the "connection"
    > > between the button and his handler.
    > >
    > > is there a way to fix this ?
    > >

    >
    >
    >
     
    roni, Aug 7, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark Sisson

    UserControl click event won't fire

    Mark Sisson, Dec 2, 2003, in forum: ASP .Net Building Controls
    Replies:
    1
    Views:
    142
    Thijs
    Dec 2, 2003
  2. roni

    first click wont fire on dynamic load of usercontro

    roni, Aug 6, 2005, in forum: ASP .Net Building Controls
    Replies:
    0
    Views:
    135
  3. Jean-Pierre Fouche

    Dynamic Datagrid with TextBoxes Textchanged events wont fire

    Jean-Pierre Fouche, Jul 28, 2003, in forum: ASP .Net Datagrid Control
    Replies:
    1
    Views:
    207
    Cristian Suazo
    Jul 29, 2003
  4. Jim Weatherly

    Click event wont fire...

    Jim Weatherly, Aug 7, 2003, in forum: ASP .Net Web Controls
    Replies:
    0
    Views:
    121
    Jim Weatherly
    Aug 7, 2003
  5. Mark Sisson

    UserControl click event won't fire

    Mark Sisson, Dec 2, 2003, in forum: ASP .Net Web Controls
    Replies:
    2
    Views:
    400
    Chris Thayer
    Dec 10, 2003
Loading...

Share This Page