float problem, on of two boxes is being pushed down when openingfavoritesIE/or left bar in Opera

Discussion in 'HTML' started by shajnday, Oct 14, 2011.

  1. shajnday

    shajnday Guest

    Hi ALL!

    After finishing the "webpage" i had to make an overlook for the errors
    and for the things i had missed to check.

    I have found only this boring error which is showing in IE
    8.0.6001.18702 and opera 11.51,

    The error shows only when i have two boxes/DIVS one after another and
    both floated to left side, i.e. one besides another.

    So everyting is allright, but once i open Opera left toolbar or opera
    favorite links, or favorites(full column) in IE, the error shows up,
    the second DIV(box) goes under the webpage, you can try it out here:
    http://jai.comule.com/zahvati.html (i admit i must enter
    some fresh images and anew ones)...


    seems like there are several options to fix this problem, it goes to
    WIDTH tag and / or positioning approach, and perhaps some other third*
    options which i would rather like to hear for!!!

    The absolute positioning through the position. property is now too
    unstable to use , i think so.


    Here is what i had successfully fixed over the WIDTH tag:


    #contentZahvati1 { padding-top: 15px; float: left; margin-bottom:
    30px; padding-bottom: 20px; width: 550px; }

    #pasusZahvati1 {
    padding-left: 230px;
    font-family: arial;
    font-size: 12px;
    color: #454545;
    }

    #contentZahvati2 { padding-top: 15px; float: left; margin-bottom:
    20px; width: 400px; padding-left: 50px; }

    #pasusZahvati2 {
    padding-left: 50px;
    margin-top: 30px;
    color: #454545;
    font-family: arial;
    font-size: 12px;
    }

    You see, firstly the WIDTH tag wasn't defind not on the DIV tags not
    in the stylesheets...then i added for testing purposes...and it did
    had had effects.

    and here is the actual page: http://jai.comule.com/zahvati.html

    so i have added width for both divs(boxes), and now the main <div
    width="1100px"> is a wrapper over this two <divs> which are written
    about and it actually s working for opera but on easyphp server it's
    still pushed bellow ...but on the net it is showing good !?!?

    i just don't understand, where the catch is...


    does anybody has a tip for that ?



    much thanks,
    c.
     
    shajnday, Oct 14, 2011
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matt
    Replies:
    0
    Views:
    3,833
  2. tshad

    Button not being pushed on Enter

    tshad, Aug 11, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    457
    Steve C. Orr [MVP, MCSD]
    Aug 12, 2005
  3. Chris
    Replies:
    5
    Views:
    1,119
    Chris
    Feb 21, 2007
  4. Arachnid
    Replies:
    0
    Views:
    885
    Arachnid
    Oct 5, 2007
  5. cwdjrxyz
    Replies:
    0
    Views:
    427
    cwdjrxyz
    Apr 28, 2009
  6. Carsten Fuchs
    Replies:
    45
    Views:
    2,294
    James Kanze
    Oct 8, 2009
  7. shajnday
    Replies:
    0
    Views:
    472
    shajnday
    Oct 14, 2011
  8. shajnday
    Replies:
    23
    Views:
    1,222
    shajnday
    Oct 20, 2011
Loading...