Forbidden Message, when accessing .pl files from Java Webserver

Discussion in 'Perl' started by Murari, Apr 1, 2004.

  1. Murari

    Murari Guest

    Hi Experts,

    This is the form I am using:

    <form name="getsomething" method="GET"
    action="http://myip:8080/cgi-bin/do.pl" TARGET="">

    <INPUT type="button" name="SUBMIT" value="CLICK ME"
    onClick="doStuff();"
    <INPUT type="hidden" name="someinfo" value="test">


    </form>

    When I run it I get : 403 Forbidden

    When I change action="http://myip/somedir/cgi-bin/do.pl" then page
    cannot be dispalyed.

    I am really tired of this. Please help me to resolve the issue.
    mailme your suggestions at :
    Murari, Apr 1, 2004
    #1
    1. Advertising

  2. Murari wrote:
    > This is the form I am using:
    >
    > <form name="getsomething" method="GET"
    > action="http://myip:8080/cgi-bin/do.pl" TARGET="">
    > <INPUT type="button" name="SUBMIT" value="CLICK ME"
    > onClick="doStuff();"
    > <INPUT type="hidden" name="someinfo" value="test">
    > </form>


    I can't help it but hat doesn't look like Perl code to me....

    > When I run it I get : 403 Forbidden
    > When I change action="http://myip/somedir/cgi-bin/do.pl" then page
    > cannot be dispalyed.


    You may want to ask in NG that actually deals with CGI or JavaScript or
    DHTML or whatever the code above is.

    jue
    Jürgen Exner, Apr 2, 2004
    #2
    1. Advertising

  3. Murari

    Kodeguru Guest

    Murari wrote:

    > Hi Experts,
    >
    > This is the form I am using:
    >
    > <form name="getsomething" method="GET"
    > action="http://myip:8080/cgi-bin/do.pl" TARGET="">
    >
    > <INPUT type="button" name="SUBMIT" value="CLICK ME"
    > onClick="doStuff();"
    > <INPUT type="hidden" name="someinfo" value="test">


    1) Check that the script is executable

    and 2) you should probably ask this in the webserver ng.


    --
    Michael O'Malley Jr.
    President
    Pillar Open Source Technologies, LLC.
    Kodeguru, Apr 2, 2004
    #3
  4. Murari

    GIMME Guest

    1. Confirm that you can run perl cgi on your server - out
    of the box perl cgis are often disabled.

    Then try

    2. changing GET to POST
    3. changing type="button" name="SUBMIT" to type=submit value="Click Me"

    PS. If you're tired of it. Do something else. No one cares if you tired
    or not.


    (Murari) wrote in message news:<>...
    > Hi Experts,
    >
    > This is the form I am using:
    >
    > <form name="getsomething" method="GET"
    > action="http://myip:8080/cgi-bin/do.pl" TARGET="">
    >
    > <INPUT type="button" name="SUBMIT" value="CLICK ME"
    > onClick="doStuff();"
    > <INPUT type="hidden" name="someinfo" value="test">
    >
    >
    > </form>
    >
    > When I run it I get : 403 Forbidden
    >
    > When I change action="http://myip/somedir/cgi-bin/do.pl" then page
    > cannot be dispalyed.
    >
    > I am really tired of this. Please help me to resolve the issue.
    > mailme your suggestions at :
    GIMME, Apr 6, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David Hunt
    Replies:
    4
    Views:
    11,283
    gullsinn
    Oct 4, 2009
  2. computerserver
    Replies:
    0
    Views:
    1,099
    computerserver
    Aug 31, 2007
  3. jthg
    Replies:
    0
    Views:
    417
  4. John Nagle
    Replies:
    1
    Views:
    311
    Martin v. Löwis
    Jun 2, 2008
  5. Mark J. McGinty

    IIS HTTP 403.1 Forbidden: Execute Access Forbidden

    Mark J. McGinty, Dec 9, 2005, in forum: ASP General
    Replies:
    2
    Views:
    342
    Kyle Peterson
    Dec 9, 2005
Loading...

Share This Page