Forms Auth and none aspx pages

Discussion in 'ASP .Net Security' started by Michael Tissington, Oct 9, 2003.

  1. I have forms authentication working for any aspx page (I'm doing this on
    both a folder level and also individual files).

    The problem I have is if the file is an exe or html then forms auth seems to
    be ignored.

    How do I get Forms auth to work for other file type too ?

    Thanks

    --
    -
    Michael Tissington
    http://www.oaklodge.com
     
    Michael Tissington, Oct 9, 2003
    #1
    1. Advertising

  2. Michael Tissington

    Lauchlan M Guest

    > I have forms authentication working for any aspx page (I'm doing this on
    > both a folder level and also individual files).
    >
    > The problem I have is if the file is an exe or html then forms auth seems

    to
    > be ignored.
    >
    > How do I get Forms auth to work for other file type too ?


    By default this is only configured for aspx files. To get it to apply to
    other files, you need to go into IIS and set up mappings for file types you
    need to secure. I don't recall the details offhand. If you have trouble
    doing it, post back here and I'll try and check again in the future and look
    up the details for you.

    HTH

    Lauchlan M
     
    Lauchlan M, Oct 9, 2003
    #2
    1. Advertising

  3. Lauchlan ,

    I've looked into various settings on IIS but can't find how to do this.

    Any pointers please?

    --
    Michael Tissington
    http://www.oaklodge.com


    "Lauchlan M" <> wrote in message
    news:eX7o%...
    > > I have forms authentication working for any aspx page (I'm doing this on
    > > both a folder level and also individual files).
    > >
    > > The problem I have is if the file is an exe or html then forms auth

    seems
    > to
    > > be ignored.
    > >
    > > How do I get Forms auth to work for other file type too ?

    >
    > By default this is only configured for aspx files. To get it to apply to
    > other files, you need to go into IIS and set up mappings for file types

    you
    > need to secure. I don't recall the details offhand. If you have trouble
    > doing it, post back here and I'll try and check again in the future and

    look
    > up the details for you.
    >
    > HTH
    >
    > Lauchlan M
    >
    >
     
    Michael Tissington, Oct 9, 2003
    #3
  4. Michael Tissington

    Lauchlan M Guest

    > Lauchlan ,
    >
    > I've looked into various settings on IIS but can't find how to do this.
    >
    > Any pointers please?


    Go into Internet Services Manager | Default Website and right-click
    'properties' on <YourWebApplication>

    Go to the 'Directory' tab. Click the 'Configuration' button. Add the kinds
    of resources you need to 'Application mappings'.

    HTH

    Lauchlan M
     
    Lauchlan M, Oct 9, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?Q2hyaXMgTW9oYW4=?=

    Configuring Windows Auth & Forms Auth in Asp.Net

    =?Utf-8?B?Q2hyaXMgTW9oYW4=?=, Apr 28, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    763
    =?Utf-8?B?Q2hyaXMgTW9oYW4=?=
    Apr 28, 2004
  2. length power
    Replies:
    2
    Views:
    115
    Rustom Mody
    Apr 10, 2014
  3. Skip Montanaro
    Replies:
    0
    Views:
    80
    Skip Montanaro
    Apr 10, 2014
  4. Johannes Schneider

    Re: why i have the output of [None, None, None]

    Johannes Schneider, Apr 10, 2014, in forum: Python
    Replies:
    0
    Views:
    71
    Johannes Schneider
    Apr 10, 2014
  5. Terry Reedy
    Replies:
    0
    Views:
    83
    Terry Reedy
    Apr 10, 2014
Loading...

Share This Page