Forms Authentication accross applications Not working in Firefox?

Discussion in 'ASP .Net' started by o0JoeCool0o, Nov 22, 2006.

  1. o0JoeCool0o

    o0JoeCool0o Guest

    Has anyone else tried this?

    I have been messing with this for a week and cant figure it out, for
    some reason firefox will not read an authentication cookie unless it
    was set by the applciation that your trying to load.

    Where as IE will read the authentication cookie if it has the same name
    (as specified in web.config) regardless of which application your in.

    I am using the same machienkey decryptkey in both applications and
    trying to just have one login page for both applciations. It works
    perfectly in IE but in firefox you have to login again to view anything
    from the second project. and you have to use the .setAuthCookie in the
    second applciation.
     
    o0JoeCool0o, Nov 22, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. cmay
    Replies:
    2
    Views:
    528
    john_teague
    Dec 7, 2005
  2. o0JoeCool0o
    Replies:
    1
    Views:
    517
    o0JoeCool0o
    Nov 22, 2006
  3. o0JoeCool0o
    Replies:
    2
    Views:
    483
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=
    Nov 23, 2006
  4. Fred
    Replies:
    1
    Views:
    322
  5. Eric
    Replies:
    2
    Views:
    578
Loading...

Share This Page