fotre8 gives undefined symbols while forte7 doesn't

Discussion in 'C++' started by pervinder, Aug 30, 2004.

  1. pervinder

    pervinder Guest

    Hi,
    I have an application which uses math/matrix solving lib like blas,
    lapack. When i build the binary using forte7 , it passes. But when i
    change the compiler to forte8, i get 2 undefined symbol errors :

    Undefined first referenced
    symbol in file
    zgetrf_
    .../../output/SunOS_32/lib/forte8/opt/libsmx.a(smxlapack.o)
    zgetrs_
    .../../output/SunOS_32/lib/forte8/opt/libsmx.a(smxlapack.o)

    Any clue as what could be the reason ? Any options i need to provide
    to
    the linker or the library which contains these functions?

    Regards, ~Pervinder
     
    pervinder, Aug 30, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Stu
    Replies:
    1
    Views:
    1,327
  2. r
    Replies:
    2
    Views:
    734
    Rob Williscroft
    Aug 2, 2003
  3. Thierry Dussuet
    Replies:
    2
    Views:
    409
    Thierry Dussuet
    May 11, 2005
  4. Christoph Kukulies

    yacc under cygwin - undefined symbols

    Christoph Kukulies, Jun 25, 2006, in forum: C Programming
    Replies:
    2
    Views:
    511
    Keith Thompson
    Jun 25, 2006
  5. Replies:
    0
    Views:
    261
Loading...

Share This Page