Framework 1.0 ad 1.1 running side by side configuration problems?

Discussion in 'ASP .Net' started by Juan Posadas, Aug 21, 2003.

  1. Juan Posadas

    Juan Posadas Guest

    All,
    I deployed my website that requires V1.1 in the
    production server. I installed the framework v1.1 with
    the dotnetfx.exe /c:"install /noaspupgrade" and
    everything went fine.

    Then, I installed my app via and installation pkg.
    without a proble,
    Then, I ran the following command to tell IIS to run my
    app with V1.1
    aspnet_regiis.exe w3svc\1\1root\Myapp
    which did the job.

    However, when I try to run it it gives me a blank page:
    Page caanot be displayed
    .....
    ....
    TTP Error 500.

    Q1. How can I make visible the actual error rather than
    the default error page?
    Q2. Should be 2 separate ASP.Net processes running for
    the 2 diiferent versions: aspnet_wp.exe?
    Q3. Do I need to configure something on the IIS?

    I remembered that when I installed V1.0 long time ago, I
    had to start the aspnet_wp.exe manually for the fist
    time.

    PS: I deployed the same app in two other testing-servers
    and they worked fine. However, they only had V1.1
    installed.
     
    Juan Posadas, Aug 21, 2003
    #1
    1. Advertising

  2. Hi Juan,

    I have reviewed your issue. Due to the nature of your issue I need to do
    additional research to determine the best way to provide assistance.

    Best regards,

    Jacob Yang
    Microsoft Online Partner Support
    <MCSD>
    Get Secure! ¨C www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
     
    Jacob Yang [MSFT], Aug 23, 2003
    #2
    1. Advertising

  3. Juan Posadas

    Juan Posadas Guest

    Jacob,
    Thank you for your effort. Actually, the problem is
    that I'm running both framework versions side by side in
    the same server. When I installed the V1.1 I did it
    as "noaspupgrade" not to affect any website on the
    server. In order to make my website use the new release I
    had to run the aspnet_regiis.exe w3svc\1\1root\Myapp from
    the new release directory. Thus, when I see the
    properties for this website it DOES reflect the change;
    however, when I run it (Login.aspx) It does not egt
    serviced (Page cannot be displayed. Error on the server)

    Thank you for your help in advance.


    JP


    >-----Original Message-----
    >Hi Juan,
    >
    >Based on my research and experience, I want to share the

    following
    >information with you:
    >
    >1. To see the more information about the error message,

    please try to
    >configure the Internet Explorer script debugging

    options. To do this,
    >follow these steps:
    >
    >1) Open Internet Explorer.
    >2) On the "Tools" menu, click "Internet Options".
    >3) In the "Internet Options" dialog box,

    click "Advanced".
    >4) Click to clear the "Disable script debugging " check

    box.
    >5) Click to select the "Display a notification about

    every script error"
    >check box.
    >6) Click "OK".
    >
    >2. To check and configure which .NET Framework is used

    in IIS, please
    >perform the following steps:
    >
    >1) Open "Internet Information Services".
    >2) Right click the folder of your web application and

    select "Properties".
    >3) In the Directory tab, click the "Configuration¡­"

    button.
    >4) Select the ".aspx" extension and double click it.
    >5) In the field of "Executable", you will find which

    version
    >aspnet_isapi.dll is used.
    >6) If you want to change it, please click the "Browse¡­"

    button.
    >
    >Does it answer your question? If I have misunderstood

    your concern, please
    >let me know.
    >
    >Best regards,
    >
    >Jacob Yang
    >Microsoft Online Partner Support
    ><MCSD>
    >Get Secure! ¨C www.microsoft.com/security
    >This posting is provided "as is" with no warranties and

    confers no rights.
    >
    >.
    >
     
    Juan Posadas, Aug 25, 2003
    #3
  4. Juan Posadas

    Natty Gur Guest

    Hi,

    check if isapifilter of the site/computer is set to the 1.1 framework.

    Natty Gur, CTO
    Dao2Com Ltd.
    34th Elkalay st. Raanana
    Israel , 43000
    Phone Numbers:
    Office: +972-(0)9-7740261
    Fax: +972-(0)9-7740261
    Mobile: +972-(0)58-888377


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Natty Gur, Aug 25, 2003
    #4
  5. HI Juan,

    Please perform the following steps on your side and tell me if you see any
    new error message:

    1) Open Internet Explorer.
    2) On the "Tools" menu, click "Internet Options".
    3) In the "Internet Options" dialog box, click "Advanced".
    4) Click to clear the "Show friendly HTTP error messages " check box.
    5) Click "Apply" and "OK".
    6) Test your web application again

    Best regrds,

    Jacob Yang
    Microsoft Online Partner Support
    <MCSD>
    Get Secure! ¨C www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
     
    Jacob Yang [MSFT], Aug 26, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Namratha Shah \(Nasha\)

    Article : .NET Framework Configuration Tool (Mscorcfg.msc)

    Namratha Shah \(Nasha\), Nov 24, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    3,233
    Namratha Shah \(Nasha\)
    Nov 24, 2004
  2. Ivan
    Replies:
    1
    Views:
    3,094
    Natty Gur
    May 21, 2004
  3. =?Utf-8?B?UkhQXzc0?=
    Replies:
    1
    Views:
    434
    Juan T. Llibre
    Feb 10, 2006
  4. Mark
    Replies:
    0
    Views:
    861
  5. Rachel
    Replies:
    1
    Views:
    952
    Rachel
    Dec 10, 2007
Loading...

Share This Page