fxruby doesn't work

Discussion in 'Ruby' started by Dirk Meijer, Oct 31, 2005.

  1. Dirk Meijer

    Dirk Meijer Guest

    ------=_Part_17970_8922945.1130793079055
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    hi everyone,
    just a few months ago, i was able to run programs that use fxruby, since
    recently, it has not been working, but i'm not as much into ruby that i'd
    write a fxruby program.. however, i would like to get it back to work.
    i use windows xp, sp2, on-click installer 1.8.2-15
    and i get the following error:
    d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
    activate fxruby (=3D 1.2.6), already activated fxruby-1.4.2-mswin32]
    (Gem::Exception)
    from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
    `require'
    from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
    from D:/ruby/bin/fxri:18:in `load'
    from D:/ruby/bin/fxri:18
    does anyone know how to fix this problem?
    greetings, Dirk.

    ------=_Part_17970_8922945.1130793079055--
     
    Dirk Meijer, Oct 31, 2005
    #1
    1. Advertising

  2. Dirk Meijer

    Lyle Johnson Guest

    On 10/31/05, Dirk Meijer <> wrote:

    > just a few months ago, i was able to run programs that use fxruby, since
    > recently, it has not been working, but i'm not as much into ruby that i'd
    > write a fxruby program.. however, i would like to get it back to work.
    > i use windows xp, sp2, on-click installer 1.8.2-15
    > and i get the following error:
    > d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
    > activate fxruby (=3D 1.2.6), already activated fxruby-1.4.2-mswin32]
    > (Gem::Exception)
    > from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
    > `require'
    > from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
    > from D:/ruby/bin/fxri:18:in `load'
    > from D:/ruby/bin/fxri:18
    > does anyone know how to fix this problem?


    Just a note to try to pin down the source of the problem: It's not a
    problem with FXRuby. It *appears* to be a problem with what "fxri" (an
    application that happens to use FXRuby) is trying to do to when it
    tries to "require" the FXRuby gem.
     
    Lyle Johnson, Oct 31, 2005
    #2
    1. Advertising

  3. Dirk Meijer

    Curt Hibbs Guest

    In version 182-15 of the One-Click Installer there is a problem
    running FXRuby programs using rubyw.exe, but they run correctly with
    ruby.exe.

    I believe this problem does not exist in 182-14, which has the same
    version of, just different versions of the pre-installed extensions.

    I will make sure that this is resolved by the time we release the
    installer for 1.8.4 (hopefully around the end of this year).

    Curt

    On 10/31/05, Dirk Meijer <> wrote:
    > hi everyone,
    > just a few months ago, i was able to run programs that use fxruby, since
    > recently, it has not been working, but i'm not as much into ruby that i'd
    > write a fxruby program.. however, i would like to get it back to work.
    > i use windows xp, sp2, on-click installer 1.8.2-15
    > and i get the following error:
    > d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
    > activate fxruby (=3D 1.2.6), already activated fxruby-1.4.2-mswin32]
    > (Gem::Exception)
    > from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
    > `require'
    > from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
    > from D:/ruby/bin/fxri:18:in `load'
    > from D:/ruby/bin/fxri:18
    > does anyone know how to fix this problem?
    > greetings, Dirk.
    >
    >
     
    Curt Hibbs, Oct 31, 2005
    #3
  4. Dirk Meijer

    Dirk Meijer Guest

    ------=_Part_23134_33173360.1130838249883
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    this doesn't solve the problem, running it with ruby.exe instead of
    rubyw.exe gives me exactly the same..
    anyone else have any solutions?
    greetings, Dirk.

    2005/10/31, Curt Hibbs <>:
    >
    > In version 182-15 of the One-Click Installer there is a problem
    > running FXRuby programs using rubyw.exe, but they run correctly with
    > ruby.exe.
    >
    > I believe this problem does not exist in 182-14, which has the same
    > version of, just different versions of the pre-installed extensions.
    >
    > I will make sure that this is resolved by the time we release the
    > installer for 1.8.4 (hopefully around the end of this year).
    >
    > Curt
    >
    > On 10/31/05, Dirk Meijer <> wrote:
    > > hi everyone,
    > > just a few months ago, i was able to run programs that use fxruby, sinc=

    e
    > > recently, it has not been working, but i'm not as much into ruby that

    > i'd
    > > write a fxruby program.. however, i would like to get it back to work.
    > > i use windows xp, sp2, on-click installer 1.8.2-15
    > > and i get the following error:
    > > d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
    > > activate fxruby (=3D 1.2.6), already activated fxruby-1.4.2-mswin32]
    > > (Gem::Exception)
    > > from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
    > > `require'
    > > from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
    > > from D:/ruby/bin/fxri:18:in `load'
    > > from D:/ruby/bin/fxri:18
    > > does anyone know how to fix this problem?
    > > greetings, Dirk.
    > >
    > >

    >
    >


    ------=_Part_23134_33173360.1130838249883--
     
    Dirk Meijer, Nov 1, 2005
    #4
  5. Dirk Meijer

    Curt Hibbs Guest

    On 11/1/05, Dirk Meijer <> wrote:
    > this doesn't solve the problem, running it with ruby.exe instead of
    > rubyw.exe gives me exactly the same..
    > anyone else have any solutions?
    > greetings, Dirk.


    You must be running in to a different problem, then.

    Curt

    > 2005/10/31, Curt Hibbs <>:
    > >
    > > In version 182-15 of the One-Click Installer there is a problem
    > > running FXRuby programs using rubyw.exe, but they run correctly with
    > > ruby.exe.
    > >
    > > I believe this problem does not exist in 182-14, which has the same
    > > version of, just different versions of the pre-installed extensions.
    > >
    > > I will make sure that this is resolved by the time we release the
    > > installer for 1.8.4 (hopefully around the end of this year).
    > >
    > > Curt
    > >
    > > On 10/31/05, Dirk Meijer <> wrote:
    > > > hi everyone,
    > > > just a few months ago, i was able to run programs that use fxruby, si=

    nce
    > > > recently, it has not been working, but i'm not as much into ruby that

    > > i'd
    > > > write a fxruby program.. however, i would like to get it back to work=
     
    Curt Hibbs, Nov 1, 2005
    #5
  6. Dirk Meijer

    Holger Arndt Guest

    Hello,

    I had the same problem after "gem update ; gem clean". I had to remove
    fxruby 1.4-x and reinstall fxruby 1.2-6. Having both versions at the
    same time didn't work for me.

    Regards,
    Holger
     
    Holger Arndt, Nov 1, 2005
    #6
  7. Dirk Meijer

    Curt Hibbs Guest

    Hmmm... I suppose this could have been my problem when I built 182-15
    of the One-Click Installer. I'll have to check this out.

    Curt

    On 11/1/05, Holger Arndt <> wrote:
    > Hello,
    >
    > I had the same problem after "gem update ; gem clean". I had to remove
    > fxruby 1.4-x and reinstall fxruby 1.2-6. Having both versions at the
    > same time didn't work for me.
    >
    > Regards,
    > Holger
    >
    >
     
    Curt Hibbs, Nov 1, 2005
    #7
  8. Dirk Meijer

    soxinbox Guest

    Is this caused by a require of a method that exists in 1.2-6 that no longer
    exists in 1.4-x?
    If anyone is brave enough to tackle this problem, than I will be glad to
    assist by testing on a system that generates this error with consistency.

    "Curt Hibbs" <> wrote in message
    news:...
    Hmmm... I suppose this could have been my problem when I built 182-15
    of the One-Click Installer. I'll have to check this out.

    Curt

    On 11/1/05, Holger Arndt <> wrote:
    > Hello,
    >
    > I had the same problem after "gem update ; gem clean". I had to remove
    > fxruby 1.4-x and reinstall fxruby 1.2-6. Having both versions at the
    > same time didn't work for me.
    >
    > Regards,
    > Holger
    >
    >
     
    soxinbox, Nov 9, 2005
    #8
  9. Dirk Meijer

    Curt Hibbs Guest

    Looks like I didn't read the original message closely enough. The
    problem I encountered was strictly with 1.2.6 and did not involve
    1.4.x. Sorry for the confusion.

    Curt

    On 11/8/05, soxinbox <> wrote:
    > Is this caused by a require of a method that exists in 1.2-6 that no long=

    er
    > exists in 1.4-x?
    > If anyone is brave enough to tackle this problem, than I will be glad to
    > assist by testing on a system that generates this error with consistency.
    >
    > "Curt Hibbs" <> wrote in message
    > news:...
    > Hmmm... I suppose this could have been my problem when I built 182-15
    > of the One-Click Installer. I'll have to check this out.
    >
    > Curt
    >
    > On 11/1/05, Holger Arndt <> wrote:
    > > Hello,
    > >
    > > I had the same problem after "gem update ; gem clean". I had to remove
    > > fxruby 1.4-x and reinstall fxruby 1.2-6. Having both versions at the
    > > same time didn't work for me.
    > >
    > > Regards,
    > > Holger
    > >
    > >

    >
    >
    >
    >
    >
     
    Curt Hibbs, Nov 9, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MZ
    Replies:
    7
    Views:
    830
    Ed Mullen
    Mar 17, 2008
  2. Tilman
    Replies:
    0
    Views:
    414
    Tilman
    Mar 19, 2008
  3. Abe Vionas_MailingList
    Replies:
    4
    Views:
    138
    Kevin Pratt
    Oct 5, 2004
  4. Guillaume Marcais

    FXRuby 1.4 doesn't compile on Mandrake Linux

    Guillaume Marcais, Nov 29, 2005, in forum: Ruby
    Replies:
    1
    Views:
    96
    Lyle Johnson
    Nov 29, 2005
  5. Lyle Johnson
    Replies:
    0
    Views:
    134
    Lyle Johnson
    May 20, 2008
Loading...

Share This Page