gcc 2.95 and gcc 3.2

Discussion in 'C++' started by gouqizi.lvcha@gmail.com, Mar 14, 2005.

  1. Guest

    Hi,

    I have a library built with gcc 3.2 , but I cannot use it with gcc
    2.95. Gcc report incompitable error.

    This is a big pain. Does anyone know how to use the library built
    in gcc 2.95 by gcc 3.2 or above.

    Rick
    , Mar 14, 2005
    #1
    1. Advertising

  2. Rolf Magnus Guest

    wrote:

    > Hi,
    >
    > I have a library built with gcc 3.2 , but I cannot use it with gcc
    > 2.95. Gcc report incompitable error.
    >
    > This is a big pain. Does anyone know how to use the library built
    > in gcc 2.95 by gcc 3.2 or above.


    You can't. As you found out, they are incompatible.
    Rolf Magnus, Mar 14, 2005
    #2
    1. Advertising

  3. Chris Theis Guest

    <> wrote in message
    news:...
    > Hi,
    >
    > I have a library built with gcc 3.2 , but I cannot use it with gcc
    > 2.95. Gcc report incompitable error.
    >
    > This is a big pain. Does anyone know how to use the library built
    > in gcc 2.95 by gcc 3.2 or above.
    >
    > Rick


    You´ll have to get a newly compiled lib or downgrade your compiler, which I
    certainly would not recommend.

    Cheers
    Chris
    Chris Theis, Mar 15, 2005
    #3
  4. Guest

    Thanks All.
    , Mar 15, 2005
    #4
  5. red floyd Guest

    wrote:
    > Thanks All.
    >


    Let me guess, you're trying to interface MATLAB 6.5. I'm fighting the
    same issue (2.95 vs. 3.2).
    red floyd, Mar 15, 2005
    #5
  6. Guest

    No. I just want to use a legacy library built with gcc 2.95. I have to
    downgrade my compiler now. Do you have anu idea besides downgrading
    compiler or upgrading library.
    , Mar 15, 2005
    #6
  7. red floyd Guest

    wrote:
    > No. I just want to use a legacy library built with gcc 2.95. I have to
    > downgrade my compiler now. Do you have anu idea besides downgrading
    > compiler or upgrading library.
    >


    No, I'm in the same boat. :(
    red floyd, Mar 15, 2005
    #7
  8. Rolf Magnus Guest

    wrote:

    > No. I just want to use a legacy library built with gcc 2.95. I have to
    > downgrade my compiler now. Do you have anu idea besides downgrading
    > compiler or upgrading library.


    It depends. I guess your library is written in C++. What about the
    interface? Is it C or C++? In the former case, you could succeed by
    additionally linking in the libstdc++ from the old one. Note that this
    might work, or it might not. I'm not an expert on such "hackery", however,
    I have seen something like that done in KDE when they started supporting
    gcc 3.x, but still needed to be able to load the macromedia flash plugin
    for netscape, which was implemented in C++ and compiled with gcc 2.95.
    Rolf Magnus, Mar 15, 2005
    #8
  9. Guest

    Interface is still c++. Old library(Built with gcc 2.95) cannot be
    easily upgraded to gcc 3
    , Mar 16, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Kevin P. Fleming

    C99 structure initialization in gcc-2.95.3 vs gcc-3.3.1

    Kevin P. Fleming, Nov 6, 2003, in forum: C Programming
    Replies:
    2
    Views:
    628
    Kevin P. Fleming
    Nov 6, 2003
  2. Replies:
    5
    Views:
    346
    Nathan Addy
    Sep 17, 2005
  3. ashnin

    GCC 3.4.3 and GCC 4.1.2

    ashnin, Jul 7, 2008, in forum: C++
    Replies:
    1
    Views:
    495
    Michael DOUBEZ
    Jul 7, 2008
  4. kas
    Replies:
    1
    Views:
    302
    red floyd
    Apr 22, 2010
  5. Sharwan Joram
    Replies:
    4
    Views:
    259
    Sharwan Joram
    Nov 22, 2013
Loading...

Share This Page