gem can't connect on Windows

Discussion in 'Ruby' started by Matthias Luedtke, Mar 4, 2005.

  1. Hi all

    I'm trying to install rails on my Windows box. I'm using the newest
    one-click installer version of Ruby.

    E:\>gem install rails --remote

    E:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --remote
    Attempting remote installation of 'rails'
    Updating Gem source index for: http://gems.rubyforge.org
    ERROR: While executing gem ... (Errno::ECONNREFUSED)
    Es konnte keine Verbindung hergestellt werden, da der Zielcomputer
    die Verbi
    ndung verweigerte. - connect(2)

    The last message is in german an means "Cannot establish connection.
    Connection refused by destination host."

    Although my computer is connected to the Inet via NAT all programs I use
    work seamlessly. A personal firewall is not installed. Can anybody give
    me any hints where/how to search for a solution to this? Are there any
    configuration options for ruby networking that I have to change,
    perhaps? TIA!

    Greets,
    Matthias
     
    Matthias Luedtke, Mar 4, 2005
    #1
    1. Advertising

  2. Glenn Smith wrote:
    > Matthias Luedtke wrote:
    >
    >> Hi all
    >>
    >> I'm trying to install rails on my Windows box. I'm using the newest
    >> one-click installer version of Ruby.
    >>
    >> E:\>gem install rails --remote
    >>
    >> E:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --remote
    >> Attempting remote installation of 'rails'
    >> Updating Gem source index for: http://gems.rubyforge.org
    >> ERROR: While executing gem ... (Errno::ECONNREFUSED)
    >> Es konnte keine Verbindung hergestellt werden, da der Zielcomputer
    >> die Verbi
    >> ndung verweigerte. - connect(2)
    >>
    >> The last message is in german an means "Cannot establish connection.
    >> Connection refused by destination host."
    >>
    >> Although my computer is connected to the Inet via NAT all programs I
    >> use work seamlessly. A personal firewall is not installed. Can anybody
    >> give me any hints where/how to search for a solution to this? Are
    >> there any configuration options for ruby networking that I have to
    >> change, perhaps? TIA!
    >>
    >> Greets,
    >> Matthias

    >
    >
    > If you are behind a proxy server, try adding:


    Not exactly that, but I forgot that I edited my InternetExplorer
    settings to use localhost:9 as a proxy in order to prevent him from
    getting out...

    > -p http://<ipaddress>:<port>
    >
    > where ipaddress:port is the ip/port of your proxy server


    ....so that solution in fact did it. Thank you!

    Matthias
     
    Matthias Luedtke, Mar 4, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Otis Mukinfus
    Replies:
    3
    Views:
    926
    Juan T. Llibre
    Jul 8, 2005
  2. Replies:
    3
    Views:
    40,313
    Roedy Green
    Nov 16, 2005
  3. Austin 7873
    Replies:
    5
    Views:
    193
    Eric Hodel
    Jan 27, 2007
  4. Replies:
    2
    Views:
    293
  5. Mohsen Pahlevanzadeh

    Qt connect and first connect or unicode

    Mohsen Pahlevanzadeh, Sep 17, 2013, in forum: Python
    Replies:
    3
    Views:
    156
    Mohsen Pahlevanzadeh
    Sep 18, 2013
Loading...

Share This Page