gem update error

Discussion in 'Ruby' started by Junkone, Apr 3, 2010.

  1. Junkone

    Junkone Guest

    dunno what to do. i have a ruby installed on my new machine and cannot
    add fastercsv.

    E:\Documents and Settings\TTS>gem install fastercsv
    WARNING: RubyGems 1.2+ index not found for:
    http://gems.rubyforge.org/

    RubyGems will revert to legacy indexes degrading performance.
    Bulk updating Gem source index for: http://gems.rubyforge.org/
    ERROR: While executing gem ... (Gem::RemoteSourceException)
    Error fetching remote gem cache: bad response Not Found 404
    (http://producti
    on.s3.rubygems.org/yaml)

    E:\Documents and Settings\TTS>ruby -ver
    ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
    -e:1:in `<main>': undefined local variable or method `r' for
    main:Object (NameEr
    ror)
    Junkone, Apr 3, 2010
    #1
    1. Advertising

  2. Junkone

    Luis Lavena Guest

    On Apr 3, 3:41 pm, Junkone <> wrote:
    > dunno what to do. i have a ruby installed on my new machine and cannot
    > add fastercsv.
    >
    > E:\Documents and Settings\TTS>gem install fastercsv
    > WARNING:  RubyGems 1.2+ index not found for:
    >        http://gems.rubyforge.org/
    >
    > RubyGems will revert to legacy indexes degrading performance.
    > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    >     Error fetching remote gem cache: bad response Not Found 404
    > (http://producti
    > on.s3.rubygems.org/yaml)
    >


    Are you behind a firewall or proxy? That is the common source of this
    problem

    See "gem help install" on how to provide proxy settings for gem
    installation.

    gem install fastercsv --http-proxy=http://user:pass@proxy:port/

    --
    Luis Lavena
    Luis Lavena, Apr 3, 2010
    #2
    1. Advertising

  3. Junkone

    Junkone Guest

    On Apr 3, 9:57 am, Luis Lavena <> wrote:
    > On Apr 3, 3:41 pm, Junkone <> wrote:
    >
    > > dunno what to do. i have a ruby installed on my new machine and cannot
    > > add fastercsv.

    >
    > > E:\Documents and Settings\TTS>gem install fastercsv
    > > WARNING:  RubyGems 1.2+ index not found for:
    > >        http://gems.rubyforge.org/

    >
    > > RubyGems will revert to legacy indexes degrading performance.
    > > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    > >     Error fetching remote gem cache: bad response Not Found 404
    > > (http://producti
    > > on.s3.rubygems.org/yaml)

    >
    > Are you behind a firewall or proxy? That is the common source of this
    > problem
    >
    > See "gem help install" on how to provide proxy settings for gem
    > installation.
    >
    > gem install fastercsv --http-proxy=http://user:pass@proxy:port/
    >
    > --
    > Luis Lavena


    no. i am in direct connection to internet.

    E:\Documents and Settings\TTS>ping rubygems.com

    Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

    Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

    Ping statistics for 174.120.120.196:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 54ms, Maximum = 55ms, Average = 54ms
    Junkone, Apr 3, 2010
    #3
  4. Junkone

    Junkone Guest

    On Apr 3, 10:27 am, Junkone <> wrote:
    > On Apr 3, 9:57 am, Luis Lavena <> wrote:
    >
    >
    >
    >
    >
    > > On Apr 3, 3:41 pm, Junkone <> wrote:

    >
    > > > dunno what to do. i have a ruby installed on my new machine and cannot
    > > > add fastercsv.

    >
    > > > E:\Documents and Settings\TTS>gem install fastercsv
    > > > WARNING:  RubyGems 1.2+ index not found for:
    > > >        http://gems.rubyforge.org/

    >
    > > > RubyGems will revert to legacy indexes degrading performance.
    > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > > > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    > > >     Error fetching remote gem cache: bad response Not Found 404
    > > > (http://producti
    > > > on.s3.rubygems.org/yaml)

    >
    > > Are you behind a firewall or proxy? That is the common source of this
    > > problem

    >
    > > See "gem help install" on how to provide proxy settings for gem
    > > installation.

    >
    > > gem install fastercsv --http-proxy=http://user:pass@proxy:port/

    >
    > > --
    > > Luis Lavena

    >
    > no. i am in direct connection to internet.
    >
    > E:\Documents and Settings\TTS>ping rubygems.com
    >
    > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:
    >
    > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    >
    > Ping statistics for 174.120.120.196:
    >     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    > Approximate round trip times in milli-seconds:
    >     Minimum = 54ms, Maximum = 55ms, Average = 54ms


    well. i tried to ping the rubygems.org and am getting a crazy error. i
    dunno where it is going to.
    E:\Documents and Settings\TTS>ping rubygems.org

    Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 8.15.7.103:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    Junkone, Apr 3, 2010
    #4
  5. Junkone

    Junkone Guest

    On Apr 3, 10:27 am, Junkone <> wrote:
    > On Apr 3, 9:57 am, Luis Lavena <> wrote:
    >
    >
    >
    >
    >
    > > On Apr 3, 3:41 pm, Junkone <> wrote:

    >
    > > > dunno what to do. i have a ruby installed on my new machine and cannot
    > > > add fastercsv.

    >
    > > > E:\Documents and Settings\TTS>gem install fastercsv
    > > > WARNING:  RubyGems 1.2+ index not found for:
    > > >        http://gems.rubyforge.org/

    >
    > > > RubyGems will revert to legacy indexes degrading performance.
    > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > > > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    > > >     Error fetching remote gem cache: bad response Not Found 404
    > > > (http://producti
    > > > on.s3.rubygems.org/yaml)

    >
    > > Are you behind a firewall or proxy? That is the common source of this
    > > problem

    >
    > > See "gem help install" on how to provide proxy settings for gem
    > > installation.

    >
    > > gem install fastercsv --http-proxy=http://user:pass@proxy:port/

    >
    > > --
    > > Luis Lavena

    >
    > no. i am in direct connection to internet.
    >
    > E:\Documents and Settings\TTS>ping rubygems.com
    >
    > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:
    >
    > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    >
    > Ping statistics for 174.120.120.196:
    >     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    > Approximate round trip times in milli-seconds:
    >     Minimum = 54ms, Maximum = 55ms, Average = 54ms



    when i tried to ping from web, it is pingable only from USA
    http://www.watchmouse.com/en/checki....com&utm_medium=link&utm_campaign=jpcheckperf
    Junkone, Apr 3, 2010
    #5
  6. Junkone

    Luis Lavena Guest

    On Apr 3, 4:30 pm, Junkone <> wrote:
    > On Apr 3, 10:27 am, Junkone <> wrote:
    >
    >
    >
    >
    >
    > > On Apr 3, 9:57 am, Luis Lavena <> wrote:

    >
    > > > On Apr 3, 3:41 pm, Junkone <> wrote:

    >
    > > > > dunno what to do. i have a ruby installed on my new machine and cannot
    > > > > add fastercsv.

    >
    > > > > E:\Documents and Settings\TTS>gem install fastercsv
    > > > > WARNING:  RubyGems 1.2+ index not found for:
    > > > >        http://gems.rubyforge.org/

    >
    > > > > RubyGems will revert to legacy indexes degrading performance.
    > > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > > > > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    > > > >     Error fetching remote gem cache: bad response Not Found 404
    > > > > (http://producti
    > > > > on.s3.rubygems.org/yaml)

    >
    > > > Are you behind a firewall or proxy? That is the common source of this
    > > > problem

    >
    > > > See "gem help install" on how to provide proxy settings for gem
    > > > installation.

    >
    > > > gem install fastercsv --http-proxy=http://user:pass@proxy:port/

    >
    > > > --
    > > > Luis Lavena

    >
    > > no. i am in direct connection to internet.

    >
    > > E:\Documents and Settings\TTS>ping rubygems.com

    >
    > > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

    >
    > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

    >
    > > Ping statistics for 174.120.120.196:
    > >     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    > > Approximate round trip times in milli-seconds:
    > >     Minimum = 54ms, Maximum = 55ms, Average = 54ms

    >
    > well. i tried to ping the rubygems.org and am getting a crazy error. i
    > dunno where it is going to.
    > E:\Documents and Settings\TTS>ping rubygems.org
    >
    > Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:
    >
    > Request timed out.
    > Request timed out.
    > Request timed out.
    > Request timed out.
    >
    > Ping statistics for 8.15.7.103:
    >     Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


    I can ping rubygems.org without issues:

    C:\Users\Luis>ping rubygems.org

    Pinging rubygems.org [72.4.120.124] with 32 bytes of data:
    Reply from 72.4.120.124: bytes=32 time=112ms TTL=50
    Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
    Reply from 72.4.120.124: bytes=32 time=103ms TTL=50

    Ping statistics for 72.4.120.124:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 103ms, Maximum = 112ms, Average = 106ms

    So this raises again my previous question: are you behind a proxy or
    firewall?

    The IP address of rubygems.org is reporting in your case do not match
    the real one.

    You're in USA on Elliot Cable network?

    http://www.ipaddresser.com/reverse.php/8.15-0

    For some reason, if that is your IP address of your current internet
    connection:

    http://www.showmyip.com/

    Means you have a miss configuration in windows hosts file.

    --
    Luis Lavena
    Luis Lavena, Apr 3, 2010
    #6
  7. Junkone

    Junkone Guest

    On Apr 3, 11:07 am, Luis Lavena <> wrote:
    > On Apr 3, 4:30 pm, Junkone <> wrote:
    >
    >
    >
    >
    >
    > > On Apr 3, 10:27 am, Junkone <> wrote:

    >
    > > > On Apr 3, 9:57 am, Luis Lavena <> wrote:

    >
    > > > > On Apr 3, 3:41 pm, Junkone <> wrote:

    >
    > > > > > dunno what to do. i have a ruby installed on my new machine and cannot
    > > > > > add fastercsv.

    >
    > > > > > E:\Documents and Settings\TTS>gem install fastercsv
    > > > > > WARNING:  RubyGems 1.2+ index not found for:
    > > > > >        http://gems.rubyforge.org/

    >
    > > > > > RubyGems will revert to legacy indexes degrading performance.
    > > > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
    > > > > > ERROR:  While executing gem ... (Gem::RemoteSourceException)
    > > > > >     Error fetching remote gem cache: bad response Not Found 404
    > > > > > (http://producti
    > > > > > on.s3.rubygems.org/yaml)

    >
    > > > > Are you behind a firewall or proxy? That is the common source of this
    > > > > problem

    >
    > > > > See "gem help install" on how to provide proxy settings for gem
    > > > > installation.

    >
    > > > > gem install fastercsv --http-proxy=http://user:pass@proxy:port/

    >
    > > > > --
    > > > > Luis Lavena

    >
    > > > no. i am in direct connection to internet.

    >
    > > > E:\Documents and Settings\TTS>ping rubygems.com

    >
    > > > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

    >
    > > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
    > > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
    > > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

    >
    > > > Ping statistics for 174.120.120.196:
    > > >     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    > > > Approximate round trip times in milli-seconds:
    > > >     Minimum = 54ms, Maximum = 55ms, Average = 54ms

    >
    > > well. i tried to ping the rubygems.org and am getting a crazy error. i
    > > dunno where it is going to.
    > > E:\Documents and Settings\TTS>ping rubygems.org

    >
    > > Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:

    >
    > > Request timed out.
    > > Request timed out.
    > > Request timed out.
    > > Request timed out.

    >
    > > Ping statistics for 8.15.7.103:
    > >     Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    >
    > I can ping rubygems.org without issues:
    >
    > C:\Users\Luis>ping rubygems.org
    >
    > Pinging rubygems.org [72.4.120.124] with 32 bytes of data:
    > Reply from 72.4.120.124: bytes=32 time=112ms TTL=50
    > Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
    > Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
    >
    > Ping statistics for 72.4.120.124:
    >     Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
    > Approximate round trip times in milli-seconds:
    >     Minimum = 103ms, Maximum = 112ms, Average = 106ms
    >
    > So this raises again my previous question: are you behind a proxy or
    > firewall?
    >
    > The IP address of rubygems.org is reporting in your case do not match
    > the real one.
    >
    > You're in USA on Elliot Cable network?
    >
    > http://www.ipaddresser.com/reverse.php/8.15-0
    >
    > For some reason, if that is your IP address of your current internet
    > connection:
    >
    > http://www.showmyip.com/
    >
    > Means you have a miss configuration in windows hosts file.
    >
    > --
    > Luis Lavena


    i trouble shooted this one. when i use the googledns, it works. when i
    use the dns from my default service provider, it stinks.

    dunno why.
    Junkone, Apr 3, 2010
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. han
    Replies:
    1
    Views:
    122
    Lyle Johnson
    Oct 24, 2005
  2. Clifford Heath
    Replies:
    7
    Views:
    305
    Shanti Braford
    Jun 9, 2006
  3. Stephan Mueller

    gem update for additional gem servers?

    Stephan Mueller, Nov 19, 2006, in forum: Ruby
    Replies:
    3
    Views:
    93
    Jan Svitok
    Nov 20, 2006
  4. Austin 7873
    Replies:
    5
    Views:
    185
    Eric Hodel
    Jan 27, 2007
  5. Älphä Blüë

    Gem versions and Gem lists different after update

    Älphä Blüë, Jul 22, 2009, in forum: Ruby
    Replies:
    1
    Views:
    126
    Älphä Blüë
    Jul 22, 2009
Loading...

Share This Page