gems and http proxy authentication

Discussion in 'Ruby' started by Eduardo Fernandez Corrales, Oct 25, 2004.

  1. Hello,

    I am trying to use gems behind a proxy (squid) that requires
    user/password for internet access

    I have set the http_proxy environment variable like this:

    http_proxy=http://login:password@proxy-hostname:8080

    But gems gives the following error:

    C:\rubygems-0.8.1>gem query --remote

    *** REMOTE GEMS ***
    Updating Gem source index for: http://gems.rubyforge.org
    ERROR: While executing gem ... (OpenURI::HTTPError)
    407 Proxy Authentication Required

    I have checked the docs, but have not found any parameter or option in
    the config file that can solve this.

    Am I overlooking something?

    Thanks in advance.
    --
    Eduardo Fernández Corrales
     
    Eduardo Fernandez Corrales, Oct 25, 2004
    #1
    1. Advertising

  2. Eduardo Fernandez Corrales

    Chad Fowler Guest

    On Mon, 25 Oct 2004 19:01:32 +0900, Eduardo Fernandez Corrales
    <> wrote:
    > Hello,
    >
    > I am trying to use gems behind a proxy (squid) that requires
    > user/password for internet access
    >
    > I have set the http_proxy environment variable like this:
    >
    > http_proxy=http://login:password@proxy-hostname:8080
    >
    > But gems gives the following error:
    >
    > C:\rubygems-0.8.1>gem query --remote
    >
    > *** REMOTE GEMS ***
    > Updating Gem source index for: http://gems.rubyforge.org
    > ERROR: While executing gem ... (OpenURI::HTTPError)
    > 407 Proxy Authentication Required
    >
    > I have checked the docs, but have not found any parameter or option in
    > the config file that can solve this.
    >
    > Am I overlooking something?
    >
    > Thanks in advance.
    > --
    > Eduardo Fernández Corrales
    >
    >


    Eduardo, I'm guessing you're the first person to try running gems
    behind a proxy that requires authentication. Unfortunately, I don't
    have one to even test with. The core of the question is: how do you
    make open-uri work with a proxy that requires authentication? I don't
    know the answer to that question, but finding the answer will help us
    solve this problem for you. I'll try to do some research on my own
    and come up with something.

    ----
    Chad Fowler
    http://chadfowler.com
    http://rubycentral.org
    http://rubygarden.org
    http://rubygems.rubyforge.org (over 20,000 gems served!)
     
    Chad Fowler, Oct 25, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tomás

    Gems -- #include <gems.hpp>

    Tomás, Mar 4, 2006, in forum: C++
    Replies:
    7
    Views:
    447
    Tomás
    Mar 5, 2006
  2. Lloyd Zusman
    Replies:
    3
    Views:
    203
    Lloyd Zusman
    Jun 21, 2005
  3. Dany Cayouette

    'private' gems/gems hierarchy

    Dany Cayouette, Nov 25, 2005, in forum: Ruby
    Replies:
    3
    Views:
    174
    Jim Weirich
    Nov 25, 2005
  4. John T.

    Gems, Proxy authentication

    John T., Aug 26, 2008, in forum: Ruby
    Replies:
    8
    Views:
    159
    Zhoran Tvalve
    Dec 15, 2008
  5. Greg
    Replies:
    4
    Views:
    334
    Steven Simpson
    Aug 16, 2012
Loading...

Share This Page