helloworld comes up with 404.

Discussion in 'ASP .Net Web Services' started by nevin, Oct 6, 2006.

  1. nevin

    nevin Guest

    Hi I am trying to load a new web service onto a production box and it's
    just not working so I am now trying with helloworld which doesn't work
    either.

    I cannot publish to the server as vs2005 tells me the IIS on that box
    doesn't have FPE even though it does so I copied the published files
    from my dev box to the production server and manually created the
    application setting in IIS.

    the root folder of the app is in the wwwroot of the server so
    http://server/helloworld/service.asmx should work but it gives a 404
    error.

    if I set directory browsing on the helloworld directory and go there I
    can see all the files of the application in the directory. clicking
    service.asmx gives 404!!
    the IIS admin tool can also see the folder and all the files and
    folders in the app directory.

    The settings in IIS are exactly the same as on my dev box...I am an
    admin on both machines and the asp.net user has full rights to the
    directory and it's set to anonymous access on that directory.

    I have no idea where to go now so can someone please give me any ideas?
    thanks
    Nev
    nevin, Oct 6, 2006
    #1
    1. Advertising

  2. nevin

    nevin Guest

    nevin wrote:
    > Hi I am trying to load a new web service onto a production box and it's
    > just not working so I am now trying with helloworld which doesn't work
    > either.
    >
    > I cannot publish to the server as vs2005 tells me the IIS on that box
    > doesn't have FPE even though it does so I copied the published files
    > from my dev box to the production server and manually created the
    > application setting in IIS.
    >
    > the root folder of the app is in the wwwroot of the server so
    > http://server/helloworld/service.asmx should work but it gives a 404
    > error.
    >
    > if I set directory browsing on the helloworld directory and go there I
    > can see all the files of the application in the directory. clicking
    > service.asmx gives 404!!
    > the IIS admin tool can also see the folder and all the files and
    > folders in the app directory.
    >
    > The settings in IIS are exactly the same as on my dev box...I am an
    > admin on both machines and the asp.net user has full rights to the
    > directory and it's set to anonymous access on that directory.
    >
    > I have no idea where to go now so can someone please give me any ideas?
    > thanks
    > Nev


    Solved it almost straight after I posted this (even though I spent ages
    searching previously)
    Basically on win2003 server you have to forcibly allow asp.net and I
    had not done that..doh!!
    nevin, Oct 6, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mister.programmer

    Trouble compiling HelloWorld with vbc

    Mister.programmer, Feb 10, 2005, in forum: ASP .Net
    Replies:
    3
    Views:
    2,427
  2. Jonathan Folland
    Replies:
    2
    Views:
    1,612
    Jonathan Folland
    Mar 17, 2005
  3. the_JAVA_Rookie
    Replies:
    5
    Views:
    10,542
    Mickey Segal
    Aug 19, 2003
  4. Guest
    Replies:
    0
    Views:
    3,675
    Guest
    Jan 18, 2004
  5. gluraski

    helloworld portlet

    gluraski, Jun 9, 2005, in forum: Java
    Replies:
    0
    Views:
    368
    gluraski
    Jun 9, 2005
Loading...

Share This Page