Help! ARGH! .net not recognizing VB

Discussion in 'ASP .Net Web Services' started by RWC, May 17, 2005.

  1. RWC

    RWC Guest

    Hi Folks,

    I have a windows 2000 server installation, IIS is running and the ASP.NET
    1.1 SDK has been installed. I'm reading a book on ASP.NET and the lessons
    call for the first line to read <%@ Page Language="VB"%>. When I save the
    page and run it (from a remote machine) I get the following message;

    "The scripting language 'VB' is not found on the server."

    I haven't been able to find ANY other solution. When I type this into
    google, I get about 4 hits. Any suggestions or diagnostic tools would be
    great.

    If you email from this post, remove the caps and underscores from the email
    address

    Thanks in Advance!
    Rick
    RWC, May 17, 2005
    #1
    1. Advertising

  2. RWC

    Marina Guest

    Are you sure asp.net is running on this machine? Does your file have a .aspx
    extension?

    "RWC" <> wrote in message
    news:Twmie.1389047$6l.987537@pd7tw2no...
    > Hi Folks,
    >
    > I have a windows 2000 server installation, IIS is running and the ASP.NET
    > 1.1 SDK has been installed. I'm reading a book on ASP.NET and the lessons
    > call for the first line to read <%@ Page Language="VB"%>. When I save the
    > page and run it (from a remote machine) I get the following message;
    >
    > "The scripting language 'VB' is not found on the server."
    >
    > I haven't been able to find ANY other solution. When I type this into
    > google, I get about 4 hits. Any suggestions or diagnostic tools would be
    > great.
    >
    > If you email from this post, remove the caps and underscores from the
    > email
    > address
    >
    > Thanks in Advance!
    > Rick
    >
    >
    >
    >
    Marina, May 17, 2005
    #2
    1. Advertising

  3. RWC

    Hans Kesting Guest

    RWC wrote:
    > Hi Folks,
    >
    > I have a windows 2000 server installation, IIS is running and the
    > ASP.NET 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    > lessons call for the first line to read <%@ Page Language="VB"%>. When I save the page and run it (from a remote machine) I get
    > the
    > following message;
    > "The scripting language 'VB' is not found on the server."
    >
    > I haven't been able to find ANY other solution. When I type this into
    > google, I get about 4 hits. Any suggestions or diagnostic tools
    > would be great.
    >
    > If you email from this post, remove the caps and underscores from the
    > email address
    >
    > Thanks in Advance!
    > Rick


    Did you install asp.net *after* installing IIS? (you should)

    Dis you give your page an aspx extension (mind the "X")?
    Hans Kesting, May 17, 2005
    #3
  4. RWC

    RWC Guest

    Hi Marina. Thanks for the quick reply.

    I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so I'm
    assuming it's running, I don't know where to look to find the current
    running version. I have it saved with a .asp extension, but have also tried
    ..aspx which produces another error (if you go to
    http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing, but
    it's driving me nutty!

    Thanks!
    Rick



    "Marina" <> wrote in message
    news:eFKkU%...
    > Are you sure asp.net is running on this machine? Does your file have a
    > .aspx extension?
    >
    > "RWC" <> wrote in message
    > news:Twmie.1389047$6l.987537@pd7tw2no...
    >> Hi Folks,
    >>
    >> I have a windows 2000 server installation, IIS is running and the ASP.NET
    >> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >> lessons
    >> call for the first line to read <%@ Page Language="VB"%>. When I save
    >> the
    >> page and run it (from a remote machine) I get the following message;
    >>
    >> "The scripting language 'VB' is not found on the server."
    >>
    >> I haven't been able to find ANY other solution. When I type this into
    >> google, I get about 4 hits. Any suggestions or diagnostic tools would be
    >> great.
    >>
    >> If you email from this post, remove the caps and underscores from the
    >> email
    >> address
    >>
    >> Thanks in Advance!
    >> Rick
    >>
    >>
    >>
    >>

    >
    >
    RWC, May 17, 2005
    #4
  5. RWC

    Marina Guest

    We can't see the error from the outside, because we are not running on that
    server.

    I don't really see, how you expected asp.net, to run an ASP page. ASP pages
    are for ASP to process. ASP.NET can only process pages that end with 'aspx'.

    In any case, we can't see your error, so not much we can do.

    "RWC" <> wrote in message
    news:3doie.1388432$8l.1380716@pd7tw1no...
    > Hi Marina. Thanks for the quick reply.
    >
    > I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so I'm
    > assuming it's running, I don't know where to look to find the current
    > running version. I have it saved with a .asp extension, but have also
    > tried .aspx which produces another error (if you go to
    > http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing, but
    > it's driving me nutty!
    >
    > Thanks!
    > Rick
    >
    >
    >
    > "Marina" <> wrote in message
    > news:eFKkU%...
    >> Are you sure asp.net is running on this machine? Does your file have a
    >> .aspx extension?
    >>
    >> "RWC" <> wrote in message
    >> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>> Hi Folks,
    >>>
    >>> I have a windows 2000 server installation, IIS is running and the
    >>> ASP.NET
    >>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>> lessons
    >>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>> the
    >>> page and run it (from a remote machine) I get the following message;
    >>>
    >>> "The scripting language 'VB' is not found on the server."
    >>>
    >>> I haven't been able to find ANY other solution. When I type this into
    >>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>> be
    >>> great.
    >>>
    >>> If you email from this post, remove the caps and underscores from the
    >>> email
    >>> address
    >>>
    >>> Thanks in Advance!
    >>> Rick
    >>>
    >>>
    >>>
    >>>

    >>
    >>

    >
    >
    Marina, May 17, 2005
    #5
  6. RWC

    RWC Guest

    Hi Mike,

    This is about as simple as it gets. The following is the page that I have
    saved as Testapp.aspx. As you can see, nothing fancy happening here (the
    actual page does not include the opening and closing quotes);

    "<%@Page Language=VB%>



    Sub Button_Click(obj as object,e As EventArgs)
    response.write(obj.text)
    end sub
    </script>
    <html><body>


    <form runat=server>
    <asp:button id="btSubmit" text="Submit"
    runat=server
    onclick="button_click"/><p>
    </form>


    </body>
    </html>"
    Rick





    "vMike" <> wrote in message
    news:F5pie.6263$...
    >
    > "RWC" <> wrote in message
    > news:Twmie.1389047$6l.987537@pd7tw2no...
    >> Hi Folks,
    >>
    >> I have a windows 2000 server installation, IIS is running and the ASP.NET
    >> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >> lessons
    >> call for the first line to read <%@ Page Language="VB"%>. When I save
    >> the
    >> page and run it (from a remote machine) I get the following message;
    >>
    >> "The scripting language 'VB' is not found on the server."
    >>
    >> I haven't been able to find ANY other solution. When I type this into
    >> google, I get about 4 hits. Any suggestions or diagnostic tools would be
    >> great.
    >>
    >> If you email from this post, remove the caps and underscores from the

    > email
    >> address
    >>
    >> Thanks in Advance!
    >> Rick
    >>
    >>

    > I don't think you have to have a language designation. Try removing it and
    > see what happens. I suspect there is some other problem.
    >
    >
    RWC, May 17, 2005
    #6
  7. RWC

    RWC Guest

    Hi Marina. As stated previously, I've tried both extensions. Per your
    request, the error:

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>


    "Marina" <> wrote in message
    news:...
    > We can't see the error from the outside, because we are not running on
    > that server.
    >
    > I don't really see, how you expected asp.net, to run an ASP page. ASP
    > pages are for ASP to process. ASP.NET can only process pages that end with
    > 'aspx'.
    >
    > In any case, we can't see your error, so not much we can do.
    >
    > "RWC" <> wrote in message
    > news:3doie.1388432$8l.1380716@pd7tw1no...
    >> Hi Marina. Thanks for the quick reply.
    >>
    >> I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so
    >> I'm assuming it's running, I don't know where to look to find the current
    >> running version. I have it saved with a .asp extension, but have also
    >> tried .aspx which produces another error (if you go to
    >> http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing, but
    >> it's driving me nutty!
    >>
    >> Thanks!
    >> Rick
    >>
    >>
    >>
    >> "Marina" <> wrote in message
    >> news:eFKkU%...
    >>> Are you sure asp.net is running on this machine? Does your file have a
    >>> .aspx extension?
    >>>
    >>> "RWC" <> wrote in message
    >>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>> Hi Folks,
    >>>>
    >>>> I have a windows 2000 server installation, IIS is running and the
    >>>> ASP.NET
    >>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>> lessons
    >>>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>>> the
    >>>> page and run it (from a remote machine) I get the following message;
    >>>>
    >>>> "The scripting language 'VB' is not found on the server."
    >>>>
    >>>> I haven't been able to find ANY other solution. When I type this into
    >>>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>>> be
    >>>> great.
    >>>>
    >>>> If you email from this post, remove the caps and underscores from the
    >>>> email
    >>>> address
    >>>>
    >>>> Thanks in Advance!
    >>>> Rick
    >>>>
    >>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #7
  8. RWC

    RWC Guest

    Oops, sorry, wrong page;


    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Server cannot access application directory 'F:\MyuFolder\'. The directory
    does not exist or is not accessible because of security settings.
    Description: An unhandled exception occurred during the execution of the
    current web request. Please review the stack trace for more information
    about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Server cannot access
    application directory 'F:\MyuFolder\'. The directory does not exist or is
    not accessible because of security settings.

    Source Error:

    An unhandled exception was generated during the execution of the
    current web request. Information regarding the origin and location of the
    exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Server cannot access application directory
    'F:\MyFolder\'. The directory does not exist or is not accessible because of
    security settings.]
    System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263

    [HttpException (0x80004005): ASP.NET Initialization Error]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +982
    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128



    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
    Version:1.1.4322.2032
    "RWC" <> wrote in message
    news:vqpie.1390873$6l.800200@pd7tw2no...
    > Hi Marina. As stated previously, I've tried both extensions. Per your
    > request, the error:
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Runtime Error
    > Description: An application error occurred on the server. The current
    > custom error settings for this application prevent the details of the
    > application error from being viewed remotely (for security reasons). It
    > could, however, be viewed by browsers running on the local server machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a custom
    > error page by modifying the "defaultRedirect" attribute of the
    > application's <customErrors> configuration tag to point to a custom error
    > page URL.
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"
    > defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >
    > "Marina" <> wrote in message
    > news:...
    >> We can't see the error from the outside, because we are not running on
    >> that server.
    >>
    >> I don't really see, how you expected asp.net, to run an ASP page. ASP
    >> pages are for ASP to process. ASP.NET can only process pages that end
    >> with 'aspx'.
    >>
    >> In any case, we can't see your error, so not much we can do.
    >>
    >> "RWC" <> wrote in message
    >> news:3doie.1388432$8l.1380716@pd7tw1no...
    >>> Hi Marina. Thanks for the quick reply.
    >>>
    >>> I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so
    >>> I'm assuming it's running, I don't know where to look to find the
    >>> current running version. I have it saved with a .asp extension, but
    >>> have also tried .aspx which produces another error (if you go to
    >>> http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing,
    >>> but it's driving me nutty!
    >>>
    >>> Thanks!
    >>> Rick
    >>>
    >>>
    >>>
    >>> "Marina" <> wrote in message
    >>> news:eFKkU%...
    >>>> Are you sure asp.net is running on this machine? Does your file have a
    >>>> .aspx extension?
    >>>>
    >>>> "RWC" <> wrote in message
    >>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>> Hi Folks,
    >>>>>
    >>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>> ASP.NET
    >>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>> lessons
    >>>>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>>>> the
    >>>>> page and run it (from a remote machine) I get the following message;
    >>>>>
    >>>>> "The scripting language 'VB' is not found on the server."
    >>>>>
    >>>>> I haven't been able to find ANY other solution. When I type this into
    >>>>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>>>> be
    >>>>> great.
    >>>>>
    >>>>> If you email from this post, remove the caps and underscores from the
    >>>>> email
    >>>>> address
    >>>>>
    >>>>> Thanks in Advance!
    >>>>> Rick
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #8
  9. RWC

    Marina Guest

    You have a permissions problem Make sure that ASP.net has access to the
    directory it is looking for. And that it actually exists.

    But what you need to do first, is to make sure a basic asp.net page can be
    served up. Forget about trying to put code in it to do file access.

    "RWC" <> wrote in message
    news:3vpie.1390932$6l.69@pd7tw2no...
    > Oops, sorry, wrong page;
    >
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------------
    >
    > Server cannot access application directory 'F:\MyuFolder\'. The directory
    > does not exist or is not accessible because of security settings.
    > Description: An unhandled exception occurred during the execution of the
    > current web request. Please review the stack trace for more information
    > about the error and where it originated in the code.
    >
    > Exception Details: System.Web.HttpException: Server cannot access
    > application directory 'F:\MyuFolder\'. The directory does not exist or is
    > not accessible because of security settings.
    >
    > Source Error:
    >
    > An unhandled exception was generated during the execution of the
    > current web request. Information regarding the origin and location of the
    > exception can be identified using the exception stack trace below.
    >
    > Stack Trace:
    >
    > [HttpException (0x80004005): Server cannot access application directory
    > 'F:\MyFolder\'. The directory does not exist or is not accessible because
    > of security settings.]
    > System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263
    >
    > [HttpException (0x80004005): ASP.NET Initialization Error]
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +982
    > System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128
    >
    >
    >
    > --------------------------------------------------------------------------------
    > Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
    > ASP.NET Version:1.1.4322.2032
    > "RWC" <> wrote in message
    > news:vqpie.1390873$6l.800200@pd7tw2no...
    >> Hi Marina. As stated previously, I've tried both extensions. Per your
    >> request, the error:
    >>
    >> Server Error in '/' Application.
    >> --------------------------------------------------------------------------------
    >>
    >> Runtime Error
    >> Description: An application error occurred on the server. The current
    >> custom error settings for this application prevent the details of the
    >> application error from being viewed remotely (for security reasons). It
    >> could, however, be viewed by browsers running on the local server
    >> machine.
    >>
    >> Details: To enable the details of this specific error message to be
    >> viewable on remote machines, please create a <customErrors> tag within a
    >> "web.config" configuration file located in the root directory of the
    >> current web application. This <customErrors> tag should then have its
    >> "mode" attribute set to "Off".
    >>
    >>
    >> <!-- Web.Config Configuration File -->
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="Off"/>
    >> </system.web>
    >> </configuration>
    >>
    >>
    >> Notes: The current error page you are seeing can be replaced by a custom
    >> error page by modifying the "defaultRedirect" attribute of the
    >> application's <customErrors> configuration tag to point to a custom error
    >> page URL.
    >>
    >>
    >> <!-- Web.Config Configuration File -->
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="RemoteOnly"
    >> defaultRedirect="mycustompage.htm"/>
    >> </system.web>
    >> </configuration>
    >>
    >>
    >> "Marina" <> wrote in message
    >> news:...
    >>> We can't see the error from the outside, because we are not running on
    >>> that server.
    >>>
    >>> I don't really see, how you expected asp.net, to run an ASP page. ASP
    >>> pages are for ASP to process. ASP.NET can only process pages that end
    >>> with 'aspx'.
    >>>
    >>> In any case, we can't see your error, so not much we can do.
    >>>
    >>> "RWC" <> wrote in message
    >>> news:3doie.1388432$8l.1380716@pd7tw1no...
    >>>> Hi Marina. Thanks for the quick reply.
    >>>>
    >>>> I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so
    >>>> I'm assuming it's running, I don't know where to look to find the
    >>>> current running version. I have it saved with a .asp extension, but
    >>>> have also tried .aspx which produces another error (if you go to
    >>>> http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing,
    >>>> but it's driving me nutty!
    >>>>
    >>>> Thanks!
    >>>> Rick
    >>>>
    >>>>
    >>>>
    >>>> "Marina" <> wrote in message
    >>>> news:eFKkU%...
    >>>>> Are you sure asp.net is running on this machine? Does your file have a
    >>>>> .aspx extension?
    >>>>>
    >>>>> "RWC" <> wrote in message
    >>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>> Hi Folks,
    >>>>>>
    >>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>> ASP.NET
    >>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>> lessons
    >>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>> save the
    >>>>>> page and run it (from a remote machine) I get the following message;
    >>>>>>
    >>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>
    >>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>> into
    >>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>> would be
    >>>>>> great.
    >>>>>>
    >>>>>> If you email from this post, remove the caps and underscores from the
    >>>>>> email
    >>>>>> address
    >>>>>>
    >>>>>> Thanks in Advance!
    >>>>>> Rick
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    Marina, May 17, 2005
    #9
  10. RWC

    Marina Guest

    You are missing the <script> start tag.

    "RWC" <> wrote in message
    news:topie.1390864$6l.1036238@pd7tw2no...
    > Hi Mike,
    >
    > This is about as simple as it gets. The following is the page that I have
    > saved as Testapp.aspx. As you can see, nothing fancy happening here (the
    > actual page does not include the opening and closing quotes);
    >
    > "<%@Page Language=VB%>
    >
    >
    >
    > Sub Button_Click(obj as object,e As EventArgs)
    > response.write(obj.text)
    > end sub
    > </script>
    > <html><body>
    >
    >
    > <form runat=server>
    > <asp:button id="btSubmit" text="Submit"
    > runat=server
    > onclick="button_click"/><p>
    > </form>
    >
    >
    > </body>
    > </html>"
    > Rick
    >
    >
    >
    >
    >
    > "vMike" <> wrote in message
    > news:F5pie.6263$...
    >>
    >> "RWC" <> wrote in message
    >> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>> Hi Folks,
    >>>
    >>> I have a windows 2000 server installation, IIS is running and the
    >>> ASP.NET
    >>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>> lessons
    >>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>> the
    >>> page and run it (from a remote machine) I get the following message;
    >>>
    >>> "The scripting language 'VB' is not found on the server."
    >>>
    >>> I haven't been able to find ANY other solution. When I type this into
    >>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>> be
    >>> great.
    >>>
    >>> If you email from this post, remove the caps and underscores from the

    >> email
    >>> address
    >>>
    >>> Thanks in Advance!
    >>> Rick
    >>>
    >>>

    >> I don't think you have to have a language designation. Try removing it
    >> and
    >> see what happens. I suspect there is some other problem.
    >>
    >>

    >
    >
    Marina, May 17, 2005
    #10
  11. RWC

    RWC Guest

    Hi Marina,

    This was transcribed verbatim out of the ASP.NET book I'm using. I had
    tried it both ways, with and without the script tag but still go the same
    message.

    Rick

    "Marina" <> wrote in message
    news:...
    > You are missing the <script> start tag.
    >
    > "RWC" <> wrote in message
    > news:topie.1390864$6l.1036238@pd7tw2no...
    >> Hi Mike,
    >>
    >> This is about as simple as it gets. The following is the page that I
    >> have saved as Testapp.aspx. As you can see, nothing fancy happening here
    >> (the actual page does not include the opening and closing quotes);
    >>
    >> "<%@Page Language=VB%>
    >>
    >>
    >>
    >> Sub Button_Click(obj as object,e As EventArgs)
    >> response.write(obj.text)
    >> end sub
    >> </script>
    >> <html><body>
    >>
    >>
    >> <form runat=server>
    >> <asp:button id="btSubmit" text="Submit"
    >> runat=server
    >> onclick="button_click"/><p>
    >> </form>
    >>
    >>
    >> </body>
    >> </html>"
    >> Rick
    >>
    >>
    >>
    >>
    >>
    >> "vMike" <> wrote in message
    >> news:F5pie.6263$...
    >>>
    >>> "RWC" <> wrote in message
    >>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>> Hi Folks,
    >>>>
    >>>> I have a windows 2000 server installation, IIS is running and the
    >>>> ASP.NET
    >>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>> lessons
    >>>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>>> the
    >>>> page and run it (from a remote machine) I get the following message;
    >>>>
    >>>> "The scripting language 'VB' is not found on the server."
    >>>>
    >>>> I haven't been able to find ANY other solution. When I type this into
    >>>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>>> be
    >>>> great.
    >>>>
    >>>> If you email from this post, remove the caps and underscores from the
    >>> email
    >>>> address
    >>>>
    >>>> Thanks in Advance!
    >>>> Rick
    >>>>
    >>>>
    >>> I don't think you have to have a language designation. Try removing it
    >>> and
    >>> see what happens. I suspect there is some other problem.
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #11
  12. RWC

    RWC Guest

    Hi Marina,

    The directory does exist. Currently I have permissions set up for
    Administrator, Myself and the InternetUser account. If there is an
    independant "ASP.NET" security account that gets set up, I don't see it.

    I have tried a basic page as well, something similar to the following;

    "<%@ Language=VB %>
    <html>
    <head>
    <meta name="GENERATOR" Content="Microsoft Visual Studio .NET 7.1">
    </head>
    <body>

    Hello!

    </body>
    </html>"

    And still get the same message.

    Rick



    "Marina" <> wrote in message
    news:...
    > You have a permissions problem Make sure that ASP.net has access to the
    > directory it is looking for. And that it actually exists.
    >
    > But what you need to do first, is to make sure a basic asp.net page can be
    > served up. Forget about trying to put code in it to do file access.
    >
    > "RWC" <> wrote in message
    > news:3vpie.1390932$6l.69@pd7tw2no...
    >> Oops, sorry, wrong page;
    >>
    >>
    >> Server Error in '/' Application.
    >> --------------------------------------------------------------------------------
    >>
    >> Server cannot access application directory 'F:\MyuFolder\'. The directory
    >> does not exist or is not accessible because of security settings.
    >> Description: An unhandled exception occurred during the execution of the
    >> current web request. Please review the stack trace for more information
    >> about the error and where it originated in the code.
    >>
    >> Exception Details: System.Web.HttpException: Server cannot access
    >> application directory 'F:\MyuFolder\'. The directory does not exist or is
    >> not accessible because of security settings.
    >>
    >> Source Error:
    >>
    >> An unhandled exception was generated during the execution of the
    >> current web request. Information regarding the origin and location of the
    >> exception can be identified using the exception stack trace below.
    >>
    >> Stack Trace:
    >>
    >> [HttpException (0x80004005): Server cannot access application directory
    >> 'F:\MyFolder\'. The directory does not exist or is not accessible because
    >> of security settings.]
    >> System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    >> System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263
    >>
    >> [HttpException (0x80004005): ASP.NET Initialization Error]
    >> System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +982
    >> System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
    >> +128
    >>
    >>
    >>
    >> --------------------------------------------------------------------------------
    >> Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
    >> ASP.NET Version:1.1.4322.2032
    >> "RWC" <> wrote in message
    >> news:vqpie.1390873$6l.800200@pd7tw2no...
    >>> Hi Marina. As stated previously, I've tried both extensions. Per your
    >>> request, the error:
    >>>
    >>> Server Error in '/' Application.
    >>> --------------------------------------------------------------------------------
    >>>
    >>> Runtime Error
    >>> Description: An application error occurred on the server. The current
    >>> custom error settings for this application prevent the details of the
    >>> application error from being viewed remotely (for security reasons). It
    >>> could, however, be viewed by browsers running on the local server
    >>> machine.
    >>>
    >>> Details: To enable the details of this specific error message to be
    >>> viewable on remote machines, please create a <customErrors> tag within a
    >>> "web.config" configuration file located in the root directory of the
    >>> current web application. This <customErrors> tag should then have its
    >>> "mode" attribute set to "Off".
    >>>
    >>>
    >>> <!-- Web.Config Configuration File -->
    >>>
    >>> <configuration>
    >>> <system.web>
    >>> <customErrors mode="Off"/>
    >>> </system.web>
    >>> </configuration>
    >>>
    >>>
    >>> Notes: The current error page you are seeing can be replaced by a custom
    >>> error page by modifying the "defaultRedirect" attribute of the
    >>> application's <customErrors> configuration tag to point to a custom
    >>> error page URL.
    >>>
    >>>
    >>> <!-- Web.Config Configuration File -->
    >>>
    >>> <configuration>
    >>> <system.web>
    >>> <customErrors mode="RemoteOnly"
    >>> defaultRedirect="mycustompage.htm"/>
    >>> </system.web>
    >>> </configuration>
    >>>
    >>>
    >>> "Marina" <> wrote in message
    >>> news:...
    >>>> We can't see the error from the outside, because we are not running on
    >>>> that server.
    >>>>
    >>>> I don't really see, how you expected asp.net, to run an ASP page. ASP
    >>>> pages are for ASP to process. ASP.NET can only process pages that end
    >>>> with 'aspx'.
    >>>>
    >>>> In any case, we can't see your error, so not much we can do.
    >>>>
    >>>> "RWC" <> wrote in message
    >>>> news:3doie.1388432$8l.1380716@pd7tw1no...
    >>>>> Hi Marina. Thanks for the quick reply.
    >>>>>
    >>>>> I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so
    >>>>> I'm assuming it's running, I don't know where to look to find the
    >>>>> current running version. I have it saved with a .asp extension, but
    >>>>> have also tried .aspx which produces another error (if you go to
    >>>>> http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing,
    >>>>> but it's driving me nutty!
    >>>>>
    >>>>> Thanks!
    >>>>> Rick
    >>>>>
    >>>>>
    >>>>>
    >>>>> "Marina" <> wrote in message
    >>>>> news:eFKkU%...
    >>>>>> Are you sure asp.net is running on this machine? Does your file have
    >>>>>> a .aspx extension?
    >>>>>>
    >>>>>> "RWC" <> wrote in message
    >>>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>>> Hi Folks,
    >>>>>>>
    >>>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>>> ASP.NET
    >>>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>>> lessons
    >>>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>>> save the
    >>>>>>> page and run it (from a remote machine) I get the following message;
    >>>>>>>
    >>>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>>
    >>>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>>> into
    >>>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>>> would be
    >>>>>>> great.
    >>>>>>>
    >>>>>>> If you email from this post, remove the caps and underscores from
    >>>>>>> the email
    >>>>>>> address
    >>>>>>>
    >>>>>>> Thanks in Advance!
    >>>>>>> Rick
    >>>>>>>
    >>>>>>>
    >>>>>>>
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #12
  13. RWC

    Marina Guest

    Just forget about scripting.

    Try just putting in:

    <html>
    <body>
    Hello World
    </body>
    </html>

    Make sure this works in a .aspx file. Then go from there.

    "RWC" <> wrote in message
    news:Fuqie.1390059$8l.366936@pd7tw1no...
    > Hi Marina,
    >
    > This was transcribed verbatim out of the ASP.NET book I'm using. I had
    > tried it both ways, with and without the script tag but still go the same
    > message.
    >
    > Rick
    >
    > "Marina" <> wrote in message
    > news:...
    >> You are missing the <script> start tag.
    >>
    >> "RWC" <> wrote in message
    >> news:topie.1390864$6l.1036238@pd7tw2no...
    >>> Hi Mike,
    >>>
    >>> This is about as simple as it gets. The following is the page that I
    >>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    >>> here (the actual page does not include the opening and closing quotes);
    >>>
    >>> "<%@Page Language=VB%>
    >>>
    >>>
    >>>
    >>> Sub Button_Click(obj as object,e As EventArgs)
    >>> response.write(obj.text)
    >>> end sub
    >>> </script>
    >>> <html><body>
    >>>
    >>>
    >>> <form runat=server>
    >>> <asp:button id="btSubmit" text="Submit"
    >>> runat=server
    >>> onclick="button_click"/><p>
    >>> </form>
    >>>
    >>>
    >>> </body>
    >>> </html>"
    >>> Rick
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> "vMike" <> wrote in message
    >>> news:F5pie.6263$...
    >>>>
    >>>> "RWC" <> wrote in message
    >>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>> Hi Folks,
    >>>>>
    >>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>> ASP.NET
    >>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>> lessons
    >>>>> call for the first line to read <%@ Page Language="VB"%>. When I save
    >>>>> the
    >>>>> page and run it (from a remote machine) I get the following message;
    >>>>>
    >>>>> "The scripting language 'VB' is not found on the server."
    >>>>>
    >>>>> I haven't been able to find ANY other solution. When I type this into
    >>>>> google, I get about 4 hits. Any suggestions or diagnostic tools would
    >>>>> be
    >>>>> great.
    >>>>>
    >>>>> If you email from this post, remove the caps and underscores from the
    >>>> email
    >>>>> address
    >>>>>
    >>>>> Thanks in Advance!
    >>>>> Rick
    >>>>>
    >>>>>
    >>>> I don't think you have to have a language designation. Try removing it
    >>>> and
    >>>> see what happens. I suspect there is some other problem.
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    Marina, May 17, 2005
    #13
  14. RWC

    RWC Guest

    Same error message. I've reviewed the permissions and can't see anything
    unusual. If permissions is the problem, then I don't see how the HTML with
    VBscript and Javascript works fine, but this doesn't. Running scripts is
    allowed in my IIS config just to clarify.

    Rick


    "Marina" <> wrote in message
    news:%...
    > Just forget about scripting.
    >
    > Try just putting in:
    >
    > <html>
    > <body>
    > Hello World
    > </body>
    > </html>
    >
    > Make sure this works in a .aspx file. Then go from there.
    >
    > "RWC" <> wrote in message
    > news:Fuqie.1390059$8l.366936@pd7tw1no...
    >> Hi Marina,
    >>
    >> This was transcribed verbatim out of the ASP.NET book I'm using. I had
    >> tried it both ways, with and without the script tag but still go the same
    >> message.
    >>
    >> Rick
    >>
    >> "Marina" <> wrote in message
    >> news:...
    >>> You are missing the <script> start tag.
    >>>
    >>> "RWC" <> wrote in message
    >>> news:topie.1390864$6l.1036238@pd7tw2no...
    >>>> Hi Mike,
    >>>>
    >>>> This is about as simple as it gets. The following is the page that I
    >>>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    >>>> here (the actual page does not include the opening and closing quotes);
    >>>>
    >>>> "<%@Page Language=VB%>
    >>>>
    >>>>
    >>>>
    >>>> Sub Button_Click(obj as object,e As EventArgs)
    >>>> response.write(obj.text)
    >>>> end sub
    >>>> </script>
    >>>> <html><body>
    >>>>
    >>>>
    >>>> <form runat=server>
    >>>> <asp:button id="btSubmit" text="Submit"
    >>>> runat=server
    >>>> onclick="button_click"/><p>
    >>>> </form>
    >>>>
    >>>>
    >>>> </body>
    >>>> </html>"
    >>>> Rick
    >>>>
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> "vMike" <> wrote in message
    >>>> news:F5pie.6263$...
    >>>>>
    >>>>> "RWC" <> wrote in message
    >>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>> Hi Folks,
    >>>>>>
    >>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>> ASP.NET
    >>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>> lessons
    >>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>> save the
    >>>>>> page and run it (from a remote machine) I get the following message;
    >>>>>>
    >>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>
    >>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>> into
    >>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>> would be
    >>>>>> great.
    >>>>>>
    >>>>>> If you email from this post, remove the caps and underscores from the
    >>>>> email
    >>>>>> address
    >>>>>>
    >>>>>> Thanks in Advance!
    >>>>>> Rick
    >>>>>>
    >>>>>>
    >>>>> I don't think you have to have a language designation. Try removing it
    >>>>> and
    >>>>> see what happens. I suspect there is some other problem.
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #14
  15. RWC

    Marina Guest

    Because executing an HTML page, or an ASP page, executes under a different
    process then ASP.NET does.

    So again, make sure the ASP.NET process has permissions to this directory -
    I am assuming you are using this for your virtual directory.

    "RWC" <> wrote in message
    news:jLqie.1390224$8l.5798@pd7tw1no...
    > Same error message. I've reviewed the permissions and can't see anything
    > unusual. If permissions is the problem, then I don't see how the HTML
    > with VBscript and Javascript works fine, but this doesn't. Running
    > scripts is allowed in my IIS config just to clarify.
    >
    > Rick
    >
    >
    > "Marina" <> wrote in message
    > news:%...
    >> Just forget about scripting.
    >>
    >> Try just putting in:
    >>
    >> <html>
    >> <body>
    >> Hello World
    >> </body>
    >> </html>
    >>
    >> Make sure this works in a .aspx file. Then go from there.
    >>
    >> "RWC" <> wrote in message
    >> news:Fuqie.1390059$8l.366936@pd7tw1no...
    >>> Hi Marina,
    >>>
    >>> This was transcribed verbatim out of the ASP.NET book I'm using. I had
    >>> tried it both ways, with and without the script tag but still go the
    >>> same message.
    >>>
    >>> Rick
    >>>
    >>> "Marina" <> wrote in message
    >>> news:...
    >>>> You are missing the <script> start tag.
    >>>>
    >>>> "RWC" <> wrote in message
    >>>> news:topie.1390864$6l.1036238@pd7tw2no...
    >>>>> Hi Mike,
    >>>>>
    >>>>> This is about as simple as it gets. The following is the page that I
    >>>>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    >>>>> here (the actual page does not include the opening and closing
    >>>>> quotes);
    >>>>>
    >>>>> "<%@Page Language=VB%>
    >>>>>
    >>>>>
    >>>>>
    >>>>> Sub Button_Click(obj as object,e As EventArgs)
    >>>>> response.write(obj.text)
    >>>>> end sub
    >>>>> </script>
    >>>>> <html><body>
    >>>>>
    >>>>>
    >>>>> <form runat=server>
    >>>>> <asp:button id="btSubmit" text="Submit"
    >>>>> runat=server
    >>>>> onclick="button_click"/><p>
    >>>>> </form>
    >>>>>
    >>>>>
    >>>>> </body>
    >>>>> </html>"
    >>>>> Rick
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>> "vMike" <> wrote in message
    >>>>> news:F5pie.6263$...
    >>>>>>
    >>>>>> "RWC" <> wrote in message
    >>>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>>> Hi Folks,
    >>>>>>>
    >>>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>>> ASP.NET
    >>>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>>> lessons
    >>>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>>> save the
    >>>>>>> page and run it (from a remote machine) I get the following message;
    >>>>>>>
    >>>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>>
    >>>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>>> into
    >>>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>>> would be
    >>>>>>> great.
    >>>>>>>
    >>>>>>> If you email from this post, remove the caps and underscores from
    >>>>>>> the
    >>>>>> email
    >>>>>>> address
    >>>>>>>
    >>>>>>> Thanks in Advance!
    >>>>>>> Rick
    >>>>>>>
    >>>>>>>
    >>>>>> I don't think you have to have a language designation. Try removing
    >>>>>> it and
    >>>>>> see what happens. I suspect there is some other problem.
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    Marina, May 17, 2005
    #15
  16. RWC

    RWC Guest

    Something unusual, I added the "Everyone" group giving full control, and
    the "Hello" html page worked, the other still would not. When I removed the
    "Everyone" group and gave the internet user account full control, the simple
    "Hello" html page would not work. I don't want to leave the folder with
    "Everyone" having full control, but obviously, I would like it work.

    Rick

    "Marina" <> wrote in message
    news:%...
    > Just forget about scripting.
    >
    > Try just putting in:
    >
    > <html>
    > <body>
    > Hello World
    > </body>
    > </html>
    >
    > Make sure this works in a .aspx file. Then go from there.
    >
    > "RWC" <> wrote in message
    > news:Fuqie.1390059$8l.366936@pd7tw1no...
    >> Hi Marina,
    >>
    >> This was transcribed verbatim out of the ASP.NET book I'm using. I had
    >> tried it both ways, with and without the script tag but still go the same
    >> message.
    >>
    >> Rick
    >>
    >> "Marina" <> wrote in message
    >> news:...
    >>> You are missing the <script> start tag.
    >>>
    >>> "RWC" <> wrote in message
    >>> news:topie.1390864$6l.1036238@pd7tw2no...
    >>>> Hi Mike,
    >>>>
    >>>> This is about as simple as it gets. The following is the page that I
    >>>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    >>>> here (the actual page does not include the opening and closing quotes);
    >>>>
    >>>> "<%@Page Language=VB%>
    >>>>
    >>>>
    >>>>
    >>>> Sub Button_Click(obj as object,e As EventArgs)
    >>>> response.write(obj.text)
    >>>> end sub
    >>>> </script>
    >>>> <html><body>
    >>>>
    >>>>
    >>>> <form runat=server>
    >>>> <asp:button id="btSubmit" text="Submit"
    >>>> runat=server
    >>>> onclick="button_click"/><p>
    >>>> </form>
    >>>>
    >>>>
    >>>> </body>
    >>>> </html>"
    >>>> Rick
    >>>>
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> "vMike" <> wrote in message
    >>>> news:F5pie.6263$...
    >>>>>
    >>>>> "RWC" <> wrote in message
    >>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>> Hi Folks,
    >>>>>>
    >>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>> ASP.NET
    >>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>> lessons
    >>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>> save the
    >>>>>> page and run it (from a remote machine) I get the following message;
    >>>>>>
    >>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>
    >>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>> into
    >>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>> would be
    >>>>>> great.
    >>>>>>
    >>>>>> If you email from this post, remove the caps and underscores from the
    >>>>> email
    >>>>>> address
    >>>>>>
    >>>>>> Thanks in Advance!
    >>>>>> Rick
    >>>>>>
    >>>>>>
    >>>>> I don't think you have to have a language designation. Try removing it
    >>>>> and
    >>>>> see what happens. I suspect there is some other problem.
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #16
  17. RWC

    RWC Guest

    Thi is set up as the Local Path / Home Directory for the site.

    Rick

    "Marina" <> wrote in message
    news:...
    > Because executing an HTML page, or an ASP page, executes under a different
    > process then ASP.NET does.
    >
    > So again, make sure the ASP.NET process has permissions to this
    > directory - I am assuming you are using this for your virtual directory.
    >
    > "RWC" <> wrote in message
    > news:jLqie.1390224$8l.5798@pd7tw1no...
    >> Same error message. I've reviewed the permissions and can't see anything
    >> unusual. If permissions is the problem, then I don't see how the HTML
    >> with VBscript and Javascript works fine, but this doesn't. Running
    >> scripts is allowed in my IIS config just to clarify.
    >>
    >> Rick
    >>
    >>
    >> "Marina" <> wrote in message
    >> news:%...
    >>> Just forget about scripting.
    >>>
    >>> Try just putting in:
    >>>
    >>> <html>
    >>> <body>
    >>> Hello World
    >>> </body>
    >>> </html>
    >>>
    >>> Make sure this works in a .aspx file. Then go from there.
    >>>
    >>> "RWC" <> wrote in message
    >>> news:Fuqie.1390059$8l.366936@pd7tw1no...
    >>>> Hi Marina,
    >>>>
    >>>> This was transcribed verbatim out of the ASP.NET book I'm using. I had
    >>>> tried it both ways, with and without the script tag but still go the
    >>>> same message.
    >>>>
    >>>> Rick
    >>>>
    >>>> "Marina" <> wrote in message
    >>>> news:...
    >>>>> You are missing the <script> start tag.
    >>>>>
    >>>>> "RWC" <> wrote in message
    >>>>> news:topie.1390864$6l.1036238@pd7tw2no...
    >>>>>> Hi Mike,
    >>>>>>
    >>>>>> This is about as simple as it gets. The following is the page that I
    >>>>>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    >>>>>> here (the actual page does not include the opening and closing
    >>>>>> quotes);
    >>>>>>
    >>>>>> "<%@Page Language=VB%>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> Sub Button_Click(obj as object,e As EventArgs)
    >>>>>> response.write(obj.text)
    >>>>>> end sub
    >>>>>> </script>
    >>>>>> <html><body>
    >>>>>>
    >>>>>>
    >>>>>> <form runat=server>
    >>>>>> <asp:button id="btSubmit" text="Submit"
    >>>>>> runat=server
    >>>>>> onclick="button_click"/><p>
    >>>>>> </form>
    >>>>>>
    >>>>>>
    >>>>>> </body>
    >>>>>> </html>"
    >>>>>> Rick
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>> "vMike" <> wrote in message
    >>>>>> news:F5pie.6263$...
    >>>>>>>
    >>>>>>> "RWC" <> wrote in message
    >>>>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    >>>>>>>> Hi Folks,
    >>>>>>>>
    >>>>>>>> I have a windows 2000 server installation, IIS is running and the
    >>>>>>>> ASP.NET
    >>>>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    >>>>>>>> lessons
    >>>>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    >>>>>>>> save the
    >>>>>>>> page and run it (from a remote machine) I get the following
    >>>>>>>> message;
    >>>>>>>>
    >>>>>>>> "The scripting language 'VB' is not found on the server."
    >>>>>>>>
    >>>>>>>> I haven't been able to find ANY other solution. When I type this
    >>>>>>>> into
    >>>>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    >>>>>>>> would be
    >>>>>>>> great.
    >>>>>>>>
    >>>>>>>> If you email from this post, remove the caps and underscores from
    >>>>>>>> the
    >>>>>>> email
    >>>>>>>> address
    >>>>>>>>
    >>>>>>>> Thanks in Advance!
    >>>>>>>> Rick
    >>>>>>>>
    >>>>>>>>
    >>>>>>> I don't think you have to have a language designation. Try removing
    >>>>>>> it and
    >>>>>>> see what happens. I suspect there is some other problem.
    >>>>>>>
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    RWC, May 17, 2005
    #17
  18. RWC

    Dan Nuttle Guest

    Drive F: Is that an NTFS drive? I had similar, but not identical problems
    when I tried to put pages on a non-NTFS drive. At any rate, try putting
    your simplest aspx file right into your c:\inetpub\wwwroot directory, and
    try to run it from there with:

    http://localhost/pagename.aspx

    Where, obviously, pagename.aspx is replaced with the name of your page. If
    it works, then drive F is the problem.

    "RWC" <> wrote in message
    news:3vpie.1390932$6l.69@pd7tw2no...
    > Oops, sorry, wrong page;
    >
    >
    > Server Error in '/' Application.
    > --------------------------------------------------------------------------

    ------
    >
    > Server cannot access application directory 'F:\MyuFolder\'. The directory
    > does not exist or is not accessible because of security settings.
    > Description: An unhandled exception occurred during the execution of the
    > current web request. Please review the stack trace for more information
    > about the error and where it originated in the code.
    >
    > Exception Details: System.Web.HttpException: Server cannot access
    > application directory 'F:\MyuFolder\'. The directory does not exist or is
    > not accessible because of security settings.
    >
    > Source Error:
    >
    > An unhandled exception was generated during the execution of the
    > current web request. Information regarding the origin and location of the
    > exception can be identified using the exception stack trace below.
    >
    > Stack Trace:
    >
    > [HttpException (0x80004005): Server cannot access application directory
    > 'F:\MyFolder\'. The directory does not exist or is not accessible because

    of
    > security settings.]
    > System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263
    >
    > [HttpException (0x80004005): ASP.NET Initialization Error]
    > System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +982
    > System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)

    +128
    >
    >
    >
    > --------------------------------------------------------------------------

    ------
    > Version Information: Microsoft .NET Framework Version:1.1.4322.2032;

    ASP.NET
    > Version:1.1.4322.2032
    > "RWC" <> wrote in message
    > news:vqpie.1390873$6l.800200@pd7tw2no...
    > > Hi Marina. As stated previously, I've tried both extensions. Per your
    > > request, the error:
    > >
    > > Server Error in '/' Application.

    >
    > --------------------------------------------------------------------------

    ------
    > >
    > > Runtime Error
    > > Description: An application error occurred on the server. The current
    > > custom error settings for this application prevent the details of the
    > > application error from being viewed remotely (for security reasons). It
    > > could, however, be viewed by browsers running on the local server

    machine.
    > >
    > > Details: To enable the details of this specific error message to be
    > > viewable on remote machines, please create a <customErrors> tag within a
    > > "web.config" configuration file located in the root directory of the
    > > current web application. This <customErrors> tag should then have its
    > > "mode" attribute set to "Off".
    > >
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="Off"/>
    > > </system.web>
    > > </configuration>
    > >
    > >
    > > Notes: The current error page you are seeing can be replaced by a custom
    > > error page by modifying the "defaultRedirect" attribute of the
    > > application's <customErrors> configuration tag to point to a custom

    error
    > > page URL.
    > >
    > >
    > > <!-- Web.Config Configuration File -->
    > >
    > > <configuration>
    > > <system.web>
    > > <customErrors mode="RemoteOnly"
    > > defaultRedirect="mycustompage.htm"/>
    > > </system.web>
    > > </configuration>
    > >
    > >
    > > "Marina" <> wrote in message
    > > news:...
    > >> We can't see the error from the outside, because we are not running on
    > >> that server.
    > >>
    > >> I don't really see, how you expected asp.net, to run an ASP page. ASP
    > >> pages are for ASP to process. ASP.NET can only process pages that end
    > >> with 'aspx'.
    > >>
    > >> In any case, we can't see your error, so not much we can do.
    > >>
    > >> "RWC" <> wrote in message
    > >> news:3doie.1388432$8l.1380716@pd7tw1no...
    > >>> Hi Marina. Thanks for the quick reply.
    > >>>
    > >>> I ran the ASPNET_REGIIS.EXE with the /i switch from the 1.1 folder, so
    > >>> I'm assuming it's running, I don't know where to look to find the
    > >>> current running version. I have it saved with a .asp extension, but
    > >>> have also tried .aspx which produces another error (if you go to
    > >>> http://hemmingway.dyns.cx/Testapp.aspx ). Not sure what I'm missing,
    > >>> but it's driving me nutty!
    > >>>
    > >>> Thanks!
    > >>> Rick
    > >>>
    > >>>
    > >>>
    > >>> "Marina" <> wrote in message
    > >>> news:eFKkU%...
    > >>>> Are you sure asp.net is running on this machine? Does your file have

    a
    > >>>> .aspx extension?
    > >>>>
    > >>>> "RWC" <> wrote in message
    > >>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    > >>>>> Hi Folks,
    > >>>>>
    > >>>>> I have a windows 2000 server installation, IIS is running and the
    > >>>>> ASP.NET
    > >>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    > >>>>> lessons
    > >>>>> call for the first line to read <%@ Page Language="VB"%>. When I

    save
    > >>>>> the
    > >>>>> page and run it (from a remote machine) I get the following message;
    > >>>>>
    > >>>>> "The scripting language 'VB' is not found on the server."
    > >>>>>
    > >>>>> I haven't been able to find ANY other solution. When I type this

    into
    > >>>>> google, I get about 4 hits. Any suggestions or diagnostic tools

    would
    > >>>>> be
    > >>>>> great.
    > >>>>>
    > >>>>> If you email from this post, remove the caps and underscores from

    the
    > >>>>> email
    > >>>>> address
    > >>>>>
    > >>>>> Thanks in Advance!
    > >>>>> Rick
    > >>>>>
    > >>>>>
    > >>>>>
    > >>>>>
    > >>>>
    > >>>>
    > >>>
    > >>>
    > >>
    > >>

    > >
    > >

    >
    >
    Dan Nuttle, May 18, 2005
    #18
  19. RWC

    Flyingbull Guest

    What groups have permission to access the folder in question? Including the
    main root folder. If you only want yourself to have access, check the IIS
    Settings and make sure to set the security to integrate your login with the
    website, that way it will run using your login credentials. Also check the
    user that is the default user, that user might not have permission to run
    asp.net.


    "RWC" wrote:

    > Something unusual, I added the "Everyone" group giving full control, and
    > the "Hello" html page worked, the other still would not. When I removed the
    > "Everyone" group and gave the internet user account full control, the simple
    > "Hello" html page would not work. I don't want to leave the folder with
    > "Everyone" having full control, but obviously, I would like it work.
    >
    > Rick
    >
    > "Marina" <> wrote in message
    > news:%...
    > > Just forget about scripting.
    > >
    > > Try just putting in:
    > >
    > > <html>
    > > <body>
    > > Hello World
    > > </body>
    > > </html>
    > >
    > > Make sure this works in a .aspx file. Then go from there.
    > >
    > > "RWC" <> wrote in message
    > > news:Fuqie.1390059$8l.366936@pd7tw1no...
    > >> Hi Marina,
    > >>
    > >> This was transcribed verbatim out of the ASP.NET book I'm using. I had
    > >> tried it both ways, with and without the script tag but still go the same
    > >> message.
    > >>
    > >> Rick
    > >>
    > >> "Marina" <> wrote in message
    > >> news:...
    > >>> You are missing the <script> start tag.
    > >>>
    > >>> "RWC" <> wrote in message
    > >>> news:topie.1390864$6l.1036238@pd7tw2no...
    > >>>> Hi Mike,
    > >>>>
    > >>>> This is about as simple as it gets. The following is the page that I
    > >>>> have saved as Testapp.aspx. As you can see, nothing fancy happening
    > >>>> here (the actual page does not include the opening and closing quotes);
    > >>>>
    > >>>> "<%@Page Language=VB%>
    > >>>>
    > >>>>
    > >>>>
    > >>>> Sub Button_Click(obj as object,e As EventArgs)
    > >>>> response.write(obj.text)
    > >>>> end sub
    > >>>> </script>
    > >>>> <html><body>
    > >>>>
    > >>>>
    > >>>> <form runat=server>
    > >>>> <asp:button id="btSubmit" text="Submit"
    > >>>> runat=server
    > >>>> onclick="button_click"/><p>
    > >>>> </form>
    > >>>>
    > >>>>
    > >>>> </body>
    > >>>> </html>"
    > >>>> Rick
    > >>>>
    > >>>>
    > >>>>
    > >>>>
    > >>>>
    > >>>> "vMike" <> wrote in message
    > >>>> news:F5pie.6263$...
    > >>>>>
    > >>>>> "RWC" <> wrote in message
    > >>>>> news:Twmie.1389047$6l.987537@pd7tw2no...
    > >>>>>> Hi Folks,
    > >>>>>>
    > >>>>>> I have a windows 2000 server installation, IIS is running and the
    > >>>>>> ASP.NET
    > >>>>>> 1.1 SDK has been installed. I'm reading a book on ASP.NET and the
    > >>>>>> lessons
    > >>>>>> call for the first line to read <%@ Page Language="VB"%>. When I
    > >>>>>> save the
    > >>>>>> page and run it (from a remote machine) I get the following message;
    > >>>>>>
    > >>>>>> "The scripting language 'VB' is not found on the server."
    > >>>>>>
    > >>>>>> I haven't been able to find ANY other solution. When I type this
    > >>>>>> into
    > >>>>>> google, I get about 4 hits. Any suggestions or diagnostic tools
    > >>>>>> would be
    > >>>>>> great.
    > >>>>>>
    > >>>>>> If you email from this post, remove the caps and underscores from the
    > >>>>> email
    > >>>>>> address
    > >>>>>>
    > >>>>>> Thanks in Advance!
    > >>>>>> Rick
    > >>>>>>
    > >>>>>>
    > >>>>> I don't think you have to have a language designation. Try removing it
    > >>>>> and
    > >>>>> see what happens. I suspect there is some other problem.
    > >>>>>
    > >>>>>
    > >>>>
    > >>>>
    > >>>
    > >>>
    > >>
    > >>

    > >
    > >

    >
    >
    >
    Flyingbull, Jun 1, 2005
    #19
  20. RWC

    Staik Guest

    Hi !

    I think, encountered the same problem, but with C#.
    Try to change the directiv, but I think it won't work either.

    The problem is, I don't remember exactly what the problem whas...
    I was installing a beta version of Visual Studio...

    After many tries to fix the problem, I gave up : I formatted my hard drive,
    installed a coporate licenced version of VS.Net and all this was over.
    My advice : don't waist your time : reinstall a fresh downloaded framework
    and test your page again...

    Staik

    "RWC" wrote:

    > Hi Folks,
    >
    > I have a windows 2000 server installation, IIS is running and the ASP.NET
    > 1.1 SDK has been installed. I'm reading a book on ASP.NET and the lessons
    > call for the first line to read <%@ Page Language="VB"%>. When I save the
    > page and run it (from a remote machine) I get the following message;
    >
    > "The scripting language 'VB' is not found on the server."
    >
    > I haven't been able to find ANY other solution. When I type this into
    > google, I get about 4 hits. Any suggestions or diagnostic tools would be
    > great.
    >
    > If you email from this post, remove the caps and underscores from the email
    > address
    >
    > Thanks in Advance!
    > Rick
    >
    >
    >
    >
    >
    Staik, Jun 1, 2005
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?Q3JhaWcgVHJheGxlcg==?=

    Visual Studio .Net not recognizing ASP.NET 1.1 on same machine

    =?Utf-8?B?Q3JhaWcgVHJheGxlcg==?=, Feb 20, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    496
    =?Utf-8?B?Q3JhaWcgVHJheGxlcg==?=
    Feb 20, 2004
  2. Marc Violette

    HELP - Not recognizing VB Sub's

    Marc Violette, Aug 22, 2004, in forum: ASP .Net
    Replies:
    5
    Views:
    386
  3. RWC
    Replies:
    20
    Views:
    827
    =?Utf-8?B?U3RhaWs=?=
    Jun 1, 2005
  4. RWC
    Replies:
    1
    Views:
    92
    Roland Hall
    May 17, 2005
  5. Replies:
    3
    Views:
    104
Loading...

Share This Page