Help, Please: Server Error in '/' Application.

Discussion in 'ASP .Net' started by =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005.

  1. "Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine. "

    This is happening when I ry to process an aspx in my default directory
    (inetpub\wwwroot).

    Well, I'm viewing it on the local machine so why is it saying that?

    I've tried editing the web.config file to no effect - it doesn't make any
    difference.

    I've tried editing the application name and that does have an effect (it
    changes the error page, but not the basic message).

    I've tried using an asp file istead, but still no joy.

    I've tried using an html file and it works. So IIS does have permission to
    read files in the root directory, but it cant execute asp or aspx.

    Anyone have any ideas, please?
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #1
    1. Advertising

  2. in IE, turn off "Friendly Error Messages" once...

    --
    Curt Christianson
    site: http://www.darkfalz.com
    blog: http://blog.darkfalz.com



    "JebBushell" wrote:

    > "Description: An application error occurred on the server. The current custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could, however,
    > be viewed by browsers running on the local server machine. "
    >
    > This is happening when I ry to process an aspx in my default directory
    > (inetpub\wwwroot).
    >
    > Well, I'm viewing it on the local machine so why is it saying that?
    >
    > I've tried editing the web.config file to no effect - it doesn't make any
    > difference.
    >
    > I've tried editing the application name and that does have an effect (it
    > changes the error page, but not the basic message).
    >
    > I've tried using an asp file istead, but still no joy.
    >
    > I've tried using an html file and it works. So IIS does have permission to
    > read files in the root directory, but it cant execute asp or aspx.
    >
    > Anyone have any ideas, please?
    >
    =?Utf-8?B?Q3VydF9DIFtNVlBd?=, Sep 14, 2005
    #2
    1. Advertising

  3. JebBushell wrote:
    > "Description: An application error occurred on the server. The
    > current custom error settings for this application prevent the
    > details of the application error from being viewed remotely (for
    > security reasons). It could, however, be viewed by browsers running
    > on the local server machine. "
    >
    > This is happening when I ry to process an aspx in my default directory
    > (inetpub\wwwroot).
    >
    > Well, I'm viewing it on the local machine so why is it saying that?
    >
    > I've tried editing the web.config file to no effect - it doesn't make
    > any difference.
    >
    > I've tried editing the application name and that does have an effect
    > (it changes the error page, but not the basic message).
    >
    > I've tried using an asp file istead, but still no joy.
    >
    > I've tried using an html file and it works. So IIS does have
    > permission to read files in the root directory, but it cant execute
    > asp or aspx.
    >
    > Anyone have any ideas, please?


    What OS? If on non-Win2003, give the process account (ASPNET by default)
    the default permissions on wwwroot. If on Win2003, give the IIS_WPG group
    the same ACLs on wwwroot.

    --
    Jim Cheshire
    JIMCO Software
    http://www.jimcosoftware.com

    FrontPage add-ins for FrontPage 2000 - 2003
    JIMCO Software, Sep 14, 2005
    #3
  4. i set the "Show friendly HTTP Messages" to off in IE Internet Options but it
    made no difference. I get a 500 status when I look at it over a GPRS
    connection (mobile phone).

    "Curt_C [MVP]" wrote:

    > in IE, turn off "Friendly Error Messages" once...
    >
    > --
    > Curt Christianson
    > site: http://www.darkfalz.com
    > blog: http://blog.darkfalz.com
    >
    >
    >
    > "JebBushell" wrote:
    >
    > > "Description: An application error occurred on the server. The current custom
    > > error settings for this application prevent the details of the application
    > > error from being viewed remotely (for security reasons). It could, however,
    > > be viewed by browsers running on the local server machine. "
    > >
    > > This is happening when I ry to process an aspx in my default directory
    > > (inetpub\wwwroot).
    > >
    > > Well, I'm viewing it on the local machine so why is it saying that?
    > >
    > > I've tried editing the web.config file to no effect - it doesn't make any
    > > difference.
    > >
    > > I've tried editing the application name and that does have an effect (it
    > > changes the error page, but not the basic message).
    > >
    > > I've tried using an asp file istead, but still no joy.
    > >
    > > I've tried using an html file and it works. So IIS does have permission to
    > > read files in the root directory, but it cant execute asp or aspx.
    > >
    > > Anyone have any ideas, please?
    > >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #4
  5. The OS is XP and I am using simple sharing so I do not know how to grant
    access rights. Is it possible to manage rights without tossing simple
    sharing? I'm somewhat reluctant to put my whole network at risk. It took
    weeks to set up.

    "JIMCO Software" wrote:

    > JebBushell wrote:
    > > "Description: An application error occurred on the server. The
    > > current custom error settings for this application prevent the
    > > details of the application error from being viewed remotely (for
    > > security reasons). It could, however, be viewed by browsers running
    > > on the local server machine. "
    > >
    > > This is happening when I ry to process an aspx in my default directory
    > > (inetpub\wwwroot).
    > >
    > > Well, I'm viewing it on the local machine so why is it saying that?
    > >
    > > I've tried editing the web.config file to no effect - it doesn't make
    > > any difference.
    > >
    > > I've tried editing the application name and that does have an effect
    > > (it changes the error page, but not the basic message).
    > >
    > > I've tried using an asp file istead, but still no joy.
    > >
    > > I've tried using an html file and it works. So IIS does have
    > > permission to read files in the root directory, but it cant execute
    > > asp or aspx.
    > >
    > > Anyone have any ideas, please?

    >
    > What OS? If on non-Win2003, give the process account (ASPNET by default)
    > the default permissions on wwwroot. If on Win2003, give the IIS_WPG group
    > the same ACLs on wwwroot.
    >
    > --
    > Jim Cheshire
    > JIMCO Software
    > http://www.jimcosoftware.com
    >
    > FrontPage add-ins for FrontPage 2000 - 2003
    >
    >
    >
    >
    >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #5
  6. Thanks, I forgot to mention that I had already checked that.

    "John Morales" wrote:

    > Hello JebBushell" jebbushell AT yahoo DOT com,
    >
    > Check that you have the "scripts" or "scripts and executables" options selected in IIS for your wwwroot/ website.
    > attached is a screenshot of the option in question.
    >
    > -john
    >
    > > "Description: An application error occurred on the server. The current
    > > custom error settings for this application prevent the details of the
    > > application error from being viewed remotely (for security reasons).
    > > It could, however, be viewed by browsers running on the local server
    > > machine. "
    > >
    > > This is happening when I ry to process an aspx in my default directory
    > > (inetpub\wwwroot).
    > >
    > > Well, I'm viewing it on the local machine so why is it saying that?
    > >
    > > I've tried editing the web.config file to no effect - it doesn't make
    > > any difference.
    > >
    > > I've tried editing the application name and that does have an effect
    > > (it changes the error page, but not the basic message).
    > >
    > > I've tried using an asp file istead, but still no joy.
    > >
    > > I've tried using an html file and it works. So IIS does have
    > > permission to read files in the root directory, but it cant execute
    > > asp or aspx.
    > >
    > > Anyone have any ideas, please?
    > >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #6
  7. =?Utf-8?B?SmViQnVzaGVsbA==?=

    John Morales Guest

    Hello JebBushell" jebbushell AT yahoo DOT com,
    How are you accessing the machine, if you are accessing from a local browser
    then the error doesnt make sense?
    have you tried
    http://127.0.0.1/
    ?

    > Thanks, I forgot to mention that I had already checked that.
    >
    > "John Morales" wrote:
    >
    >> Hello JebBushell" jebbushell AT yahoo DOT com,
    >>
    >> Check that you have the "scripts" or "scripts and executables"
    >> options selected in IIS for your wwwroot/ website.
    >>
    >> attached is a screenshot of the option in question.
    >>
    >> -john
    >>
    >>> "Description: An application error occurred on the server. The
    >>> current custom error settings for this application prevent the
    >>> details of the application error from being viewed remotely (for
    >>> security reasons). It could, however, be viewed by browsers running
    >>> on the local server machine. "
    >>>
    >>> This is happening when I ry to process an aspx in my default
    >>> directory (inetpub\wwwroot).
    >>>
    >>> Well, I'm viewing it on the local machine so why is it saying that?
    >>>
    >>> I've tried editing the web.config file to no effect - it doesn't
    >>> make any difference.
    >>>
    >>> I've tried editing the application name and that does have an effect
    >>> (it changes the error page, but not the basic message).
    >>>
    >>> I've tried using an asp file istead, but still no joy.
    >>>
    >>> I've tried using an html file and it works. So IIS does have
    >>> permission to read files in the root directory, but it cant execute
    >>> asp or aspx.
    >>>
    >>> Anyone have any ideas, please?
    >>>
    John Morales, Sep 14, 2005
    #7
  8. JebBushell wrote:
    > The OS is XP and I am using simple sharing so I do not know how to
    > grant access rights. Is it possible to manage rights without
    > tossing simple sharing? I'm somewhat reluctant to put my whole
    > network at risk. It took weeks to set up.
    >


    I'm going to have to bow out. I have no idea how Simple Sharing would
    affect this. I have never dealt with anyone who was using it. Sorry.

    --
    Jim Cheshire
    JIMCO Software
    http://www.jimcosoftware.com

    FrontPage add-ins for FrontPage 2000 - 2003
    JIMCO Software, Sep 14, 2005
    #8
  9. Thanks, yes I'd tried that as well, not that I understand its significance.
    However, I have now fixed the problem, I think, by reinstalling IIS. Phew!
    What a sweat.

    Thanks to you and Jimco and Curt_C for helping.

    "John Morales" wrote:

    > Hello JebBushell" jebbushell AT yahoo DOT com,
    > How are you accessing the machine, if you are accessing from a local browser
    > then the error doesnt make sense?
    > have you tried
    > http://127.0.0.1/
    > ?
    >
    > > Thanks, I forgot to mention that I had already checked that.
    > >
    > > "John Morales" wrote:
    > >
    > >> Hello JebBushell" jebbushell AT yahoo DOT com,
    > >>
    > >> Check that you have the "scripts" or "scripts and executables"
    > >> options selected in IIS for your wwwroot/ website.
    > >>
    > >> attached is a screenshot of the option in question.
    > >>
    > >> -john
    > >>
    > >>> "Description: An application error occurred on the server. The
    > >>> current custom error settings for this application prevent the
    > >>> details of the application error from being viewed remotely (for
    > >>> security reasons). It could, however, be viewed by browsers running
    > >>> on the local server machine. "
    > >>>
    > >>> This is happening when I ry to process an aspx in my default
    > >>> directory (inetpub\wwwroot).
    > >>>
    > >>> Well, I'm viewing it on the local machine so why is it saying that?
    > >>>
    > >>> I've tried editing the web.config file to no effect - it doesn't
    > >>> make any difference.
    > >>>
    > >>> I've tried editing the application name and that does have an effect
    > >>> (it changes the error page, but not the basic message).
    > >>>
    > >>> I've tried using an asp file istead, but still no joy.
    > >>>
    > >>> I've tried using an html file and it works. So IIS does have
    > >>> permission to read files in the root directory, but it cant execute
    > >>> asp or aspx.
    > >>>
    > >>> Anyone have any ideas, please?
    > >>>

    >
    >
    >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #9
  10. Reinstall IIS.

    "JebBushell" wrote:

    > "Description: An application error occurred on the server. The current custom
    > error settings for this application prevent the details of the application
    > error from being viewed remotely (for security reasons). It could, however,
    > be viewed by browsers running on the local server machine. "
    >
    > This is happening when I ry to process an aspx in my default directory
    > (inetpub\wwwroot).
    >
    > Well, I'm viewing it on the local machine so why is it saying that?
    >
    > I've tried editing the web.config file to no effect - it doesn't make any
    > difference.
    >
    > I've tried editing the application name and that does have an effect (it
    > changes the error page, but not the basic message).
    >
    > I've tried using an asp file istead, but still no joy.
    >
    > I've tried using an html file and it works. So IIS does have permission to
    > read files in the root directory, but it cant execute asp or aspx.
    >
    > Anyone have any ideas, please?
    >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #10
  11. Thanks for trying. I reinstalled IIS in the end and it seems to have worked.

    "JIMCO Software" wrote:

    > JebBushell wrote:
    > > The OS is XP and I am using simple sharing so I do not know how to
    > > grant access rights. Is it possible to manage rights without
    > > tossing simple sharing? I'm somewhat reluctant to put my whole
    > > network at risk. It took weeks to set up.
    > >

    >
    > I'm going to have to bow out. I have no idea how Simple Sharing would
    > affect this. I have never dealt with anyone who was using it. Sorry.
    >
    > --
    > Jim Cheshire
    > JIMCO Software
    > http://www.jimcosoftware.com
    >
    > FrontPage add-ins for FrontPage 2000 - 2003
    >
    >
    >
    >
    >
    =?Utf-8?B?SmViQnVzaGVsbA==?=, Sep 14, 2005
    #11
  12. How do you reinstall IIS? I"m having a page won't display issue that no-one
    seems to understand or know how to fix. Maybe reinstalling IIS will help me,
    but I wouldn't have a clue how to.

    Thanks,
    Sarah

    "JebBushell" wrote:

    > Reinstall IIS.
    >
    > "JebBushell" wrote:
    >
    > > "Description: An application error occurred on the server. The current custom
    > > error settings for this application prevent the details of the application
    > > error from being viewed remotely (for security reasons). It could, however,
    > > be viewed by browsers running on the local server machine. "
    > >
    > > This is happening when I ry to process an aspx in my default directory
    > > (inetpub\wwwroot).
    > >
    > > Well, I'm viewing it on the local machine so why is it saying that?
    > >
    > > I've tried editing the web.config file to no effect - it doesn't make any
    > > difference.
    > >
    > > I've tried editing the application name and that does have an effect (it
    > > changes the error page, but not the basic message).
    > >
    > > I've tried using an asp file istead, but still no joy.
    > >
    > > I've tried using an html file and it works. So IIS does have permission to
    > > read files in the root directory, but it cant execute asp or aspx.
    > >
    > > Anyone have any ideas, please?
    > >
    =?Utf-8?B?U2FyYWggU2FyYWg=?=, Sep 14, 2005
    #12
  13. Add/Remove - Windows Components
    Uncheck IIS, click ok, reboot.
    Go in again, check it.

    --
    Curt Christianson
    site: http://www.darkfalz.com
    blog: http://blog.darkfalz.com



    "Sarah Sarah" wrote:

    > How do you reinstall IIS? I"m having a page won't display issue that no-one
    > seems to understand or know how to fix. Maybe reinstalling IIS will help me,
    > but I wouldn't have a clue how to.
    >
    > Thanks,
    > Sarah
    >
    > "JebBushell" wrote:
    >
    > > Reinstall IIS.
    > >
    > > "JebBushell" wrote:
    > >
    > > > "Description: An application error occurred on the server. The current custom
    > > > error settings for this application prevent the details of the application
    > > > error from being viewed remotely (for security reasons). It could, however,
    > > > be viewed by browsers running on the local server machine. "
    > > >
    > > > This is happening when I ry to process an aspx in my default directory
    > > > (inetpub\wwwroot).
    > > >
    > > > Well, I'm viewing it on the local machine so why is it saying that?
    > > >
    > > > I've tried editing the web.config file to no effect - it doesn't make any
    > > > difference.
    > > >
    > > > I've tried editing the application name and that does have an effect (it
    > > > changes the error page, but not the basic message).
    > > >
    > > > I've tried using an asp file istead, but still no joy.
    > > >
    > > > I've tried using an html file and it works. So IIS does have permission to
    > > > read files in the root directory, but it cant execute asp or aspx.
    > > >
    > > > Anyone have any ideas, please?
    > > >
    =?Utf-8?B?Q3VydF9DIFtNVlBd?=, Sep 14, 2005
    #13
  14. Thanks, I'll try that.

    "Curt_C [MVP]" wrote:

    > Add/Remove - Windows Components
    > Uncheck IIS, click ok, reboot.
    > Go in again, check it.
    >
    > --
    > Curt Christianson
    > site: http://www.darkfalz.com
    > blog: http://blog.darkfalz.com
    >
    >
    >
    > "Sarah Sarah" wrote:
    >
    > > How do you reinstall IIS? I"m having a page won't display issue that no-one
    > > seems to understand or know how to fix. Maybe reinstalling IIS will help me,
    > > but I wouldn't have a clue how to.
    > >
    > > Thanks,
    > > Sarah
    > >
    > > "JebBushell" wrote:
    > >
    > > > Reinstall IIS.
    > > >
    > > > "JebBushell" wrote:
    > > >
    > > > > "Description: An application error occurred on the server. The current custom
    > > > > error settings for this application prevent the details of the application
    > > > > error from being viewed remotely (for security reasons). It could, however,
    > > > > be viewed by browsers running on the local server machine. "
    > > > >
    > > > > This is happening when I ry to process an aspx in my default directory
    > > > > (inetpub\wwwroot).
    > > > >
    > > > > Well, I'm viewing it on the local machine so why is it saying that?
    > > > >
    > > > > I've tried editing the web.config file to no effect - it doesn't make any
    > > > > difference.
    > > > >
    > > > > I've tried editing the application name and that does have an effect (it
    > > > > changes the error page, but not the basic message).
    > > > >
    > > > > I've tried using an asp file istead, but still no joy.
    > > > >
    > > > > I've tried using an html file and it works. So IIS does have permission to
    > > > > read files in the root directory, but it cant execute asp or aspx.
    > > > >
    > > > > Anyone have any ideas, please?
    > > > >
    =?Utf-8?B?U2FyYWggU2FyYWg=?=, Sep 14, 2005
    #14
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ketul Patel
    Replies:
    1
    Views:
    711
    Alvin Bruney
    Nov 29, 2003
  2. =?Utf-8?B?bWFqbw==?=
    Replies:
    6
    Views:
    2,781
    =?Utf-8?B?bWFqbw==?=
    Mar 15, 2006
  3. Replies:
    4
    Views:
    484
    Chris Uppal
    May 5, 2005
  4. KK
    Replies:
    2
    Views:
    498
    Big Brian
    Oct 14, 2003
  5. MuZZy
    Replies:
    7
    Views:
    1,710
    Mike Hewson
    Jan 7, 2005
Loading...

Share This Page