Help with ASP server calls

Discussion in 'ASP General' started by Marek Krzeminski, Jan 30, 2005.

  1. I am new to ASP and I am having some problems that I hope someone can help
    me with.

    I am using WindowsXP and a book to try to learn ASP.

    The book instructed me to install IIS & .Net Framework v1.1 (which I did)

    In the book they gave me the following code:

    <script language="vb" runat="server">
    Sub Page_Load()
    time.text=Hour(Now) & ":" & Minute(Now) & ":" & Second(Now)
    End Sub
    </script>

    <html>
    <head><title>The Punctual Web Server</title></head>
    <body>
    <h1>Welcome</h1>
    In WebServerLand the time is currently:
    <asp:label id="time" runat="server" />
    </body>
    </html>

    which I saved under the name "test.aspx" in my "C:\Inetpub\wwwroot"
    directory.

    When I open http://localhost/test.aspx in internet explorer, I only see:

    Welcome
    In WebServerLand the time is currently:



    For some reason the server side code does not execute.

    How can I fix this problem? I'm guessing that there is a setup step that I
    am missing somewhere.

    Help!
    Marek Krzeminski, Jan 30, 2005
    #1
    1. Advertising

  2. Marek Krzeminski

    McKirahan Guest

    "Marek Krzeminski" <> wrote in message
    news:yq8Ld.1341$...
    > I am new to ASP and I am having some problems that I hope someone can help
    > me with.
    >
    > I am using WindowsXP and a book to try to learn ASP.
    >
    > The book instructed me to install IIS & .Net Framework v1.1 (which I did)
    >
    > In the book they gave me the following code:
    >
    > <script language="vb" runat="server">
    > Sub Page_Load()
    > time.text=Hour(Now) & ":" & Minute(Now) & ":" & Second(Now)
    > End Sub
    > </script>
    >
    > <html>
    > <head><title>The Punctual Web Server</title></head>
    > <body>
    > <h1>Welcome</h1>
    > In WebServerLand the time is currently:
    > <asp:label id="time" runat="server" />
    > </body>
    > </html>
    >
    > which I saved under the name "test.aspx" in my "C:\Inetpub\wwwroot"
    > directory.
    >
    > When I open http://localhost/test.aspx in internet explorer, I only see:
    >
    > Welcome
    > In WebServerLand the time is currently:
    >
    >
    >
    > For some reason the server side code does not execute.
    >
    > How can I fix this problem? I'm guessing that there is a setup step that

    I
    > am missing somewhere.
    >
    > Help!



    http://www.aspfaq.com/5003
    McKirahan, Jan 30, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Marek Krzeminski

    Help with ASP server calls

    Marek Krzeminski, Jan 30, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    358
    Ken Cox [Microsoft MVP]
    Feb 1, 2005
  2. Honne Gowda A
    Replies:
    2
    Views:
    872
    Karl Heinz Buchegger
    Oct 31, 2003
  3. andy6
    Replies:
    2
    Views:
    756
    andy6 via DotNetMonster.com
    Jun 9, 2006
  4. Richard Tobin
    Replies:
    24
    Views:
    783
  5. Bob
    Replies:
    5
    Views:
    259
Loading...

Share This Page