Hep -- Authentication issue

Discussion in 'ASP .Net' started by Winnie, Aug 23, 2003.

  1. Winnie

    Winnie Guest

    I am having issues with setting up the authentication for .net.
    I have an aspx page in e:\myApp. I have set the virtual directory
    "MyApp" in IIS and give IUSER_XXX and ANONYMOUS USER permission to
    read and execute. Also, ASPNET user has the permission to read and
    execute.

    I changed my web.config and machine.config of my application to
    <authentication mode="None" /> but it is still asking users from other
    client Username and password. How can i disable the authentication?

    Also, I have Runtime Error as followed:

    Description: An application error occurred on the server. The current
    custom error settings for this application prevent the details of the
    application error from being viewed remotely (for security reasons).
    It could, however, be viewed by browsers running on the local server
    machine.

    Details: To enable the details of this specific error message to be
    viewable on remote machines, please create a <customErrors> tag within
    a "web.config" configuration file located in the root directory of the
    current web application. This <customErrors> tag should then have its
    "mode" attribute set to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a
    custom error page by modifying the "defaultRedirect" attribute of the
    application's <customErrors> configuration tag to point to a custom
    error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly"
    defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>


    I have checked my web.config and <customErrors mode="Off" /> is
    set.
    What's happening????

    Winnie
     
    Winnie, Aug 23, 2003
    #1
    1. Advertising

  2. I suspect there's a few things going on here.
    You say users from other PCs are getting asked for a username and password?
    This is probably because of network access, not access determined by .NET
    Try granting access to the network users specifically or turning on Windows
    Integration Authentication in IIS (same tab as Anonymous access). Turn on
    both.

    Second thing I think is .NET related, the custom errors.
    An exception is being thrown but you are not allowed see the error message
    when you access the site from anything other than http://localhost/MyApp

    From this page:
    http://msdn.microsoft.com/library/d...us/cpgenref/html/gngrfcustomerrorssection.asp
    RemoteOnly Specifies that custom errors are shown only to remote
    clients and ASP.NET errors are shown to the local host. This is the default.


    I hope this helps,
    -fs


    "Winnie" <> wrote in message
    news:...
    > I am having issues with setting up the authentication for .net.
    > I have an aspx page in e:\myApp. I have set the virtual directory
    > "MyApp" in IIS and give IUSER_XXX and ANONYMOUS USER permission to
    > read and execute. Also, ASPNET user has the permission to read and
    > execute.
    >
    > I changed my web.config and machine.config of my application to
    > <authentication mode="None" /> but it is still asking users from other
    > client Username and password. How can i disable the authentication?
    >
    > Also, I have Runtime Error as followed:
    >
    > Description: An application error occurred on the server. The current
    > custom error settings for this application prevent the details of the
    > application error from being viewed remotely (for security reasons).
    > It could, however, be viewed by browsers running on the local server
    > machine.
    >
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within
    > a "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    >
    >
    > Notes: The current error page you are seeing can be replaced by a
    > custom error page by modifying the "defaultRedirect" attribute of the
    > application's <customErrors> configuration tag to point to a custom
    > error page URL.
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="RemoteOnly"
    > defaultRedirect="mycustompage.htm"/>
    > </system.web>
    > </configuration>
    >
    >
    > I have checked my web.config and <customErrors mode="Off" /> is
    > set.
    > What's happening????
    >
    > Winnie
     
    Francis Shanahan, Aug 23, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. raghava_kumar85
    Replies:
    0
    Views:
    663
    raghava_kumar85
    Dec 26, 2005
  2. Andrew Connell
    Replies:
    1
    Views:
    553
    Natty Gur
    Oct 21, 2003
  3. raj mandadi
    Replies:
    0
    Views:
    437
    raj mandadi
    Dec 22, 2003
  4. Manmeet

    Hep

    Manmeet, May 21, 2008, in forum: C++
    Replies:
    7
    Views:
    468
    James Kanze
    May 22, 2008
  5. sm
    Replies:
    0
    Views:
    110
Loading...

Share This Page